Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

tabtext disappears

10 posts in Objects Last posting was on 2005-08-29 09:47:25.0Z
Chris Werner Posted on 2005-08-26 12:02:50.0Z
From: "Chris Werner" <cw{please_no_spam}ATf-s.de>
Newsgroups: sybase.public.powerbuilder.objects
Subject: tabtext disappears
Lines: 1257
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
X-RFC2646: Format=Flowed; Original
X-Original-NNTP-Posting-Host: 62.8.156.42
Message-ID: <430f04e5@forums-2-dub>
X-Original-Trace: 26 Aug 2005 05:02:45 -0700, 62.8.156.42
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 26 Aug 2005 05:02:47 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 26 Aug 2005 05:02:50 -0700
X-Trace: forums-1-dub 1125057770 10.22.108.75 (26 Aug 2005 05:02:50 -0700)
X-Original-Trace: 26 Aug 2005 05:02:50 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:8544
Article PK: 735765

Hi,

have posted this earlier but got no answer.
Betimes the tabtexts of the tabpages on a tab object disappear.
This happens occasionally without making any changes to the
tab object. I've defined the tabtexts in the tabpages:
...
global type u_tp_mona_ltst_avis from u_tp_mona_ltst
integer height = 1389
string text = "Auftrag" // <- Text defined here
string powertiptext = "Anzeige der aktuellen Produktion mit
Auftragszuordnung"
boolean is_constructed = true
string c_defaulttext = "Sortiment"
dw_avis dw_avis
end type
...

I've appended a screenshot of a tab object containing
this and other tabpages. As you can see, the text is'nt
visible and the property TabText for the page is empty.
I'm absolutly sure that nobody changes this. The edit
source for the tabpage inside the tab object looks like
follows:

...
type tabpage_avis from u_tp_mona_ltst_avis within u_tab_mona_ltst_show
integer x = 18
integer y = 100
integer width = 2222
integer height = 1380
string powertiptext = "aktuelle Produktionsposition am Aufrichter mit
Auftragszuordnung"
string c_defaulttext = "Auftrag"
end type
...

Using PB 9.0.2 7509
Somebody knows this problem or better a solution for it?

TIA

Chris Werner

tabTextProblem.JPG

Philip Salgannik Posted on 2005-08-26 13:15:48.0Z
From: "Philip Salgannik" <philemaxNOSPAM@comcast.net>
Newsgroups: sybase.public.powerbuilder.objects
References: <430f04e5@forums-2-dub>
Subject: Re: tabtext disappears
Lines: 16
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
X-RFC2646: Format=Flowed; Response
NNTP-Posting-Host: c-24-218-137-221.hsd1.ma.comcast.net
X-Original-NNTP-Posting-Host: c-24-218-137-221.hsd1.ma.comcast.net
Message-ID: <430f1604$1@forums-1-dub>
Date: 26 Aug 2005 06:15:48 -0700
X-Trace: forums-1-dub 1125062148 24.218.137.221 (26 Aug 2005 06:15:48 -0700)
X-Original-Trace: 26 Aug 2005 06:15:48 -0700, c-24-218-137-221.hsd1.ma.comcast.net
X-Authenticated-User: pbtenbeta
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:8545
Article PK: 735768

Somewhere along the line your code sets the text to nothing.


pbm_thisusuallydoesnothelp:-))
Philip Salgannik

"Chris Werner" <cw{please_no_spam}ATf-s.de> wrote in message
news:430f04e5@forums-2-dub...
> Hi,
>
> have posted this earlier but got no answer.
> Betimes the tabtexts of the tabpages on a tab object disappear.
> This happens occasionally without making any changes to the
> tab object. I've defined the tabtexts in the tabpages:


Jason 'Bug' Fenter <fenter_bug_ Posted on 2005-08-26 13:50:26.0Z
From: Jason 'Bug' Fenter <fenter_bug_@_hot_mail_dot_com>
User-Agent: Mozilla Thunderbird 1.0.2 (Windows/20050317)
X-Accept-Language: en-us, en
MIME-Version: 1.0
Newsgroups: sybase.public.powerbuilder.objects
Subject: Re: tabtext disappears
References: <430f04e5@forums-2-dub> <430f1604$1@forums-1-dub>
In-Reply-To: <430f1604$1@forums-1-dub>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: 66.196.228.211
X-Original-NNTP-Posting-Host: 66.196.228.211
Message-ID: <430f1e22$1@forums-1-dub>
Date: 26 Aug 2005 06:50:26 -0700
X-Trace: forums-1-dub 1125064226 66.196.228.211 (26 Aug 2005 06:50:26 -0700)
X-Original-Trace: 26 Aug 2005 06:50:26 -0700, 66.196.228.211
Lines: 38
X-Authenticated-User: pb105beta
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:8546
Article PK: 735769

Very good possibility, Philip. However, how would that affect the object
in the painter as the screen shot shows?

Philip Salgannik wrote:
> Somewhere along the line your code sets the text to nothing.
>
>
> pbm_thisusuallydoesnothelp:-))
> Philip Salgannik
>
> "Chris Werner" <cw{please_no_spam}ATf-s.de> wrote in message
> news:430f04e5@forums-2-dub...
>
>>Hi,
>>
>>have posted this earlier but got no answer.
>>Betimes the tabtexts of the tabpages on a tab object disappear.
>>This happens occasionally without making any changes to the
>>tab object. I've defined the tabtexts in the tabpages:
>
>
>

--
"Don't just fix; teach."

For GUI ideas, visit
http://guiolympics.codexchange.sybase.com
http://fenterbug.homeip.net/gallery

On using newsgroups in general:
news:news.announce.newusers
http://www.geocities.com/nnqweb/
http://www.catb.org/~esr/faqs/smart-questions.html
http://www.caliburn.nl/topposting.html
http://www.netmeister.org/news/learn2quote.html


Philip Salgannik Posted on 2005-08-26 15:19:44.0Z
Sender: 29d9.430f32bc.1804289383@sybase.com
From: Philip Salgannik
Newsgroups: sybase.public.powerbuilder.objects
Subject: Re: tabtext disappears
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <430f3310.29e5.1681692777@sybase.com>
References: <430f1e22$1@forums-1-dub>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 26 Aug 2005 08:19:44 -0700
X-Trace: forums-1-dub 1125069584 10.22.241.41 (26 Aug 2005 08:19:44 -0700)
X-Original-Trace: 26 Aug 2005 08:19:44 -0700, 10.22.241.41
Lines: 43
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:8547
Article PK: 735770

The screen shot shows the tabpage with Tabtext empty, so it
is not an indication of anything but the fact that either
somebody did NOT define it OR somebody DELETED it.

> Very good possibility, Philip. However, how would that
> affect the object in the painter as the screen shot
> shows?
>
>
> Philip Salgannik wrote:
> > Somewhere along the line your code sets the text to
> > nothing.
> >
> > pbm_thisusuallydoesnothelp:-))
> > Philip Salgannik
> >
> > "Chris Werner" <cw{please_no_spam}ATf-s.de> wrote in
> > message news:430f04e5@forums-2-dub...
> >
> >>Hi,
> >>
> >>have posted this earlier but got no answer.
> >>Betimes the tabtexts of the tabpages on a tab object
> disappear. >>This happens occasionally without making any
> changes to the >>tab object. I've defined the tabtexts in
> > the tabpages:
> >
> >
>
>
> --
> "Don't just fix; teach."
>
> For GUI ideas, visit
> http://guiolympics.codexchange.sybase.com
> http://fenterbug.homeip.net/gallery
>
> On using newsgroups in general:
> news:news.announce.newusers
> http://www.geocities.com/nnqweb/
> http://www.catb.org/~esr/faqs/smart-questions.html
> http://www.caliburn.nl/topposting.html
> http://www.netmeister.org/news/learn2quote.html


Chris Werner Posted on 2005-08-26 16:36:02.0Z
From: "Chris Werner" <cw{please_no_spam}ATf-s.de>
Newsgroups: sybase.public.powerbuilder.objects
References: <430f1e22$1@forums-1-dub> <430f3310.29e5.1681692777@sybase.com>
Subject: Re: tabtext disappears
Lines: 65
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
X-RFC2646: Format=Flowed; Original
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
NNTP-Posting-Host: 62.8.156.42
X-Original-NNTP-Posting-Host: 62.8.156.42
Message-ID: <430f44f2@forums-1-dub>
Date: 26 Aug 2005 09:36:02 -0700
X-Trace: forums-1-dub 1125074162 62.8.156.42 (26 Aug 2005 09:36:02 -0700)
X-Original-Trace: 26 Aug 2005 09:36:02 -0700, 62.8.156.42
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:8548
Article PK: 735772

Hi Jason and Phillip,

thank you for the interest.

The problem is, that the PowerBuilder behaves as if "either
somebody did NOT define it OR somebody DELETED it"
but i know by sure that

1) the property tabtext is defined in the userobjects acting
as tabpages in the tab object
2) Nobody deleted it, neither in the tabpage object nor
in the tab object (because this issue raises again and
again after correcting it)


Chris Werner


<Philip Salgannik> schrieb im Newsbeitrag
news:430f3310.29e5.1681692777@sybase.com...

> The screen shot shows the tabpage with Tabtext empty, so it
> is not an indication of anything but the fact that either
> somebody did NOT define it OR somebody DELETED it.
>
>> Very good possibility, Philip. However, how would that
>> affect the object in the painter as the screen shot
>> shows?
>>
>>
>> Philip Salgannik wrote:
>> > Somewhere along the line your code sets the text to
>> > nothing.
>> >
>> > pbm_thisusuallydoesnothelp:-))
>> > Philip Salgannik
>> >
>> > "Chris Werner" <cw{please_no_spam}ATf-s.de> wrote in
>> > message news:430f04e5@forums-2-dub...
>> >
>> >>Hi,
>> >>
>> >>have posted this earlier but got no answer.
>> >>Betimes the tabtexts of the tabpages on a tab object
>> disappear. >>This happens occasionally without making any
>> changes to the >>tab object. I've defined the tabtexts in
>> > the tabpages:
>> >
>> >
>>
>>
>> --
>> "Don't just fix; teach."
>>
>> For GUI ideas, visit
>> http://guiolympics.codexchange.sybase.com
>> http://fenterbug.homeip.net/gallery
>>
>> On using newsgroups in general:
>> news:news.announce.newusers
>> http://www.geocities.com/nnqweb/
>> http://www.catb.org/~esr/faqs/smart-questions.html
>> http://www.caliburn.nl/topposting.html
>> http://www.netmeister.org/news/learn2quote.html


Philip Salgannik Posted on 2005-08-26 17:42:55.0Z
Sender: 2982.430f53ce.1804289383@sybase.com
From: Philip Salgannik
Newsgroups: sybase.public.powerbuilder.objects
Subject: Re: tabtext disappears
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <430f549b.298c.1681692777@sybase.com>
References: <430f44f2@forums-1-dub>
X-Original-NNTP-Posting-Host: 10.22.241.42
X-Original-Trace: 26 Aug 2005 10:42:51 -0700, 10.22.241.42
Lines: 70
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 26 Aug 2005 10:42:52 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 26 Aug 2005 10:42:55 -0700
X-Trace: forums-1-dub 1125078175 10.22.108.75 (26 Aug 2005 10:42:55 -0700)
X-Original-Trace: 26 Aug 2005 10:42:55 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:8549
Article PK: 735775

To be honest, I don't believe you.
I work extensively with tab pages and never seen this
behaviour neither in the version you are using nor in any
other one for that matter. Nor I ever heard anybody but you
complaining about this problem :-)
If it was so real and repeatable, the amount of whining in
these forums would have been pretty noticeable...

> The problem is, that the PowerBuilder behaves as if
> "either somebody did NOT define it OR somebody DELETED it"
> but i know by sure that
>
> 1) the property tabtext is defined in the userobjects
> acting
> as tabpages in the tab object
> 2) Nobody deleted it, neither in the tabpage object nor
> in the tab object (because this issue raises again and
> again after correcting it)
>
>
> Chris Werner
>
>
> <Philip Salgannik> schrieb im Newsbeitrag
> news:430f3310.29e5.1681692777@sybase.com...
> > The screen shot shows the tabpage with Tabtext empty, so
> > it is not an indication of anything but the fact that
> > either somebody did NOT define it OR somebody DELETED
> it. >
> >> Very good possibility, Philip. However, how would that
> >> affect the object in the painter as the screen shot
> >> shows?
> >>
> >>
> >> Philip Salgannik wrote:
> >> > Somewhere along the line your code sets the text to
> >> > nothing.
> >> >
> >> > pbm_thisusuallydoesnothelp:-))
> >> > Philip Salgannik
> >> >
> >> > "Chris Werner" <cw{please_no_spam}ATf-s.de> wrote in
> >> > message news:430f04e5@forums-2-dub...
> >> >
> >> >>Hi,
> >> >>
> >> >>have posted this earlier but got no answer.
> >> >>Betimes the tabtexts of the tabpages on a tab object
> >> disappear. >>This happens occasionally without making
> any >> changes to the >>tab object. I've defined the
> tabtexts in >> > the tabpages:
> >> >
> >> >
> >>
> >>
> >> --
> >> "Don't just fix; teach."
> >>
> >> For GUI ideas, visit
> >> http://guiolympics.codexchange.sybase.com
> >> http://fenterbug.homeip.net/gallery
> >>
> >> On using newsgroups in general:
> >> news:news.announce.newusers
> >> http://www.geocities.com/nnqweb/
> >> http://www.catb.org/~esr/faqs/smart-questions.html
> >> http://www.caliburn.nl/topposting.html
> >> http://www.netmeister.org/news/learn2quote.html
>
>