Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Appeon and connecting to database

2 posts in Appeon (partner product) Last posting was on 2005-09-07 03:46:21.0Z
Carlo Borreo Posted on 2005-09-06 15:53:29.0Z
From: "Carlo Borreo" <carlo.borreo@unv.org>
Newsgroups: sybase.public.appeon
Subject: Appeon and connecting to database
Lines: 40
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1506
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1506
NNTP-Posting-Host: 194.95.38.30
X-Original-NNTP-Posting-Host: 194.95.38.30
Message-ID: <431dbb79@forums-1-dub>
Date: 6 Sep 2005 08:53:29 -0700
X-Trace: forums-1-dub 1126022009 194.95.38.30 (6 Sep 2005 08:53:29 -0700)
X-Original-Trace: 6 Sep 2005 08:53:29 -0700, 194.95.38.30
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:1119
Article PK: 21049

I have some existing PFC-based PB applications, connecting to a database
ASE.
I am trying to convert one of them to Appeon, using Appeon Xcelerator and
replacing all the PFC files with their Appeon counterparts.
I can see the application running in the browser, and this is already good.
But, there is no communication with the database: when there is a
pfc_retrieve(), or an inline SELECT statement, I receive an error message
saying can't connect to database.
I even tried to modify pfc_n_tr.of_connect(), to understand what is going
on. I wrote this code there:

*** Code begin
this.logid="<my login>"
this.logpass="<my pw>"
connect using this;
ll_rc = this.SQLCode
MessageBox( "Connecting result", string( ll_rc ) + this.SQLErrText )
SELECT MAX(code)
INTO :ls_Temp
FROM customers
USING this ;
MessageBox( "MaxCode", ls_Temp )
MessageBox( "SQL error code and text", string( this.SQLCode ) + " " +
this.SQLErrText )
*** Code end

Result:
From PB it runs fine, I get a valid maxcode and no error.
From Appeon, the connection appears successful (it prints "0"), but then the
MaxCode is empty, and the subsequent error code and text is "-1 Failed to
connect to database".
In "Appeon Developer Configuration" for my application (named a_debug) I
configured the database ASE.

What did I do wrong?

TIA
Carlo Borreo


Julie Jiang Posted on 2005-09-07 03:46:21.0Z
From: "Julie Jiang" <julie.jiang@appeon.net>
Newsgroups: sybase.public.appeon
References: <431dbb79@forums-1-dub>
Subject: Re: Appeon and connecting to database
Lines: 171
MIME-Version: 1.0
Content-Type: multipart/alternative; boundary="----=_NextPart_000_024A_01C5B3A1.9A9CC8C0"
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1106
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1106
X-Original-NNTP-Posting-Host: 210.21.221.178
Message-ID: <431e6289@forums-2-dub>
X-Original-Trace: 6 Sep 2005 20:46:17 -0700, 210.21.221.178
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 6 Sep 2005 20:46:18 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 6 Sep 2005 20:46:21 -0700
X-Trace: forums-1-dub 1126064781 10.22.108.75 (6 Sep 2005 20:46:21 -0700)
X-Original-Trace: 6 Sep 2005 20:46:21 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:1120
Article PK: 21050

Hi Carlo,
 
You need to use EAServer connection cache for connecting to the database for the Web application.  Connection cache is the bridge between the application and database at runtime.  The DB type you configured in the Developer Configuration is only for application deployment purpose.  
 
Please refer to Chapter 7: Database Connection Setup in the Appeon Migration Guide for instructions on how to set up the connection cache and configure it for the Web application.  If you do not have Appeon Migration Guide at hand, you can download it from http://www.appeon.com/support/manuals/.
 
Regards,
Julie
"Carlo Borreo" <carlo.borreo@unv.org> wrote in message news:431dbb79@forums-1-dub...
I have some existing PFC-based PB applications, connecting to a database
ASE.
I am trying to convert one of them to Appeon, using Appeon Xcelerator and
replacing all the PFC files with their Appeon counterparts.
I can see the application running in the browser, and this is already good.
But, there is no communication with the database: when there is a
pfc_retrieve(), or an inline SELECT statement, I receive an error message
saying can't connect to database.
I even tried to modify pfc_n_tr.of_connect(), to understand what is going
on. I wrote this code there:

*** Code begin
this.logid="<my login>"
this.logpass="<my pw>"
connect using this;
ll_rc = this.SQLCode
MessageBox( "Connecting result", string( ll_rc ) + this.SQLErrText )
SELECT MAX(code)
  INTO :ls_Temp
  FROM customers
 USING this ;
MessageBox( "MaxCode", ls_Temp )
MessageBox( "SQL error code and text", string( this.SQLCode ) + " " +
this.SQLErrText )
*** Code end

Result:
From PB it runs fine, I get a valid maxcode and no error.
From Appeon, the connection appears successful (it prints "0"), but then the
MaxCode is empty, and the subsequent error code and text is "-1 Failed to
connect to database".
In "Appeon Developer Configuration" for my application (named a_debug) I
configured the database ASE.

What did I do wrong?

TIA
Carlo Borreo