Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Display differences in Appeon 3.0 AX app

4 posts in Appeon (partner product) Last posting was on 2005-09-09 09:41:08.0Z
Chuck Kahn Posted on 2005-09-07 20:17:52.0Z
From: "Chuck Kahn" <chuck.kahn@lmco.com>
Newsgroups: sybase.public.appeon
Subject: Display differences in Appeon 3.0 AX app
Lines: 17
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
X-RFC2646: Format=Flowed; Original
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
X-Original-NNTP-Posting-Host: edge1a.lmco.com
Message-ID: <431f4aec$1@forums-2-dub>
X-Original-Trace: 7 Sep 2005 13:17:48 -0700, edge1a.lmco.com
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 7 Sep 2005 13:17:50 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 7 Sep 2005 13:17:52 -0700
X-Trace: forums-1-dub 1126124272 10.22.108.75 (7 Sep 2005 13:17:52 -0700)
X-Original-Trace: 7 Sep 2005 13:17:52 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:1122
Article PK: 21051

I am working on a Appeon 3.0 AX application. When I am in a DW, a date
field is being displayed in the format mm/dd/yyyy. However, when I click in
the same date field, the date format changes to yyyy-mm-dd. For example,
when my cursor is not in the date field, it displays 01/03/1996 but when I
click inside the date field, it changes to 1996-01-03.

What can I do to make it stay the same format when running through Appeon?
I looked in AEM but could not find anyway to keep the date formats the same.

BTW: The format stays the same when running as a client / server
application.

Thank you

Chuck


Sally Li Posted on 2005-09-08 09:27:48.0Z
From: "Sally Li" <appeon.support@appeon.net>
Newsgroups: sybase.public.appeon
References: <431f4aec$1@forums-2-dub>
Subject: Re: Display differences in Appeon 3.0 AX app
Lines: 104
MIME-Version: 1.0
Content-Type: multipart/alternative; boundary="----=_NextPart_000_0410_01C5B49A.82747280"
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1106
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1106
NNTP-Posting-Host: 210.21.221.178
X-Original-NNTP-Posting-Host: 210.21.221.178
Message-ID: <43200414@forums-1-dub>
Date: 8 Sep 2005 02:27:48 -0700
X-Trace: forums-1-dub 1126171668 210.21.221.178 (8 Sep 2005 02:27:48 -0700)
X-Original-Trace: 8 Sep 2005 02:27:48 -0700, 210.21.221.178
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:1127
Article PK: 12863

Hi Chuck,
 
In order to keep the format unchanged, please change the edit style of the date column to EditMask in PowerBuilder and set the mask of the column to "mm/dd/yyyy",and then redeploy the application.
 
Regards
Sally
"Chuck Kahn" <chuck.kahn@lmco.com> wrote in message news:431f4aec$1@forums-2-dub...
I am working on a Appeon 3.0 AX application.  When I am in a DW, a date
field is being displayed in the format mm/dd/yyyy.  However, when I click in
the same date field, the date format changes to yyyy-mm-dd.  For example,
when my cursor is not in the date field, it displays 01/03/1996 but when I
click inside the date field, it changes to 1996-01-03.

What can I do to make it stay the same format when running through Appeon?
I looked in AEM but could not find anyway to keep the date formats the same.

BTW: The format stays the same when running as a client / server
application.

Thank you

Chuck


Chuck Kahn Posted on 2005-09-08 16:39:02.0Z
From: "Chuck Kahn" <chuck.kahn@lmco.com>
Newsgroups: sybase.public.appeon
References: <431f4aec$1@forums-2-dub> <43200414@forums-1-dub>
Subject: Re: Display differences in Appeon 3.0 AX app
Lines: 156
MIME-Version: 1.0
Content-Type: multipart/alternative; boundary="----=_NextPart_000_000A_01C5B461.873A27D0"
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
NNTP-Posting-Host: edge1a.lmco.com
X-Original-NNTP-Posting-Host: edge1a.lmco.com
Message-ID: <43206926$1@forums-1-dub>
Date: 8 Sep 2005 09:39:02 -0700
X-Trace: forums-1-dub 1126197542 192.31.106.194 (8 Sep 2005 09:39:02 -0700)
X-Original-Trace: 8 Sep 2005 09:39:02 -0700, edge1a.lmco.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:1130
Article PK: 12864

Our application is huge and this cannot be done in hundreds of places.  There must be one place that it can be changed.  Why is it working fine in the client / server application but not through Appeon.  There must be one place that it is being set in Appeon or EAS.  We have to have a way of changing the format in one place.  It doesn't appear it allows me to do this for XCelerator applications.  I cannot change my complete application to utilize EditMasks.   
 
Please provide a workaround or someway of changing this format when clicking in the field.
 
Thank you
 
Chuck
 
"Sally Li" <appeon.support@appeon.net> wrote in message news:43200414@forums-1-dub...
Hi Chuck,
 
In order to keep the format unchanged, please change the edit style of the date column to EditMask in PowerBuilder and set the mask of the column to "mm/dd/yyyy",and then redeploy the application.
 
Regards
Sally
"Chuck Kahn" <chuck.kahn@lmco.com> wrote in message news:431f4aec$1@forums-2-dub...
I am working on a Appeon 3.0 AX application.  When I am in a DW, a date
field is being displayed in the format mm/dd/yyyy.  However, when I click in
the same date field, the date format changes to yyyy-mm-dd.  For example,
when my cursor is not in the date field, it displays 01/03/1996 but when I
click inside the date field, it changes to 1996-01-03.

What can I do to make it stay the same format when running through Appeon?
I looked in AEM but could not find anyway to keep the date formats the same.

BTW: The format stays the same when running as a client / server
application.

Thank you

Chuck


Julie Jiang Posted on 2005-09-09 09:41:08.0Z
From: "Julie Jiang" <julie.jiang@appeon.net>
Newsgroups: sybase.public.appeon
References: <431f4aec$1@forums-2-dub> <43200414@forums-1-dub> <43206926$1@forums-1-dub>
Subject: Re: Display differences in Appeon 3.0 AX app
Lines: 215
MIME-Version: 1.0
Content-Type: multipart/alternative; boundary="----=_NextPart_000_029B_01C5B565.82E817A0"
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1106
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1106
X-Original-NNTP-Posting-Host: 210.21.221.178
Message-ID: <432158b1@forums-2-dub>
X-Original-Trace: 9 Sep 2005 02:41:05 -0700, 210.21.221.178
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 9 Sep 2005 02:41:06 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 9 Sep 2005 02:41:08 -0700
X-Trace: forums-1-dub 1126258868 10.22.108.75 (9 Sep 2005 02:41:08 -0700)
X-Original-Trace: 9 Sep 2005 02:41:08 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:1132
Article PK: 12867

Hi Chuck,
 
When a column is in edit status, Appeon Web Library retrieves the actual value from the database (which may be different from the display value), and must use a format for displaying the actual value.   Then for Date the format yyyy-mm-dd is used.  Appeon Web Library cannot rely on the display format because if it were display format, some parts in the actual value may be lost.   To simply put, it is the way Appeon Web Library makes sure the data input is correct.
 
So I have to say that using the EditMask is the best way if you want to control the behavior.  My suggestion is: you may look at how many Date fields are really affected by this behavior, and then make changes to a number of places (not all the hundreds of places).
 
Regards,
Julie
"Chuck Kahn" <chuck.kahn@lmco.com> wrote in message news:43206926$1@forums-1-dub...
Our application is huge and this cannot be done in hundreds of places.  There must be one place that it can be changed.  Why is it working fine in the client / server application but not through Appeon.  There must be one place that it is being set in Appeon or EAS.  We have to have a way of changing the format in one place.  It doesn't appear it allows me to do this for XCelerator applications.  I cannot change my complete application to utilize EditMasks.   
 
Please provide a workaround or someway of changing this format when clicking in the field.
 
Thank you
 
Chuck
 
"Sally Li" <appeon.support@appeon.net> wrote in message news:43200414@forums-1-dub...
Hi Chuck,
 
In order to keep the format unchanged, please change the edit style of the date column to EditMask in PowerBuilder and set the mask of the column to "mm/dd/yyyy",and then redeploy the application.
 
Regards
Sally
"Chuck Kahn" <chuck.kahn@lmco.com> wrote in message news:431f4aec$1@forums-2-dub...
I am working on a Appeon 3.0 AX application.  When I am in a DW, a date
field is being displayed in the format mm/dd/yyyy.  However, when I click in
the same date field, the date format changes to yyyy-mm-dd.  For example,
when my cursor is not in the date field, it displays 01/03/1996 but when I
click inside the date field, it changes to 1996-01-03.

What can I do to make it stay the same format when running through Appeon?
I looked in AEM but could not find anyway to keep the date formats the same.

BTW: The format stays the same when running as a client / server
application.

Thank you

Chuck