Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Probable library file I/O error

5 posts in Objects Last posting was on 2005-09-23 11:25:29.0Z
TMehrens Posted on 2005-09-21 22:56:00.0Z
From: "TMehrens" <tmehrens@mt.gov>
Newsgroups: sybase.public.powerbuilder.objects
Subject: Probable library file I/O error
Lines: 12
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
NNTP-Posting-Host: user77157.public.state.mt.us
X-Original-NNTP-Posting-Host: user77157.public.state.mt.us
Message-ID: <4331e500$1@forums-1-dub>
Date: 21 Sep 2005 15:56:00 -0700
X-Trace: forums-1-dub 1127343360 161.7.77.157 (21 Sep 2005 15:56:00 -0700)
X-Original-Trace: 21 Sep 2005 15:56:00 -0700, user77157.public.state.mt.us
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:8627
Article PK: 735842

When I perform a ReBuild I am getting the following errors on two DW;
d_arguments.dwo failed. Probable library file I/O error.
d_childarguments.dwo failed. Probable library file I/O error.

The application has many other DW's but these two are the only ones getting
flaged with this error.
Any ideas on what would cause this and better yet, how to resolve it
appreciated.

Tim


Andy Turiansky [TeamSybase] Posted on 2005-09-22 11:58:35.0Z
From: "Andy Turiansky [TeamSybase]" <aturiansky.SpamFree@comcast.net>
Newsgroups: sybase.public.powerbuilder.objects
Organization: 216.98.24.70
References: <4331e500$1@forums-1-dub>
X-Newsreader: AspNNTP 1.50 (Takeshi Eto)
Subject: Re: Probable library file I/O error
Mime-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: web110.discountasp.net
X-Original-NNTP-Posting-Host: web110.discountasp.net
Message-ID: <43329c6b$1@forums-1-dub>
Date: 22 Sep 2005 04:58:35 -0700
X-Trace: forums-1-dub 1127390315 64.79.161.40 (22 Sep 2005 04:58:35 -0700)
X-Original-Trace: 22 Sep 2005 04:58:35 -0700, web110.discountasp.net
Lines: 17
X-Authenticated-User: teamsybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:8630
Article PK: 735843

Is the library of the same version as the other PBL's?

On 21 Sep 2005 15:56:00 -0700,
in sybase.public.powerbuilder.objects

TMehrens <tmehrens@mt.gov> wrote:
>When I perform a ReBuild I am getting the following errors on two DW;
>d_arguments.dwo failed. Probable library file I/O error.
>d_childarguments.dwo failed. Probable library file I/O error.
>
>The application has many other DW's but these two are the only ones getting
>flaged with this error.
>Any ideas on what would cause this and better yet, how to resolve it
>appreciated.
>
>Tim
>
>


TMehrens Posted on 2005-09-22 14:20:22.0Z
From: "TMehrens" <tmehrens@mt.gov>
Newsgroups: sybase.public.powerbuilder.objects
References: <4331e500$1@forums-1-dub> <43329c6b$1@forums-1-dub>
Subject: Re: Probable library file I/O error
Lines: 30
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
X-Original-NNTP-Posting-Host: user8150.public.state.mt.us
Message-ID: <4332bd5d$1@forums-2-dub>
X-Original-Trace: 22 Sep 2005 07:19:09 -0700, user8150.public.state.mt.us
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 22 Sep 2005 07:19:10 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 22 Sep 2005 07:20:22 -0700
X-Trace: forums-1-dub 1127398822 10.22.108.75 (22 Sep 2005 07:20:22 -0700)
X-Original-Trace: 22 Sep 2005 07:20:22 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:8631
Article PK: 735845

Andy,

I am migrating from PB 9 to 10 and some of the pbls have errors. Are you
thinking once I get a clean migration this will go away?

TIA,
Tim

"Andy Turiansky [TeamSybase]" <aturiansky.SpamFree@comcast.net> wrote in
message news:43329c6b$1@forums-1-dub...
> Is the library of the same version as the other PBL's?
>
> On 21 Sep 2005 15:56:00 -0700,
> in sybase.public.powerbuilder.objects
> TMehrens <tmehrens@mt.gov> wrote:
> >When I perform a ReBuild I am getting the following errors on two DW;
> >d_arguments.dwo failed. Probable library file I/O error.
> >d_childarguments.dwo failed. Probable library file I/O error.
> >
> >The application has many other DW's but these two are the only ones
getting
> >flaged with this error.
> >Any ideas on what would cause this and better yet, how to resolve it
> >appreciated.
> >
> >Tim
> >
> >


Andy Turiansky [TeamSybase] Posted on 2005-09-23 11:25:29.0Z
From: "Andy Turiansky [TeamSybase]" <aturiansky.SpamFree@comcast.net>
Newsgroups: sybase.public.powerbuilder.objects
Organization: 216.98.25.70
References: <4331e500$1@forums-1-dub> <43329c6b$1@forums-1-dub> <4332bd5d$1@forums-2-dub>
X-Newsreader: AspNNTP 1.50 (Takeshi Eto)
Subject: Re: Probable library file I/O error
Mime-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: web110.discountasp.net
X-Original-NNTP-Posting-Host: web110.discountasp.net
Message-ID: <4333e629$1@forums-1-dub>
Date: 23 Sep 2005 04:25:29 -0700
X-Trace: forums-1-dub 1127474729 64.79.161.40 (23 Sep 2005 04:25:29 -0700)
X-Original-Trace: 23 Sep 2005 04:25:29 -0700, web110.discountasp.net
Lines: 37
X-Authenticated-User: teamsybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:8633
Article PK: 735847

Are these two DW's in a single PBL? Are the other objects in the PBL OK? Have
you attempted to regenerate and optimize the PBL's? Try exporting the two DW's
and them import into a new PBL, deleting the original ones.

On 22 Sep 2005 07:20:22 -0700,
in sybase.public.powerbuilder.objects

TMehrens <tmehrens@mt.gov> wrote:
>Andy,
>
>I am migrating from PB 9 to 10 and some of the pbls have errors. Are you
>thinking once I get a clean migration this will go away?
>
>TIA,
>Tim
>
>"Andy Turiansky [TeamSybase]" <aturiansky.SpamFree@comcast.net> wrote in
>message news:43329c6b$1@forums-1-dub...
>> Is the library of the same version as the other PBL's?
>>
>> On 21 Sep 2005 15:56:00 -0700,
>> in sybase.public.powerbuilder.objects
>> TMehrens <tmehrens@mt.gov> wrote:
>> >When I perform a ReBuild I am getting the following errors on two DW;
>> >d_arguments.dwo failed. Probable library file I/O error.
>> >d_childarguments.dwo failed. Probable library file I/O error.
>> >
>> >The application has many other DW's but these two are the only ones
>getting
>> >flaged with this error.
>> >Any ideas on what would cause this and better yet, how to resolve it
>> >appreciated.
>> >
>> >Tim
>> >
>> >
>
>


Sanjiv Das Posted on 2005-09-22 00:13:59.0Z
From: "Sanjiv Das" <No-Spam-SDas_TeamSybase@HotMail.Com>
Newsgroups: sybase.public.powerbuilder.objects
References: <4331e500$1@forums-1-dub>
Subject: Re: Probable library file I/O error
Lines: 33
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2527
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2527
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: 208.12.125.121
X-Original-NNTP-Posting-Host: 208.12.125.121
Message-ID: <4331f747$1@forums-1-dub>
Date: 21 Sep 2005 17:13:59 -0700
X-Trace: forums-1-dub 1127348039 208.12.125.121 (21 Sep 2005 17:13:59 -0700)
X-Original-Trace: 21 Sep 2005 17:13:59 -0700, 208.12.125.121
X-Authenticated-User: TeamSybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:8628
Article PK: 735846

Tim,

Not sure why that error would occur, except that the PBL may have somehow
been corrupted.

I'd try copying the objects into a new PBL to see if that clears the errors.
Or try exporting the objects in the PBL and reimporting them into another
PBL.

Do you have a backup of a version of the PBL where these DWs compiled
correctly? You could try using that PBL as a base and copy the other objects
over.

Sanjiv.

"TMehrens" <tmehrens@mt.gov> wrote in message
news:4331e500$1@forums-1-dub...
> When I perform a ReBuild I am getting the following errors on two DW;
> d_arguments.dwo failed. Probable library file I/O error.
> d_childarguments.dwo failed. Probable library file I/O error.
>
> The application has many other DW's but these two are the only ones
> getting
> flaged with this error.
> Any ideas on what would cause this and better yet, how to resolve it
> appreciated.
>
> Tim
>
>