Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Tools Sync

7 posts in General Discussion Last posting was on 2005-10-14 08:15:43.0Z
Robert Posted on 2005-10-12 10:53:05.0Z
Reply-To: "Robert" <robert@cyberprop.com>
From: "Robert" <robert@cyberprop.com>
Newsgroups: ianywhere.public.mbusinessanywhere.general
Subject: Tools Sync
Lines: 40
Organization: USP Designs
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
X-RFC2646: Format=Flowed; Original
X-Original-NNTP-Posting-Host: rrba-146-114-238.telkomadsl.co.za
Message-ID: <434cea54@forums-2-dub>
X-Original-Trace: 12 Oct 2005 03:49:56 -0700, rrba-146-114-238.telkomadsl.co.za
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 12 Oct 2005 03:49:57 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 12 Oct 2005 03:53:05 -0700
X-Trace: forums-1-dub 1129114385 10.22.108.75 (12 Oct 2005 03:53:05 -0700)
X-Original-Trace: 12 Oct 2005 03:53:05 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!forums-2-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.mbusinessanywhere.general:586
Article PK: 8966

Running Mbusiness 5.5 build 113 on Windows XP and Windows CE.NET.
When I do a tools sync I get an error.
Application ulConnect.exe has performed an illegal operation
Exception 0xC0000005
Address 03f4cc20
The sync then goes thru then I get an error
Application Avantogo.exe has performed an illegal operation
Exception 0x80000002
Address 0146639c

If however you go home first and close the application then open the
application on the home page the Tools-Sync works fine.
I need to know if this problem has been sorted out as I have a new device
that runs Windows CE .NET and I think my clients are going to buy the new
device.
Its a Psion TekLogix Notebook ( the little one )

Thanks

--------------------------------------------------------------------------------
Robert Craill
Web Development
USP Designs (Pty) Ltd

E: robert@cyberprop.com
T: +27 11 955 9100
F: +27 11 955 9110
W: www.cyberprop.com
W: www.cyberagent.co.za
W: www.cyberbonds.co.za

USP Designs (Pty) Ltd is Proudly South African!

This message and any attachments are confidential and intended solely for
the addressee. Any unauthorized use, alteration or dissemination is
prohibited. USP Designs (Pty) Ltd. accepts no liability whatsoever for any
loss, whether it be direct, indirect or consequential, arising from
information made available and actions resulting there from.


Greg Fenton Posted on 2005-10-12 13:18:46.0Z
From: Greg Fenton <greg.fenton_NOSPAM_@ianywhere.com>
Organization: iAnywhere Solutions Inc.
User-Agent: Mozilla Thunderbird 1.6.3.2f (Windows/20050317)
X-Accept-Language: en-us, en
MIME-Version: 1.0
Newsgroups: ianywhere.public.mbusinessanywhere.general
Subject: Re: Tools Sync
References: <434cea54@forums-2-dub>
In-Reply-To: <434cea54@forums-2-dub>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: gfenton-t30.sybase.com
X-Original-NNTP-Posting-Host: gfenton-t30.sybase.com
Message-ID: <434d0d36$1@forums-1-dub>
Date: 12 Oct 2005 06:18:46 -0700
X-Trace: forums-1-dub 1129123126 10.25.98.144 (12 Oct 2005 06:18:46 -0700)
X-Original-Trace: 12 Oct 2005 06:18:46 -0700, gfenton-t30.sybase.com
Lines: 22
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.mbusinessanywhere.general:587
Article PK: 8967


Robert wrote:
> Running Mbusiness 5.5 build 113 on Windows XP and Windows CE.NET.
> When I do a tools sync I get an error.
> Application ulConnect.exe has performed an illegal operation
> Exception 0xC0000005
> Address 03f4cc20

Are you trying to use One-Button Sync for synchronizing an UltraLite
database?

Which version and build number of SQLAnywhere are you using? (e.g. for
SQLAnywhere 9.x, use the command "dbeng9 -v")

greg.fenton
--
Greg Fenton
Consultant, Solution Services, iAnywhere Solutions
--------
Visit the iAnywhere Solutions Developer Community
Whitepapers, TechDocs, Downloads
http://www.ianywhere.com/developer/


Robert Posted on 2005-10-12 13:43:29.0Z
Reply-To: "Robert" <robert@cyberprop.com>
From: "Robert" <robert@cyberprop.com>
Newsgroups: ianywhere.public.mbusinessanywhere.general
References: <434cea54@forums-2-dub> <434d0d36$1@forums-1-dub>
Subject: Re: Tools Sync
Lines: 46
Organization: USP Designs
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
X-RFC2646: Format=Flowed; Response
X-Original-NNTP-Posting-Host: rrba-146-82-81.telkomadsl.co.za
Message-ID: <434d1243@forums-2-dub>
X-Original-Trace: 12 Oct 2005 06:40:19 -0700, rrba-146-82-81.telkomadsl.co.za
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 12 Oct 2005 06:40:20 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 12 Oct 2005 06:43:29 -0700
X-Trace: forums-1-dub 1129124609 10.22.108.75 (12 Oct 2005 06:43:29 -0700)
X-Original-Trace: 12 Oct 2005 06:43:29 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!forums-2-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.mbusinessanywhere.general:588
Article PK: 17730

File -- sync from within Mbusiness.
It seems to only happen on a device running Windows CE .NET and on Windows
XP as a client
Runs perfectly on a HP Ipaq 3715rx
Running ASA 9.0.2.2451

Also my pod cannot connect to the database on the Windows CE.NET device.
It is a Psion Teklogix little notebook
Device has the following Settings
Windows CE .NET
Version 4.20
Processor Intel ARM-PXA255
Memory 81476KB
WinCE date code J124p

----- Original Message -----
From: "Greg Fenton" <greg.fenton_NOSPAM_@ianywhere.com>
Newsgroups: ianywhere.public.mbusinessanywhere.general
Sent: Wednesday, October 12, 2005 3:18 PM
Subject: Re: Tools Sync

"Greg Fenton" <greg.fenton_NOSPAM_@ianywhere.com> wrote in message
news:434d0d36$1@forums-1-dub...
> Robert wrote:
>> Running Mbusiness 5.5 build 113 on Windows XP and Windows CE.NET.
>> When I do a tools sync I get an error.
>> Application ulConnect.exe has performed an illegal operation
>> Exception 0xC0000005
>> Address 03f4cc20
>
>
> Are you trying to use One-Button Sync for synchronizing an UltraLite
> database?
>
> Which version and build number of SQLAnywhere are you using? (e.g. for
> SQLAnywhere 9.x, use the command "dbeng9 -v")
>
> greg.fenton
> --
> Greg Fenton
> Consultant, Solution Services, iAnywhere Solutions
> --------
> Visit the iAnywhere Solutions Developer Community
> Whitepapers, TechDocs, Downloads
> http://www.ianywhere.com/developer/


Greg Fenton Posted on 2005-10-12 16:02:08.0Z
From: Greg Fenton <greg.fenton_NOSPAM_@ianywhere.com>
Organization: iAnywhere Solutions Inc.
User-Agent: Mozilla Thunderbird 1.6.3.2f (Windows/20050317)
X-Accept-Language: en-us, en
MIME-Version: 1.0
Newsgroups: ianywhere.public.mbusinessanywhere.general
Subject: Re: Tools Sync
References: <434cea54@forums-2-dub> <434d0d36$1@forums-1-dub> <434d1243@forums-2-dub>
In-Reply-To: <434d1243@forums-2-dub>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: gfenton-t30.sybase.com
X-Original-NNTP-Posting-Host: gfenton-t30.sybase.com
Message-ID: <434d3380@forums-1-dub>
Date: 12 Oct 2005 09:02:08 -0700
X-Trace: forums-1-dub 1129132928 10.25.98.144 (12 Oct 2005 09:02:08 -0700)
X-Original-Trace: 12 Oct 2005 09:02:08 -0700, gfenton-t30.sybase.com
Lines: 37
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.mbusinessanywhere.general:589
Article PK: 8968

Based on your post in the SQLAnywhere newsgroup:

Robert wrote:
> I want to run Mbusiness Client and connect to my ASA server via
> Ultralite or such.

MBA can only communicate with UltraLite (unless you create your own
ASA-communication PODS or something like that). You would synchronize
data to your consolidated (which can be ASA) using the MobiLink
Synchronization Server.

Another alternative is to use the mBA XML datastore (a.k.a. "Virgil").

> I had to copy some additoional files but got the Mbusiness to connect
> but I get errors on my pictures pod.

What errors?

BTW: I'm told that mBA is not officially supported on CE.NET yet. So
this might be the root of the problem you are having.

> But I cannot connect to the database via the pod

I have not tried ULPod on CE.NET at all.

> Runs perfectly on a HP Ipaq 3715rx

What OS runs on that device?

greg.fenton
--
Greg Fenton
Consultant, Solution Services, iAnywhere Solutions
--------
Visit the iAnywhere Solutions Developer Community
Whitepapers, TechDocs, Downloads
http://www.ianywhere.com/developer/


Robert Posted on 2005-10-13 07:27:31.0Z
Reply-To: "Robert" <robert@cyberprop.com>
From: "Robert" <robert@cyberprop.com>
Newsgroups: ianywhere.public.mbusinessanywhere.general
References: <434cea54@forums-2-dub> <434d0d36$1@forums-1-dub> <434d1243@forums-2-dub> <434d3380@forums-1-dub>
Subject: Re: Tools Sync
Lines: 60
Organization: USP Designs
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
X-RFC2646: Format=Flowed; Response
NNTP-Posting-Host: rrba-146-82-81.telkomadsl.co.za
X-Original-NNTP-Posting-Host: rrba-146-82-81.telkomadsl.co.za
Message-ID: <434e0c63@forums-1-dub>
Date: 13 Oct 2005 00:27:31 -0700
X-Trace: forums-1-dub 1129188451 165.146.82.81 (13 Oct 2005 00:27:31 -0700)
X-Original-Trace: 13 Oct 2005 00:27:31 -0700, rrba-146-82-81.telkomadsl.co.za
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.mbusinessanywhere.general:591
Article PK: 8973

I use MobiLink to sync data. XML does not work in my application. We tried
at first to use Xml but it fell short of the functionality we needed so we
switched to Mobilink and Ultralite.
The pod error is that it cannot connect to the database from with in the
pod.
The pod must open the database and write the "file(jpg file) to binary" into
the binary field in the data base so that the data sync can send the picture
to the server .

The other error I get on CE .NET is when File sync I get a Ulconnect.exe
has cause ann exception error and will be shutdown.
Same thing on Windows XP as client

> Runs perfectly on a HP Ipaq 3715rx
>
> What OS runs on that device?

Windows Mobile 2003 Second Edition version 4.21.1088 build (14235.2.0.0.)
ARM processor

"Greg Fenton" <greg.fenton_NOSPAM_@ianywhere.com> wrote in message
news:434d3380@forums-1-dub...
> Based on your post in the SQLAnywhere newsgroup:
>
> Robert wrote:
>> I want to run Mbusiness Client and connect to my ASA server via
>> Ultralite or such.
>
> MBA can only communicate with UltraLite (unless you create your own
> ASA-communication PODS or something like that). You would synchronize
> data to your consolidated (which can be ASA) using the MobiLink
> Synchronization Server.
>
> Another alternative is to use the mBA XML datastore (a.k.a. "Virgil").
>
>> I had to copy some additoional files but got the Mbusiness to connect
>> but I get errors on my pictures pod.
>
> What errors?
>
> BTW: I'm told that mBA is not officially supported on CE.NET yet. So this
> might be the root of the problem you are having.
>
>> But I cannot connect to the database via the pod
>
> I have not tried ULPod on CE.NET at all.
>
>> Runs perfectly on a HP Ipaq 3715rx
>
> What OS runs on that device?
>
> greg.fenton
> --
> Greg Fenton
> Consultant, Solution Services, iAnywhere Solutions
> --------
> Visit the iAnywhere Solutions Developer Community
> Whitepapers, TechDocs, Downloads
> http://www.ianywhere.com/developer/


Greg Fenton Posted on 2005-10-13 13:38:12.0Z
From: Greg Fenton <greg.fenton_NOSPAM_@ianywhere.com>
Organization: iAnywhere Solutions Inc.
User-Agent: Mozilla Thunderbird 1.6.3.2f (Windows/20050317)
X-Accept-Language: en-us, en
MIME-Version: 1.0
Newsgroups: ianywhere.public.mbusinessanywhere.general
Subject: Re: Tools Sync
References: <434cea54@forums-2-dub> <434d0d36$1@forums-1-dub> <434d1243@forums-2-dub> <434d3380@forums-1-dub> <434e0c63@forums-1-dub>
In-Reply-To: <434e0c63@forums-1-dub>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
X-Original-NNTP-Posting-Host: gfenton-t30.sybase.com
Message-ID: <434e6282$1@forums-2-dub>
X-Original-Trace: 13 Oct 2005 06:34:58 -0700, gfenton-t30.sybase.com
Lines: 22
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 13 Oct 2005 06:34:59 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 13 Oct 2005 06:38:12 -0700
X-Trace: forums-1-dub 1129210692 10.22.108.75 (13 Oct 2005 06:38:12 -0700)
X-Original-Trace: 13 Oct 2005 06:38:12 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!forums-2-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.mbusinessanywhere.general:597
Article PK: 17732


Robert wrote:
> The pod error is that it cannot connect to the database from with in the
> pod.

Hmmm...I think you are in a bit of a weird situation. ULPod is
documented as supporting CE 3.0 and later and mBA 5.3 and later, but I
think that mBA 5.5 was released well before CE.NET was available. There
is a good chance that changes in the newer OS has broken something.

I recommend opening a case with iAnywhere Technical Support:

http://www.ianywhere.com/support/contact/contact_support.html

Hope this helps,
greg.fenton
--
Greg Fenton
Consultant, Solution Services, iAnywhere Solutions
--------
Visit the iAnywhere Solutions Developer Community
Whitepapers, TechDocs, Downloads
http://www.ianywhere.com/developer/


Robert Posted on 2005-10-14 08:15:43.0Z
Reply-To: "Robert" <robert@cyberprop.com>
From: "Robert" <robert@cyberprop.com>
Newsgroups: ianywhere.public.mbusinessanywhere.general
References: <434cea54@forums-2-dub> <434d0d36$1@forums-1-dub> <434d1243@forums-2-dub> <434d3380@forums-1-dub> <434e0c63@forums-1-dub> <434e6282$1@forums-2-dub>
Subject: Re: Tools Sync
Lines: 51
Organization: USP Designs
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
X-RFC2646: Format=Flowed; Response
X-Original-NNTP-Posting-Host: rrba-146-120-108.telkomadsl.co.za
Message-ID: <434f6867@forums-2-dub>
X-Original-Trace: 14 Oct 2005 01:12:23 -0700, rrba-146-120-108.telkomadsl.co.za
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 14 Oct 2005 01:12:24 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 14 Oct 2005 01:15:43 -0700
X-Trace: forums-1-dub 1129277743 10.22.108.75 (14 Oct 2005 01:15:43 -0700)
X-Original-Trace: 14 Oct 2005 01:15:43 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!forums-2-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.mbusinessanywhere.general:599
Article PK: 8975

Thank Greg
Will get Sybase SA to log query.

Any ideas on why ulconnect.exe give exception error on Windows XP and CE
.NET as client when doing a File->Sync

Application ulConnect.exe has performed an illegal operation
Exception 0xC0000005
Address 03f4cc20

The sync then goes thru then I get an error

Application Avantogo.exe has performed an illegal operation
Exception 0x80000002
Address 0146639c

I removed ulconnect.exe from the pods directory and that stopped the
ulconnect illegal operation but I till get the Avantgo.exe error when the
File->Sync finishes.
Surely Windows XP as a client is supported

New Question.
How does one get the pod to work on Windows XP or CE .NET Mbusiness 5.7.

"Greg Fenton" <greg.fenton_NOSPAM_@ianywhere.com> wrote in message
news:434e6282$1@forums-2-dub...
> Robert wrote:
>> The pod error is that it cannot connect to the database from with in the
>> pod.
>
> Hmmm...I think you are in a bit of a weird situation. ULPod is documented
> as supporting CE 3.0 and later and mBA 5.3 and later, but I think that mBA
> 5.5 was released well before CE.NET was available. There is a good chance
> that changes in the newer OS has broken something.
>
> I recommend opening a case with iAnywhere Technical Support:
>
> http://www.ianywhere.com/support/contact/contact_support.html
>
> Hope this helps,
> greg.fenton
> --
> Greg Fenton
> Consultant, Solution Services, iAnywhere Solutions
> --------
> Visit the iAnywhere Solutions Developer Community
> Whitepapers, TechDocs, Downloads
> http://www.ianywhere.com/developer/