Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

ASA .Net data provider issue

6 posts in General Discussion Last posting was on 2005-10-17 13:28:49.0Z
"Alsin" Posted on 2005-10-12 16:19:45.0Z
From: "Alsin" <a.sinitsin[hot dog]ukr.net>
Newsgroups: ianywhere.public.general
Subject: ASA .Net data provider issue
Lines: 19
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
X-RFC2646: Format=Flowed; Original
X-Comment-To: All
FL-Build: Fidolook 2002 (SL) 6.0.2800.86 - 14/6/2003 22:16:25
NNTP-Posting-Host: alvion.com.ua
X-Original-NNTP-Posting-Host: alvion.com.ua
Message-ID: <434d37a1@forums-1-dub>
Date: 12 Oct 2005 09:19:45 -0700
X-Trace: forums-1-dub 1129133985 83.170.209.66 (12 Oct 2005 09:19:45 -0700)
X-Original-Trace: 12 Oct 2005 09:19:45 -0700, alvion.com.ua
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:4852
Article PK: 17451

Hello, All!

I'm made application using Net data provider and trying to deploy it on
production server. I'm read carefuly deploying instruction and implement all
steps. So I have dbdata9.dll in my PATH and iAnywhere.Data.AsaClient.dll in
GAC.
On my development environment all works very well and fast.
But on production I have strange issue:
First statement that touches AsaClient assembly takes a looong time:

AsaConnection conn = new AsaConnection(ConnString);

And then fauls on conn.Open(). Error just 'System error'.

What's wrong? How it can be cured?

With best regards, Alsin. E-mail: a.sinitsin[hot dog]ukr.net


Jason Hinsperger (iAnywhere) Posted on 2005-10-13 15:12:42.0Z
From: "Jason Hinsperger \(iAnywhere\)" <NOjason_hinspergerSPAM@hotmail.com>
Newsgroups: ianywhere.public.general
References: <434d37a1@forums-1-dub>
Subject: Re: ASA .Net data provider issue
Lines: 35
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2527
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2527
X-RFC2646: Format=Flowed; Response
X-Original-NNTP-Posting-Host: hinsperg-xp.sybase.com
Message-ID: <434e78a6$1@forums-2-dub>
X-Original-Trace: 13 Oct 2005 08:09:26 -0700, hinsperg-xp.sybase.com
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 13 Oct 2005 08:09:27 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 13 Oct 2005 08:12:42 -0700
X-Trace: forums-1-dub 1129216362 10.22.108.75 (13 Oct 2005 08:12:42 -0700)
X-Original-Trace: 13 Oct 2005 08:12:42 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!forums-2-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:4853
Article PK: 8577

Have you got the same version of the .Net Framework on both machines?

--
Jason Hinsperger
Product Manager
iAnywhere Solutions
************************************************************
For the latest downloads technotes, whitepapers, webcasts and other
developer
resources, go to: http://www.ianywhere.com/developer/
************************************************************

"Alsin" <a.sinitsin[hot dog]ukr.net> wrote in message
news:434d37a1@forums-1-dub...
> Hello, All!
>
> I'm made application using Net data provider and trying to deploy it on
> production server. I'm read carefuly deploying instruction and implement
> all steps. So I have dbdata9.dll in my PATH and
> iAnywhere.Data.AsaClient.dll in GAC.
> On my development environment all works very well and fast.
> But on production I have strange issue:
> First statement that touches AsaClient assembly takes a looong time:
>
> AsaConnection conn = new AsaConnection(ConnString);
>
> And then fauls on conn.Open(). Error just 'System error'.
>
> What's wrong? How it can be cured?
>
> With best regards, Alsin. E-mail: a.sinitsin[hot dog]ukr.net
>


"Alsin" Posted on 2005-10-14 09:42:25.0Z
From: "Alsin" <a.sinitsin[hot dog]ukr.net>
Newsgroups: ianywhere.public.general
References: <434d37a1@forums-1-dub> <434e78a6$1@forums-2-dub>
Subject: Re: ASA .Net data provider issue
Lines: 7
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
X-RFC2646: Format=Flowed; Response
X-Comment-To: Jason Hinsperger (iAnywhere)
FL-Build: Fidolook 2002 (SL) 6.0.2800.86 - 14/6/2003 22:16:25
X-Original-NNTP-Posting-Host: alvion.com.ua
Message-ID: <434f7cb4$1@forums-2-dub>
X-Original-Trace: 14 Oct 2005 02:39:00 -0700, alvion.com.ua
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 14 Oct 2005 02:39:02 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 14 Oct 2005 02:42:25 -0700
X-Trace: forums-1-dub 1129282945 10.22.108.75 (14 Oct 2005 02:42:25 -0700)
X-Original-Trace: 14 Oct 2005 02:42:25 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!forums-2-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:4854
Article PK: 17452

It's not an Net issue. ASA client should be installed. Net data provider
doesn't work without client.

JHi> Have you got the same version of the .Net Framework on both machines?


Jason Hinsperger (iAnywhere) Posted on 2005-10-14 14:01:46.0Z
From: "Jason Hinsperger \(iAnywhere\)" <NOjason_hinspergerSPAM@hotmail.com>
Newsgroups: ianywhere.public.general
References: <434d37a1@forums-1-dub> <434e78a6$1@forums-2-dub> <434f7cb4$1@forums-2-dub>
Subject: Re: ASA .Net data provider issue
Lines: 33
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2527
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2527
X-RFC2646: Format=Flowed; Response
NNTP-Posting-Host: vpn-concord-174.sybase.com
X-Original-NNTP-Posting-Host: vpn-concord-174.sybase.com
Message-ID: <434fba4a$1@forums-1-dub>
Date: 14 Oct 2005 07:01:46 -0700
X-Trace: forums-1-dub 1129298506 158.159.8.174 (14 Oct 2005 07:01:46 -0700)
X-Original-Trace: 14 Oct 2005 07:01:46 -0700, vpn-concord-174.sybase.com
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:4855
Article PK: 31459

Your response isn;t clear to me. I asked if you have the same version of
the Microsoft .Net framework installed on both machines. The .Net framework
is required in order to use the ADO.Net data provider.
The fact that you have the same version of the ASA client software installed
on both machines and you have registered the provider with the gacutil, and
it works on one machine but not the other, indicates that the problem is in
the environment.
You need to determine what is different between the machines that could be
causing the problem. Different versions of the .Net Framework is something
that could be giving you trouble.

--
Jason Hinsperger
Product Manager
iAnywhere Solutions
************************************************************
For the latest downloads technotes, whitepapers, webcasts and other
developer
resources, go to: http://www.ianywhere.com/developer/
************************************************************

"Alsin" <a.sinitsin[hot dog]ukr.net> wrote in message
news:434f7cb4$1@forums-2-dub...
> It's not an Net issue. ASA client should be installed. Net data provider
> doesn't work without client.
>
> JHi> Have you got the same version of the .Net Framework on both machines?
>
>
>


"Alsin" Posted on 2005-10-17 08:01:44.0Z
From: "Alsin" <a.sinitsin[hot dog]ukr.net>
Newsgroups: ianywhere.public.general
References: <434d37a1@forums-1-dub> <434e78a6$1@forums-2-dub> <434f7cb4$1@forums-2-dub> <434fba4a$1@forums-1-dub>
Subject: Re: ASA .Net data provider issue
Lines: 15
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
X-RFC2646: Format=Flowed; Response
X-Comment-To: Jason Hinsperger (iAnywhere)
FL-Build: Fidolook 2002 (SL) 6.0.2800.86 - 14/6/2003 22:16:25
NNTP-Posting-Host: alvion.com.ua
X-Original-NNTP-Posting-Host: alvion.com.ua
Message-ID: <43535a68@forums-1-dub>
Date: 17 Oct 2005 01:01:44 -0700
X-Trace: forums-1-dub 1129536104 83.170.209.66 (17 Oct 2005 01:01:44 -0700)
X-Original-Trace: 17 Oct 2005 01:01:44 -0700, alvion.com.ua
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:4856
Article PK: 31460

Hello, Jason!
You wrote on 14 Oct 2005 07:01:46 -0700:

JHi> You need to determine what is different between the machines that
JHi> could be causing the problem. Different versions of the .Net
JHi> Framework is something that could be giving you trouble.

Both environements have NET Framework installed, but my developer
environment have ASA client software installed and production environement
don't have it. It's the reason. To work with ASA NET data provider we need
entire ASA client, not only data provider files.

With best regards, Alsin. E-mail: al_sin[hot dog]ukr.net


Greg Fenton Posted on 2005-10-17 13:28:49.0Z
From: Greg Fenton <greg.fenton_NOSPAM_@ianywhere.com>
Organization: iAnywhere Solutions Inc.
User-Agent: Mozilla Thunderbird 1.6.3.2f (Windows/20050317)
X-Accept-Language: en-us, en
MIME-Version: 1.0
Newsgroups: ianywhere.public.general
Subject: Re: ASA .Net data provider issue
References: <434d37a1@forums-1-dub> <434e78a6$1@forums-2-dub> <434f7cb4$1@forums-2-dub> <434fba4a$1@forums-1-dub> <43535a68@forums-1-dub>
In-Reply-To: <43535a68@forums-1-dub>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
X-Original-NNTP-Posting-Host: gfenton-t30.sybase.com
Message-ID: <4353a636$1@forums-2-dub>
X-Original-Trace: 17 Oct 2005 06:25:10 -0700, gfenton-t30.sybase.com
Lines: 28
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 17 Oct 2005 06:25:11 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 17 Oct 2005 06:28:49 -0700
X-Trace: forums-1-dub 1129555729 10.22.108.75 (17 Oct 2005 06:28:49 -0700)
X-Original-Trace: 17 Oct 2005 06:28:49 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!forums-2-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:4857
Article PK: 8578


Alsin wrote:
> Both environements have NET Framework installed, but my developer
> environment have ASA client software installed and production environement
> don't have it. It's the reason. To work with ASA NET data provider we need
> entire ASA client, not only data provider files.
>

Please always post the version and build number of SQLAnywhere that you
are using (e.g. use the command "dbeng9 -v" for SQLAnywhere 9.x).


In the SQLAnywhere 9.x online documentation, see the section:

ASA Programming Guide
Developing Applications with the .NET Data Provider
- Deploying the Adaptive Server Anywhere .NET data provider

and more specifically the link "Adaptive Server Anywhere .NET data
provider required files" on that page.

greg.fenton
--
Greg Fenton
Consultant, Solution Services, iAnywhere Solutions
--------
Visit the iAnywhere Solutions Developer Community
Whitepapers, TechDocs, Downloads
http://www.ianywhere.com/developer/