Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Provider not found error

2 posts in Visual Basic Last posting was on 2005-10-25 19:48:51.0Z
King Wilder Posted on 2005-10-25 01:47:59.0Z
From: "King Wilder" <king@gizmobeach.com>
Newsgroups: advantage.visual_basic
Subject: Provider not found error
Date: Mon, 24 Oct 2005 18:47:59 -0700
Lines: 37
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.3790.326
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.326
NNTP-Posting-Host: 216.165.224.155
Message-ID: <435d90ad@solutions.advantagedatabase.com>
X-Trace: 24 Oct 2005 19:55:57 -0700, 216.165.224.155
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!216.165.224.155
Xref: solutions.advantagedatabase.com Advantage.Visual_Basic:1036
Article PK: 1137829

I've written a VB 6 app that connects to a remote (or local) DBF file using
ADS.

On my development machine the app works perfectly. On Client 1 machine it
works perfectly. On Client 2 and 3 machines it returns the error.

I've created a Setup file using the Package and Deployment wizard and
installed it on the clients XP machines using PCAnywhere and the app returns
an error: "Provider not found" on both machines.

I've included all the necessary ADS files in the installation. Does anyone
know why this error would occur?

I know I'm probably missing something but I can't figure out what it is.
This is my connection string:

Provider=Advantage.OLEDB.1;Data
Source=P:\AbacusMR;ServerType=ADS_REMOTE_SERVER|ADS_LOCAL_SERVER;TableType=A
DS_CDX;CharType=ADS_ANSI;LockMode=ADS_PROPRIETARY_LOCKING;SecurityMode=ADS_I
GNORERIGHTS

Any help would be appreciated.

Thanks,

King Wilder


--
----------------------
Gizmo Beach
www.gizmobeach.com
king@gizmobeach.com
626 351-4334
---------------------


Brad Schmidt Posted on 2005-10-25 19:48:51.0Z
From: Brad Schmidt <brad.schmidt.nospam@extendedsystems.com>
Newsgroups: advantage.visual_basic
Subject: Re: Provider not found error
Date: Tue, 25 Oct 2005 13:48:51 -0600
Message-ID: <MPG.1dc83a0b6c0c890f989808@solutions.AdvantageDatabase.com>
References: <435d90ad@solutions.advantagedatabase.com>
Organization: ESI
X-Newsreader: MicroPlanet Gravity v2.50
NNTP-Posting-Host: 198.102.102.23
X-Trace: 25 Oct 2005 13:56:58 -0700, 198.102.102.23
Lines: 36
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!198.102.102.23
Xref: solutions.advantagedatabase.com Advantage.Visual_Basic:1037
Article PK: 1137832

In addition to installing the Advantage OLE DB Provider DLL
(adsoledb.dll), did you also register it on clients 2 and 3?

In article <435d90ad@solutions.advantagedatabase.com>,
king@gizmobeach.com says...

> I've written a VB 6 app that connects to a remote (or local) DBF file using
> ADS.
>
> On my development machine the app works perfectly. On Client 1 machine it
> works perfectly. On Client 2 and 3 machines it returns the error.
>
> I've created a Setup file using the Package and Deployment wizard and
> installed it on the clients XP machines using PCAnywhere and the app returns
> an error: "Provider not found" on both machines.
>
> I've included all the necessary ADS files in the installation. Does anyone
> know why this error would occur?
>
> I know I'm probably missing something but I can't figure out what it is.
> This is my connection string:
>
> Provider=Advantage.OLEDB.1;Data
> Source=P:\AbacusMR;ServerType=ADS_REMOTE_SERVER|ADS_LOCAL_SERVER;TableType=A
> DS_CDX;CharType=ADS_ANSI;LockMode=ADS_PROPRIETARY_LOCKING;SecurityMode=ADS_I
> GNORERIGHTS
>
> Any help would be appreciated.
>
> Thanks,
>
> King Wilder

Brad
--
* Brad Schmidt
* Extended Systems, Inc