Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Failure to load AEP with with REMOTE, but LOCAL ok

7 posts in AEP Last posting was on 2006-02-10 16:03:50.0Z
Jim Kowalka Posted on 2005-10-26 17:58:46.0Z
From: "Jim Kowalka" <jim@fhgsystems.com>
Newsgroups: Advantage.AEP
Subject: Failure to load AEP with with REMOTE, but LOCAL ok
Date: Wed, 26 Oct 2005 13:58:46 -0400
Lines: 26
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1506
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1506
NNTP-Posting-Host: 24.29.38.25
Message-ID: <435fc5b7@solutions.advantagedatabase.com>
X-Trace: 26 Oct 2005 12:06:47 -0700, 24.29.38.25
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!24.29.38.25
Xref: solutions.advantagedatabase.com Advantage.AEP:448
Article PK: 1103732

My AEP execution return the following error when the Advantage Server is
running:

BuildListFileAEP:
Error 7200:
AQE Error:
State = HY000;
NativeError = 5154;
[Extended Systems][Advantage SQL][ASA]Error 5154: Execution of the stored
procedure failed.
The stored procedure named "BuildPLCData" requires the AEP named
"C:\VVSVIEW\VWRAEP.AEP".
The AEP failed to load with an error code 127.
The specified procedure could not be found.

The AEP call works fine when the ADS is NOT running and I am using the Local
Server. The VWRAEP.AEP dll IS located in the directory. The BuildPLCData
procedure IS properly exported in the AEP DLL. Once again, the AEP works
fine as soon as I stop the Advantage Server. Can anyone give me any
pointers as to what the problem is. The only thing I can think of is that
the Server is has an issue with the path the AEP, but the AEP is in the same
directory ast the dictionary.

Any help is greatly appreciated...Jim K.


Joachim Duerr (ADS Support) Posted on 2005-10-27 14:26:04.0Z
From: "Joachim Duerr (ADS Support)" <jojo.duerr@gmx.de>
Subject: Re: Failure to load AEP with with REMOTE, but LOCAL ok
Newsgroups: Advantage.AEP
References: <435fc5b7@solutions.advantagedatabase.com>
Organization: Extended Systems GmbH
User-Agent: XanaNews/1.17.6.5
X-Face: ,QMv7[luB)BpWAQ~:"kw6n%0ieY63.:g2K3n~8ky0;||5Xle*Xq+=~<Fy:0CVC2nx@8~vZ
MIME-Version: 1.0
Content-Type: text/plain; charset=iso-8859-1
NNTP-Posting-Host: 195.2.185.25
Message-ID: <4360d56c@solutions.advantagedatabase.com>
Date: 27 Oct 2005 07:26:04 -0700
X-Trace: 27 Oct 2005 07:26:04 -0700, 195.2.185.25
Lines: 17
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!195.2.185.25
Xref: solutions.advantagedatabase.com Advantage.AEP:449
Article PK: 1103729


Jim Kowalka wrote in <435fc5b7@solutions.advantagedatabase.com>:

> The AEP call works fine when the ADS is NOT running and I am using
> the Local Server. The VWRAEP.AEP dll IS located in the directory.
> The BuildPLCData procedure IS properly exported in the AEP DLL. Once
> again, the AEP works fine as soon as I stop the Advantage Server.
> Can anyone give me any pointers as to what the problem is. The only
> thing I can think of is that the Server is has an issue with the path
> the AEP, but the AEP is in the same directory ast the dictionary.

could you please post the SQL dump of the AEP (generated via
Architect->select the AEP->right mouse->generate SQL script)?

--
Joachim Duerr
EMEA Lead ADS Support, Extended Systems GmbH, Germany
advantage[AT]extendsys.de


Jim Kowalka Posted on 2005-10-28 17:51:19.0Z
From: "Jim Kowalka" <jim@fhgsystems.com>
Newsgroups: Advantage.AEP
References: <435fc5b7@solutions.advantagedatabase.com> <4360d56c@solutions.advantagedatabase.com>
Subject: Re: Failure to load AEP with with REMOTE, but LOCAL ok
Date: Fri, 28 Oct 2005 13:51:19 -0400
Lines: 37
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1506
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1506
NNTP-Posting-Host: 24.29.38.25
Message-ID: <43626703@solutions.advantagedatabase.com>
X-Trace: 28 Oct 2005 11:59:31 -0700, 24.29.38.25
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!24.29.38.25
Xref: solutions.advantagedatabase.com Advantage.AEP:450
Article PK: 1103733


"Joachim Duerr (ADS Support)" <jojo.duerr@gmx.de> wrote in message
news:4360d56c@solutions.advantagedatabase.com...
> Jim Kowalka wrote in <435fc5b7@solutions.advantagedatabase.com>:
>
> > The AEP call works fine when the ADS is NOT running and I am using
> > the Local Server. The VWRAEP.AEP dll IS located in the directory.
> > The BuildPLCData procedure IS properly exported in the AEP DLL. Once
> > again, the AEP works fine as soon as I stop the Advantage Server.
> > Can anyone give me any pointers as to what the problem is. The only
> > thing I can think of is that the Server is has an issue with the path
> > the AEP, but the AEP is in the same directory ast the dictionary.
>
> could you please post the SQL dump of the AEP (generated via
> Architect->select the AEP->right mouse->generate SQL script)?
>
> --
> Joachim Duerr
> EMEA Lead ADS Support, Extended Systems GmbH, Germany
> advantage[AT]extendsys.de

I'm sorry, but I wasn't able to figure out how to get the SQL dump. I am
using Delphi 5
with an ADSStoredProc component. It doesn't return SQL data. It is
designed to create some data files
on the server which are then loaded at a later time by the client. I opened
the dictionary in data architect, but the AEP file was not listed there. If
I try to open the AEP directly, it give a database error(it isn't a table
component).
But the main problem that I can
see is that it doesn't seem like the ADS server is locating the AEP file, or
it is not able to get the handle of the exported routine from the dll. If
the local server reads and loads the procedure ok and the ADS doesn't, are
there any ADS Server parameters that might need to be set to enable the
server to correctly find the aep location?


Joachim Duerr (ADS Support) Posted on 2005-10-28 20:02:17.0Z
From: "Joachim Duerr (ADS Support)" <jojo.duerr@gmx.de>
Subject: Re: Failure to load AEP with with REMOTE, but LOCAL ok
Newsgroups: Advantage.AEP
References: <435fc5b7@solutions.advantagedatabase.com> <4360d56c@solutions.advantagedatabase.com> <43626703@solutions.advantagedatabase.com>
Organization: Extended Systems GmbH
User-Agent: XanaNews/1.17.6.5
X-Face: ,QMv7[luB)BpWAQ~:"kw6n%0ieY63.:g2K3n~8ky0;||5Xle*Xq+=~<Fy:0CVC2nx@8~vZ
MIME-Version: 1.0
Content-Type: text/plain; charset=iso-8859-1
NNTP-Posting-Host: 84.158.149.181
Message-ID: <436275b9@solutions.advantagedatabase.com>
Date: 28 Oct 2005 13:02:17 -0700
X-Trace: 28 Oct 2005 13:02:17 -0700, 84.158.149.181
Lines: 26
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!84.158.149.181
Xref: solutions.advantagedatabase.com Advantage.AEP:451
Article PK: 1103740


Jim Kowalka wrote in <43626703@solutions.advantagedatabase.com>:

> I'm sorry, but I wasn't able to figure out how to get the SQL dump.
> I am using Delphi 5
> with an ADSStoredProc component. It doesn't return SQL data. It is
> designed to create some data files
> on the server which are then loaded at a later time by the client. I
> opened the dictionary in data architect, but the AEP file was not
> listed there. If I try to open the AEP directly, it give a database
> error(it isn't a table component).
> But the main problem that I can
> see is that it doesn't seem like the ADS server is locating the AEP
> file, or it is not able to get the handle of the exported routine
> from the dll. If the local server reads and loads the procedure ok
> and the ADS doesn't, are there any ADS Server parameters that might
> need to be set to enable the server to correctly find the aep
> location?

If Architect doen't show the AEP in the tree, than you didn't set it up
in the dictionary. You first need to add it to the dictionary, defining
the name, the path, the method name and the parameters.

--
Joachim Duerr
EMEA Lead ADS Support, Extended Systems GmbH, Germany
advantage[AT]extendsys.de


Jim Kowalka Posted on 2005-10-29 15:22:20.0Z
From: "Jim Kowalka" <jim@fhgsystems.com>
Newsgroups: Advantage.AEP
References: <435fc5b7@solutions.advantagedatabase.com> <4360d56c@solutions.advantagedatabase.com> <43626703@solutions.advantagedatabase.com> <436275b9@solutions.advantagedatabase.com>
Subject: Re: Failure to load AEP with with REMOTE, but LOCAL ok
Date: Sat, 29 Oct 2005 11:22:20 -0400
Lines: 65
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1506
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1506
NNTP-Posting-Host: 24.29.38.25
Message-ID: <43639596@solutions.advantagedatabase.com>
X-Trace: 29 Oct 2005 09:30:30 -0700, 24.29.38.25
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!24.29.38.25
Xref: solutions.advantagedatabase.com Advantage.AEP:452
Article PK: 1103739


"Joachim Duerr (ADS Support)" <jojo.duerr@gmx.de> wrote in message
news:436275b9@solutions.advantagedatabase.com...
> Jim Kowalka wrote in <43626703@solutions.advantagedatabase.com>:
>
> > I'm sorry, but I wasn't able to figure out how to get the SQL dump.
> > I am using Delphi 5
> > with an ADSStoredProc component. It doesn't return SQL data. It is
> > designed to create some data files
> > on the server which are then loaded at a later time by the client. I
> > opened the dictionary in data architect, but the AEP file was not
> > listed there. If I try to open the AEP directly, it give a database
> > error(it isn't a table component).
> > But the main problem that I can
> > see is that it doesn't seem like the ADS server is locating the AEP
> > file, or it is not able to get the handle of the exported routine
> > from the dll. If the local server reads and loads the procedure ok
> > and the ADS doesn't, are there any ADS Server parameters that might
> > need to be set to enable the server to correctly find the aep
> > location?
>
> If Architect doen't show the AEP in the tree, than you didn't set it up
> in the dictionary. You first need to add it to the dictionary, defining
> the name, the path, the method name and the parameters.
>
> --
> Joachim Duerr
> EMEA Lead ADS Support, Extended Systems GmbH, Germany
> advantage[AT]extendsys.de

The procedure has been added into the dictionary through the Delphi
Dictionary Component Addprocedure method.
The Architect doesn't show it in any tree, but "Select * from
system.storedprocedures" returns:
Item Name Proc_Input Proc_Output
Proc_DLL_Name Proc_Function_Name Comment
----------------------------------------------------------------------------
-------------------------------------------
1 BuildPLCData INFILE,Char,256 OUTFILE,Char,256 .\VWRAEP.AEP
BuildPLCData

I tried defining the DLL Name with and without the '.\'. The procedure was
added to the dictionary with the Delphi
ADDPROCEDURE call:
AddProcedure('BuildPLCData','.\VWRAEP.AEP','BuildPLCData',
ADS_STORED_PROC,'INFILE,Char,256',
'OUTFILE,Char,256','');

Does the AEP function need to be defined in the DLL all upper or lowercase?
I've tried all lower and that doesn't work either.

Error 127 is returned:
The AEP failed to load with an error code 127.
The specified procedure could not be found.
Do you know if the error 127 means that the AEP itself was unable to load
(because it can't find the DLL), or does it mean that the exported
BuildPLCData address was not able to be located within the loaded AEP? If I
knew exactly what the error was referring to I might be able to figure it
out easier.

Thanks for your help...Jim


J.D. Mullin Posted on 2005-10-31 18:08:08.0Z
From: "J.D. Mullin" <no@email.com>
Newsgroups: Advantage.AEP
References: <435fc5b7@solutions.advantagedatabase.com>
Subject: Re: Failure to load AEP with with REMOTE, but LOCAL ok
Date: Mon, 31 Oct 2005 11:08:08 -0700
Lines: 43
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: 198.102.102.44
Message-ID: <43665f8b@solutions.advantagedatabase.com>
X-Trace: 31 Oct 2005 11:16:43 -0700, 198.102.102.44
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!solutions.advantagedatabase.com!198.102.102.44
Xref: solutions.advantagedatabase.com Advantage.AEP:453
Article PK: 1103737

Your server might be loading a different (older) version of ACE? Verify all
of the DLLs your DLL requires are in the search path that the ADS server
will use. Check the ace32.dll in your Advantage server directory too.

You will get the 127 error if any of the DLLs yours depends on are not in
the search path.

--
J.D. Mullin
Advantage R&D
--

"Jim Kowalka" <jim@fhgsystems.com> wrote in message
news:435fc5b7@solutions.advantagedatabase.com...
> My AEP execution return the following error when the Advantage Server is
> running:
>
> BuildListFileAEP:
> Error 7200:
> AQE Error:
> State = HY000;
> NativeError = 5154;
> [Extended Systems][Advantage SQL][ASA]Error 5154: Execution of the stored
> procedure failed.
> The stored procedure named "BuildPLCData" requires the AEP named
> "C:\VVSVIEW\VWRAEP.AEP".
> The AEP failed to load with an error code 127.
> The specified procedure could not be found.
>
> The AEP call works fine when the ADS is NOT running and I am using the
> Local
> Server. The VWRAEP.AEP dll IS located in the directory. The BuildPLCData
> procedure IS properly exported in the AEP DLL. Once again, the AEP works
> fine as soon as I stop the Advantage Server. Can anyone give me any
> pointers as to what the problem is. The only thing I can think of is that
> the Server is has an issue with the path the AEP, but the AEP is in the
> same
> directory ast the dictionary.
>
> Any help is greatly appreciated...Jim K.
>
>


Joachim Duerr (ADS Support) Posted on 2006-02-10 16:03:50.0Z
From: "Joachim Duerr (ADS Support)" <jojo.duerr@gmx.de>
Subject: Re: Failure to load AEP with with REMOTE, but LOCAL ok
Newsgroups: Advantage.AEP
References: <435fc5b7@solutions.advantagedatabase.com>
Organization: iAnywhere
User-Agent: XanaNews/1.17.6.5
X-Face: ,QMv7[luB)BpWAQ~:"kw6n%0ieY63.:g2K3n~8ky0;||5Xle*Xq+=~<Fy:0CVC2nx@8~vZ
MIME-Version: 1.0
Content-Type: text/plain; charset=iso-8859-1
NNTP-Posting-Host: 195.2.185.25
Message-ID: <43ecb966@solutions.advantagedatabase.com>
Date: 10 Feb 2006 09:03:50 -0700
X-Trace: 10 Feb 2006 09:03:50 -0700, 195.2.185.25
Lines: 18
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!195.2.185.25
Xref: solutions.advantagedatabase.com Advantage.AEP:454
Article PK: 1103738


Jim Kowalka wrote in <435fc5b7@solutions.advantagedatabase.com>:

> The AEP call works fine when the ADS is NOT running and I am using
> the Local Server. The VWRAEP.AEP dll IS located in the directory.
> The BuildPLCData procedure IS properly exported in the AEP DLL. Once
> again, the AEP works fine as soon as I stop the Advantage Server.
> Can anyone give me any pointers as to what the problem is. The only
> thing I can think of is that the Server is has an issue with the path
> the AEP, but the AEP is in the same directory ast the dictionary.

Check out if the SYSTEM group has full access rights to the folder and
the file.

--
Joachim Duerr
Senior Product Support Analyst (Advantage Database Server)
iAnywhere Solutions / Extended Systems
advantage[AT]extendsys.de