Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Getting -1 in createjavaVM() in PB10

5 posts in EJB Client Last posting was on 2005-10-28 09:44:50.0Z
Sreelatha Posted on 2005-10-26 21:34:13.0Z
From: "Sreelatha" <sreelatha.budideti@medica.com>
Newsgroups: sybase.public.powerbuilder.ejbclient
Organization: 207.126.177.34
X-Newsreader: AspNNTP 1.50 (Takeshi Eto)
Subject: Getting -1 in createjavaVM() in PB10
Mime-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: web110.discountasp.net
X-Original-NNTP-Posting-Host: web110.discountasp.net
Message-ID: <435ff655$1@forums-1-dub>
Date: 26 Oct 2005 14:34:13 -0700
X-Trace: forums-1-dub 1130362453 64.79.161.40 (26 Oct 2005 14:34:13 -0700)
X-Original-Trace: 26 Oct 2005 14:34:13 -0700, web110.discountasp.net
Lines: 11
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.ejbclient:587
Article PK: 424715

Hi,
We are testing PB10 beta to get migrate our code. It's working fine for me in PB
workspace and even executable in shared drive. If somebody accesses the
executable from shared drive they getting Exeception in CreateJavaVM(). It's
returning -1. I'm using PB10 with RAD6 EJBs.
Any help would be appreciated.
Thanks,
Sreelatha

---== Posted via the PFCGuide Web Newsreader ==---
http://www.pfcguide.com/_newsgroups/group_list.asp


Bede <bede_nosp Posted on 2005-10-27 06:47:05.0Z
From: Bede <bede_nosp@m_sofico.be>
Newsgroups: sybase.public.powerbuilder.ejbclient
Subject: Re: Getting -1 in createjavaVM() in PB10
Message-ID: <MPG.1dca9536bb2196d1989752@forums.sybase.com>
References: <435ff655$1@forums-1-dub>
Organization: Sofico
MIME-Version: 1.0
Content-Type: text/plain; charset="iso-8859-15"
Content-Transfer-Encoding: 7bit
User-Agent: MicroPlanet-Gravity/2.70.2067
NNTP-Posting-Host: uu194-7-38-226.unknown.uunet.be
X-Original-NNTP-Posting-Host: uu194-7-38-226.unknown.uunet.be
Date: 26 Oct 2005 23:47:05 -0700
X-Trace: forums-1-dub 1130395625 194.7.38.226 (26 Oct 2005 23:47:05 -0700)
X-Original-Trace: 26 Oct 2005 23:47:05 -0700, uu194-7-38-226.unknown.uunet.be
Lines: 36
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.ejbclient:588
Article PK: 424716

Hi,

Could you be more precise about what exactly is going wrong when?
=> "It's working fine .. even executable in shared drive"

but then you add "If somebody accesses the executable from shared drive
they getting Exeception in CreateJavaVM()."

I'm not so sure about the exe and pbds (i believe it is not recommended
to put these in a shared dir), we just put the jre in the directory of
the exe (the pb dll files are there too i hope).
The classpath can include jars of shared drives without problems.

Anyway, am still wondering which version and manufacturer(Sun/IBM) of
JDK/JRE you're using and how you eventually got it to work. (see your
previous post in this group)

Good luck,

Ben


In article <435ff655$1@forums-1-dub>, sreelatha.budideti@medica.com
says...

> Hi,
> We are testing PB10 beta to get migrate our code. It's working fine for me in PB
> workspace and even executable in shared drive. If somebody accesses the
> executable from shared drive they getting Exeception in CreateJavaVM(). It's
> returning -1. I'm using PB10 with RAD6 EJBs.
> Any help would be appreciated.
> Thanks,
> Sreelatha
>
> ---== Posted via the PFCGuide Web Newsreader ==---
> http://www.pfcguide.com/_newsgroups/group_list.asp
>


Sreelatha Posted on 2005-10-27 15:24:39.0Z
From: "Sreelatha" <sreelatha.budideti@medica.com>
Newsgroups: sybase.public.powerbuilder.ejbclient
Organization: 207.126.177.34
References: <435ff655$1@forums-1-dub> <MPG.1dca9536bb2196d1989752@forums.sybase.com>
X-Newsreader: AspNNTP 1.50 (Takeshi Eto)
Subject: Re: Getting -1 in createjavaVM() in PB10
Mime-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: web110.discountasp.net
X-Original-NNTP-Posting-Host: web110.discountasp.net
Message-ID: <4360f137$1@forums-1-dub>
Date: 27 Oct 2005 08:24:39 -0700
X-Trace: forums-1-dub 1130426679 64.79.161.40 (27 Oct 2005 08:24:39 -0700)
X-Original-Trace: 27 Oct 2005 08:24:39 -0700, web110.discountasp.net
Lines: 57
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.ejbclient:589
Article PK: 424717

I compiled the code put that in the shared directory, so that testers can access
it. If I run the exe from my machine, it is working for me. If tester access
that from their machines it is NOT working for them. I think I had all the dlls
I need in that exe folder. We never put jvm.dll in PB9 compile. But, it was
finding in the classpath and was working fine.

Now I tried to put the jvm.dll in the directory of exe, I'm getting same
exception as testers. Somehow, it's finiding some dll (or what not) finding in
my classpath. So, it is working in my machine, but not any other machine. So, I
need to find WHAT it is finding in my classpath.


I'm using JDK1.4(Sun). RAD6 didn't work with PB9, I got problems all over the
code. So, I'm trying with PB10.

-Latha

On 26 Oct 2005 23:47:05 -0700,
in sybase.public.powerbuilder.ejbclient

Bede <bede_nosp@m_sofico.be> wrote:
>Hi,
>
>Could you be more precise about what exactly is going wrong when?
>=> "It's working fine .. even executable in shared drive"
>
>but then you add "If somebody accesses the executable from shared drive
>they getting Exeception in CreateJavaVM()."
>
>I'm not so sure about the exe and pbds (i believe it is not recommended
>to put these in a shared dir), we just put the jre in the directory of
>the exe (the pb dll files are there too i hope).
>The classpath can include jars of shared drives without problems.
>
>Anyway, am still wondering which version and manufacturer(Sun/IBM) of
>JDK/JRE you're using and how you eventually got it to work. (see your
>previous post in this group)
>
>Good luck,
>
>Ben
>
>
>In article <435ff655$1@forums-1-dub>, sreelatha.budideti@medica.com
>says...
>> Hi,
>> We are testing PB10 beta to get migrate our code. It's working fine for me in
PB
>> workspace and even executable in shared drive. If somebody accesses the
>> executable from shared drive they getting Exeception in CreateJavaVM(). It's
>> returning -1. I'm using PB10 with RAD6 EJBs.
>> Any help would be appreciated.
>> Thanks,
>> Sreelatha
>>
>> ---== Posted via the PFCGuide Web Newsreader ==---
>> http://www.pfcguide.com/_newsgroups/group_list.asp
>>


Bede <bede_nosp Posted on 2005-10-28 09:44:50.0Z
From: Bede <bede_nosp@m_sofico.be>
Newsgroups: sybase.public.powerbuilder.ejbclient
Subject: Re: Getting -1 in createjavaVM() in PB10
Message-ID: <MPG.1dcc106b59477c71989754@forums.sybase.com>
References: <435ff655$1@forums-1-dub> <MPG.1dca9536bb2196d1989752@forums.sybase.com> <4360f137$1@forums-1-dub>
Organization: Sofico
MIME-Version: 1.0
Content-Type: text/plain; charset="iso-8859-15"
Content-Transfer-Encoding: 7bit
User-Agent: MicroPlanet-Gravity/2.70.2067
X-Original-NNTP-Posting-Host: uu194-7-38-226.unknown.uunet.be
X-Original-Trace: 28 Oct 2005 02:40:09 -0700, uu194-7-38-226.unknown.uunet.be
Lines: 74
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 28 Oct 2005 02:40:10 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 28 Oct 2005 02:44:50 -0700
X-Trace: forums-1-dub 1130492690 10.22.108.75 (28 Oct 2005 02:44:50 -0700)
X-Original-Trace: 28 Oct 2005 02:44:50 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!forums-2-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.ejbclient:591
Article PK: 424718

btw,

the jvm.dll is part of your jre,

so make sure the directory that contains the exe also contains a jre
folder and the loaded jre.dll is .\jre\bin\client\jvm.dll


Ben

PS: we're on JDK142_07 (Sun) and working fine (but beware the runtime
java startup props in LOCAL_MACHINE)


In article <4360f137$1@forums-1-dub>, sreelatha.budideti@medica.com
says...

> I compiled the code put that in the shared directory, so that testers can access
> it. If I run the exe from my machine, it is working for me. If tester access
> that from their machines it is NOT working for them. I think I had all the dlls
> I need in that exe folder. We never put jvm.dll in PB9 compile. But, it was
> finding in the classpath and was working fine.
>
> Now I tried to put the jvm.dll in the directory of exe, I'm getting same
> exception as testers. Somehow, it's finiding some dll (or what not) finding in
> my classpath. So, it is working in my machine, but not any other machine. So, I
> need to find WHAT it is finding in my classpath.
>
>
> I'm using JDK1.4(Sun). RAD6 didn't work with PB9, I got problems all over the
> code. So, I'm trying with PB10.
>
> -Latha
>
> On 26 Oct 2005 23:47:05 -0700,
> in sybase.public.powerbuilder.ejbclient
> Bede <bede_nosp@m_sofico.be> wrote:
> >Hi,
> >
> >Could you be more precise about what exactly is going wrong when?
> >=> "It's working fine .. even executable in shared drive"
> >
> >but then you add "If somebody accesses the executable from shared drive
> >they getting Exeception in CreateJavaVM()."
> >
> >I'm not so sure about the exe and pbds (i believe it is not recommended
> >to put these in a shared dir), we just put the jre in the directory of
> >the exe (the pb dll files are there too i hope).
> >The classpath can include jars of shared drives without problems.
> >
> >Anyway, am still wondering which version and manufacturer(Sun/IBM) of
> >JDK/JRE you're using and how you eventually got it to work. (see your
> >previous post in this group)
> >
> >Good luck,
> >
> >Ben
> >
> >
> >In article <435ff655$1@forums-1-dub>, sreelatha.budideti@medica.com
> >says...
> >> Hi,
> >> We are testing PB10 beta to get migrate our code. It's working fine for me in
> PB
> >> workspace and even executable in shared drive. If somebody accesses the
> >> executable from shared drive they getting Exeception in CreateJavaVM(). It's
> >> returning -1. I'm using PB10 with RAD6 EJBs.
> >> Any help would be appreciated.
> >> Thanks,
> >> Sreelatha
> >>
> >> ---== Posted via the PFCGuide Web Newsreader ==---
> >> http://www.pfcguide.com/_newsgroups/group_list.asp
> >>
>


Bede <bede_nosp Posted on 2005-10-28 09:38:43.0Z
From: Bede <bede_nosp@m_sofico.be>
Newsgroups: sybase.public.powerbuilder.ejbclient
Subject: Re: Getting -1 in createjavaVM() in PB10
Message-ID: <MPG.1dcc0edbdbec0d989753@forums.sybase.com>
References: <435ff655$1@forums-1-dub> <MPG.1dca9536bb2196d1989752@forums.sybase.com> <4360f137$1@forums-1-dub>
Organization: Sofico
MIME-Version: 1.0
Content-Type: text/plain; charset="iso-8859-15"
Content-Transfer-Encoding: 7bit
User-Agent: MicroPlanet-Gravity/2.70.2067
X-Original-NNTP-Posting-Host: uu194-7-38-226.unknown.uunet.be
X-Original-Trace: 28 Oct 2005 02:33:59 -0700, uu194-7-38-226.unknown.uunet.be
Lines: 99
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 28 Oct 2005 02:34:00 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 28 Oct 2005 02:38:43 -0700
X-Trace: forums-1-dub 1130492323 10.22.108.75 (28 Oct 2005 02:38:43 -0700)
X-Original-Trace: 28 Oct 2005 02:38:43 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!forums-2-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.ejbclient:590
Article PK: 424719

Hi,

sounds indeed like a case of either a missing or wrong file version that
works for you because of local path settings.

spose you double-checked the version of the jvm.dll..
there are tools available to verify what dlls are loaded and which
version they're of
(eg: http://www.sysinternals.com/Utilities/ProcessExplorer.html)

i'd still advise to copy all files onto the tester's machine and try
that first, before using a shared drive.

FYI, here's our dll list for pb90; depending on your requirements you
may need more/less files.

libjcc.dll
libjsybheap.dll
pbdwe90.dll
pbejbclient90.dll
pbejbclient90.jar
pbejbclient90.pbd
pbjvm90.dll
pblab90.ini
pbodb90.dll
pbodb90.ini
pbrtc90.dll
pbtra90.dll
pbvm90.dll
PBXerces90.dll
pfccom32.DLL
pfcdlg.hlp
xerces-c_1_5_1.dll
xerces-c_2_1_0.dll

Cheers,

Ben

In article <4360f137$1@forums-1-dub>, sreelatha.budideti@medica.com
says...

> I compiled the code put that in the shared directory, so that testers can access
> it. If I run the exe from my machine, it is working for me. If tester access
> that from their machines it is NOT working for them. I think I had all the dlls
> I need in that exe folder. We never put jvm.dll in PB9 compile. But, it was
> finding in the classpath and was working fine.
>
> Now I tried to put the jvm.dll in the directory of exe, I'm getting same
> exception as testers. Somehow, it's finiding some dll (or what not) finding in
> my classpath. So, it is working in my machine, but not any other machine. So, I
> need to find WHAT it is finding in my classpath.
>
>
> I'm using JDK1.4(Sun). RAD6 didn't work with PB9, I got problems all over the
> code. So, I'm trying with PB10.
>
> -Latha
>
> On 26 Oct 2005 23:47:05 -0700,
> in sybase.public.powerbuilder.ejbclient
> Bede <bede_nosp@m_sofico.be> wrote:
> >Hi,
> >
> >Could you be more precise about what exactly is going wrong when?
> >=> "It's working fine .. even executable in shared drive"
> >
> >but then you add "If somebody accesses the executable from shared drive
> >they getting Exeception in CreateJavaVM()."
> >
> >I'm not so sure about the exe and pbds (i believe it is not recommended
> >to put these in a shared dir), we just put the jre in the directory of
> >the exe (the pb dll files are there too i hope).
> >The classpath can include jars of shared drives without problems.
> >
> >Anyway, am still wondering which version and manufacturer(Sun/IBM) of
> >JDK/JRE you're using and how you eventually got it to work. (see your
> >previous post in this group)
> >
> >Good luck,
> >
> >Ben
> >
> >
> >In article <435ff655$1@forums-1-dub>, sreelatha.budideti@medica.com
> >says...
> >> Hi,
> >> We are testing PB10 beta to get migrate our code. It's working fine for me in
> PB
> >> workspace and even executable in shared drive. If somebody accesses the
> >> executable from shared drive they getting Exeception in CreateJavaVM(). It's
> >> returning -1. I'm using PB10 with RAD6 EJBs.
> >> Any help would be appreciated.
> >> Thanks,
> >> Sreelatha
> >>
> >> ---== Posted via the PFCGuide Web Newsreader ==---
> >> http://www.pfcguide.com/_newsgroups/group_list.asp
> >>
>