Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

dbbackup.exe fails on windows server 2003

10 posts in General Discussion Last posting was on 2006-05-17 14:04:08.0Z
Eran Posted on 2005-12-04 14:31:03.0Z
Sender: 6c09.4392fbc9.1804289383@sybase.com
From: Eran
Newsgroups: ianywhere.public.general
Subject: dbbackup.exe fails on windows server 2003
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4392fda7.6c15.1681692777@sybase.com>
MIME-Version: 1.0
Content-Type: text/plain; charset="ISO-8859-1"
Content-Transfer-Encoding: quoted-printable
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 4 Dec 2005 06:31:03 -0800
X-Trace: forums-1-dub 1133706663 10.22.241.41 (4 Dec 2005 06:31:03 -0800)
X-Original-Trace: 4 Dec 2005 06:31:03 -0800, 10.22.241.41
Lines: 18
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:5018
Article PK: 17481

Hi
I'm trying to run dbbackup for ASA 8.0.2.4513.
the command line is :
dbbackup.exe" -o %logFile% -c
"dbf=%testPath%\bin\sybase\mydb.db;uid=%uid%;pwd=%pwd%"
"ºckupDir%"

I get error:
Adaptive Server Anywhere Backup Utility Version 8.0.2.4513
Specified database is invalid
ERROR: Unable to copy netally.db to backup directory c:\tmp.

if I create dsnfile and use it in the in the connection the
backup works just fine .
Any idea ????

Thanks
Eran


Greg Fenton Posted on 2005-12-04 19:27:26.0Z
From: Greg Fenton <greg.fenton_NOSPAM_@ianywhere.com>
Organization: iAnywhere Solutions Inc.
User-Agent: Mozilla Thunderbird 1.6.3.2f (Windows/20050317)
X-Accept-Language: en-us, en
MIME-Version: 1.0
Newsgroups: ianywhere.public.general
Subject: Re: dbbackup.exe fails on windows server 2003
References: <4392fda7.6c15.1681692777@sybase.com>
In-Reply-To: <4392fda7.6c15.1681692777@sybase.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 8bit
X-Original-NNTP-Posting-Host: 10.18.242.10
Message-ID: <4393412b$1@forums-2-dub>
X-Original-Trace: 4 Dec 2005 11:19:07 -0800, 10.18.242.10
Lines: 33
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 4 Dec 2005 11:19:08 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 4 Dec 2005 11:27:26 -0800
X-Trace: forums-1-dub 1133724446 10.22.108.75 (4 Dec 2005 11:27:26 -0800)
X-Original-Trace: 4 Dec 2005 11:27:26 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:5019
Article PK: 8644


Eran wrote:
> dbbackup.exe" -o %logFile% -c
> "dbf=%testPath%\bin\sybase\mydb.db;uid=%uid%;pwd=%pwd%"
> "ºckupDir%"
>
> I get error:
> Adaptive Server Anywhere Backup Utility Version 8.0.2.4513
> Specified database is invalid
> ERROR: Unable to copy netally.db to backup directory c:\tmp.
>

I'm confused....your command above is connecting to "mydb.db" but the
error being spit out is for "netally.db".

Can you run the commands from the command line without the use of
variables just to confirm that behaviour of one connection string
without DSN is different from that with a DSN?

If they are the same, then slowly start adding variables back in until
the error re-appears.

Another option is to run the script with @ECHO ON and see the actual
values being used. Post the output of the working and the non-working
commands (using copy-paste to avoid any potential transcription errors).

greg.fenton
--
Greg Fenton
Consultant, Solution Services, iAnywhere Solutions
--------
Visit the iAnywhere Solutions Developer Community
Whitepapers, TechDocs, Downloads
http://www.ianywhere.com/developer/


Eran Posted on 2005-12-05 07:09:47.0Z
Sender: 6c54.43930901.1804289383@sybase.com
From: Eran
Newsgroups: ianywhere.public.general
Subject: Re: dbbackup.exe fails on windows server 2003
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4393e7bb.72c3.1681692777@sybase.com>
References: <4393412b$1@forums-2-dub>
MIME-Version: 1.0
Content-Type: text/plain; charset="ISO-8859-1"
Content-Transfer-Encoding: quoted-printable
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 4 Dec 2005 23:09:47 -0800
X-Trace: forums-1-dub 1133766587 10.22.241.41 (4 Dec 2005 23:09:47 -0800)
X-Original-Trace: 4 Dec 2005 23:09:47 -0800, 10.22.241.41
Lines: 95
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:5020
Article PK: 17480

I'm sorry for the confusion.I'll try to clear thing up.
I tried to run the the command both from command line and
script
it didn't work in any of them .
if I use the same command on other os it is working.
I should also say that the databse is embeded in my
application the dbsrv params are :
-c 8000K -Q -sb 0 -m -n netallydb -gk all -x
tcpip(ServerPort=2638) "C:\Program
Files\NetAlly\TestCenter\bin\sybase\netally.db"
here are some of the commands I used for db backup and their
results :
@ECHO on
REM server params for embeded db
REM -c 8000K -Q -sb 0 -m -n netallydb -gk all -x
tcpip(ServerPort=2638) "C:\Program
Files\NetAlly\TestCenter\bin\sybase\netally.db"
set uid=dbo
set pwd=netally
set dbfile=C:\Program
Files\NetAlly\TestCenter\bin\sybase\netally.db
set sybwin32=C:\Program
Files\NetAlly\TestCenter\bin\sybase\win32
set logfile=c:\temp\backup.log
set backupdir=c:\temp
call "%sybwin32%\dbbackup.exe" -o %logFile% -c
"ENG=netallydb;UID=%uid%;PWD=%pwd%" "ºckupDir%"
call "%sybwin32%\dbbackup.exe" -o %logFile% -c
"DBF=Ûfile%;uid=%uid%;pwd=%pwd%" "ºckupDir%"
call "%sybwin32%\dbbackup.exe" -o %logFile% -c
"DBN=netally;ENG=netallydb;UID=%uid%;PWD=%pwd%"
"ºckupDir%"
call "%sybwin32%\dbbackup.exe" -o %logFile% -c
"DBN=netallydb;ENG=netally;UID=%uid%;PWD=%pwd%"
"ºckupDir%"
and the results are :
C:\Program Files\NetAlly\TestCenter\bin>REM server params
for embeded db

C:\Program Files\NetAlly\TestCenter\bin>REM -c 8000K -Q -sb
0 -m -n netallydb -gk all -x tcpip(ServerPort=2638)
"C:\Program Files\NetAlly\TestCenter\bin\sybase\netally.db"

C:\Program Files\NetAlly\TestCenter\bin>set uid=dbo

C:\Program Files\NetAlly\TestCenter\bin>set pwd=netally

C:\Program Files\NetAlly\TestCenter\bin>set
dbfile=C:\Program
Files\NetAlly\TestCenter\bin\sybase\netally.db

C:\Program Files\NetAlly\TestCenter\bin>set
sybwin32=C:\Program
Files\NetAlly\TestCenter\bin\sybase\win32

C:\Program Files\NetAlly\TestCenter\bin>set
logfile=c:\temp\backup.log

C:\Program Files\NetAlly\TestCenter\bin>set
backupdir=c:\temp

C:\Program Files\NetAlly\TestCenter\bin>call "C:\Program
Files\NetAlly\TestCenter\bin\sybase\win32\dbbackup.exe" -o
c:\temp\backup.log -c
"ENG=netallydb;UID=dbo;PWD=netally" "c:\temp"
Adaptive Server Anywhere Backup Utility Version 8.0.2.4513
Database server not found

C:\Program Files\NetAlly\TestCenter\bin>call "C:\Program
Files\NetAlly\TestCenter\bin\sybase\win32\dbbackup.exe" -o
c:\temp\backup.log -c "DBF=C:\Program
Files\NetAlly\TestCenter\bin\sybase\netally.db
;uid=dbo;pwd=netally" "c:\temp"
Adaptive Server Anywhere Backup Utility Version 8.0.2.4513
Specified database is invalid

C:\Program Files\NetAlly\TestCenter\bin>call "C:\Program
Files\NetAlly\TestCenter\bin\sybase\win32\dbbackup.exe" -o
c:\temp\backup.log -c
"DBN=netally;ENG=netallydb;UID=dbo;PWD=netally"
"c:\temp"
Adaptive Server Anywhere Backup Utility Version 8.0.2.4513
Specified database not found

C:\Program Files\NetAlly\TestCenter\bin>call "C:\Program
Files\NetAlly\TestCenter\bin\sybase\win32\dbbackup.exe" -o
c:\temp\backup.log -c
"DBN=netallydb;ENG=netally;UID=dbo;PWD=netally"
"c:\temp"
Adaptive Server Anywhere Backup Utility Version 8.0.2.4513
Specified database not found
C:\Program Files\NetAlly\TestCenter\bin>

even if I run each command spereate from the command line it
does not work.


Eran Posted on 2005-12-05 08:51:24.0Z
Sender: 6c54.43930901.1804289383@sybase.com
From: Eran
Newsgroups: ianywhere.public.general
Subject: Re: dbbackup.exe fails on windows server 2003
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4393ff8c.7375.1681692777@sybase.com>
References: <4392fda7.6c15.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 5 Dec 2005 00:51:24 -0800
X-Trace: forums-1-dub 1133772684 10.22.241.41 (5 Dec 2005 00:51:24 -0800)
X-Original-Trace: 5 Dec 2005 00:51:24 -0800, 10.22.241.41
Lines: 7
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:5021
Article PK: 17482

and here is what i get when i run dblocate
C:\Program
Files\NetAlly\TestCenter\bin\sybase\win32>dblocate
Adaptive Server Anywhere Server Enumeration Utility Version
8.0.2.4513

No servers found


Eran Posted on 2005-12-05 08:55:16.0Z
Sender: 6c54.43930901.1804289383@sybase.com
From: Eran
Newsgroups: ianywhere.public.general
Subject: Re: dbbackup.exe fails on windows server 2003
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <43940073.738b.1681692777@sybase.com>
References: <4392fda7.6c15.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 5 Dec 2005 00:55:16 -0800
X-Trace: forums-1-dub 1133772916 10.22.241.41 (5 Dec 2005 00:55:16 -0800)
X-Original-Trace: 5 Dec 2005 00:55:16 -0800, 10.22.241.41
Lines: 38
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:5022
Article PK: 17483

here is dbping results
C:\Program Files\NetAlly\TestCenter\bin\sybase\win32>dbping
-c "eng=netallydb;commlinks=tcpip;uid=dbo;pwd=netally" -d -z
-o c:\testing1.txt
Adaptive Server Anywhere Server Ping Utility Version
8.0.2.4513
Application information:
"HOST=SHRC4;OS=Windows 2003 Build 3790
;PID=0xc1c;THREAD=0x1ec;EXE=C:\Program
Files\NetAlly\TestCenter\bin\sybase\win32\dbping.exe;VERSION=8.0.2.4513;
API=DBLIB;TIMEZONEADJUSTMENT=120"
Attempting to connect using:
UID=dbo;PWD=*******;ENG=netallydb;LINKS=tcpip
Attempting to connect to a running server...
Trying to start TCPIP link ...
Loading wsock32.dll
Loading ws2_32.dll
TCP using Winsock version 2.0
My IP address is 192.168.160.4
My IP address is 127.0.0.1
TCPIP link started successfully
Attempting TCPIP connection (no asasrv.ini cached address)
Looking for server with name netallydb
Sending broadcast to find server
Using broadcast address of: 192.168.160.255:2638
Sending broadcast to find server
Using broadcast address of: 127.255.255.255:2638
Resending
Resending
Resending
Resending
Server not found (no reply received)
Failed to connect over TCPIP
Not attempting to autostart server
Cannot connect to server
Ping database failed -- Database server not found.

C:\Program Files\NetAlly\TestCenter\bin\sybase\win32>


Stephen Rice Posted on 2005-12-05 21:50:38.0Z
From: Stephen Rice <NSsrice@ianywhere.com>
Reply-To: NSsrice@ianywhere.com
Organization: iAnywhere Solutions
User-Agent: Mozilla Thunderbird 1.0.2 (Windows/20050317)
X-Accept-Language: en-us, en
MIME-Version: 1.0
Newsgroups: ianywhere.public.general
Subject: Re: dbbackup.exe fails on windows server 2003
References: <4392fda7.6c15.1681692777@sybase.com> <43940073.738b.1681692777@sybase.com>
In-Reply-To: <43940073.738b.1681692777@sybase.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: srice-laptop.sybase.com
X-Original-NNTP-Posting-Host: srice-laptop.sybase.com
Message-ID: <4394b62e$1@forums-1-dub>
Date: 5 Dec 2005 13:50:38 -0800
X-Trace: forums-1-dub 1133819438 10.25.98.210 (5 Dec 2005 13:50:38 -0800)
X-Original-Trace: 5 Dec 2005 13:50:38 -0800, srice-laptop.sybase.com
Lines: 55
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:5032
Article PK: 17485

sure looks like you have something hiding your SQL Anywhere server from
the box running the script. My bet is either a firewall or a gateway
that is blocking udp packets. Look at using the host= and dobroadcast=
connection parameters to get past this

/steve

Eran wrote:
> here is dbping results
> C:\Program Files\NetAlly\TestCenter\bin\sybase\win32>dbping
> -c "eng=netallydb;commlinks=tcpip;uid=dbo;pwd=netally" -d -z
> -o c:\testing1.txt
> Adaptive Server Anywhere Server Ping Utility Version
> 8.0.2.4513
> Application information:
> "HOST=SHRC4;OS=Windows 2003 Build 3790
> ;PID=0xc1c;THREAD=0x1ec;EXE=C:\Program
> Files\NetAlly\TestCenter\bin\sybase\win32\dbping.exe;VERSION=8.0.2.4513;
> API=DBLIB;TIMEZONEADJUSTMENT=120"
> Attempting to connect using:
> UID=dbo;PWD=*******;ENG=netallydb;LINKS=tcpip
> Attempting to connect to a running server...
> Trying to start TCPIP link ...
> Loading wsock32.dll
> Loading ws2_32.dll
> TCP using Winsock version 2.0
> My IP address is 192.168.160.4
> My IP address is 127.0.0.1
> TCPIP link started successfully
> Attempting TCPIP connection (no asasrv.ini cached address)
> Looking for server with name netallydb
> Sending broadcast to find server
> Using broadcast address of: 192.168.160.255:2638
> Sending broadcast to find server
> Using broadcast address of: 127.255.255.255:2638
> Resending
> Resending
> Resending
> Resending
> Server not found (no reply received)
> Failed to connect over TCPIP
> Not attempting to autostart server
> Cannot connect to server
> Ping database failed -- Database server not found.
>
> C:\Program Files\NetAlly\TestCenter\bin\sybase\win32>

--
Stephen Rice
Technical Services Manager
iAnywhere Solutions

--- Please Post ---
Whitepapers, Tech Docs, Solved Cases, Bug Fixes and
"Report a bug" are all available on www.ianywhere.com


Eran Posted on 2005-12-06 14:44:53.0Z
Sender: 8d8.4395a1e7.1804289383@sybase.com
From: Eran
Newsgroups: ianywhere.public.general
Subject: Re: dbbackup.exe fails on windows server 2003
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4395a3e5.8f6.1681692777@sybase.com>
References: <4394b62e$1@forums-1-dub>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 6 Dec 2005 06:44:53 -0800
X-Trace: forums-1-dub 1133880293 10.22.241.41 (6 Dec 2005 06:44:53 -0800)
X-Original-Trace: 6 Dec 2005 06:44:53 -0800, 10.22.241.41
Lines: 7
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:5034
Article PK: 17486

spoke to my sysadmin there is no firewall or any thing like
that .
Meantime I found solution if I change the -sb param to 1
instead of 0 and in the tcpip define HOST=127.0.0.1 then
dbbackup and dblocate works. I guess what it actually do is
brodcast limited to the server only. The weird thing is that
dbbackup is working on other servers with -sb 0 and no HOST=