Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

RTE PB10.5 and HTML

5 posts in Objects Last posting was on 2006-07-17 19:25:32.0Z
jean duf Posted on 2006-05-10 09:12:12.0Z
From: "jean duf" <jduf@wavesoft.org>
Newsgroups: sybase.public.powerbuilder.objects
Subject: RTE PB10.5 and HTML
Lines: 11
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2869
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2869
X-RFC2646: Format=Flowed; Original
X-Antivirus: avast! (VPS 0619-0, 08/05/2006), Outbound message
X-Antivirus-Status: Clean
X-Original-NNTP-Posting-Host: 194.3.101.81
Message-ID: <4461ae58$1@forums-2-dub>
X-Original-Trace: 10 May 2006 02:11:52 -0700, 194.3.101.81
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 10 May 2006 02:11:55 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 10 May 2006 02:12:12 -0700
X-Trace: forums-1-dub 1147252332 10.22.108.75 (10 May 2006 02:12:12 -0700)
X-Original-Trace: 10 May 2006 02:12:12 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:8852
Article PK: 736054

I use component RTE of PB10.5.
Insertion of document to format HTML, does not display the images!
The posting of the same page is correctly with IE or Word.

Any idea ?


Thanks
Jean


Bruce Armstrong [TeamSybase] Posted on 2006-05-10 13:59:16.0Z
From: "Bruce Armstrong [TeamSybase]" <NOCANSPAM_bruce.armstrong@teamsybase.com>
Newsgroups: sybase.public.powerbuilder.objects
Subject: Re: RTE PB10.5 and HTML
Organization: TeamSybase
Reply-To: NOCANSPAM_bruce.armstrong@teamsybase.com
Message-ID: <mas362pdkt63mnrapetoo3glgjjcmrc1rv@4ax.com>
References: <4461ae58$1@forums-2-dub>
X-Newsreader: Forte Agent 2.0/32.652
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
X-Original-NNTP-Posting-Host: 68-190-226-38.static.lsan.ca.charter.com
X-Original-Trace: 10 May 2006 06:58:57 -0700, 68-190-226-38.static.lsan.ca.charter.com
Lines: 30
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 10 May 2006 06:58:58 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 10 May 2006 06:59:16 -0700
X-Trace: forums-1-dub 1147269556 10.22.108.75 (10 May 2006 06:59:16 -0700)
X-Original-Trace: 10 May 2006 06:59:16 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:8853
Article PK: 736058

PB's native mail handling is through MAPI, which isn't suitable for
HTML email:

http://support.microsoft.com/?id=268440

You might want to use OLE Automation of Outlook instead or use an SMTP
component.

On 10 May 2006 02:12:12 -0700, "jean duf" <jduf@wavesoft.org> wrote:

>I use component RTE of PB10.5.
>Insertion of document to format HTML, does not display the images!
>The posting of the same page is correctly with IE or Word.
>
>Any idea ?
>
>
>Thanks
>Jean
>

Bruce Armstrong [TeamSybase]
http://www.teamsybase.com

In Defense of Top Posting
http://alpage.ath.cx/toppost/toppost.htm

Preach the gospel at all times. If necessary, use words. - Francis of Assisi
http://www.needhim.org


jean duf Posted on 2006-05-10 17:36:25.0Z
From: "jean duf" <jduf@wavesoft.org>
Newsgroups: sybase.public.powerbuilder.objects
References: <4461ae58$1@forums-2-dub> <mas362pdkt63mnrapetoo3glgjjcmrc1rv@4ax.com>
Subject: Re: RTE PB10.5 and HTML
Lines: 42
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2869
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2869
X-RFC2646: Format=Flowed; Original
X-Antivirus: avast! (VPS 0619-0, 08/05/2006), Outbound message
X-Antivirus-Status: Clean
X-Original-NNTP-Posting-Host: 194.3.101.81
Message-ID: <44622484$1@forums-2-dub>
X-Original-Trace: 10 May 2006 10:36:04 -0700, 194.3.101.81
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 10 May 2006 10:36:07 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 10 May 2006 10:36:25 -0700
X-Trace: forums-1-dub 1147282585 10.22.108.75 (10 May 2006 10:36:25 -0700)
X-Original-Trace: 10 May 2006 10:36:25 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:8854
Article PK: 736057

I use a SMTP and POP component (EasyMail), I thus have the message with
format HTML. How to display the message (html) in PB?
I Try with a RTE component, but dont work.

Thanks,
Jean

"Bruce Armstrong [TeamSybase]" <NOCANSPAM_bruce.armstrong@teamsybase.com> a
écrit dans le message de news: mas362pdkt63mnrapetoo3glgjjcmrc1rv@4ax.com...

>
> PB's native mail handling is through MAPI, which isn't suitable for
> HTML email:
>
> http://support.microsoft.com/?id=268440
>
> You might want to use OLE Automation of Outlook instead or use an SMTP
> component.
>
> On 10 May 2006 02:12:12 -0700, "jean duf" <jduf@wavesoft.org> wrote:
>
>>I use component RTE of PB10.5.
>>Insertion of document to format HTML, does not display the images!
>>The posting of the same page is correctly with IE or Word.
>>
>>Any idea ?
>>
>>
>>Thanks
>>Jean
>>
>
> Bruce Armstrong [TeamSybase]
> http://www.teamsybase.com
>
> In Defense of Top Posting
> http://alpage.ath.cx/toppost/toppost.htm
>
> Preach the gospel at all times. If necessary, use words. - Francis of
> Assisi
> http://www.needhim.org


Bruce Armstrong [TeamSybase] Posted on 2006-05-11 01:11:48.0Z
From: "Bruce Armstrong [TeamSybase]" <NOCANSPAM_bruce.armstrong@teamsybase.com>
Newsgroups: sybase.public.powerbuilder.objects
Subject: Re: RTE PB10.5 and HTML
Organization: TeamSybase
Reply-To: NOCANSPAM_bruce.armstrong@teamsybase.com
Message-ID: <hp3562lhduq94jvto3hal9rdph0l689pnf@4ax.com>
References: <4461ae58$1@forums-2-dub> <mas362pdkt63mnrapetoo3glgjjcmrc1rv@4ax.com> <44622484$1@forums-2-dub>
X-Newsreader: Forte Agent 2.0/32.652
MIME-Version: 1.0
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 8bit
NNTP-Posting-Host: 68-190-226-38.static.lsan.ca.charter.com
X-Original-NNTP-Posting-Host: 68-190-226-38.static.lsan.ca.charter.com
Date: 10 May 2006 18:11:48 -0700
X-Trace: forums-1-dub 1147309908 68.190.226.38 (10 May 2006 18:11:48 -0700)
X-Original-Trace: 10 May 2006 18:11:48 -0700, 68-190-226-38.static.lsan.ca.charter.com
Lines: 54
X-Authenticated-User: TeamSybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:8855
Article PK: 736056

OIC. I'd suggest trying to embed a browser control in the app.

On 10 May 2006 10:36:25 -0700, "jean duf" <jduf@wavesoft.org> wrote:

>I use a SMTP and POP component (EasyMail), I thus have the message with
>format HTML. How to display the message (html) in PB?
>I Try with a RTE component, but dont work.
>
>Thanks,
>Jean
>
>"Bruce Armstrong [TeamSybase]" <NOCANSPAM_bruce.armstrong@teamsybase.com> a
>écrit dans le message de news: mas362pdkt63mnrapetoo3glgjjcmrc1rv@4ax.com...
>>
>> PB's native mail handling is through MAPI, which isn't suitable for
>> HTML email:
>>
>> http://support.microsoft.com/?id=268440
>>
>> You might want to use OLE Automation of Outlook instead or use an SMTP
>> component.
>>
>> On 10 May 2006 02:12:12 -0700, "jean duf" <jduf@wavesoft.org> wrote:
>>
>>>I use component RTE of PB10.5.
>>>Insertion of document to format HTML, does not display the images!
>>>The posting of the same page is correctly with IE or Word.
>>>
>>>Any idea ?
>>>
>>>
>>>Thanks
>>>Jean
>>>
>>
>> Bruce Armstrong [TeamSybase]
>> http://www.teamsybase.com
>>
>> In Defense of Top Posting
>> http://alpage.ath.cx/toppost/toppost.htm
>>
>> Preach the gospel at all times. If necessary, use words. - Francis of
>> Assisi
>> http://www.needhim.org
>

Bruce Armstrong [TeamSybase]
http://www.teamsybase.com

In Defense of Top Posting
http://alpage.ath.cx/toppost/toppost.htm

Preach the gospel at all times. If necessary, use words. - Francis of Assisi
http://www.needhim.org


Tim Posted on 2006-07-17 19:25:32.0Z
Sender: 5803.44bbdefe.1804289383@sybase.com
From: Tim
Newsgroups: sybase.public.powerbuilder.objects
Subject: Re: RTE PB10.5 and HTML
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <44bbe28d.583e.1681692777@sybase.com>
References: <hp3562lhduq94jvto3hal9rdph0l689pnf@4ax.com>
MIME-Version: 1.0
Content-Type: text/plain; charset="ISO-8859-1"
Content-Transfer-Encoding: quoted-printable
X-Original-NNTP-Posting-Host: 10.22.241.42
X-Original-Trace: 17 Jul 2006 12:18:37 -0700, 10.22.241.42
Lines: 70
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 17 Jul 2006 12:18:38 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 17 Jul 2006 12:25:32 -0700
X-Trace: forums-1-dub 1153164332 10.22.108.75 (17 Jul 2006 12:25:32 -0700)
X-Original-Trace: 17 Jul 2006 12:25:32 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:8947
Article PK: 736142

I have a similar problem. My users need to (Business
requirement) copy and paste emails from OutLook into a RTE
screen in my application so that the text can be stored in
the database.

Everything works except the occasional HTML page. Are you
telling me after all the wait for the new RTE PowerBuilder
still can't handle rich text like MS Word does?

Is there any workaround?

> OIC. I'd suggest trying to embed a browser control in the
> app.
>
> On 10 May 2006 10:36:25 -0700, "jean duf"
> <jduf@wavesoft.org> wrote:
>
> >I use a SMTP and POP component (EasyMail), I thus have
> the message with >format HTML. How to display the
> message (html) in PB? >I Try with a RTE component, but
> dont work. >
> >Thanks,
> >Jean
> >
> >"Bruce Armstrong [TeamSybase]"
> <NOCANSPAM_bruce.armstrong@teamsybase.com> a >écrit
dans
> le message de news:
> mas362pdkt63mnrapetoo3glgjjcmrc1rv@4ax.com... >>
> >> PB's native mail handling is through MAPI, which isn't
> suitable for >> HTML email:
> >>
> >> http://support.microsoft.com/?id=268440
> >>
> >> You might want to use OLE Automation of Outlook instead
> or use an SMTP >> component.
> >>
> >> On 10 May 2006 02:12:12 -0700, "jean duf"
> <jduf@wavesoft.org> wrote: >>
> >>>I use component RTE of PB10.5.
> >>>Insertion of document to format HTML, does not display
> the images! >>>The posting of the same page is correctly
> with IE or Word. >>>
> >>>Any idea ?
> >>>
> >>>
> >>>Thanks
> >>>Jean
> >>>
> >>
> >> Bruce Armstrong [TeamSybase]
> >> http://www.teamsybase.com
> >>
> >> In Defense of Top Posting
> >> http://alpage.ath.cx/toppost/toppost.htm
> >>
> >> Preach the gospel at all times. If necessary, use
> words. - Francis of >> Assisi
> >> http://www.needhim.org
> >
>
> Bruce Armstrong [TeamSybase]
> http://www.teamsybase.com
>
> In Defense of Top Posting
> http://alpage.ath.cx/toppost/toppost.htm
>
> Preach the gospel at all times. If necessary, use words. -
> Francis of Assisi http://www.needhim.org