Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

USM structure file not downloading to device

2 posts in General Discussion Last posting was on 2006-05-18 21:44:55.0Z
Jan Posted on 2006-05-18 15:43:55.0Z
From: "Jan" <jan@cyberprop.com>
Newsgroups: ianywhere.public.mbusinessanywhere.general
Subject: USM structure file not downloading to device
Lines: 23
X-Newsreader: Microsoft Outlook Express 6.00.2900.2869
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2869
X-RFC2646: Format=Flowed; Original
X-Original-NNTP-Posting-Host: c1-231-11.rrba.isadsl.co.za
Message-ID: <446c95f8@forums-2-dub>
X-Original-Trace: 18 May 2006 08:42:48 -0700, c1-231-11.rrba.isadsl.co.za
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 18 May 2006 08:42:50 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 18 May 2006 08:43:55 -0700
X-Trace: forums-1-dub 1147967035 10.22.108.75 (18 May 2006 08:43:55 -0700)
X-Original-Trace: 18 May 2006 08:43:55 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.mbusinessanywhere.general:830
Article PK: 17809

Hi all,

We've got our solution working - it's deployed to at least 100 devices...
BUT

All of a sudden - I find that the USM file (ultralite data structure file)
is no longer being downloaded to the devices...

I can't understand why it's not coming down... there is no mention in the
IIS logs that the file was even attempted to be downloaded (OK - not exactly
true... since it is working for some users - but for others it's not!)

Has it got something to do with the users' cache? Or the channel cache?

The bottom line is that the USM file on the device is older than the USM
file on the server - yet it is not coming down???

Any ideas?

Thanks!
Jan


Shuchit Posted on 2006-05-18 21:44:55.0Z
Newsgroups: ianywhere.public.mbusinessanywhere.general
Subject: Re: USM structure file not downloading to device
From: Shuchit <me@privacy.net>
References: <446c95f8@forums-2-dub>
Message-ID: <Xns97C7B3C257CE4svelkarprivacynet@127.0.0.1>
User-Agent: Xnews/2005.10.18 Hamster/2.1.0.0
X-Original-NNTP-Posting-Host: 10.18.242.59
X-Original-Trace: 18 May 2006 14:43:47 -0700, 10.18.242.59
Lines: 33
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 18 May 2006 14:43:48 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 18 May 2006 14:44:55 -0700
X-Trace: forums-1-dub 1147988695 10.22.108.75 (18 May 2006 14:44:55 -0700)
X-Original-Trace: 18 May 2006 14:44:55 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.mbusinessanywhere.general:833
Article PK: 17810


"Jan" <jan@cyberprop.com> wrote in news:446c95f8@forums-2-dub:

> Hi all,
>
> We've got our solution working - it's deployed to at least 100
> devices... BUT
>
> All of a sudden - I find that the USM file (ultralite data structure
> file) is no longer being downloaded to the devices...
>
> I can't understand why it's not coming down... there is no mention in
> the IIS logs that the file was even attempted to be downloaded (OK - not
> exactly true... since it is working for some users - but for others it's
> not!)
>

Can you try requesting the usm file from IIS outside of MBuisness ? ie. use a
web-browser on your desktop and try requesting the file.

You might have to add .usm to the IIS mime-types so that MBusiness sees it as
a binary file. I found this documented at
<http://makeashorterlink.com/?K1B95112D> which maps to

<http://www.microsoft.com/technet/prodtechnol/windows2000serv/technologies/ii
s/maintain/featusability/mimeiis.mspx>

I would map usm to application/octet-stream

Btw, you should always mention what version of MBusiness and IIS you are
using.

cheers,
Shuchit