Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Integrated login question

3 posts in General Discussion Last posting was on 2006-05-29 19:35:38.0Z
Eugene Posted on 2006-05-22 18:13:30.0Z
Sender: 3ab9.4471f9fe.1804289383@sybase.com
From: Eugene
Newsgroups: ianywhere.public.general
Subject: Integrated login question
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4471ff4a.3b14.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 22 May 2006 11:13:30 -0700
X-Trace: forums-1-dub 1148321610 10.22.241.41 (22 May 2006 11:13:30 -0700)
X-Original-Trace: 22 May 2006 11:13:30 -0700, 10.22.241.41
Lines: 7
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:5365
Article PK: 1415

We have mapped the windows account id with database user
account when we connect to the database using ODBC the
current user is correct but when we connect through the same
ODBC datasource name throgh an ASP application and invoke
the current user it is always the database owner. We need
to know why the current user is database owner rather then
the user the windows account is mapped to.


Matthew Chestnut Posted on 2006-05-22 21:59:23.0Z
From: Matthew Chestnut <matthew_chestnut_nospam@hotmail.nospam.com>
Newsgroups: ianywhere.public.general
Subject: Re: Integrated login question
Message-ID: <brc472pnbu5neig2t96d3tl6keac2thevv@4ax.com>
References: <4471ff4a.3b14.1681692777@sybase.com>
X-Newsreader: Forte Free Agent 3.3/32.846
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: 63.111.4.180
X-Original-NNTP-Posting-Host: 63.111.4.180
Date: 22 May 2006 14:59:23 -0700
X-Trace: forums-1-dub 1148335163 63.111.4.180 (22 May 2006 14:59:23 -0700)
X-Original-Trace: 22 May 2006 14:59:23 -0700, 63.111.4.180
Lines: 15
X-Authenticated-User: pb11ctp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:5366
Article PK: 1417

It's probably due to the fact that the ASP application is executed via
IIS which is running as a Windows service, hence the "current user" is
not the logged in user, but rather the account the service is
configured to run as.

On 22 May 2006 11:13:30 -0700, Eugene wrote:

>We have mapped the windows account id with database user
>account when we connect to the database using ODBC the
>current user is correct but when we connect through the same
>ODBC datasource name throgh an ASP application and invoke
>the current user it is always the database owner. We need
>to know why the current user is database owner rather then
>the user the windows account is mapped to.


Shuchit Posted on 2006-05-29 19:35:38.0Z
Newsgroups: ianywhere.public.general
Subject: Re: Integrated login question
From: Shuchit <me@privacy.net>
References: <4471ff4a.3b14.1681692777@sybase.com>
Message-ID: <Xns97D29DEC145C7svelkarprivacynet@127.0.0.1>
User-Agent: Xnews/2005.10.18 Hamster/2.1.0.0
NNTP-Posting-Host: svelkar-pc.sybase.com
X-Original-NNTP-Posting-Host: svelkar-pc.sybase.com
Date: 29 May 2006 12:35:38 -0700
X-Trace: forums-1-dub 1148931338 10.25.98.136 (29 May 2006 12:35:38 -0700)
X-Original-Trace: 29 May 2006 12:35:38 -0700, svelkar-pc.sybase.com
Lines: 18
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:5403
Article PK: 1454


Eugene wrote in news:4471ff4a.3b14.1681692777@sybase.com:

> We have mapped the windows account id with database user
> account when we connect to the database using ODBC the
> current user is correct but when we connect through the same
> ODBC datasource name throgh an ASP application and invoke
> the current user it is always the database owner. We need
> to know why the current user is database owner rather then
> the user the windows account is mapped to.
>

What version of ASA are you using ?
What error do you get ?
What version of IIS/webserver are you using ?
Also show us the ASP code you are using to connect to the database.


Shuchit