Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Integrated login failed

5 posts in General Discussion Last posting was on 2006-05-31 13:47:30.0Z
Eugene Posted on 2006-05-25 18:54:08.0Z
Sender: 65e0.4475fb0c.1804289383@sybase.com
From: Eugene
Newsgroups: ianywhere.public.general
Subject: Integrated login failed
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4475fce4.65f9.1681692777@sybase.com>
X-Original-NNTP-Posting-Host: 10.22.241.42
X-Original-Trace: 25 May 2006 11:52:20 -0700, 10.22.241.42
Lines: 3
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 25 May 2006 11:52:21 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 25 May 2006 11:54:08 -0700
X-Trace: forums-1-dub 1148583248 10.22.108.75 (25 May 2006 11:54:08 -0700)
X-Original-Trace: 25 May 2006 11:54:08 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:5391
Article PK: 1441

Client ASP application could never connect to the ASA 9.0
database using integrated login. Please help.
Thank you.


David Fishburn Posted on 2006-05-30 19:03:28.0Z
Newsgroups: ianywhere.public.general
Subject: Re: Integrated login failed
From: David Fishburn <fishburn_spam@off.ianywhere.com>
References: <4475fce4.65f9.1681692777@sybase.com>
Organization: iAnywhere Solutions
Message-ID: <Xns97D398B96A38Dfishburnsybasecom@127.0.0.1>
User-Agent: Xnews/2005.10.18 Hamster/2.1.0.0
X-Original-NNTP-Posting-Host: wireless-wat-2.sybase.com
X-Original-Trace: 30 May 2006 12:01:11 -0700, wireless-wat-2.sybase.com
Lines: 38
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 30 May 2006 12:01:12 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 30 May 2006 12:03:28 -0700
X-Trace: forums-1-dub 1149015808 10.22.108.75 (30 May 2006 12:03:28 -0700)
X-Original-Trace: 30 May 2006 12:03:28 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:5407
Article PK: 1457

Eugene wrote in news:4475fce4.65f9.1681692777@sybase.com
of ianywhere.public.general:

E> Client ASP application could never connect to the ASA 9.0
E> database using integrated login. Please help.
E> Thank you.

Please ALWAYS include version and MORE importantly BUILD number
with EACH post (dbeng9 -v).

What happens when you attempt to login using DBISQL and integrated
logins?

What error messages are you seeing?

What is the SA database option login_mode set to?

--
David Fishburn
Certified ASA Developer Version 8
iAnywhere Solutions - Sybase
Professional Services
Please only post to the newsgroup
Please ALWAYS include version and MORE importantly BUILD number with
EACH post (dbeng9 -v).

EBFs and Maintenance Releases
http://downloads.sybase.com/

Developer Community / Whitepapers
http://www.ianywhere.com/developer

CaseXpress - to report bugs
http://casexpress.sybase.com

CodeXchange - Free samples
http://ianywhere.codexchange.sybase.com/servlets/ProjectDocumentList


Eugene Posted on 2006-05-31 13:43:44.0Z
Sender: 702a.447d977e.1804289383@sybase.com
From: Eugene
Newsgroups: ianywhere.public.general
Subject: Re: Integrated login failed
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <447d9d90.707e.1681692777@sybase.com>
References: <Xns97D398B96A38Dfishburnsybasecom@127.0.0.1>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 31 May 2006 06:43:44 -0700
X-Trace: forums-1-dub 1149083024 10.22.241.41 (31 May 2006 06:43:44 -0700)
X-Original-Trace: 31 May 2006 06:43:44 -0700, 10.22.241.41
Lines: 52
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:5412
Article PK: 1462

Thank you for your answer. We are using Adaptive Server
Anywhere 9.0.1.1751. We don't have any problem to connect
Sybase Central to the database using an integrated login.
But as soon as we do it through the client ASP application
we are always getting an error 'Integrated login failed'.
Maybe because additional layers come to the seen (IIS, ADO -
?) - we don't know. IIS is configured for an anonymous
access. Maybe this is the problem?

Thank you
Eugene

> Eugene wrote in news:4475fce4.65f9.1681692777@sybase.com
> of ianywhere.public.general:
>
> E> Client ASP application could never connect to the ASA
> 9.0 E> database using integrated login. Please help.
> E> Thank you.
>
> Please ALWAYS include version and MORE importantly BUILD
> number with EACH post (dbeng9 -v).
>
> What happens when you attempt to login using DBISQL and
> integrated logins?
>
> What error messages are you seeing?
>
> What is the SA database option login_mode set to?
>
> --
> David Fishburn
> Certified ASA Developer Version 8
> iAnywhere Solutions - Sybase
> Professional Services
> Please only post to the newsgroup
> Please ALWAYS include version and MORE importantly BUILD
> number with EACH post (dbeng9 -v).
>
> EBFs and Maintenance Releases
> http://downloads.sybase.com/
>
> Developer Community / Whitepapers
> http://www.ianywhere.com/developer
>
> CaseXpress - to report bugs
> http://casexpress.sybase.com
>
> CodeXchange - Free samples
>
http://ianywhere.codexchange.sybase.com/servlets/ProjectDocumentList
>


Stephen Rice Posted on 2006-05-30 19:43:07.0Z
From: "Stephen Rice" <sriceATianywhereDOTcom>
Newsgroups: ianywhere.public.general
References: <4475fce4.65f9.1681692777@sybase.com>
Subject: Re: Integrated login failed
Lines: 27
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2869
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2869
X-RFC2646: Format=Flowed; Original
X-Original-NNTP-Posting-Host: srice-xp2.sybase.com
Message-ID: <447c9fc2@forums-2-dub>
X-Original-Trace: 30 May 2006 12:40:50 -0700, srice-xp2.sybase.com
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 30 May 2006 12:40:51 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 30 May 2006 12:43:07 -0700
X-Trace: forums-1-dub 1149018187 10.22.108.75 (30 May 2006 12:43:07 -0700)
X-Original-Trace: 30 May 2006 12:43:07 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:5408
Article PK: 1458

There was a fix made in 9.0.2 Build #3289

Integrated login connections could have failed if INTEGRATED LOGIN was
granted
to a Windows group, and the Windows group contained the particular user
that
was connecting as domain\username. This has been fixed so that user
'username'
is now successfully logged in, even if they are in the Windows group as
'domain\username'.

Other than that we've not had any recent reports of issues
--
/steve

Stephen Rice
Technical Services Manager
iAnywhere (a Sybase Company)
email: srice@ianywhere.com

<Eugene> wrote in message news:4475fce4.65f9.1681692777@sybase.com...
> Client ASP application could never connect to the ASA 9.0
> database using integrated login. Please help.
> Thank you.


Eugene Posted on 2006-05-31 13:47:30.0Z
Sender: 702a.447d977e.1804289383@sybase.com
From: Eugene
Newsgroups: ianywhere.public.general
Subject: Re: Integrated login failed
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <447d9e72.7091.1681692777@sybase.com>
References: <447c9fc2@forums-2-dub>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 31 May 2006 06:47:30 -0700
X-Trace: forums-1-dub 1149083250 10.22.241.41 (31 May 2006 06:47:30 -0700)
X-Original-Trace: 31 May 2006 06:47:30 -0700, 10.22.241.41
Lines: 31
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:5413
Article PK: 1463

Thank you for your help.
Eugene

> There was a fix made in 9.0.2 Build #3289
>
> Integrated login connections could have failed if
> INTEGRATED LOGIN was granted
> to a Windows group, and the Windows group contained the
> particular user that
> was connecting as domain\username. This has been fixed so
> that user 'username'
> is now successfully logged in, even if they are in the
> Windows group as 'domain\username'.
>
> Other than that we've not had any recent reports of issues
> --
> /steve
>
> Stephen Rice
> Technical Services Manager
> iAnywhere (a Sybase Company)
> email: srice@ianywhere.com
>
>
> <Eugene> wrote in message
> > news:4475fce4.65f9.1681692777@sybase.com... Client ASP
> > application could never connect to the ASA 9.0 database
> > using integrated login. Please help. Thank you.
>
>