Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

error 5153 when adding a stored procedure

2 posts in AEP Last posting was on 2006-06-06 21:23:34.0Z
Paul Man Posted on 2006-06-02 10:52:08.0Z
From: "Paul Man" <paulman@datasoft.ie>
Newsgroups: Advantage.AEP
Subject: error 5153 when adding a stored procedure
Date: Fri, 2 Jun 2006 11:52:08 +0100
Lines: 9
Organization: DSoft
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2869
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2869
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: 82.141.233.142
Message-ID: <448017c5@solutions.advantagedatabase.com>
X-Trace: 2 Jun 2006 04:49:41 -0700, 82.141.233.142
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!82.141.233.142
Xref: solutions.advantagedatabase.com Advantage.AEP:488
Article PK: 1103780

We have a number of databse copies on our server. We add a new stored
procedure aep dll to one of them. when we go to add it to another database
using create procedure we get an error 5153. The aep file is in a single
common folder for all databases so is this the cause? to get around it we
created it using a variation of the name and then right mouse clicked on the
stored procedure and used rename. but still is this behaviour (creating the
same stored proc in multiple databases) a bug?


Jeremy Mullin Posted on 2006-06-06 21:23:34.0Z
Date: Tue, 6 Jun 2006 21:23:34 +0000 (UTC)
Message-ID: <886edc1513abf8c857944f59a1e0@devzone.advantagedatabase.com>
From: Jeremy Mullin <no@email.com>
Subject: Re: error 5153 when adding a stored procedure
Newsgroups: Advantage.AEP
References: <448017c5@solutions.advantagedatabase.com>
MIME-Version: 1.0
Content-Transfer-Encoding: 8bit
Content-Type: text/plain; charset=iso-8859-1; format=flowed
X-Newsreader: JetBrains Omea Reader 928.2
NNTP-Posting-Host: 10.24.38.116
X-Trace: 6 Jun 2006 15:19:59 -0700, 10.24.38.116
Lines: 18
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!10.24.38.116
Xref: solutions.advantagedatabase.com Advantage.AEP:489
Article PK: 1103775

A 5153 is an "invalid sql statement" error. How are you adding the procedure?
Are you using ARC? If so, which version? Try adding the AEP using a CREATE
PROCEDURE statement and see if that works, it might just be an arc bug.

J.D. Mullin
Advantage R&D

> We have a number of databse copies on our server. We add a new stored
> procedure aep dll to one of them. when we go to add it to another
> database using create procedure we get an error 5153. The aep file
> is in a single common folder for all databases so is this the cause?
> to get around it we created it using a variation of the name and then
> right mouse clicked on the stored procedure and used rename. but
> still is this behaviour (creating the same stored proc in multiple
> databases) a bug?
>