Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Retrieval argument in PB10.5 pipeline using ODBC

4 posts in Objects Last posting was on 2006-07-31 18:09:42.0Z
Merete Posted on 2006-07-28 08:32:18.0Z
From: "Merete" <noone@nowhere.com>
Newsgroups: sybase.public.powerbuilder.objects
Subject: Retrieval argument in PB10.5 pipeline using ODBC
Lines: 21
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2869
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2869
X-RFC2646: Format=Flowed; Original
X-Original-NNTP-Posting-Host: cpe.atm2-0-1031195.0x50a61bbe.odnxx2.customer.tele.dk
Message-ID: <44c9c9b6@forums-2-dub>
X-Original-Trace: 28 Jul 2006 01:24:22 -0700, cpe.atm2-0-1031195.0x50a61bbe.odnxx2.customer.tele.dk
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 28 Jul 2006 01:24:23 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 28 Jul 2006 01:32:18 -0700
X-Trace: forums-1-dub 1154075538 10.22.108.75 (28 Jul 2006 01:32:18 -0700)
X-Original-Trace: 28 Jul 2006 01:32:18 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:8985
Article PK: 736182

I just migrated an application from PB8 to PB10.5. It works fine except for
the pipelines. As one of the databases the pipeline connects to is an SQL
Server (the source DB), I also had to change the database profile from 'MSS
Microsoft SQL Server 6.x' to ODBC (SQL Server 2000.85.1117.00).

I have traced the pipeline problem to the fact that pipeline retrieval
arguments are not sent to the database. pipe_xx.start(tr_1, tr_2, dw_err,
1234) works all right, but if I use an argument - pipe_xx.start(tr_1, tr_2,
dw_err, li_arg) - the statement that reaches the database says: ..where
(v_indrevaerdi.id>=). If I open edit source for the pipeline it says:

RETRIEVE(statement="PBSELECT( VERSION(400) TABLE(NAME=~"v_indrevaerdi~")
COLUMN(NAME=~"v_indrevaerdi.id~") COLUMN(NAME=~"v_indrevaerdi.isin~")
WHERE( EXP1 =~"v_indrevaerdi.id~" OP =~">=~" EXP2
=~":ar_fra_sekvensnr~" ) ) ARG(NAME = ~"ar_fra_sekvensnr~" TYPE =
number)",arguments((ar_fra_sekvensnr,Number)))

Really hope someone can help me!
Best regards Merete


Chris Pollach Posted on 2006-07-31 11:47:00.0Z
From: "Chris Pollach" <cpollach@travel-net.dot.com>
Newsgroups: sybase.public.powerbuilder.objects
References: <44c9c9b6@forums-2-dub>
Subject: Re: Retrieval argument in PB10.5 pipeline using ODBC
Lines: 40
Organization: STD Inc.
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.50.4927.1200
X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4927.1200
X-Original-NNTP-Posting-Host: stealth.nserc.ca
Message-ID: <44cdebc4$1@forums-2-dub>
X-Original-Trace: 31 Jul 2006 04:38:44 -0700, stealth.nserc.ca
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 31 Jul 2006 04:38:46 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 31 Jul 2006 04:47:00 -0700
X-Trace: forums-1-dub 1154346420 10.22.108.75 (31 Jul 2006 04:47:00 -0700)
X-Original-Trace: 31 Jul 2006 04:47:00 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:8988
Article PK: 736189

PB 10.5 is quite buggy (hopefully Sybase will issue a full maintenance
release in August). Have you tried this using PB 10.2.1?

Yes, the "MSS" Driver is gone because Microsoft dropped support for a
native driver and the old MSS (DbLib) driver is ANSI not Unicode like PB
10.0 and higher.
http://chrispollach.pbdjmagazine.com/sqlserver2005__who_redesigned_this_rele
ase.htm

Regards ... Chris

"Merete" <noone@nowhere.com> wrote in message news:44c9c9b6@forums-2-dub...
> I just migrated an application from PB8 to PB10.5. It works fine except
for
> the pipelines. As one of the databases the pipeline connects to is an SQL
> Server (the source DB), I also had to change the database profile from
'MSS
> Microsoft SQL Server 6.x' to ODBC (SQL Server 2000.85.1117.00).
>
> I have traced the pipeline problem to the fact that pipeline retrieval
> arguments are not sent to the database. pipe_xx.start(tr_1, tr_2, dw_err,
> 1234) works all right, but if I use an argument - pipe_xx.start(tr_1,
tr_2,
> dw_err, li_arg) - the statement that reaches the database says: ..where
> (v_indrevaerdi.id>=). If I open edit source for the pipeline it says:
>
> RETRIEVE(statement="PBSELECT( VERSION(400) TABLE(NAME=~"v_indrevaerdi~")
> COLUMN(NAME=~"v_indrevaerdi.id~") COLUMN(NAME=~"v_indrevaerdi.isin~")
> WHERE( EXP1 =~"v_indrevaerdi.id~" OP =~">=~" EXP2
> =~":ar_fra_sekvensnr~" ) ) ARG(NAME = ~"ar_fra_sekvensnr~" TYPE =
> number)",arguments((ar_fra_sekvensnr,Number)))
>
> Really hope someone can help me!
> Best regards Merete
>
>


Merete Posted on 2006-07-31 13:30:00.0Z
From: "Merete" <noone@nowhere.com>
Newsgroups: sybase.public.powerbuilder.objects
References: <44c9c9b6@forums-2-dub> <44cdebc4$1@forums-2-dub>
Subject: Re: Retrieval argument in PB10.5 pipeline using ODBC
Lines: 9
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2869
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2869
X-RFC2646: Format=Flowed; Original
X-Original-NNTP-Posting-Host: cpe.atm2-0-1031195.0x50a61bbe.odnxx2.customer.tele.dk
Message-ID: <44ce03e9$1@forums-2-dub>
X-Original-Trace: 31 Jul 2006 06:21:45 -0700, cpe.atm2-0-1031195.0x50a61bbe.odnxx2.customer.tele.dk
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 31 Jul 2006 06:21:46 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 31 Jul 2006 06:30:00 -0700
X-Trace: forums-1-dub 1154352600 10.22.108.75 (31 Jul 2006 06:30:00 -0700)
X-Original-Trace: 31 Jul 2006 06:30:00 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:8989
Article PK: 736186


> PB 10.5 is quite buggy (hopefully Sybase will issue a full maintenance
> release in August). Have you tried this using PB 10.2.1?

NO - but I have discovered that if the argument is sent as a string calling
pipe_xx.start() it works even though the argument in the pipeline is defined
as a number...

Merete


Chris Pollach Posted on 2006-07-31 18:09:42.0Z
From: "Chris Pollach" <cpollach@travel-net.dot.com>
Newsgroups: sybase.public.powerbuilder.objects
References: <44c9c9b6@forums-2-dub> <44cdebc4$1@forums-2-dub> <44ce03e9$1@forums-2-dub>
Subject: Re: Retrieval argument in PB10.5 pipeline using ODBC
Lines: 19
Organization: STD Inc.
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.50.4927.1200
X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4927.1200
NNTP-Posting-Host: stealth.nserc.ca
X-Original-NNTP-Posting-Host: stealth.nserc.ca
Message-ID: <44ce4766$1@forums-1-dub>
Date: 31 Jul 2006 11:09:42 -0700
X-Trace: forums-1-dub 1154369382 198.96.2.93 (31 Jul 2006 11:09:42 -0700)
X-Original-Trace: 31 Jul 2006 11:09:42 -0700, stealth.nserc.ca
X-Authenticated-User: pb105beta
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:8994
Article PK: 736190

I suspect that this is a PB 10.5 bug.

"Merete" <noone@nowhere.com> wrote in message
news:44ce03e9$1@forums-2-dub...
> > PB 10.5 is quite buggy (hopefully Sybase will issue a full maintenance
> > release in August). Have you tried this using PB 10.2.1?
> NO - but I have discovered that if the argument is sent as a string
calling
> pipe_xx.start() it works even though the argument in the pipeline is
defined
> as a number...
>
> Merete
>
>