Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

String comparison: difference between PB10.5 and PB8.0.3

2 posts in General Discussion (Chinese) Last posting was on 2006-08-08 06:24:00.0Z
Zidane Posted on 2006-08-04 04:22:02.0Z
Sender: 6d13.44d2c97b.1804289383@sybase.com
From: Zidane
Newsgroups: sybase.public.chinese.powerbuilder.general
Subject: String comparison: difference between PB10.5 and PB8.0.3
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <44d2cb6a.6d22.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 3 Aug 2006 21:22:02 -0700
X-Trace: forums-1-dub 1154665322 10.22.241.41 (3 Aug 2006 21:22:02 -0700)
X-Original-Trace: 3 Aug 2006 21:22:02 -0700, 10.22.241.41
Lines: 14
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.chinese.powerbuilder.general:88
Article PK: 104131

I am working on migration of PB applications from PB8.0.3 to
PB10.5.

I found that the results of the following codes in both
versions are different:

if 'a' > 'A' then
messagebox('', '>')
else
messagebox('', '<=')
end if

Did anyone encounter the problems? any solution for it?


EltoroDong Posted on 2006-08-08 06:24:00.0Z
Reply-To: "EltoroDong" <jiwei_dong@hotmail.com>
From: "EltoroDong" <jiwei_dong@hotmail.com>
Newsgroups: sybase.public.chinese.powerbuilder.general
References: <44d2cb6a.6d22.1681692777@sybase.com>
Subject: Re: String comparison: difference between PB10.5 and PB8.0.3
Lines: 20
Organization: LG CNS China
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2869
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2869
X-RFC2646: Format=Flowed; Original
X-Original-NNTP-Posting-Host: 219.142.93.15
Message-ID: <44d82be1@forums-2-dub>
X-Original-Trace: 7 Aug 2006 23:14:57 -0700, 219.142.93.15
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 7 Aug 2006 23:15:00 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 7 Aug 2006 23:24:00 -0700
X-Trace: forums-1-dub 1155018240 10.22.108.75 (7 Aug 2006 23:24:00 -0700)
X-Original-Trace: 7 Aug 2006 23:24:00 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.chinese.powerbuilder.general:90
Article PK: 104135

The PB 10 and above version use UNICODE now, but the PB 6,7,8,9 are not.
So, the results are different.

<Zidane> wrote in message news:44d2cb6a.6d22.1681692777@sybase.com...
>
> I am working on migration of PB applications from PB8.0.3 to
> PB10.5.
>
> I found that the results of the following codes in both
> versions are different:
>
> if 'a' > 'A' then
> messagebox('', '>')
> else
> messagebox('', '<=')
> end if
>
> Did anyone encounter the problems? any solution for it?