Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

other problem from Appeon 3.1 to Appeon 5.0 (Oracle DB)

4 posts in Appeon (partner product) Last posting was on 2006-10-04 15:55:41.0Z
Marco Meoni Posted on 2006-09-04 13:25:14.0Z
From: "Marco Meoni" <marco.meoni@cern.ch>
Newsgroups: sybase.public.appeon
Subject: other problem from Appeon 3.1 to Appeon 5.0 (Oracle DB)
Lines: 6950
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2869
X-RFC2646: Format=Flowed; Original
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2962
X-Original-NNTP-Posting-Host: 159.213.37.151
Message-ID: <44fc2680@forums-2-dub>
X-Original-Trace: 4 Sep 2006 06:13:36 -0700, 159.213.37.151
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 4 Sep 2006 06:13:37 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 4 Sep 2006 06:25:14 -0700
X-Trace: forums-1-dub 1157376314 10.22.108.75 (4 Sep 2006 06:25:14 -0700)
X-Original-Trace: 4 Sep 2006 06:25:14 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:1544
Article PK: 13047

I use PB 9.0.3 and Oracle 9.2 (via ODBC).

I hoped that migrating from 3.1 to 5.0 (I'm using the trial edition, waiting
for the delivery of the purchased one) could solve some unsupported
features.
My web app used to work fine in Appeon 3.1, now I'm struggling with a series
of weird errors (already written about date format misbehaviour).

Now I've a critical error to deal with:

Picture appeon1 shows a normal dw with retrieved data. If I perform
dw_1.Update(), WITHOUT CHANGING ANYTHING, I get the message that everything
has been stored.

If I change any field, or make an InsertRow(0), populate the new row and
finally perform the Update(), I get an Oracle error (see appeon2.jpg).

I don't understand the reason of that message, if I update or insert rows
either from the PB IDE or from the CLIENT-SERVER version everything is
correctly updated.
Actually the table "visora.rpgini" exists and is correctly reachable via the
suited connection cache (mapped by the transaction object sqlcb)

Please help.

Thank you in advance

appeon1.jpg
appeon2.jpg

Sally Li Posted on 2006-09-08 12:55:24.0Z
From: "Sally Li" <sally.li@appeon.com>
Newsgroups: sybase.public.appeon
References: <44fc2680@forums-2-dub>
Subject: Re: other problem from Appeon 3.1 to Appeon 5.0 (Oracle DB)
Lines: 156
Organization: Appeon
MIME-Version: 1.0
Content-Type: multipart/alternative; boundary="----=_NextPart_000_013C_01C6D388.FA1AC830"
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
NNTP-Posting-Host: 59.37.60.2
X-Original-NNTP-Posting-Host: 59.37.60.2
Message-ID: <4501683c@forums-1-dub>
Date: 8 Sep 2006 05:55:24 -0700
X-Trace: forums-1-dub 1157720124 59.37.60.2 (8 Sep 2006 05:55:24 -0700)
X-Original-Trace: 8 Sep 2006 05:55:24 -0700, 59.37.60.2
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:1564
Article PK: 13053

Hi Marco Meoni,
 
Issue one: If I perform  dw_1.Update(), WITHOUT CHANGING ANYTHING, I get the message that everything  has been stored.
This problem could be caused by using Null value. If there is NULL value introduced in the If statement, the running result on the Web should be different with in PowerBuilder. You may need to adjust your PowerBuilder application to work around this issue.
 
Issue two: If I change any field, or make an InsertRow(0), populate the new row and  finally perform the Update(), I get an Oracle error
According to the provided information, the problem may be caused by the improper configurations. Please check whether you use the owner name before the table name. If it does, I suggest you de-select the option "EnClose table and column names in Quotes" in DataWindow Type Profile Configuration window in Appeon Developer and redeploy the application.
 
Regards
Sally Li
 
"Marco Meoni" <marco.meoni@cern.ch> wrote in message news:44fc2680@forums-2-dub...
>I use PB 9.0.3 and Oracle 9.2 (via ODBC).
>
> I hoped that migrating from 3.1 to 5.0 (I'm using the trial edition, waiting
> for the delivery of the purchased one) could solve some unsupported
> features.
> My web app used to work fine in Appeon 3.1, now I'm struggling with a series
> of weird errors (already written about date format misbehaviour).
>
> Now I've a critical error to deal with:
>
> Picture appeon1 shows a normal dw with retrieved data. If I perform
> dw_1.Update(), WITHOUT CHANGING ANYTHING, I get the message that everything
> has been stored.
>
> If I change any field, or make an InsertRow(0), populate the new row and
> finally perform the Update(), I get an Oracle error (see appeon2.jpg).
>
> I don't understand the reason of that message, if I update or insert rows
> either from the PB IDE or from the CLIENT-SERVER version everything is
> correctly updated.
> Actually the table "visora.rpgini" exists and is correctly reachable via the
> suited connection cache (mapped by the transaction object sqlcb)
>
> Please help.
>
> Thank you in advance
>
>
>


Herman Limas Posted on 2006-09-21 05:45:58.0Z
From: "Herman Limas" <edp@pacc.com.sg>
Newsgroups: sybase.public.appeon
References: <44fc2680@forums-2-dub> <4501683c@forums-1-dub>
Subject: Re: other problem from Appeon 3.1 to Appeon 5.0 (Oracle DB)
Lines: 2248
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2869
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2962
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: 203.120.19.162
X-Original-NNTP-Posting-Host: 203.120.19.162
Message-ID: <45122716@forums-1-dub>
Date: 20 Sep 2006 22:45:58 -0700
X-Trace: forums-1-dub 1158817558 203.120.19.162 (20 Sep 2006 22:45:58 -0700)
X-Original-Trace: 20 Sep 2006 22:45:58 -0700, 203.120.19.162
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:1578
Article PK: 13057

Hi Sally,

I am facing the same problem, application run in Appeon 3.1 but error occurs
when in SAVE event in Appeon 5. See attach screen shot picture. Deployment
environment are as follows:
- Appeon 5, workgroup edition
- Oracle 10g
- PB9 EBF build 8716
- Pentium 4 machine with OS Windows 2000 SP4 and RAM 512MB

Marco, did u get it solved? How?

On top of that, I can deploy my application using Oracle Express Edittion in
Appeon 3.1. I use JDBC-ODBC bridge for my cache connection driver. But I can
not get the same application run in Appeon 5. Any idea?

thks in advance,
Herman



"Sally Li" <sally.li@appeon.com> wrote in message
news:4501683c@forums-1-dub...
Hi Marco Meoni,

Issue one: If I perform dw_1.Update(), WITHOUT CHANGING ANYTHING, I get the
message that everything has been stored.
This problem could be caused by using Null value. If there is NULL value
introduced in the If statement, the running result on the Web should be
different with in PowerBuilder. You may need to adjust your PowerBuilder
application to work around this issue.

Issue two: If I change any field, or make an InsertRow(0), populate the new
row and finally perform the Update(), I get an Oracle error
According to the provided information, the problem may be caused by the
improper configurations. Please check whether you use the owner name before
the table name. If it does, I suggest you de-select the option "EnClose
table and column names in Quotes" in DataWindow Type Profile Configuration
window in Appeon Developer and redeploy the application.

Regards
Sally Li

"Marco Meoni" <marco.meoni@cern.ch> wrote in message
news:44fc2680@forums-2-dub...
>I use PB 9.0.3 and Oracle 9.2 (via ODBC).
>
> I hoped that migrating from 3.1 to 5.0 (I'm using the trial edition,
> waiting
> for the delivery of the purchased one) could solve some unsupported
> features.
> My web app used to work fine in Appeon 3.1, now I'm struggling with a
> series
> of weird errors (already written about date format misbehaviour).
>
> Now I've a critical error to deal with:
>
> Picture appeon1 shows a normal dw with retrieved data. If I perform
> dw_1.Update(), WITHOUT CHANGING ANYTHING, I get the message that
> everything
> has been stored.
>
> If I change any field, or make an InsertRow(0), populate the new row and
> finally perform the Update(), I get an Oracle error (see appeon2.jpg).
>
> I don't understand the reason of that message, if I update or insert rows
> either from the PB IDE or from the CLIENT-SERVER version everything is
> correctly updated.
> Actually the table "visora.rpgini" exists and is correctly reachable via
> the
> suited connection cache (mapped by the transaction object sqlcb)
>
> Please help.
>
> Thank you in advance
>
>
>

Oracle DB Save Error.jpg

Marco Meoni Posted on 2006-10-04 15:55:41.0Z
From: "Marco Meoni" <marco.meoni@cern.ch>
Newsgroups: sybase.public.appeon
References: <44fc2680@forums-2-dub> <4501683c@forums-1-dub> <45122716@forums-1-dub>
Subject: Re: other problem from Appeon 3.1 to Appeon 5.0 (Oracle DB)
Lines: 90
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2869
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2962
X-RFC2646: Format=Flowed; Response
X-Original-NNTP-Posting-Host: pb-d-128-141-49-108.cern.ch
Message-ID: <4523d8df$1@forums-2-dub>
X-Original-Trace: 4 Oct 2006 08:53:03 -0700, pb-d-128-141-49-108.cern.ch
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 4 Oct 2006 08:53:04 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 4 Oct 2006 08:55:41 -0700
X-Trace: forums-1-dub 1159977341 10.22.108.75 (4 Oct 2006 08:55:41 -0700)
X-Original-Trace: 4 Oct 2006 08:55:41 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:1593
Article PK: 13063

I've rebuilt the whole dw, using syntax sql in place of graphical, written
all the table and field names in capital letter and with double quotes.
Moreover, used "Key columns" as "Where clause for update/delete".
Then it works.
Marco

"Herman Limas" <edp@pacc.com.sg> wrote in message
news:45122716@forums-1-dub...
> Hi Sally,
>
> I am facing the same problem, application run in Appeon 3.1 but error
> occurs when in SAVE event in Appeon 5. See attach screen shot picture.
> Deployment environment are as follows:
> - Appeon 5, workgroup edition
> - Oracle 10g
> - PB9 EBF build 8716
> - Pentium 4 machine with OS Windows 2000 SP4 and RAM 512MB
>
> Marco, did u get it solved? How?
>
> On top of that, I can deploy my application using Oracle Express Edittion
> in Appeon 3.1. I use JDBC-ODBC bridge for my cache connection driver. But
> I can not get the same application run in Appeon 5. Any idea?
>
> thks in advance,
> Herman
>
>
>
> "Sally Li" <sally.li@appeon.com> wrote in message
> news:4501683c@forums-1-dub...
> Hi Marco Meoni,
>
> Issue one: If I perform dw_1.Update(), WITHOUT CHANGING ANYTHING, I get
> the message that everything has been stored.
> This problem could be caused by using Null value. If there is NULL value
> introduced in the If statement, the running result on the Web should be
> different with in PowerBuilder. You may need to adjust your PowerBuilder
> application to work around this issue.
>
> Issue two: If I change any field, or make an InsertRow(0), populate the
> new row and finally perform the Update(), I get an Oracle error
> According to the provided information, the problem may be caused by the
> improper configurations. Please check whether you use the owner name
> before the table name. If it does, I suggest you de-select the option
> "EnClose table and column names in Quotes" in DataWindow Type Profile
> Configuration window in Appeon Developer and redeploy the application.
>
> Regards
> Sally Li
>
> "Marco Meoni" <marco.meoni@cern.ch> wrote in message
> news:44fc2680@forums-2-dub...
>>I use PB 9.0.3 and Oracle 9.2 (via ODBC).
>>
>> I hoped that migrating from 3.1 to 5.0 (I'm using the trial edition,
>> waiting
>> for the delivery of the purchased one) could solve some unsupported
>> features.
>> My web app used to work fine in Appeon 3.1, now I'm struggling with a
>> series
>> of weird errors (already written about date format misbehaviour).
>>
>> Now I've a critical error to deal with:
>>
>> Picture appeon1 shows a normal dw with retrieved data. If I perform
>> dw_1.Update(), WITHOUT CHANGING ANYTHING, I get the message that
>> everything
>> has been stored.
>>
>> If I change any field, or make an InsertRow(0), populate the new row and
>> finally perform the Update(), I get an Oracle error (see appeon2.jpg).
>>
>> I don't understand the reason of that message, if I update or insert rows
>> either from the PB IDE or from the CLIENT-SERVER version everything is
>> correctly updated.
>> Actually the table "visora.rpgini" exists and is correctly reachable via
>> the
>> suited connection cache (mapped by the transaction object sqlcb)
>>
>> Please help.
>>
>> Thank you in advance
>>
>>
>>
>
>