Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Retrieve of Datastore fails

7 posts in Appeon (partner product) Last posting was on 2007-01-21 23:49:06.0Z
abiewer Posted on 2007-01-17 10:45:14.0Z
From: abiewer@plansoft.de
Subject: Retrieve of Datastore fails
Newsgroups: sybase.public.appeon
MIME-Version: 1.0
X-Newsreader: Lotus Notes Release 6.0.3 September 26, 2003
X-MIMETrack: Serialize by Notes Client on Axel Biewer/Plansoft(Release 6.0.3|September 26, 2003) at 17.01.2007 12:31:49, Serialize complete at 17.01.2007 12:31:49
Content-Type: text/plain; charset="US-ASCII"
NNTP-Posting-Host: psgate.plan-software.de
X-Original-NNTP-Posting-Host: psgate.plan-software.de
Message-ID: <45ae0c4a$1@forums-1-dub>
Date: 17 Jan 2007 03:45:14 -0700
X-Trace: forums-1-dub 1169034314 193.158.76.67 (17 Jan 2007 03:45:14 -0700)
X-Original-Trace: 17 Jan 2007 03:45:14 -0700, psgate.plan-software.de
Lines: 26
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:1736
Article PK: 13126

We create a Datastore and assign a DataObject
with the following Code:

IDS_DBMS_INFO=Create Datastore
IDS_DBMS_INFO.DataObject="d_dbms_info"

TRhe DataObject is well defined as a simple Select.

when we launch the Retrieve:

IDS_DBMS_INFO.Retrieve();

we get ReturnCode : -1

and the following ErrorMasse in SQLCA.ErrText;

"Failed to get DataWindow SQL from Appeon Server (Application = dm23w,
DataObject = d_dbms_info, DBType = 100). Please make sure you have
deployed your application correctly."

In the native-application This works fine.
Does this not work in APPEON?

Any Tip?


Vincent Posted on 2007-01-18 07:49:35.0Z
Sender: 715f.45ade26d.1804289383@sybase.com
From: Vincent
Newsgroups: sybase.public.appeon
Subject: Re: Retrieve of Datastore fails
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <45af349f.8d8.1681692777@sybase.com>
References: <45ae0c4a$1@forums-1-dub>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 18 Jan 2007 00:49:35 -0700
X-Trace: forums-1-dub 1169110175 10.22.241.41 (18 Jan 2007 00:49:35 -0700)
X-Original-Trace: 18 Jan 2007 00:49:35 -0700, 10.22.241.41
Lines: 42
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:1741
Article PK: 13128

First, please notice there is a statement
IDS_DBMS_INFO.settransobject(SQLCA) or else is missing.

IDS_DBMS_INFO=Create Datastore
IDS_DBMS_INFO.DataObject="d_dbms_info"
IDS_DBMS_INFO.settransobject(SQLCA)
IDS_DBMS_INFO.Retrieve();

Second, the detailed error information are usually given if
the deployment failed. Please give us those information or
screenshots.
If no error information, we believe you have selected a
wrong database type or the wrong database is connected
instead of the intended one. Please check it.

> We create a Datastore and assign a DataObject
> with the following Code:
>
> IDS_DBMS_INFO=Create Datastore
> IDS_DBMS_INFO.DataObject="d_dbms_info"
>
> TRhe DataObject is well defined as a simple Select.
>
> when we launch the Retrieve:
>
> IDS_DBMS_INFO.Retrieve();
>
> we get ReturnCode : -1
>
> and the following ErrorMasse in SQLCA.ErrText;
>
> "Failed to get DataWindow SQL from Appeon Server
> (Application = dm23w, DataObject = d_dbms_info, DBType =
> 100). Please make sure you have deployed your application
> correctly."
>
> In the native-application This works fine.
> Does this not work in APPEON?
>
> Any Tip?
>
>


abiewer Posted on 2007-01-18 20:14:07.0Z
From: abiewer@plansoft.de
Subject: Re: Retrieve of Datastore fails
Newsgroups: sybase.public.appeon
MIME-Version: 1.0
References: <45ae0c4a$1@forums-1-dub> <45af349f.8d8.1681692777@sybase.com>
X-Newsreader: Lotus Notes Release 6.0.3 September 26, 2003
X-MIMETrack: Serialize by Notes Client on Axel Biewer/Plansoft(Release 6.0.3|September 26, 2003) at 18.01.2007 21:59:37, Serialize complete at 18.01.2007 21:59:37
Content-Type: text/plain; charset="US-ASCII"
NNTP-Posting-Host: psgate.plan-software.de
X-Original-NNTP-Posting-Host: psgate.plan-software.de
Message-ID: <45afe31f$1@forums-1-dub>
Date: 18 Jan 2007 13:14:07 -0700
X-Trace: forums-1-dub 1169154847 193.158.76.67 (18 Jan 2007 13:14:07 -0700)
X-Original-Trace: 18 Jan 2007 13:14:07 -0700, psgate.plan-software.de
Lines: 64
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:1742
Article PK: 21340

The application works fine in Native Mode.

the Code is:

DS_DBMS_INFO = Create dm_n_ds_sql_select_binary_search;
--> dm_n_ds_sql_select_binary_search is derived from Datastore
IDS_DBMS_INFO.DataObject = "d_dbms_info"; -->
d_dbms_info is well defined

li_ret=IDS_DBMS_INFO.SetTransObject(SQLCA); --> returns 1 (o.k.)
LL_RANZ=IDS_DBMS_INFO.Retrieve(LS_DBMS); -> returns -1 (not o.k.)

I'm quite sure that the Database Connection is correct, because other
Statements work properly

The SQLError Message is exactly:

Failed to get DataWindow SQL from Appeon Server (Application = dm23w,
DataObject = d_dbms_info, DBType = 100). Please make sure you have
deployed your application correctly.

When I deploy I get 2 Errors:

The Log of Deployment Wizard
Application Name: dm23w
Log Option: Summary mode
Log Startup Time: 2007-01-18 21:56:20
Log File Location:
D:\Programme\Appeon\Developer5.0\AXProject\dm23w\debug\LOG\DeployWizardLog_20070118215620.xml



--------------------------------------------------------------------------------


Time Content
21:56:22 Generating DWSQL...
21:56:22 Exporting PB object...
21:56:22 Organizing objects...
21:56:24 00051:Failed to get object from the memory stack. --> Error
1
21:56:26 Start generating Web files...
21:56:31 Generating other files.
21:56:34 Generating AppInfo.xml file.
21:56:34 Finished generating Web files.
21:56:35 Connecting to Appeon Server: localhost
21:56:35 Deploying application name to Appeon Server...
21:56:35 Deploying INI file(s) to Appeon Server...
21:56:35 Deploying DataWindow SQL to Appeon Server...
21:56:37 Deploying embedded SQL to Appeon Server...
21:56:37 Deploying DataWindow Syntax to Appeon Server...
21:56:37 Committing changes to Appeon Server...
21:56:37 --> Error 2
21:56:37 Deploying Web files to all Web server(s)...
21:56:37 Connecting to Web server:Local Web Server
21:56:37 Deployed config\dm23w.xml to Local Web Server.
21:56:37 Deployed config\appinfo.xml to Local Web Server.
21:56:37 Deployed index.html to Local Web Server.
21:56:37 Deployed index.htm to Local Web Server.
21:56:37 Deployed application.htm to Local Web Server.

Thank's axel


abiewer Posted on 2007-01-18 20:27:01.0Z
From: abiewer@plansoft.de
Subject: Re: Retrieve of Datastore fails
Newsgroups: sybase.public.appeon
MIME-Version: 1.0
References: <45ae0c4a$1@forums-1-dub> <45af349f.8d8.1681692777@sybase.com>
X-Newsreader: Lotus Notes Release 6.0.3 September 26, 2003
X-MIMETrack: Serialize by Notes Client on Axel Biewer/Plansoft(Release 6.0.3|September 26, 2003) at 18.01.2007 22:14:06, Serialize complete at 18.01.2007 22:14:06
Content-Type: text/plain; charset="US-ASCII"
NNTP-Posting-Host: psgate.plan-software.de
X-Original-NNTP-Posting-Host: psgate.plan-software.de
Message-ID: <45afe625@forums-1-dub>
Date: 18 Jan 2007 13:27:01 -0700
X-Trace: forums-1-dub 1169155621 193.158.76.67 (18 Jan 2007 13:27:01 -0700)
X-Original-Trace: 18 Jan 2007 13:27:01 -0700, psgate.plan-software.de
Lines: 2
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:1745
Article PK: 21341

Even if we Create a pure Datastore, the behaviour is the same.
axel