Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

WorkSpace deplynig old version of JSP?? - No launchable artifact could be found in the selection

4 posts in General Discussion Last posting was on 2007-01-31 03:31:03.0Z
JA Posted on 2007-01-29 14:19:18.0Z
Sender: 2030.45b7741e.1804289383@sybase.com
From: JA
Newsgroups: sybase.public.workspace.general
Subject: WorkSpace deplynig old version of JSP?? - No launchable artifact could be found in the selection
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <45be1075.1ee9.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 29 Jan 2007 07:19:18 -0700
X-Trace: forums-1-dub 1170083958 10.22.241.41 (29 Jan 2007 07:19:18 -0700)
X-Original-Trace: 29 Jan 2007 07:19:18 -0700, 10.22.241.41
Lines: 30
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.workspace.general:296
Article PK: 1087980

Hi all-

I have the following situation:

I've developed a web application which has several JSPs and
2 Servlets.

Suddenly I've realized that although I've changed one of my
JSPs, WorkSpace is still deploying an old version, which
does not include my modifications!

I usually deploy/run my projects by right clicking on the
project and then selecting Run as... -> Run on server... or
just Run.

Another thing I've noticed is that if I try to deploy or run
the JSP by right-clicking the JSP and the selecting Run
as... -> Run on server... the following pop-up appears: "No
launchable artifact could be found in the selection".

Environment:
* Syabse WorkSpace 1.5, Build id: 2006051914
* Sybase EAServer 5.5, Build 55012 (Windows 2003)

Any help, ideas, suggestions and/or workarounds will be
appreciated!

Thanks in advance!

Juan


Samir Nigam Posted on 2007-01-29 18:05:34.0Z
From: "Samir Nigam" <samir_dot_nigam@sybase.com>
Newsgroups: sybase.public.workspace.general
References: <45be1075.1ee9.1681692777@sybase.com>
Subject: Re: WorkSpace deplynig old version of JSP?? - No launchable artifact could be found in the selection
Lines: 2291
MIME-Version: 1.0
Content-Type: multipart/related; type="multipart/alternative"; boundary="----=_NextPart_000_0036_01C74393.728B8C30"
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3028
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3028
NNTP-Posting-Host: snigamxp.sybase.com
X-Original-NNTP-Posting-Host: snigamxp.sybase.com
Message-ID: <45be457e$1@forums-1-dub>
Date: 29 Jan 2007 11:05:34 -0700
X-Trace: forums-1-dub 1170097534 10.22.85.194 (29 Jan 2007 11:05:34 -0700)
X-Original-Trace: 29 Jan 2007 11:05:34 -0700, snigamxp.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.workspace.general:297
Article PK: 1087994

Juan,
 
There are two possibilities.. First, somehow your generated binaries are newer than the source. You can try doing a project->clean to see it helps. More likely, there is a problem with your webapp project's natures and/or builders. Make sure that the project has Web Application Nature and the all builders are enabled.
 
Lookup a project properties via right-click on the Project name in WS Navigator, and select Properties option. Second issue with JSP not being a valid launchable artifact seems like the same problem too..
 
Screenshots attached..
 
 
 
Regards,
Samidr
 
<JA> wrote in message news:45be1075.1ee9.1681692777@sybase.com...
> Hi all-
>
> I have the following situation:
>
> I've developed a web application which has several JSPs and
> 2 Servlets.
>
> Suddenly I've realized that although I've changed one of my
> JSPs, WorkSpace is still deploying an old version, which
> does not include my modifications!
>
> I usually deploy/run my projects by right clicking on the
> project and then selecting Run as... -> Run on server... or
> just Run.
>
> Another thing I've noticed is that if I try to deploy or run
> the JSP by right-clicking the JSP and the selecting Run
> as... -> Run on server... the following pop-up appears: "No
> launchable artifact could be found in the selection".
>
> Environment:
> * Syabse WorkSpace 1.5, Build id: 2006051914
> * Sybase EAServer 5.5, Build 55012 (Windows 2003)
>
> Any help, ideas, suggestions and/or workarounds will be
> appreciated!
>
> Thanks in advance!
>
> Juan

projectnatures.jpg
projectbuilders.jpg