Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Problem after upgrade from 3.1 to 5.0

7 posts in Appeon (partner product) Last posting was on 2007-02-26 09:39:47.0Z
steve wong Posted on 2007-02-06 09:21:11.0Z
From: "steve wong" <nospam_stevewong1999@yahoo.com>
Newsgroups: sybase.public.appeon
Subject: Problem after upgrade from 3.1 to 5.0
Lines: 15
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
NNTP-Posting-Host: 202.64.139.7
X-Original-NNTP-Posting-Host: 202.64.139.7
Message-ID: <45c85697$1@forums-1-dub>
Date: 6 Feb 2007 02:21:11 -0700
X-Trace: forums-1-dub 1170757271 202.64.139.7 (6 Feb 2007 02:21:11 -0700)
X-Original-Trace: 6 Feb 2007 02:21:11 -0700, 202.64.139.7
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:1784
Article PK: 13148

Hi,

Just recently upgraded from appeon 3.1 to appeon 5.0 on a PB10.2 application
and some problems came out. Pls help.

In a nested report under a compositive Datawindow, all rowcount(), page(),
getrow() functions return abnormal. For example, all page() return 1 even
there are several pages after retrieved the compositive datawindow.

Pls help. It works perfectly in appeon 3.1 but not in appeon 5.0.


Dave Hentrich Posted on 2007-02-06 17:03:01.0Z
From: "Dave Hentrich" <dhentrich@responsegroupinc.com>
Newsgroups: sybase.public.appeon
References: <45c85697$1@forums-1-dub>
Subject: Re: Problem after upgrade from 3.1 to 5.0
Lines: 25
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3028
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3028
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: adsl-70-232-174-43.dsl.emhril.sbcglobal.net
X-Original-NNTP-Posting-Host: adsl-70-232-174-43.dsl.emhril.sbcglobal.net
Message-ID: <45c8c2d5$1@forums-1-dub>
Date: 6 Feb 2007 10:03:01 -0700
X-Trace: forums-1-dub 1170784981 70.232.174.43 (6 Feb 2007 10:03:01 -0700)
X-Original-Trace: 6 Feb 2007 10:03:01 -0700, adsl-70-232-174-43.dsl.emhril.sbcglobal.net
X-Authenticated-User: pb110beta
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:1785
Article PK: 13149

I am having the same problem with the Page() datawindow function. Unless my
datawindow has groups, Page() always returns a 1. PageCount() returns the
correct value, but Page() does not. I am also using the latest EBF of 5.0.

"steve wong" <nospam_stevewong1999@yahoo.com> wrote in message
news:45c85697$1@forums-1-dub...
> Hi,
>
> Just recently upgraded from appeon 3.1 to appeon 5.0 on a PB10.2
> application
> and some problems came out. Pls help.
>
> In a nested report under a compositive Datawindow, all rowcount(), page(),
> getrow() functions return abnormal. For example, all page() return 1 even
> there are several pages after retrieved the compositive datawindow.
>
> Pls help. It works perfectly in appeon 3.1 but not in appeon 5.0.
>
>
>
>
>


Dave Hentrich Posted on 2007-02-06 17:09:12.0Z
From: "Dave Hentrich" <dhentrich@responsegroupinc.com>
Newsgroups: sybase.public.appeon
References: <45c85697$1@forums-1-dub>
Subject: Re: Problem after upgrade from 3.1 to 5.0
Lines: 25
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3028
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3028
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: adsl-70-232-174-43.dsl.emhril.sbcglobal.net
X-Original-NNTP-Posting-Host: adsl-70-232-174-43.dsl.emhril.sbcglobal.net
Message-ID: <45c8c448@forums-1-dub>
Date: 6 Feb 2007 10:09:12 -0700
X-Trace: forums-1-dub 1170785352 70.232.174.43 (6 Feb 2007 10:09:12 -0700)
X-Original-Trace: 6 Feb 2007 10:09:12 -0700, adsl-70-232-174-43.dsl.emhril.sbcglobal.net
X-Authenticated-User: pb110beta
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:1786
Article PK: 21365

I've confirmed on my application that if I create a datawindow group, the
Page() function returns the appropriate value. If the datawindow does not
have groups, it always returns 1. Definitely a bug, but I need a better
work around than having to create a "dummy" group on every datawindow.

"steve wong" <nospam_stevewong1999@yahoo.com> wrote in message
news:45c85697$1@forums-1-dub...
> Hi,
>
> Just recently upgraded from appeon 3.1 to appeon 5.0 on a PB10.2
> application
> and some problems came out. Pls help.
>
> In a nested report under a compositive Datawindow, all rowcount(), page(),
> getrow() functions return abnormal. For example, all page() return 1 even
> there are several pages after retrieved the compositive datawindow.
>
> Pls help. It works perfectly in appeon 3.1 but not in appeon 5.0.
>
>
>
>
>


Dave Hentrich Posted on 2007-02-06 17:26:20.0Z
From: "Dave Hentrich" <dhentrich@responsegroupinc.com>
Newsgroups: sybase.public.appeon
References: <45c85697$1@forums-1-dub> <45c8c448@forums-1-dub>
Subject: Re: Problem after upgrade from 3.1 to 5.0
Lines: 34
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3028
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3028
X-RFC2646: Format=Flowed; Response
NNTP-Posting-Host: adsl-70-232-174-43.dsl.emhril.sbcglobal.net
X-Original-NNTP-Posting-Host: adsl-70-232-174-43.dsl.emhril.sbcglobal.net
Message-ID: <45c8c84c$1@forums-1-dub>
Date: 6 Feb 2007 10:26:20 -0700
X-Trace: forums-1-dub 1170786380 70.232.174.43 (6 Feb 2007 10:26:20 -0700)
X-Original-Trace: 6 Feb 2007 10:26:20 -0700, adsl-70-232-174-43.dsl.emhril.sbcglobal.net
X-Authenticated-User: pb110beta
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:1787
Article PK: 21364

I've logged case #11322742 to report this. So far, to get around it, I
created a datawindow group on a retrieval argument to ensure there is only 1
group for the entire report. Page() works fine then.

"Dave Hentrich" <dhentrich@responsegroupinc.com> wrote in message
news:45c8c448@forums-1-dub...
> I've confirmed on my application that if I create a datawindow group, the
> Page() function returns the appropriate value. If the datawindow does not
> have groups, it always returns 1. Definitely a bug, but I need a better
> work around than having to create a "dummy" group on every datawindow.
>
> "steve wong" <nospam_stevewong1999@yahoo.com> wrote in message
> news:45c85697$1@forums-1-dub...
>> Hi,
>>
>> Just recently upgraded from appeon 3.1 to appeon 5.0 on a PB10.2
>> application
>> and some problems came out. Pls help.
>>
>> In a nested report under a compositive Datawindow, all rowcount(),
>> page(),
>> getrow() functions return abnormal. For example, all page() return 1 even
>> there are several pages after retrieved the compositive datawindow.
>>
>> Pls help. It works perfectly in appeon 3.1 but not in appeon 5.0.
>>
>>
>>
>>
>>
>
>


Yang yongqing Posted on 2007-02-13 09:21:35.0Z
Sender: 1a57.45cc2b3c.1804289383@sybase.com
From: Yang yongqing
Newsgroups: sybase.public.appeon
Subject: Re: Problem after upgrade from 3.1 to 5.0
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <45d1831f.7c69.1681692777@sybase.com>
References: <45c8c84c$1@forums-1-dub>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 13 Feb 2007 01:21:35 -0800
X-Trace: forums-1-dub 1171358495 10.22.241.41 (13 Feb 2007 01:21:35 -0800)
X-Original-Trace: 13 Feb 2007 01:21:35 -0800, 10.22.241.41
Lines: 6
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:1793
Article PK: 21369

Hi,
We have reproduced this issue. It will be fixed in the
next EBF.

Regards,
Yang yongqing