Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

ARC Generated SQL does not work

4 posts in Replication Last posting was on 2007-02-20 16:28:35.0Z
Paul Man Posted on 2007-02-15 09:39:50.0Z
From: "Paul Man" <paulman@datasoft.ie>
Newsgroups: advantage.Replication
Subject: ARC Generated SQL does not work
Date: Thu, 15 Feb 2007 09:39:50 -0000
Lines: 26
Organization: DSoft
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3028
X-RFC2646: Format=Flowed; Original
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3028
NNTP-Posting-Host: 82.141.233.142
Message-ID: <45d42992@solutions.advantagedatabase.com>
X-Trace: 15 Feb 2007 02:36:18 -0700, 82.141.233.142
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!82.141.233.142
Xref: solutions.advantagedatabase.com Advantage.Replication:168
Article PK: 1134027

Hi

I generated the following SQL script from a database replication so that I
could implement it elsewhere. The problem is that it wont' run as it gives
a 5132 error that the specific object does not exist. What's wrong?


EXECUTE PROCEDURE
sp_CreatePublication (
'BasicReplication',
'Basic Replication publication',
0 );
EXECUTE PROCEDURE
sp_CreateArticle (
'BasicReplication',
'CURRENCY',
'CODE;',
'',
0 );
/* The error occurs next even though Currency table exists */
EXECUTE PROCEDURE sp_ModifyArticleProperty( 'CURRENCY',
'BasicReplication',
'Include_Columns',
'CODE;NAME;RATE;' );


Paul Man Posted on 2007-02-15 11:40:23.0Z
From: "Paul Man" <paulman@datasoft.ie>
Newsgroups: advantage.Replication
References: <45d42992@solutions.advantagedatabase.com>
Subject: Re: ARC Generated SQL does not work
Date: Thu, 15 Feb 2007 11:40:23 -0000
Lines: 38
Organization: DSoft
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3028
X-RFC2646: Format=Flowed; Response
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3028
NNTP-Posting-Host: 82.141.233.142
Message-ID: <45d445d2@solutions.advantagedatabase.com>
X-Trace: 15 Feb 2007 04:36:50 -0700, 82.141.233.142
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!82.141.233.142
Xref: solutions.advantagedatabase.com Advantage.Replication:169
Article PK: 1134028

The problem is that it generates incorrect code.
It should be
EXECUTE PROCEDURE sp_ModifyArticleProperty( 'BasicReplication' , <-
publication
'CURRENCY',
<- table
'Include_Columns',
'CODE;NAME;RATE;' );

"Paul Man" <paulman@datasoft.ie> wrote in message
news:45d42992@solutions.advantagedatabase.com...
> Hi
>
> I generated the following SQL script from a database replication so that I
> could implement it elsewhere. The problem is that it wont' run as it
> gives a 5132 error that the specific object does not exist. What's wrong?
>
>
> EXECUTE PROCEDURE
> sp_CreatePublication (
> 'BasicReplication',
> 'Basic Replication publication',
> 0 );
> EXECUTE PROCEDURE
> sp_CreateArticle (
> 'BasicReplication',
> 'CURRENCY',
> 'CODE;',
> '',
> 0 );
> /* The error occurs next even though Currency table exists */
> EXECUTE PROCEDURE sp_ModifyArticleProperty( 'CURRENCY',
> 'BasicReplication',
> 'Include_Columns',
> 'CODE;NAME;RATE;' );
>


Lance Schmidt Posted on 2007-02-15 16:37:35.0Z
From: "Lance Schmidt" <LanceSc@ExtendSys.com>
Newsgroups: advantage.Replication
References: <45d42992@solutions.advantagedatabase.com>
Subject: Re: ARC Generated SQL does not work
Date: Thu, 15 Feb 2007 09:37:35 -0700
Lines: 38
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3028
X-RFC2646: Format=Flowed; Response
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3028
NNTP-Posting-Host: 10.24.38.197
Message-ID: <45d48b47@solutions.advantagedatabase.com>
X-Trace: 15 Feb 2007 09:33:11 -0700, 10.24.38.197
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!10.24.38.197
Xref: solutions.advantagedatabase.com Advantage.Replication:174
Article PK: 1134033

Hi Paul,

Thank you for the bug report this will be fixed in the next release.

Best Regards,

Lance Schmidt
Advantage R&D

"Paul Man" <paulman@datasoft.ie> wrote in message
news:45d42992@solutions.advantagedatabase.com...
> Hi
>
> I generated the following SQL script from a database replication so that I
> could implement it elsewhere. The problem is that it wont' run as it
> gives a 5132 error that the specific object does not exist. What's wrong?
>
>
> EXECUTE PROCEDURE
> sp_CreatePublication (
> 'BasicReplication',
> 'Basic Replication publication',
> 0 );
> EXECUTE PROCEDURE
> sp_CreateArticle (
> 'BasicReplication',
> 'CURRENCY',
> 'CODE;',
> '',
> 0 );
> /* The error occurs next even though Currency table exists */
> EXECUTE PROCEDURE sp_ModifyArticleProperty( 'CURRENCY',
> 'BasicReplication',
> 'Include_Columns',
> 'CODE;NAME;RATE;' );
>


Paul Man Posted on 2007-02-20 16:28:35.0Z
From: "Paul Man" <paulman@datasoft.ie>
Newsgroups: advantage.Replication
References: <45d42992@solutions.advantagedatabase.com> <45d48b47@solutions.advantagedatabase.com>
Subject: Re: ARC Generated SQL does not work
Date: Tue, 20 Feb 2007 16:28:35 -0000
Lines: 49
Organization: DSoft
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3028
X-RFC2646: Format=Flowed; Response
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3028
NNTP-Posting-Host: 82.141.233.142
Message-ID: <45db20eb@solutions.advantagedatabase.com>
X-Trace: 20 Feb 2007 09:25:15 -0700, 82.141.233.142
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!82.141.233.142
Xref: solutions.advantagedatabase.com Advantage.Replication:180
Article PK: 1134039

Another problem is that the generated SQL attempts to set the primary key
index to the new index before it gets to create the index. The order of
course is 1) Create primary key index and 2) set table primary key to that
index.

"Lance Schmidt" <LanceSc@ExtendSys.com> wrote in message
news:45d48b47@solutions.advantagedatabase.com...
> Hi Paul,
>
> Thank you for the bug report this will be fixed in the next release.
>
> Best Regards,
>
> Lance Schmidt
> Advantage R&D
>
> "Paul Man" <paulman@datasoft.ie> wrote in message
> news:45d42992@solutions.advantagedatabase.com...
>> Hi
>>
>> I generated the following SQL script from a database replication so that
>> I could implement it elsewhere. The problem is that it wont' run as it
>> gives a 5132 error that the specific object does not exist. What's
>> wrong?
>>
>>
>> EXECUTE PROCEDURE
>> sp_CreatePublication (
>> 'BasicReplication',
>> 'Basic Replication publication',
>> 0 );
>> EXECUTE PROCEDURE
>> sp_CreateArticle (
>> 'BasicReplication',
>> 'CURRENCY',
>> 'CODE;',
>> '',
>> 0 );
>> /* The error occurs next even though Currency table exists */
>> EXECUTE PROCEDURE sp_ModifyArticleProperty( 'CURRENCY',
>> 'BasicReplication',
>> 'Include_Columns',
>> 'CODE;NAME;RATE;' );
>>
>
>