Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

RTE Clear

16 posts in Objects Last posting was on 2007-06-07 20:17:59.0Z
Suresh Thoduvail Posted on 2007-02-28 00:19:11.0Z
Sender: 63ad.45e4c892.1804289383@sybase.com
From: Suresh Thoduvail
Newsgroups: sybase.public.powerbuilder.objects
Subject: RTE Clear
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <45e4ca7f.63c8.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 27 Feb 2007 16:19:11 -0800
X-Trace: forums-1-dub 1172621951 10.22.241.41 (27 Feb 2007 16:19:11 -0800)
X-Original-Trace: 27 Feb 2007 16:19:11 -0800, 10.22.241.41
Lines: 16
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:9246
Article PK: 736407

Hi All,

I have created a table with rows and columns in RTE
Control and have populated lots of data from the database
into those rows and columns.

when i re-retrieve the report ( RTE ) i need to clean up the
slate (RTE) and starting populating the RTE table again.

When I do a rte_1.Clear() it deletes the data but not the
table i have created, is there a work around. All i need to
to clear up the entire richtext object and start doing stuff
again.

Any help greately appreciated.
Suresh


Brad Wery[TeamSybase] Posted on 2007-02-28 14:12:44.0Z
From: "Brad Wery[TeamSybase]" <bradweryatagricoreunited.com>
User-Agent: Mozilla Thunderbird 1.0.2 (Windows/20050317)
X-Accept-Language: en-us, en
MIME-Version: 1.0
Newsgroups: sybase.public.powerbuilder.objects
Subject: Re: RTE Clear
References: <45e4ca7f.63c8.1681692777@sybase.com>
In-Reply-To: <45e4ca7f.63c8.1681692777@sybase.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: ugg10.unitedgrain.ca
X-Original-NNTP-Posting-Host: ugg10.unitedgrain.ca
Message-ID: <45e58ddc$1@forums-1-dub>
Date: 28 Feb 2007 06:12:44 -0800
X-Trace: forums-1-dub 1172671964 165.23.247.49 (28 Feb 2007 06:12:44 -0800)
X-Original-Trace: 28 Feb 2007 06:12:44 -0800, ugg10.unitedgrain.ca
Lines: 25
X-Authenticated-User: teamsybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:9248
Article PK: 736409

What if you did a SelectTextAll() before the Clear?

Suresh Thoduvail wrote:
> Hi All,
>
> I have created a table with rows and columns in RTE
> Control and have populated lots of data from the database
> into those rows and columns.
>
> when i re-retrieve the report ( RTE ) i need to clean up the
> slate (RTE) and starting populating the RTE table again.
>
> When I do a rte_1.Clear() it deletes the data but not the
> table i have created, is there a work around. All i need to
> to clear up the entire richtext object and start doing stuff
> again.
>
> Any help greately appreciated.
> Suresh

--

Join the Advanced GUI Development project on CodeXchange
https://advanced-gui-development.codexchange.sybase.com/


Suresh Thoduvail Posted on 2007-03-01 20:08:41.0Z
Sender: 6423.45e4d0cb.1804289383@sybase.com
From: Suresh Thoduvail
Newsgroups: sybase.public.powerbuilder.objects
Subject: Re: RTE Clear
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <45e732c9.2061.1681692777@sybase.com>
References: <45e58ddc$1@forums-1-dub>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 1 Mar 2007 12:08:41 -0800
X-Trace: forums-1-dub 1172779721 10.22.241.41 (1 Mar 2007 12:08:41 -0800)
X-Original-Trace: 1 Mar 2007 12:08:41 -0800, 10.22.241.41
Lines: 39
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:9250
Article PK: 736412

Hi Brad,

If i do a AelectTextAll(), it selects all the text in
the table and then if i give a Clear(), it clears the text,
but not the table. Table is still there, one solution that
was a quick fix sort of thing which i did earlier was:

Do While True
aru_rte.undo()
IF not aru_rte.canundo( ) Then Exit
Loop

Sometimes works sometimes does not work.

> What if you did a SelectTextAll() before the Clear?
>
> Suresh Thoduvail wrote:
> > Hi All,
> >
> > I have created a table with rows and columns in RTE
> > Control and have populated lots of data from the
> > database into those rows and columns.
> >
> > when i re-retrieve the report ( RTE ) i need to clean up
> > the slate (RTE) and starting populating the RTE table
> > again.
> > When I do a rte_1.Clear() it deletes the data but not
> > the table i have created, is there a work around. All i
> > need to to clear up the entire richtext object and start
> > doing stuff again.
> >
> > Any help greately appreciated.
> > Suresh
>
>
> --
>
> Join the Advanced GUI Development project on CodeXchange
> https://advanced-gui-development.codexchange.sybase.com/


Brad Wery[TeamSybase] Posted on 2007-03-01 20:30:11.0Z
From: "Brad Wery[TeamSybase]" <bradweryatagricoreunited.com>
User-Agent: Mozilla Thunderbird 1.0.2 (Windows/20050317)
X-Accept-Language: en-us, en
MIME-Version: 1.0
Newsgroups: sybase.public.powerbuilder.objects
Subject: Re: RTE Clear
References: <45e58ddc$1@forums-1-dub> <45e732c9.2061.1681692777@sybase.com>
In-Reply-To: <45e732c9.2061.1681692777@sybase.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: ugg10.unitedgrain.ca
X-Original-NNTP-Posting-Host: ugg10.unitedgrain.ca
Message-ID: <45e737d3$1@forums-1-dub>
Date: 1 Mar 2007 12:30:11 -0800
X-Trace: forums-1-dub 1172781011 165.23.247.49 (1 Mar 2007 12:30:11 -0800)
X-Original-Trace: 1 Mar 2007 12:30:11 -0800, ugg10.unitedgrain.ca
Lines: 86
X-Authenticated-User: teamsybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:9251
Article PK: 736410

I do something similar here. I allow my users to select form types from
a drop down list. Some of those forms have tables in them. If I do a
SelectTextAll then a PasteRTF, the new selected document gets inserted
and the old document is deleted.

Would that work for you (SelectTextAll with PasteRTF).

This is what I do:

Blob lb_data
Long ll_line, ll_col, ll_id
String ls_user
DateTime ldt_today

rte_1.Position(ll_line, ll_col)

rte_1.SetRedraw(FALSE)

ll_id = Long(sle_1.Text)

SELECTBLOB rtf_syntax
INTO :lb_data
FROM my_blob_table
WHERE my_key_column = :ll_id;

rte_1.SelectTextAll()
rte_1.PasteRTF(String(lb_data))

RTE_1.SelectText(ll_line, ll_col, 0, 0)

RTE_1.Modified = FALSE

rte_1.SetRedraw(TRUE)



Brad

Suresh Thoduvail wrote:
> Hi Brad,
>
> If i do a AelectTextAll(), it selects all the text in
> the table and then if i give a Clear(), it clears the text,
> but not the table. Table is still there, one solution that
> was a quick fix sort of thing which i did earlier was:
>
> Do While True
> aru_rte.undo()
> IF not aru_rte.canundo( ) Then Exit
> Loop
>
> Sometimes works sometimes does not work.
>
>
>>What if you did a SelectTextAll() before the Clear?
>>
>>Suresh Thoduvail wrote:
>>
>>>Hi All,
>>>
>>> I have created a table with rows and columns in RTE
>>>Control and have populated lots of data from the
>>>database into those rows and columns.
>>>
>>>when i re-retrieve the report ( RTE ) i need to clean up
>>>the slate (RTE) and starting populating the RTE table
>>>again.
>>> When I do a rte_1.Clear() it deletes the data but not
>>>the table i have created, is there a work around. All i
>>>need to to clear up the entire richtext object and start
>>>doing stuff again.
>>>
>>>Any help greately appreciated.
>>>Suresh
>>
>>
>>--
>>
>>Join the Advanced GUI Development project on CodeXchange
>>https://advanced-gui-development.codexchange.sybase.com/

--

Join the Advanced GUI Development project on CodeXchange
https://advanced-gui-development.codexchange.sybase.com/


Suresh Thoduvail Posted on 2007-03-01 22:47:19.0Z
Sender: 23f4.45e75484.1804289383@sybase.com
From: Suresh Thoduvail
Newsgroups: sybase.public.powerbuilder.objects
Subject: Re: RTE Clear
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <45e757f7.243c.1681692777@sybase.com>
References: <45e737d3$1@forums-1-dub>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 1 Mar 2007 14:47:19 -0800
X-Trace: forums-1-dub 1172789239 10.22.241.41 (1 Mar 2007 14:47:19 -0800)
X-Original-Trace: 1 Mar 2007 14:47:19 -0800, 10.22.241.41
Lines: 135
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:9252
Article PK: 736411

Hello Brad,


I tried your solution, unfortunately it does not work for
me. as i earlier said select text all and then pasting the
blob still keeps the table i have created earlier.
eg: if there are 3 records to be populated i create 3 rows
and 4 columns. the data would look like.
----------------------------------------------------------
Date Type RTE data Office
----------------------------------------------------------
xx | ABC | xx RTE data | some office
_____|__________|_____________________|__________________

xx | ABC | xx RTE data | some office
_____|__________|_____________________|__________________

xx | ABC | xx RTE data | some office
_____|__________|_____________________|__________________

This is because the users want RTF data in one column and
that
data can be a few KB.

My Undo solution is not working because if the RTE data
spreads across few pages, the undo does not work.
what my undo logic is doing is as follows.
----------------------------------------------------------
Date Type RTE data Office
----------------------------------------------------------
xx | ABC | xx RTE data | some office
_____|__________|_____________________|__________________

xx | ABC | xx RTE data | some office
_____|__________|_____________________|__________________

xx | ABC | xx RTE data | some office
_____|__________|_____________________|__________________

| | |

_____|__________|_____________________|__________________
| | |
_____|__________|_____________________|__________________

ie, keeping my initial 3 rows it is not discarding the table
i
created in RTF. Any solution greatly appreciated.


> I do something similar here. I allow my users to select
> form types from a drop down list. Some of those forms
> have tables in them. If I do a SelectTextAll then a
> PasteRTF, the new selected document gets inserted and the
> old document is deleted.
>
> Would that work for you (SelectTextAll with PasteRTF).
>
> This is what I do:
>
> Blob lb_data
> Long ll_line, ll_col, ll_id
> String ls_user
> DateTime ldt_today
>
> rte_1.Position(ll_line, ll_col)
>
> rte_1.SetRedraw(FALSE)
>
> ll_id = Long(sle_1.Text)
>
> SELECTBLOB rtf_syntax
> INTO :lb_data
> FROM my_blob_table
> WHERE my_key_column = :ll_id;
>
> rte_1.SelectTextAll()
> rte_1.PasteRTF(String(lb_data))
>
> RTE_1.SelectText(ll_line, ll_col, 0, 0)
>
> RTE_1.Modified = FALSE
>
> rte_1.SetRedraw(TRUE)
>
>
>
> Brad
>
> Suresh Thoduvail wrote:
> > Hi Brad,
> >
> > If i do a AelectTextAll(), it selects all the text in
> > the table and then if i give a Clear(), it clears the
> > text, but not the table. Table is still there, one
> > solution that was a quick fix sort of thing which i did
> > earlier was:
> > Do While True
> > aru_rte.undo()
> > IF not aru_rte.canundo( ) Then Exit
> > Loop
> >
> > Sometimes works sometimes does not work.
> >
> >
> >>What if you did a SelectTextAll() before the Clear?
> >>
> >>Suresh Thoduvail wrote:
> >>
> >>>Hi All,
> >>>
> >>> I have created a table with rows and columns in RTE
> >>>Control and have populated lots of data from the
> >>>database into those rows and columns.
> >>>
> >>>when i re-retrieve the report ( RTE ) i need to clean
> up >>>the slate (RTE) and starting populating the RTE
> table >>>again.
> >>> When I do a rte_1.Clear() it deletes the data but not
> >>>the table i have created, is there a work around. All i
> >>>need to to clear up the entire richtext object and
> start >>>doing stuff again.
> >>>
> >>>Any help greately appreciated.
> >>>Suresh
> >>
> >>
> >>--
> >>
> >>Join the Advanced GUI Development project on CodeXchange
> >>https://advanced-gui-development.codexchange.sybase.com/
>
>
> --
>
> Join the Advanced GUI Development project on CodeXchange
> https://advanced-gui-development.codexchange.sybase.com/


Brad Wery[TeamSybase] Posted on 2007-03-02 14:16:25.0Z
From: "Brad Wery[TeamSybase]" <bradweryatagricoreunited.com>
User-Agent: Mozilla Thunderbird 1.0.2 (Windows/20050317)
X-Accept-Language: en-us, en
MIME-Version: 1.0
Newsgroups: sybase.public.powerbuilder.objects
Subject: Re: RTE Clear
References: <45e737d3$1@forums-1-dub> <45e757f7.243c.1681692777@sybase.com>
In-Reply-To: <45e757f7.243c.1681692777@sybase.com>
Content-Type: multipart/mixed; boundary="------------020908060004010204090105"
NNTP-Posting-Host: ugg10.unitedgrain.ca
X-Original-NNTP-Posting-Host: ugg10.unitedgrain.ca
Message-ID: <45e831b9$1@forums-1-dub>
Date: 2 Mar 2007 06:16:25 -0800
X-Trace: forums-1-dub 1172844985 165.23.247.49 (2 Mar 2007 06:16:25 -0800)
X-Original-Trace: 2 Mar 2007 06:16:25 -0800, ugg10.unitedgrain.ca
Lines: 841
X-Authenticated-User: teamsybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:9255
Article PK: 736415

I just want to confirm that we're both on the same page. Are you using
PB10.5 (the rte control in PB 10.5 supports tables)? And are you
creating a table like the one seen in the attached image?

There is one other work around that I can think of (which I would only
use as a last resort). You could create the RTE dynamically on the
window (OpenUserObject). When you want to reset you can close the RTE
and reopen.

Did you try apply any of the latest EBF's? If applying the newest EBF
does not help you should open a case with Sybase.


Brad

Suresh Thoduvail wrote:
> Hello Brad,
>
>
> I tried your solution, unfortunately it does not work for
> me. as i earlier said select text all and then pasting the
> blob still keeps the table i have created earlier.
> eg: if there are 3 records to be populated i create 3 rows
> and 4 columns. the data would look like.
> ----------------------------------------------------------
> Date Type RTE data Office
> ----------------------------------------------------------
> xx | ABC | xx RTE data | some office
> _____|__________|_____________________|__________________
>
> xx | ABC | xx RTE data | some office
> _____|__________|_____________________|__________________
>
> xx | ABC | xx RTE data | some office
> _____|__________|_____________________|__________________
>
> This is because the users want RTF data in one column and
> that
> data can be a few KB.
>
> My Undo solution is not working because if the RTE data
> spreads across few pages, the undo does not work.
> what my undo logic is doing is as follows.
> ----------------------------------------------------------
> Date Type RTE data Office
> ----------------------------------------------------------
> xx | ABC | xx RTE data | some office
> _____|__________|_____________________|__________________
>
> xx | ABC | xx RTE data | some office
> _____|__________|_____________________|__________________
>
> xx | ABC | xx RTE data | some office
> _____|__________|_____________________|__________________
> | | |
> _____|__________|_____________________|__________________
> | | |
> _____|__________|_____________________|__________________
>
> ie, keeping my initial 3 rows it is not discarding the table
> i
> created in RTF. Any solution greatly appreciated.
>

--

Join the Advanced GUI Development project on CodeXchange
https://advanced-gui-development.codexchange.sybase.com/

rtftable.JPG

Suresh Thoduvail Posted on 2007-03-02 20:27:06.0Z
Sender: 245d.45e75959.1804289383@sybase.com
From: Suresh Thoduvail
Newsgroups: sybase.public.powerbuilder.objects
Subject: Re: RTE Clear
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <45e8889a.40d2.1681692777@sybase.com>
References: <45e831b9$1@forums-1-dub>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 2 Mar 2007 12:27:06 -0800
X-Trace: forums-1-dub 1172867226 10.22.241.41 (2 Mar 2007 12:27:06 -0800)
X-Original-Trace: 2 Mar 2007 12:27:06 -0800, 10.22.241.41
Lines: 97
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:9259
Article PK: 736417

Yes, we are on the same page,

I am creating a table on RTE( Rich Text Edit Control)
using the PasteRTF() [by defining cells]. Thank you for the
suggestion of opening and closing user object.

Thanks again,
Suresh

> I just want to confirm that we're both on the same page.
> Are you using PB10.5 (the rte control in PB 10.5 supports
> tables)? And are you creating a table like the one seen
> in the attached image?
>
> There is one other work around that I can think of (which
> I would only use as a last resort). You could create the
> RTE dynamically on the window (OpenUserObject). When you
> want to reset you can close the RTE and reopen.
>
> Did you try apply any of the latest EBF's? If applying the
> newest EBF does not help you should open a case with
> Sybase.
>
>
> Brad
>
> Suresh Thoduvail wrote:
> > Hello Brad,
> >
> >
> > I tried your solution, unfortunately it does not work
> > for me. as i earlier said select text all and then
> > pasting the blob still keeps the table i have created
> > earlier. eg: if there are 3 records to be populated i
> > create 3 rows and 4 columns. the data would look like.
> >
> >
> ----------------------------------------------------------
> > Date Type RTE data Office
> >
> ----------------------------------------------------------
> > xx | ABC | xx RTE data | some office
> >
> >
> _____|__________|_____________________|__________________
> > xx | ABC | xx RTE data | some office
> >
> >
> _____|__________|_____________________|__________________
> > xx | ABC | xx RTE data | some office
> >
> >
> _____|__________|_____________________|__________________
> > This is because the users want RTF data in one column
> > and that data can be a few KB.
> >
> > My Undo solution is not working because if the RTE data
> > spreads across few pages, the undo does not work.
> > what my undo logic is doing is as follows.
> >
> >
> ----------------------------------------------------------
> > Date Type RTE data Office
> >
> ----------------------------------------------------------
> > xx | ABC | xx RTE data | some office
> >
> >
> _____|__________|_____________________|__________________
> > xx | ABC | xx RTE data | some office
> >
> >
> _____|__________|_____________________|__________________
> > xx | ABC | xx RTE data | some office
> >
> _____|__________|_____________________|__________________
> > | | |
> >
> _____|__________|_____________________|__________________
> > | | |
> >
> >
> _____|__________|_____________________|__________________
> ie, keeping my initial 3 rows it is not discarding the
> > table i
> > created in RTF. Any solution greatly appreciated.
> >
>
>
>
> --
>
> Join the Advanced GUI Development project on CodeXchange
> https://advanced-gui-development.codexchange.sybase.com/
>
>
> [Attachment: rtftable.JPG]


Suresh Thoduvail Posted on 2007-03-16 16:52:17.0Z
Sender: 43d9.45e8b368.1804289383@sybase.com
From: Suresh Thoduvail
Newsgroups: sybase.public.powerbuilder.objects
Subject: Re: RTE Clear
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <45facb41.7947.1681692777@sybase.com>
References: <45e831b9$1@forums-1-dub>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 16 Mar 2007 08:52:17 -0800
X-Trace: forums-1-dub 1174063937 10.22.241.41 (16 Mar 2007 08:52:17 -0800)
X-Original-Trace: 16 Mar 2007 08:52:17 -0800, 10.22.241.41
Lines: 94
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:9278
Article PK: 736440

Hello Brad,

Is there a way to print the grid of the table created in
RTE. The users would like to print the document with the
grid lines in it.

> I just want to confirm that we're both on the same page.
> Are you using PB10.5 (the rte control in PB 10.5 supports
> tables)? And are you creating a table like the one seen
> in the attached image?
>
> There is one other work around that I can think of (which
> I would only use as a last resort). You could create the
> RTE dynamically on the window (OpenUserObject). When you
> want to reset you can close the RTE and reopen.
>
> Did you try apply any of the latest EBF's? If applying the
> newest EBF does not help you should open a case with
> Sybase.
>
>
> Brad
>
> Suresh Thoduvail wrote:
> > Hello Brad,
> >
> >
> > I tried your solution, unfortunately it does not work
> > for me. as i earlier said select text all and then
> > pasting the blob still keeps the table i have created
> > earlier. eg: if there are 3 records to be populated i
> > create 3 rows and 4 columns. the data would look like.
> >
> >
> ----------------------------------------------------------
> > Date Type RTE data Office
> >
> ----------------------------------------------------------
> > xx | ABC | xx RTE data | some office
> >
> >
> _____|__________|_____________________|__________________
> > xx | ABC | xx RTE data | some office
> >
> >
> _____|__________|_____________________|__________________
> > xx | ABC | xx RTE data | some office
> >
> >
> _____|__________|_____________________|__________________
> > This is because the users want RTF data in one column
> > and that data can be a few KB.
> >
> > My Undo solution is not working because if the RTE data
> > spreads across few pages, the undo does not work.
> > what my undo logic is doing is as follows.
> >
> >
> ----------------------------------------------------------
> > Date Type RTE data Office
> >
> ----------------------------------------------------------
> > xx | ABC | xx RTE data | some office
> >
> >
> _____|__________|_____________________|__________________
> > xx | ABC | xx RTE data | some office
> >
> >
> _____|__________|_____________________|__________________
> > xx | ABC | xx RTE data | some office
> >
> _____|__________|_____________________|__________________
> > | | |
> >
> _____|__________|_____________________|__________________
> > | | |
> >
> >
> _____|__________|_____________________|__________________
> ie, keeping my initial 3 rows it is not discarding the
> > table i
> > created in RTF. Any solution greatly appreciated.
> >
>
>
>
> --
>
> Join the Advanced GUI Development project on CodeXchange
> https://advanced-gui-development.codexchange.sybase.com/
>
>
> [Attachment: rtftable.JPG]


Brad Wery[TeamSybase] Posted on 2007-03-16 17:22:29.0Z
From: "Brad Wery[TeamSybase]" <bradweryatagricoreunited.com>
User-Agent: Mozilla Thunderbird 1.0.2 (Windows/20050317)
X-Accept-Language: en-us, en
MIME-Version: 1.0
Newsgroups: sybase.public.powerbuilder.objects
Subject: Re: RTE Clear
References: <45e831b9$1@forums-1-dub> <45facb41.7947.1681692777@sybase.com>
In-Reply-To: <45facb41.7947.1681692777@sybase.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: ugg10.unitedgrain.ca
X-Original-NNTP-Posting-Host: ugg10.unitedgrain.ca
Message-ID: <45fad255$1@forums-1-dub>
Date: 16 Mar 2007 09:22:29 -0800
X-Trace: forums-1-dub 1174065749 165.23.247.49 (16 Mar 2007 09:22:29 -0800)
X-Original-Trace: 16 Mar 2007 09:22:29 -0800, ugg10.unitedgrain.ca
Lines: 17
X-Authenticated-User: teamsybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:9279
Article PK: 736439

The grid lines print fine for me. I'm not sure why it wouldn't work for you.

Suresh Thoduvail wrote:
> Hello Brad,
>
> Is there a way to print the grid of the table created in
> RTE. The users would like to print the document with the
> grid lines in it.
>
>

--

Join the Advanced GUI Development project on CodeXchange
https://advanced-gui-development.codexchange.sybase.com/


Brad Wery[TeamSybase] Posted on 2007-03-16 17:36:42.0Z
From: "Brad Wery[TeamSybase]" <bradweryatagricoreunited.com>
User-Agent: Mozilla Thunderbird 1.0.2 (Windows/20050317)
X-Accept-Language: en-us, en
MIME-Version: 1.0
Newsgroups: sybase.public.powerbuilder.objects
Subject: Re: RTE Clear
References: <45fad255$1@forums-1-dub> <45fad397.7a66.1681692777@sybase.com>
In-Reply-To: <45fad397.7a66.1681692777@sybase.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: ugg10.unitedgrain.ca
X-Original-NNTP-Posting-Host: ugg10.unitedgrain.ca
Message-ID: <45fad5aa$1@forums-1-dub>
Date: 16 Mar 2007 09:36:42 -0800
X-Trace: forums-1-dub 1174066602 165.23.247.49 (16 Mar 2007 09:36:42 -0800)
X-Original-Trace: 16 Mar 2007 09:36:42 -0800, ugg10.unitedgrain.ca
Lines: 56
X-Authenticated-User: teamsybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:9282
Article PK: 736441

I don't create the tables dynamically like you do. I pasted mine in from
Word. Maybe do that then look at the RTF syntax to make sure it looks
correct.

Suresh Thoduvail wrote:
> I am creating the table using this syntax. Are you creating
> the table with the same syntax..?
>
> rte_control.PasteRtf("{initail section of rtf and
> then...\par \trowd \trqc\trgaph108\trrh280\trleft36
> \clbrdrt\brdrth \clbrdrl\brdrth \clbrdrb\brdrdb
> \clbrdrr\brdrdb \cellx3636\clbrdrt\brdrth
> \clbrdrl\brdrdb \clbrdrb\brdrdb \clbrdrr\brdrdb
> \cellx7236\clbrdrt\brdrth \clbrdrl\brdrdb
> \clbrdrb\brdrdb \clbrdrr\brdrdb \cellx10836\pard \intbl
> \cell \pard \intbl \cell \pard \intbl \cell \pard \intbl
> \row
> \trowd \trqc\trgaph108\trrh280\trleft36 \clbrdrt\brdrdb
> \clbrdrl\brdrth \clbrdrb \brdrsh\brdrs \clbrdrr\brdrdb
> \cellx3636\clbrdrt\brdrdb \clbrdr \brdrdb
> \clbrdrb\brdrsh\brdrs \clbrdrr\brdrdb
> \cellx7236\clbrdrt\brdrdb \clbrdr \brdrdb
> \clbrdrb\brdrsh\brdrs \clbrdrr\brdrdb \cellx10836\pard
> \intbl \cell \pard \intbl \cell \pard \intbl \cell \pard
> \intbl \row \pard}')
>
>
>
>
>>The grid lines print fine for me. I'm not sure why it
>>wouldn't work for you.
>>
>>Suresh Thoduvail wrote:
>>
>>>Hello Brad,
>>>
>>> Is there a way to print the grid of the table created
>>>in RTE. The users would like to print the document with
>>>the grid lines in it.
>>>
>>>
>>
>>
>>
>>--
>>
>>Join the Advanced GUI Development project on CodeXchange
>>https://advanced-gui-development.codexchange.sybase.com/

--

Join the Advanced GUI Development project on CodeXchange
https://advanced-gui-development.codexchange.sybase.com/


Suresh Thoduvail Posted on 2007-03-16 21:59:19.0Z
Sender: 7a79.45fad463.1804289383@sybase.com
From: Suresh Thoduvail
Newsgroups: sybase.public.powerbuilder.objects
Subject: Re: RTE Clear
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <45fb1337.1ae.1681692777@sybase.com>
References: <45fad5aa$1@forums-1-dub>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 16 Mar 2007 13:59:19 -0800
X-Trace: forums-1-dub 1174082359 10.22.241.41 (16 Mar 2007 13:59:19 -0800)
X-Original-Trace: 16 Mar 2007 13:59:19 -0800, 10.22.241.41
Lines: 72
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:9284
Article PK: 736443

Thanks Brad,

I did copy the table form the word and took a look at
the
RTF syntax and did the same thing to the code, now the print
with grid lines works. Is there a way to set the page size
to Legal for the RTF document and one more thing is there is
a way to display the print preview of the document and allow
the user to print using the preview dialog. I did see one of
my earlier applications doing a preview of the document and
it shows a navigation arrow and the user could print using
that preview, but it was done in PFC, we do not use PFC in
this application.

Thanks

> I don't create the tables dynamically like you do. I
> pasted mine in from Word. Maybe do that then look at the
> RTF syntax to make sure it looks correct.
>
>
>
> Suresh Thoduvail wrote:
> > I am creating the table using this syntax. Are you
> > creating the table with the same syntax..?
> >
> > rte_control.PasteRtf("{initail section of rtf and
> > then...\par \trowd \trqc\trgaph108\trrh280\trleft36
> > \clbrdrt\brdrth \clbrdrl\brdrth \clbrdrb\brdrdb
> > \clbrdrr\brdrdb \cellx3636\clbrdrt\brdrth
> > \clbrdrl\brdrdb \clbrdrb\brdrdb \clbrdrr\brdrdb
> > \cellx7236\clbrdrt\brdrth \clbrdrl\brdrdb
> > \clbrdrb\brdrdb \clbrdrr\brdrdb \cellx10836\pard \intbl
> > \cell \pard \intbl \cell \pard \intbl \cell \pard \intbl
> > \row
> > \trowd \trqc\trgaph108\trrh280\trleft36 \clbrdrt\brdrdb
> > \clbrdrl\brdrth \clbrdrb \brdrsh\brdrs \clbrdrr\brdrdb
> > \cellx3636\clbrdrt\brdrdb \clbrdr \brdrdb
> > \clbrdrb\brdrsh\brdrs \clbrdrr\brdrdb
> > \cellx7236\clbrdrt\brdrdb \clbrdr \brdrdb
> > \clbrdrb\brdrsh\brdrs \clbrdrr\brdrdb \cellx10836\pard
> > \intbl \cell \pard \intbl \cell \pard \intbl \cell \pard
> > \intbl \row \pard}')
> >
> >
> >
> >
> >>The grid lines print fine for me. I'm not sure why it
> >>wouldn't work for you.
> >>
> >>Suresh Thoduvail wrote:
> >>
> >>>Hello Brad,
> >>>
> >>> Is there a way to print the grid of the table
> created >>>in RTE. The users would like to print the
> document with >>>the grid lines in it.
> >>>
> >>>
> >>
> >>
> >>
> >>--
> >>
> >>Join the Advanced GUI Development project on CodeXchange
> >>https://advanced-gui-development.codexchange.sybase.com/
>
>
> --
>
> Join the Advanced GUI Development project on CodeXchange
> https://advanced-gui-development.codexchange.sybase.com/


Brad Wery[TeamSybase] Posted on 2007-03-19 19:23:30.0Z
From: "Brad Wery[TeamSybase]" <bradweryatagricoreunited.com>
User-Agent: Mozilla Thunderbird 1.0.2 (Windows/20050317)
X-Accept-Language: en-us, en
MIME-Version: 1.0
Newsgroups: sybase.public.powerbuilder.objects
Subject: Re: RTE Clear
References: <45fad5aa$1@forums-1-dub> <45fb1337.1ae.1681692777@sybase.com>
In-Reply-To: <45fb1337.1ae.1681692777@sybase.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: ugg10.unitedgrain.ca
X-Original-NNTP-Posting-Host: ugg10.unitedgrain.ca
Message-ID: <45fee332$1@forums-1-dub>
Date: 19 Mar 2007 11:23:30 -0800
X-Trace: forums-1-dub 1174332210 165.23.247.49 (19 Mar 2007 11:23:30 -0800)
X-Original-Trace: 19 Mar 2007 11:23:30 -0800, ugg10.unitedgrain.ca
Lines: 33
X-Authenticated-User: teamsybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:9299
Article PK: 736458

I'm not sure how to change the RTE's orienation so it uses landscape.
I'll have to look into this.

I'm not sure what you're saying about print preview. Are you talking
about displaying a printer dialog while in print preview mode? Just call
the PrintEx function for the RTE. You should get the dialog.

Brad

Suresh Thoduvail wrote:
> Thanks Brad,
>
> I did copy the table form the word and took a look at
> the
> RTF syntax and did the same thing to the code, now the print
> with grid lines works. Is there a way to set the page size
> to Legal for the RTF document and one more thing is there is
> a way to display the print preview of the document and allow
> the user to print using the preview dialog. I did see one of
> my earlier applications doing a preview of the document and
> it shows a navigation arrow and the user could print using
> that preview, but it was done in PFC, we do not use PFC in
> this application.
>
> Thanks
>
>

--

Join the Advanced GUI Development project on CodeXchange
https://advanced-gui-development.codexchange.sybase.com/


Suresh Thoduvail Posted on 2007-03-20 13:40:42.0Z
Sender: 192e.45ffe150.1804289383@sybase.com
From: Suresh Thoduvail
Newsgroups: sybase.public.powerbuilder.objects
Subject: Re: RTE Clear
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <45ffe45a.1975.1681692777@sybase.com>
References: <45fee332$1@forums-1-dub>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 20 Mar 2007 05:40:42 -0800
X-Trace: forums-1-dub 1174398042 10.22.241.41 (20 Mar 2007 05:40:42 -0800)
X-Original-Trace: 20 Mar 2007 05:40:42 -0800, 10.22.241.41
Lines: 59
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:9300
Article PK: 736460

Hi,

Thanks for the response. Imagine a legal document with 4
columns with typed in data and the data might extend beyond
a page extending another page with in the columns. That is
what i am trying to achieve in RTE. Two more things i need
to achieve

1. Make the RTE document Legal Size ie, 8.5 x 14".
2. Dispaly the Print Dialog letting the user key in page
No's.
3. Not to display the lines in the Header and Footer.

The creation of table was sucessfull, now the problem is
that the lines are extending to the header and footer of the
document, is there a way to not show the lines in the footer
and header section of the RTE. By preview I meant in one of
my earlier applications, i did see the zoomed preview of the
RTE on the left hand side of the main RTE with arrow keys
and zoom etc, I am still not sure weather it was a
customised.
Thanks for all your feedback, it was really helpfull.

Suresh

> I'm not sure how to change the RTE's orienation so it uses
> landscape. I'll have to look into this.
>
> I'm not sure what you're saying about print preview. Are
> you talking about displaying a printer dialog while in
> print preview mode? Just call the PrintEx function for
> the RTE. You should get the dialog.
>
> Brad
>
>
> Suresh Thoduvail wrote:
> > Thanks Brad,
> >
> > I did copy the table form the word and took a look
> > at the
> > RTF syntax and did the same thing to the code, now the
> > print with grid lines works. Is there a way to set the
> > page size to Legal for the RTF document and one more
> > thing is there is a way to display the print preview of
> > the document and allow the user to print using the
> > preview dialog. I did see one of my earlier applications
> > doing a preview of the document and it shows a
> > navigation arrow and the user could print using that
> > preview, but it was done in PFC, we do not use PFC in
> > this application.
> > Thanks
> >
> >
>
> --
>
> Join the Advanced GUI Development project on CodeXchange
> https://advanced-gui-development.codexchange.sybase.com/


sergio Posted on 2007-04-06 14:14:26.0Z
From: "sergio" <sergioesp@gmail.com>
Newsgroups: sybase.public.powerbuilder.objects
Subject: Re: RTE Clear
Date: 6 Apr 2007 07:14:26 -0700
Organization: http://groups.google.com
Lines: 28
Message-ID: <1175868866.019831.33910@l77g2000hsb.googlegroups.com>
References: <45e4ca7f.63c8.1681692777@sybase.com>
NNTP-Posting-Host: 72.244.105.114
Mime-Version: 1.0
Content-Type: text/plain; charset="iso-8859-1"
X-Trace: posting.google.com 1175868866 19868 127.0.0.1 (6 Apr 2007 14:14:26 GMT)
X-Complaints-To: groups-abuse@google.com
NNTP-Posting-Date: Fri, 6 Apr 2007 14:14:26 +0000 (UTC)
In-Reply-To: <45e4ca7f.63c8.1681692777@sybase.com>
User-Agent: G2/1.0
X-HTTP-UserAgent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; InfoPath.1; .NET CLR 2.0.50727),gzip(gfe),gzip(gfe)
Complaints-To: groups-abuse@google.com
Injection-Info: l77g2000hsb.googlegroups.com; posting-host=72.244.105.114; posting-account=A4tMzQ0AAAAgXSOdM7QqgeDrd7Myd-8P
Path: forums-1-dub!forums-master!newswest.sybase.com!newsfeed2.dallas1.level3.net!news.level3.com!postnews.google.com!l77g2000hsb.googlegroups.com!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:9316
Article PK: 736477


On Feb 27, 8:19 pm, Suresh Thoduvail wrote:
> Hi All,
>
> I have created atablewith rows and columns inRTE
> Control and have populated lots of data from the database
> into those rows and columns.
>
> when i re-retrieve the report (RTE) i need to clean up the
> slate (RTE) and starting populating theRTEtableagain.
>
> When I do a rte_1.Clear() it deletes the data but not thetablei have created, is there a work around. All i need to
> to clear up the entire richtext object and start doing stuff
> again.
>
> Any help greately appreciated.
> Suresh

I have the same exact problem. I'm able to delete the table if and
only if there is a line of text before the Table it self. When table
is in the first line of the rtf neither clear() nor selecttextall
would work.

Have you find a solution to do this? I'm also trying to do like a
right click popup menu that will let you delete:insert columns,
rows... How could I know if the pointer is on top of a table?

THanks for your help in advance.


Suresh Posted on 2007-06-07 20:17:59.0Z
Sender: 7621.4668657d.1804289383@sybase.com
From: Suresh
Newsgroups: sybase.public.powerbuilder.objects
Subject: Re: RTE Clear
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <466867f7.768e.1681692777@sybase.com>
References: <1175868866.019831.33910@l77g2000hsb.googlegroups.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 7 Jun 2007 13:17:59 -0700
X-Trace: forums-1-dub 1181247479 10.22.241.41 (7 Jun 2007 13:17:59 -0700)
X-Original-Trace: 7 Jun 2007 13:17:59 -0700, 10.22.241.41
Lines: 37
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:9372
Article PK: 736531

Hi sergio,
The solution I implemented it to call CloseUserObject and
then OpenUserObject function calls, as RTE would not clear
of some characters. This works for me atleast for now.

Thanks
Suresh

> On Feb 27, 8:19 pm, Suresh Thoduvail wrote:
> > Hi All,
> >
> > I have created atablewith rows and columns inRTE
> > Control and have populated lots of data from the
> > database into those rows and columns.
> >
> > when i re-retrieve the report (RTE) i need to clean up
> > the slate (RTE) and starting populating
> theRTEtableagain. >
> > When I do a rte_1.Clear() it deletes the data but not
> thetablei have created, is there a work around. All i need
> > to to clear up the entire richtext object and start
> > doing stuff again.
> >
> > Any help greately appreciated.
> > Suresh
>
> I have the same exact problem. I'm able to delete the
> table if and only if there is a line of text before the
> Table it self. When table is in the first line of the rtf
> neither clear() nor selecttextall would work.
>
> Have you find a solution to do this? I'm also trying to do
> like a right click popup menu that will let you
> delete:insert columns, rows... How could I know if the
> pointer is on top of a table?
>
> THanks for your help in advance.
>