Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Linked Servers On ASA8 to ASA10 Upgrade

2 posts in General Discussion Last posting was on 2007-03-30 18:33:41.0Z
James Parks Posted on 2007-03-29 19:32:41.0Z
Sender: 319a.460c126e.1804289383@sybase.com
From: James Parks
Newsgroups: ianywhere.public.general
Subject: Linked Servers On ASA8 to ASA10 Upgrade
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <460c1459.31e5.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 29 Mar 2007 11:32:41 -0800
X-Trace: forums-1-dub 1175196761 10.22.241.41 (29 Mar 2007 11:32:41 -0800)
X-Original-Trace: 29 Mar 2007 11:32:41 -0800, 10.22.241.41
Lines: 7
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:5930
Article PK: 1905

We are migrating from ASA8 to ASA10. Our ASA server has been
a Linked server in a MMSSQL2000 database for years. With our
ASA8 server we could create a user in both servers, create a
System DSN OLEDB connection and viola! Everything works
great. Now with ASA10 the ONLY login that can access the
ASA10 Server is the DBA login! Any help would be
appreceiated! P.S we are using the ASA10 oledb provider.


James Parks Posted on 2007-03-30 18:33:41.0Z
Sender: 5280.460d5546.1804289383@sybase.com
From: James Parks
Newsgroups: ianywhere.public.general
Subject: Issue Solved
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <460d5805.52d4.1681692777@sybase.com>
References: <460c1459.31e5.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 30 Mar 2007 10:33:41 -0800
X-Trace: forums-1-dub 1175279621 10.22.241.41 (30 Mar 2007 10:33:41 -0800)
X-Original-Trace: 30 Mar 2007 10:33:41 -0800, 10.22.241.41
Lines: 17
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:5933
Article PK: 1906

From Sybase Support:

I spent a couple of hours yesterday testing this on SQL
Server 2000 and could not find any problems. So I began to
wonder if the database on the Novell server was an older 8.0
DB. If so the OLEDB schema support SQL scripts in the DB
might be out of date.

Your message below confirms this, although I am surprised
that the upgrade wizard seems to not have updated the OLEDB
scripts.

The customer should run dbisql, connect to their DB, load
scripts\oleschem.sql from the SQL Anywhere installation and
run the script. This will update the OLEDB schema support
in the database. This should be done for evey older DB for
which they want to use OLEDB.