Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Nested Reports and Appeon 5.0 and Powerbuilder 10.5.1

2 posts in Appeon (partner product) Last posting was on 2007-04-05 09:21:47.0Z
Ed Rhodes Posted on 2007-04-03 14:33:15.0Z
Sender: 5d71.46125633.1804289383@sybase.com
From: Ed Rhodes
Newsgroups: sybase.public.appeon
Subject: Nested Reports and Appeon 5.0 and Powerbuilder 10.5.1
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4612579b.5da6.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 3 Apr 2007 06:33:15 -0800
X-Trace: forums-1-dub 1175607195 10.22.241.41 (3 Apr 2007 06:33:15 -0800)
X-Original-Trace: 3 Apr 2007 06:33:15 -0800, 10.22.241.41
Lines: 6
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:1844
Article PK: 21389

I just upgrade to PowerBuilder 10.5.1 from PowerBuilder 9
with Appeon 5.0. I installed all EBF's and on one of my
reports with nested datawindows, that worked perfectly
before, now gives a -1 on the retrieve. Also it works
perfectly just running the application form inside of power
builder. Any suggestions.


Sally Li Posted on 2007-04-05 09:21:47.0Z
Sender: 590b.460886d8.1804289383@sybase.com
From: Sally Li
Newsgroups: sybase.public.appeon
Subject: Re: Nested Reports and Appeon 5.0 and Powerbuilder 10.5.1
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4614b19b.1836.1681692777@sybase.com>
References: <4612579b.5da6.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 5 Apr 2007 01:21:47 -0800
X-Trace: forums-1-dub 1175761307 10.22.241.41 (5 Apr 2007 01:21:47 -0800)
X-Original-Trace: 5 Apr 2007 01:21:47 -0800, 10.22.241.41
Lines: 35
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:1848
Article PK: 21388

Hi
It seems you also send an email to Appeon tech support and
following is my answer.
The problem should be caused by using an Appeon incompatible
PBVM. Appeon certified build for PB 10.5 is 10.5.0.4523
but 10.5.1 plus.
Since this is an Appeon Java-script deployed application,
the Composite datawindow (Image DataWindow) will largely
depend on the PBVM generating pictures and then be shown on
the client side.

Generally PowerBuilder won't adjust the component mechanism
too much within same version but different builds, so we
suggest you try the steps below:
Step 1. Install PowerBuilder 10.5.1 plus to the EAServer
hosting machine.
Step 2. Copy the file
%Sybase%shared\PowerBuilder\pbjdbc12105.jar to the directory
%Sybase%\easerver\java\lib.
Step 3. Generate the stub and skeleton according to the
instructions in Appeon help | Appeon Migration Guide| Appeon
Migration Tutorial| Modifying Unsupported Features|
Modification Instructions.

Let me know if the problem is still there.

Regards
Sally Li

> I just upgrade to PowerBuilder 10.5.1 from PowerBuilder 9
> with Appeon 5.0. I installed all EBF's and on one of my
> reports with nested datawindows, that worked perfectly
> before, now gives a -1 on the retrieve. Also it works
> perfectly just running the application form inside of
> power builder. Any suggestions.