Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

PowerBuilder 10.5 PrintJob

2 posts in General Discussion (Chinese) Last posting was on 2007-06-25 20:03:34.0Z
llumaju Posted on 2007-04-19 12:03:06.0Z
Sender: 46c.462746bf.1804289383@sybase.com
From: llumaju
Newsgroups: sybase.public.chinese.powerbuilder.general
Subject: PowerBuilder 10.5 PrintJob
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <46275a7a.716.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 19 Apr 2007 05:03:06 -0700
X-Trace: forums-1-dub 1176984186 10.22.241.41 (19 Apr 2007 05:03:06 -0700)
X-Original-Trace: 19 Apr 2007 05:03:06 -0700, 10.22.241.41
Lines: 21
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.chinese.powerbuilder.general:223
Article PK: 104251

We migrate some app. from PB6.5 to PB10.5.1 build 6565.

In the application we use in some places the next code:

il_Job = PrintOpen("Invoice Stats : " + ls_RamDesRam )
lf_DefineFont()
PrintSetFont(il_Job,5)
Print(il_Job,1,"")
Print(il_Job,1,"")
Print(il_Job,1,"INVOICE STATS
" + ls_RamDesRam)
Etc...

We execute this report in the same computer and print at the
same printer the diference is PB. But the look of both
reports (pb6.5 - pb10.5) are diferent.

Someone had this problem?
Someone have some idea?

TIA.


Ranjith Posted on 2007-06-25 20:03:34.0Z
Sender: 4a0f.46801ec8.1804289383@sybase.com
From: Ranjith
Newsgroups: sybase.public.chinese.powerbuilder.general
Subject: Re: PowerBuilder 10.5 PrintJob
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <46801f96.4a2a.1681692777@sybase.com>
References: <46275a7a.716.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 25 Jun 2007 13:03:34 -0700
X-Trace: forums-1-dub 1182801814 10.22.241.41 (25 Jun 2007 13:03:34 -0700)
X-Original-Trace: 25 Jun 2007 13:03:34 -0700, 10.22.241.41
Lines: 25
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.chinese.powerbuilder.general:253
Article PK: 104280

If you are using the Printer API's check on that. Since the
PB 10 and above is unicode based.

> We migrate some app. from PB6.5 to PB10.5.1 build 6565.
>
> In the application we use in some places the next code:
>
> il_Job = PrintOpen("Invoice Stats : " + ls_RamDesRam )
> lf_DefineFont()
> PrintSetFont(il_Job,5)
> Print(il_Job,1,"")
> Print(il_Job,1,"")
> Print(il_Job,1,"INVOICE STATS
>
> " + ls_RamDesRam)
> Etc...
>
> We execute this report in the same computer and print at
> the same printer the diference is PB. But the look of
> both reports (pb6.5 - pb10.5) are diferent.
>
> Someone had this problem?
> Someone have some idea?
>
> TIA.