Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Conversion of version 5 database fails with Unload Database Wizard

5 posts in General Discussion Last posting was on 2007-04-24 13:27:37.0Z
avhays Posted on 2007-04-23 15:39:06.0Z
Sender: 28f2.462cce73.1804289383@sybase.com
From: avhays
Newsgroups: ianywhere.public.general
Subject: Conversion of version 5 database fails with Unload Database Wizard
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <462cd31a.29a9.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 23 Apr 2007 08:39:06 -0700
X-Trace: forums-1-dub 1177342746 10.22.241.41 (23 Apr 2007 08:39:06 -0700)
X-Original-Trace: 23 Apr 2007 08:39:06 -0700, 10.22.241.41
Lines: 21
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:5948
Article PK: 1923

I have a version 5 database that seems to work fine with
Adaptive Server Anywhere 9.0 as is (so I guess I could
continue to use it as a version 5 database). However, I
wanted to validate it. Under version 5 one can do this
without connecting. Under version 9 one must first connect
to the database when using Sybase Central. When I try to
connect, I get the message that Sybase Central only works
with databases that are version 7 or later, and it asks me
if I want to unload and reload it to convert it.

I then go thru the screens to do this (I got a crash until I
installed the latests patches). When it starts the
unloading, it stops with this error:

Writing Option Settings
SQL error: Invalid option
'NON_KEYWORDS'-- no PUBLIC setting exists.

Can anyone help me with this error?

Thanks.


Stephen Rice Posted on 2007-04-23 17:53:57.0Z
From: "Stephen Rice" <sriceATianywhereDOTcom>
Newsgroups: ianywhere.public.general
References: <462cd31a.29a9.1681692777@sybase.com>
Subject: Re: Conversion of version 5 database fails with Unload Database Wizard
Lines: 49
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3028
X-RFC2646: Format=Flowed; Original
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3028
NNTP-Posting-Host: srice-xp2.sybase.com
X-Original-NNTP-Posting-Host: srice-xp2.sybase.com
Message-ID: <462cf2b5$1@forums-1-dub>
Date: 23 Apr 2007 10:53:57 -0700
X-Trace: forums-1-dub 1177350837 10.25.98.210 (23 Apr 2007 10:53:57 -0700)
X-Original-Trace: 23 Apr 2007 10:53:57 -0700, srice-xp2.sybase.com
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:5949
Article PK: 1920

A two part answer

1) You do not need Sybase Central to validate a database. dbvalid exists in
v9 as it did in v5, but with considerably more functionality. Just run
dbvalid from the v9 install directory
2) The error means it has tried to access an option that does not exist for
the public group. This was an ancient problem. The best way to approach
the problem is to do a manual rebuild by:
- using v9 to do a data and schema dbunload
- using v9 to initialize a new v9 database
- using dbisql to read the reload.sql created in step #1. If any errors
occur fix them in the script (or if it is only this one, "continue" from it)
These steps are documented at
ASA SQL User's Guide
Importing and Exporting Data
Rebuilding databases
Rebuild and reload tools
Using the dbunload and dbisql utilities to rebuild databases


--
/steve
Stephen Rice
Sybase iAnywhere

<avhays> wrote in message news:462cd31a.29a9.1681692777@sybase.com...
>I have a version 5 database that seems to work fine with
> Adaptive Server Anywhere 9.0 as is (so I guess I could
> continue to use it as a version 5 database). However, I
> wanted to validate it. Under version 5 one can do this
> without connecting. Under version 9 one must first connect
> to the database when using Sybase Central. When I try to
> connect, I get the message that Sybase Central only works
> with databases that are version 7 or later, and it asks me
> if I want to unload and reload it to convert it.
>
> I then go thru the screens to do this (I got a crash until I
> installed the latests patches). When it starts the
> unloading, it stops with this error:
>
> Writing Option Settings
> SQL error: Invalid option
> 'NON_KEYWORDS'-- no PUBLIC setting exists.
>
> Can anyone help me with this error?
>
> Thanks.


avhays Posted on 2007-04-23 18:17:06.0Z
Sender: 2e64.462cf76c.1804289383@sybase.com
From: avhays
Newsgroups: ianywhere.public.general
Subject: Re: Conversion of version 5 database fails with Unload Database Wizard
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <462cf821.2e7e.1681692777@sybase.com>
References: <462cf2b5$1@forums-1-dub>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 23 Apr 2007 11:17:06 -0700
X-Trace: forums-1-dub 1177352226 10.22.241.41 (23 Apr 2007 11:17:06 -0700)
X-Original-Trace: 23 Apr 2007 11:17:06 -0700, 10.22.241.41
Lines: 56
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:5950
Article PK: 1922

Thanks for this excellent info. Do you foresee any problems
if I continue to use the v5 database with either v9 or the
latest v10?

> A two part answer
>
> 1) You do not need Sybase Central to validate a database.
> dbvalid exists in v9 as it did in v5, but with
> considerably more functionality. Just run dbvalid from
> the v9 install directory 2) The error means it has tried
> to access an option that does not exist for the public
> group. This was an ancient problem. The best way to
> approach the problem is to do a manual rebuild by:
> - using v9 to do a data and schema dbunload
> - using v9 to initialize a new v9 database
> - using dbisql to read the reload.sql created in step #1.
> If any errors occur fix them in the script (or if it is
> only this one, "continue" from it) These steps are
> documented at ASA SQL User's Guide
> Importing and Exporting Data
> Rebuilding databases
> Rebuild and reload tools
> Using the dbunload and dbisql utilities to rebuild
> databases
>
>
> --
> /steve
> Stephen Rice
> Sybase iAnywhere
>
> <avhays> wrote in message
> news:462cd31a.29a9.1681692777@sybase.com... >I have a
> > version 5 database that seems to work fine with Adaptive
> > Server Anywhere 9.0 as is (so I guess I could continue
> > to use it as a version 5 database). However, I wanted
> > to validate it. Under version 5 one can do this without
> > connecting. Under version 9 one must first connect to
> > the database when using Sybase Central. When I try to
> > connect, I get the message that Sybase Central only
> works with databases that are version 7 or later, and it
> > asks me if I want to unload and reload it to convert it.
> >
> > I then go thru the screens to do this (I got a crash
> > until I installed the latests patches). When it starts
> > the unloading, it stops with this error:
> >
> > Writing Option Settings
> > SQL error: Invalid option
> > 'NON_KEYWORDS'-- no PUBLIC setting exists.
> >
> > Can anyone help me with this error?
> >
> > Thanks.
>
>


Chris Keating (Sybase iAnywhere) Posted on 2007-04-23 18:28:57.0Z
From: "Chris Keating (Sybase iAnywhere)" <keating@iAnywhere.Dot.com>
User-Agent: Thunderbird 1.5.0.10 (Windows/20070221)
MIME-Version: 1.0
Newsgroups: ianywhere.public.general
Subject: Re: Conversion of version 5 database fails with Unload Database Wizard
References: <462cf2b5$1@forums-1-dub> <462cf821.2e7e.1681692777@sybase.com>
In-Reply-To: <462cf821.2e7e.1681692777@sybase.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: keating-dm20.sybase.com
X-Original-NNTP-Posting-Host: keating-dm20.sybase.com
Message-ID: <462cfae9$1@forums-1-dub>
Date: 23 Apr 2007 11:28:57 -0700
X-Trace: forums-1-dub 1177352937 10.25.98.170 (23 Apr 2007 11:28:57 -0700)
X-Original-Trace: 23 Apr 2007 11:28:57 -0700, keating-dm20.sybase.com
Lines: 27
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:5951
Article PK: 1924

SQL Anywhere 10 requires that the database file be rebuilt in SQL
Anywhere 10. This differs from ASA9 and earlier engines that supported a
number of database file versions .
--

Chris Keating
Sybase Adaptive Server Anywhere Professional Version 8

*****************************************************************************

Sign up today for your copy of the SQL Anywhere Studio 10 Developer
Edition =and try out the market-leading database for mobile, embedded
and small to medium sized business environments for free!

http://www.ianywhere.com/downloads/software/sql_anywhere_intro.html

*****************************************************************************

iAnywhere Solutions http://www.iAnywhere.com

** Please only post to the newsgroup

** Whitepapers can be found at http://www.iAnywhere.com/developer
** EBFs can be found at http://downloads.sybase.com/swx/sdmain.stm
** Use Case Express to report bugs http://case-express.sybase.com

*****************************************************************************


Rob Waywell Posted on 2007-04-24 13:27:37.0Z
From: "Rob Waywell" <rwaywell_no_spam_please@ianywhere.com>
Newsgroups: ianywhere.public.general
References: <462cf2b5$1@forums-1-dub> <462cf821.2e7e.1681692777@sybase.com>
Subject: Re: Conversion of version 5 database fails with Unload Database Wizard
Lines: 88
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3028
X-RFC2646: Format=Flowed; Original
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3028
NNTP-Posting-Host: rwaywell-xp2.sybase.com
X-Original-NNTP-Posting-Host: rwaywell-xp2.sybase.com
Message-ID: <462e05c9$1@forums-1-dub>
Date: 24 Apr 2007 06:27:37 -0700
X-Trace: forums-1-dub 1177421257 10.25.98.235 (24 Apr 2007 06:27:37 -0700)
X-Original-Trace: 24 Apr 2007 06:27:37 -0700, rwaywell-xp2.sybase.com
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:5954
Article PK: 1927

As Chris mentioned version 10 requires you to rebuild the database.

For version 9 you are forced to rebuild the database, however it is the
recommended approach. There have been significant enhancements made to the
database engine since version 5.x. Some of these features rely on changes to
the physical database file format. If you do not rebuild the database when
upgrading from version 5.x to version 9.x then you will not get the full
benefit of the performance enhancements in the newer version and you may
find cases where performance is negatively impacted.

--
-----------------------------------------------
Robert Waywell
Sybase Adaptive Server Anywhere Developer - Version 8
Sybase Certified Professional

Sybase's iAnywhere Solutions

Please respond ONLY to newsgroup

EBF's and Patches: http://downloads.sybase.com
choose SQL Anywhere Studio >> change 'time frame' to all

To Submit Bug Reports:
http://case-express.sybase.com/cx/cx.stm?starturl=casemessage.ssc?CASETYPE=Bug

SQL Anywhere Studio Supported Platforms and Support Status
http://my.sybase.com/detail?id=1002288

<avhays> wrote in message news:462cf821.2e7e.1681692777@sybase.com...
> Thanks for this excellent info. Do you foresee any problems
> if I continue to use the v5 database with either v9 or the
> latest v10?
>
>> A two part answer
>>
>> 1) You do not need Sybase Central to validate a database.
>> dbvalid exists in v9 as it did in v5, but with
>> considerably more functionality. Just run dbvalid from
>> the v9 install directory 2) The error means it has tried
>> to access an option that does not exist for the public
>> group. This was an ancient problem. The best way to
>> approach the problem is to do a manual rebuild by:
>> - using v9 to do a data and schema dbunload
>> - using v9 to initialize a new v9 database
>> - using dbisql to read the reload.sql created in step #1.
>> If any errors occur fix them in the script (or if it is
>> only this one, "continue" from it) These steps are
>> documented at ASA SQL User's Guide
>> Importing and Exporting Data
>> Rebuilding databases
>> Rebuild and reload tools
>> Using the dbunload and dbisql utilities to rebuild
>> databases
>>
>>
>> --
>> /steve
>> Stephen Rice
>> Sybase iAnywhere
>>
>> <avhays> wrote in message
>> news:462cd31a.29a9.1681692777@sybase.com... >I have a
>> > version 5 database that seems to work fine with Adaptive
>> > Server Anywhere 9.0 as is (so I guess I could continue
>> > to use it as a version 5 database). However, I wanted
>> > to validate it. Under version 5 one can do this without
>> > connecting. Under version 9 one must first connect to
>> > the database when using Sybase Central. When I try to
>> > connect, I get the message that Sybase Central only
>> works with databases that are version 7 or later, and it
>> > asks me if I want to unload and reload it to convert it.
>> >
>> > I then go thru the screens to do this (I got a crash
>> > until I installed the latests patches). When it starts
>> > the unloading, it stops with this error:
>> >
>> > Writing Option Settings
>> > SQL error: Invalid option
>> > 'NON_KEYWORDS'-- no PUBLIC setting exists.
>> >
>> > Can anyone help me with this error?
>> >
>> > Thanks.
>>
>>