Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Unicode Support in PB10

3 posts in General Discussion (Chinese) Last posting was on 2007-08-02 17:41:00.0Z
Vicki Chan Posted on 2007-05-26 02:10:54.0Z
Sender: 3560.465796cb.1804289383@sybase.com
From: Vicki Chan
Newsgroups: sybase.public.chinese.powerbuilder.general
Subject: Unicode Support in PB10
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4657972e.3563.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 25 May 2007 19:10:54 -0700
X-Trace: forums-1-dub 1180145454 10.22.241.41 (25 May 2007 19:10:54 -0700)
X-Original-Trace: 25 May 2007 19:10:54 -0700, 10.22.241.41
Lines: 7
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.chinese.powerbuilder.general:238
Article PK: 104267

Hi,

Unicode support is available in PB10. But when I tried to
retrieve the Chinese characters in unicode with a "string"
type, I got "###" <-- which supposed to be 3 chinese
characters. How can I enable the unicode support in PB10?
Thanks.


<Jonathan Chan> Posted on 2007-06-05 05:20:17.0Z
From: <Jonathan Chan>
Newsgroups: sybase.public.chinese.powerbuilder.general
References: <4657972e.3563.1681692777@sybase.com>
Subject: Re: Unicode Support in PB10
Lines: 15
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3028
X-RFC2646: Format=Flowed; Original
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3028
NNTP-Posting-Host: pcd644198.netvigator.com
X-Original-NNTP-Posting-Host: pcd644198.netvigator.com
Message-ID: <4664f291$1@forums-1-dub>
Date: 4 Jun 2007 22:20:17 -0700
X-Trace: forums-1-dub 1181020817 218.102.176.198 (4 Jun 2007 22:20:17 -0700)
X-Original-Trace: 4 Jun 2007 22:20:17 -0700, pcd644198.netvigator.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.chinese.powerbuilder.general:243
Article PK: 104271

I guess you may be seeing three rectangles instead of three "#" (pound sign)
characters. If in that case, it should be a font problem. Try to use the
"Tahoma" font for your window/datawindow object and try again.

Hope this help.

<Vicki Chan> wrote in message news:4657972e.3563.1681692777@sybase.com...
> Hi,
>
> Unicode support is available in PB10. But when I tried to
> retrieve the Chinese characters in unicode with a "string"
> type, I got "###" <-- which supposed to be 3 chinese
> characters. How can I enable the unicode support in PB10?
> Thanks.


Henok Belai Posted on 2007-08-02 17:41:00.0Z
Sender: 1bba.46b1eaa1.1804289383@sybase.com
From: Henok Belai
Newsgroups: sybase.public.chinese.powerbuilder.general
Subject: Re: Unicode Support in PB10
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <46b2172c.20da.1681692777@sybase.com>
References: <4664f291$1@forums-1-dub>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 2 Aug 2007 10:41:00 -0700
X-Trace: forums-1-dub 1186076460 10.22.241.41 (2 Aug 2007 10:41:00 -0700)
X-Original-Trace: 2 Aug 2007 10:41:00 -0700, 10.22.241.41
Lines: 9
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.chinese.powerbuilder.general:273
Article PK: 104300

Dear
I am using PB 10.5 and nvarchar(max) datatype for MSSQL and
NCLOB datatype for Oracle. I am tring to save a UNICODE
phrase and they are saved in DB as ??????
I thought PB 10.5 support UNICODE, that's the only reason
we upgraded to PB 10.5. Do I need to do anything with my
datawindow.
Any help will be apperciated.
Thanks in advance