Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

CreateInstance

2 posts in Appeon (partner product) Last posting was on 2007-06-12 02:12:04.0Z
Fili Sosa Posted on 2007-06-08 18:58:52.0Z
Sender: 19c4.4669a138.1804289383@sybase.com
From: Fili Sosa
Newsgroups: sybase.public.appeon
Subject: CreateInstance
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4669a6ec.1a68.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 8 Jun 2007 11:58:52 -0700
X-Trace: forums-1-dub 1181329132 10.22.241.41 (8 Jun 2007 11:58:52 -0700)
X-Original-Trace: 8 Jun 2007 11:58:52 -0700, 10.22.241.41
Lines: 34
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:1914
Article PK: 13200

When I run this code in powerbuilder it runs fine, but when
I run in in appeon code, it returns an error

g_connetion = create connection
g_connetion.driver = "jaguar"
g_connetion.location = gstr_appserver.servername
g_connetion.userid = gstr_appserver.userid
g_connetion.password = gstr_appserver.password

ll_rc = ll_rc = g_connetion.ConnectToServer()
IF ll_rc <> 0 THEN
MessageBox( 'Error', "connection failed" )
return -1
END IF

ll_rc = g_connetion.CreateInstance( lnv_files, ls_interfase
)
IF ll_rc <> 0 THEN
MessageBox( 'instance of the componente failed', ll_rc )
RETURN
END IF

in powerbuilder it works fine.

In appeon sends me the message that
"instance of the component failed", and it returns 57
which means NOT CONNECTED.

What else do I need to do in appeon so it can work like
in powerbuilder ?

thanks

fili sosa


Sally Li Posted on 2007-06-12 02:12:04.0Z
Sender: 1e7e.466cb34f.1804289383@sybase.com
From: Sally Li
Newsgroups: sybase.public.appeon
Subject: Re: CreateInstance
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <466e00f4.4124.1681692777@sybase.com>
References: <4669a6ec.1a68.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 11 Jun 2007 19:12:04 -0700
X-Trace: forums-1-dub 1181614324 10.22.241.41 (11 Jun 2007 19:12:04 -0700)
X-Original-Trace: 11 Jun 2007 19:12:04 -0700, 10.22.241.41
Lines: 67
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:1920
Article PK: 21430

Hi Fili Sosa,
Generally speaking you need to follow the steps below to
implement the distributed DataWindow/application on the Web.

1. Derive distributed DataWindows and DataStore objects from
appeondatawindow and appeondatastore. And derive
PowerBuilder GetFullState, SetFullState, GetChanges and
SetChanges functions from corresponding Appeon functions.

2. Deploy the server DataStore that are inherited from
appeondatastore/appeondatawindow to Appeon Server. At the
same time you need to deploy the appeondatastore and
appeondatawindow. AppeonDataWindow and AppeonDataStore are
two standard user objects provided by Appeon. The
appeondatawindow is inherited from the PowerBuilder system
DataWindow control, and the appeondatastoreis inherited from
the PowerBuilder system DataStore object. Therefore the way
of deploying appeondatastore and appeondatawindow is the
same as deploy a PowerBuilder NVO.

3. Generate stubs and skeletons for the server DataStores in
the application.

You can refer to Appeon 5.0 for PowerBuilder Help | Appeon
Migration Guide | Building and Migrating Distributed
Applications | Migrating distributed
applications with distributed DataWindows | Workaround
required if you use distributed DataWindows.

Regards
Sally Li

> When I run this code in powerbuilder it runs fine, but
> when I run in in appeon code, it returns an error
>
> g_connetion = create connection
> g_connetion.driver = "jaguar"
> g_connetion.location = gstr_appserver.servername
> g_connetion.userid = gstr_appserver.userid
> g_connetion.password = gstr_appserver.password
>
> ll_rc = ll_rc = g_connetion.ConnectToServer()
> IF ll_rc <> 0 THEN
> MessageBox( 'Error', "connection failed" )
> return -1
> END IF
>
> ll_rc = g_connetion.CreateInstance( lnv_files,
> ls_interfase )
> IF ll_rc <> 0 THEN
> MessageBox( 'instance of the componente failed', ll_rc
> )
> RETURN
> END IF
>
> in powerbuilder it works fine.
>
> In appeon sends me the message that
> "instance of the component failed", and it returns 57
> which means NOT CONNECTED.
>
> What else do I need to do in appeon so it can work like
> in powerbuilder ?
>
> thanks
>
> fili sosa