Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

OLE Custom Control

2 posts in Objects Last posting was on 2007-06-11 13:18:27.0Z
MJPC Posted on 2007-06-11 12:55:36.0Z
Sender: 2d69.466d4051.1804289383@sybase.com
From: MJPC
Newsgroups: sybase.public.powerbuilder.objects
Subject: OLE Custom Control
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <466d4648.2df3.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 11 Jun 2007 05:55:36 -0700
X-Trace: forums-1-dub 1181566536 10.22.241.41 (11 Jun 2007 05:55:36 -0700)
X-Original-Trace: 11 Jun 2007 05:55:36 -0700, 10.22.241.41
Lines: 11
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:9373
Article PK: 736535

I have an OLE Custom Control on my form, when I get to this
line of my code I get an error:

ole_1.object.TargetURL = ls_target

The error I get is:

"Error accessing external object property targeturl"

I have checked to make sure that the ls_target variable does
in fact hold a valid url. Any ideas how to correct this?


Chris Werner Posted on 2007-06-11 13:18:27.0Z
From: "Chris Werner" <cwAT{PleaseNoSpam}f-s.de>
Newsgroups: sybase.public.powerbuilder.objects
References: <466d4648.2df3.1681692777@sybase.com>
Subject: Re: OLE Custom Control
Lines: 27
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3028
x-mimeole: Produced By Microsoft MimeOLE V6.00.2900.3028
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: 62.8.156.42
X-Original-NNTP-Posting-Host: 62.8.156.42
Message-ID: <466d4ba3$1@forums-1-dub>
Date: 11 Jun 2007 06:18:27 -0700
X-Trace: forums-1-dub 1181567907 62.8.156.42 (11 Jun 2007 06:18:27 -0700)
X-Original-Trace: 11 Jun 2007 06:18:27 -0700, 62.8.156.42
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:9374
Article PK: 736532

This usually says that the OLE Custom Control doesn't have
the property targetURL. Have you checked that? You can
do that using the object browser: Mainmenu: Tools/Browser,
choose the tabpage OLE, search OLE Custom Controls for
the control in question, expand "Properties". You have to
find string TargetURL there.

HTH

Chris Werner
f+s software gmbh


<MJPC> schrieb im Newsbeitrag news:466d4648.2df3.1681692777@sybase.com...

>I have an OLE Custom Control on my form, when I get to this
> line of my code I get an error:
>
> ole_1.object.TargetURL = ls_target
>
> The error I get is:
>
> "Error accessing external object property targeturl"
>
> I have checked to make sure that the ls_target variable does
> in fact hold a valid url. Any ideas how to correct this?