Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

PowerBuilder 11 Migration

2 posts in Help with NNTP newsgroups Last posting was on 2007-08-14 16:44:23.0Z
Jie Zhu Posted on 2007-08-14 16:27:53.0Z
From: "Jie Zhu" <zhuja0@maritz.com>
Newsgroups: news.help
Subject: PowerBuilder 11 Migration
Lines: 37
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-RFC2646: Format=Flowed; Original
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3138
NNTP-Posting-Host: maritzfw11.maritz.com
X-Original-NNTP-Posting-Host: maritzfw11.maritz.com
Message-ID: <46c1d809@forums-1-dub>
Date: 14 Aug 2007 09:27:53 -0700
X-Trace: forums-1-dub 1187108873 156.45.254.11 (14 Aug 2007 09:27:53 -0700)
X-Original-Trace: 14 Aug 2007 09:27:53 -0700, maritzfw11.maritz.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub news.help:503
Article PK: 19532

Hi, all:

Your help will be greatly appreciated.

For PowerBuilder (PB) 11 Migration, two issues were identified: When

1. declaring a stored procedure in powerscript and running it, error
occurs (for both compile and run time):

DECLARE sp_GetPrgmID PROCEDURE FOR @ll_rc = GetPrgmID
:al_PrgmNO,
:al_CompanyOrgCode,
:al_CompanyOrgDBC,
@al_PrgmID = 0 OUTPUT
USING luc_Trans;

EXECUTE sp_GetPrgmID;

There are errors for both @ll_rc (getting returned status code
for a stored procedure) and @al_PrgmID = 0 OUTPUT (output parameter type). I
tried to add owner prefix, like dbo.GetPrgmID, error occur still in run
time,.

2. Using DYNAMIC FUNCTION calls

Most of our calls are getting exe error, then application stops.

Both 1 and 2 are perfectly working with PB9, but PB11.


Thanks in advance.

Jie Zhu

jie.zhu@maritz.com


Bruce Armstrong [TeamSybase] Posted on 2007-08-14 16:44:23.0Z
From: "Bruce Armstrong [TeamSybase]" <NOCANSPAM_bruce.armstrong@teamsybase.com>
Newsgroups: news.help
References: <46c1d809@forums-1-dub>
Subject: Re: PowerBuilder 11 Migration
Lines: 42
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-RFC2646: Format=Flowed; Response
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3138
NNTP-Posting-Host: 12.198.167.34
X-Original-NNTP-Posting-Host: 12.198.167.34
Message-ID: <46c1dbe7$1@forums-1-dub>
Date: 14 Aug 2007 09:44:23 -0700
X-Trace: forums-1-dub 1187109863 12.198.167.34 (14 Aug 2007 09:44:23 -0700)
X-Original-Trace: 14 Aug 2007 09:44:23 -0700, 12.198.167.34
X-Authenticated-User: TeamSybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub news.help:504
Article PK: 11384

You should post your question in one of the sybase.public.powerbuilder
forums.

"Jie Zhu" <zhuja0@maritz.com> wrote in message news:46c1d809@forums-1-dub...
> Hi, all:
>
> Your help will be greatly appreciated.
>
> For PowerBuilder (PB) 11 Migration, two issues were identified: When
>
> 1. declaring a stored procedure in powerscript and running it,
> error occurs (for both compile and run time):
>
> DECLARE sp_GetPrgmID PROCEDURE FOR @ll_rc = GetPrgmID
> :al_PrgmNO,
> :al_CompanyOrgCode,
> :al_CompanyOrgDBC,
> @al_PrgmID = 0 OUTPUT
> USING luc_Trans;
>
> EXECUTE sp_GetPrgmID;
>
> There are errors for both @ll_rc (getting returned status code
> for a stored procedure) and @al_PrgmID = 0 OUTPUT (output parameter type).
> I tried to add owner prefix, like dbo.GetPrgmID, error occur still in run
> time,.
>
> 2. Using DYNAMIC FUNCTION calls
>
> Most of our calls are getting exe error, then application stops.
>
> Both 1 and 2 are perfectly working with PB9, but PB11.
>
>
> Thanks in advance.
>
> Jie Zhu
>
> jie.zhu@maritz.com
>