Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

SQL Server Error when using update Blob

2 posts in Appeon (partner product) Last posting was on 2007-08-31 01:36:53.0Z
Jeff Sta. Ana Posted on 2007-08-30 01:14:47.0Z
Sender: 2363.46d61514.1804289383@sybase.com
From: Jeff Sta. Ana
Newsgroups: sybase.public.appeon
Subject: SQL Server Error when using update Blob
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <46d61a07.23c1.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 29 Aug 2007 18:14:47 -0700
X-Trace: forums-1-dub 1188436487 10.22.241.41 (29 Aug 2007 18:14:47 -0700)
X-Original-Trace: 29 Aug 2007 18:14:47 -0700, 10.22.241.41
Lines: 24
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:1981
Article PK: 13229

Good day,

We're using Appeon 5, Easerver 5.3, with MS SQL 2000 jdbc

Upon executing the following piece of code:

updateblob Extraction_Depot
set fileimage = :tot_b
where id = :ll_id
using SQLCA;

SQLCA.sqlcode = -1 and SQLCA.sqlerrtext =
"[Microsoft][SQLServer 2000 Driver for JDBC]Invalid
parameter binding(s)"

Said code works fine on client-server, even on a previous
Appeon 3.1 deployment. Running Appeon debugger shows that
the two variables (tot_b and ll_id) have correct values.

So we're pretty much stumped.

Any ideas?

Thanks.


Steven Yang Posted on 2007-08-31 01:36:53.0Z
Sender: 432d.46d76fbd.1804289383@sybase.com
From: Steven Yang
Newsgroups: sybase.public.appeon
Subject: Re: SQL Server Error when using update Blob
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <46d770b5.433a.1681692777@sybase.com>
References: <46d61a07.23c1.1681692777@sybase.com>
MIME-Version: 1.0
Content-Type: text/plain; charset="ISO-8859-1"
Content-Transfer-Encoding: quoted-printable
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 30 Aug 2007 18:36:53 -0700
X-Trace: forums-1-dub 1188524213 10.22.241.41 (30 Aug 2007 18:36:53 -0700)
X-Original-Trace: 30 Aug 2007 18:36:53 -0700, 10.22.241.41
Lines: 36
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:1982
Article PK: 21465

Hi Jeff,
I recommand you update your SQLServer 2000 to Service Pack
4 and use SQL Server 2000 Driver for JDBC Service Pack 3.
If this method can't solve this issue, could you provide the
following log files to us. You must first set Log mode to
Debug in the AEM.
1.êServer%\appeon\repository\Jaguar\log\AppeonServer.log
2.êServer%\appeon\repository\Jaguar\log\AppeonError.log

Regards
Steven

> Good day,
>
> We're using Appeon 5, Easerver 5.3, with MS SQL 2000 jdbc
>
> Upon executing the following piece of code:
>
> updateblob Extraction_Depot
> set fileimage = :tot_b
> where id = :ll_id
> using SQLCA;
>
> SQLCA.sqlcode = -1 and SQLCA.sqlerrtext =
> "[Microsoft][SQLServer 2000 Driver for JDBC]Invalid
> parameter binding(s)"
>
> Said code works fine on client-server, even on a previous
> Appeon 3.1 deployment. Running Appeon debugger shows that
> the two variables (tot_b and ll_id) have correct values.
>
> So we're pretty much stumped.
>
> Any ideas?
>
> Thanks.