Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Using ejb_proxy for java call - error in compiled runtime

7 posts in EJB Client Last posting was on 2008-02-06 15:03:46.0Z
Steve Posted on 2007-09-06 17:35:04.0Z
From: "Steve" <nobody@home.com>
Newsgroups: sybase.public.powerbuilder.ejbclient
Subject: Using ejb_proxy for java call - error in compiled runtime
Lines: 30
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2869
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2962
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: 12.185.233.126
X-Original-NNTP-Posting-Host: 12.185.233.126
Message-ID: <46e03a48$1@forums-1-dub>
Date: 6 Sep 2007 10:35:04 -0700
X-Trace: forums-1-dub 1189100104 12.185.233.126 (6 Sep 2007 10:35:04 -0700)
X-Original-Trace: 6 Sep 2007 10:35:04 -0700, 12.185.233.126
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.ejbclient:758
Article PK: 424858

I posted this over on the pbni forum but was told to try here, so sorry for
the crosspost.

I've got a simple ejb proxy working in the IDE (PB10) and have managed to
compile it. Problem is, when I click the button running the code which
makes the proxy call, I get an App Terminated Error:

Error calling method of a PBNI object

The error is happening on this line:

li_return = l_jvm.createJavaVM( "C:\Development\PBuilder\TestingThings",
FALSE )

This is a project with 3 pbls, 1 that is a regular pbl that compiles to an
.exe, the other two are the ejbclient and one that is the holder of the
proxy object. The .exe is running from the same directory as the code is
but I'm figuring it's something to do with the app not finding a resource
that the IDE is aware of. Problem is, I'm new to this so I'm not exactly
sure what I should be looking for or checking; Java isn't in my 'comfort'
zone as far as understanding goes.

Any hints? The end goal is to take the ejb proxy we create (to make java
calls) and deploy the whole thing as an app. This is just a small test of
some larger functionality we need to create.

Thanks.


<Ivan> Posted on 2007-09-08 01:32:21.0Z
From: <Ivan>
Newsgroups: sybase.public.powerbuilder.ejbclient
References: <46e03a48$1@forums-1-dub>
Subject: Re: Using ejb_proxy for java call - error in compiled runtime
Lines: 39
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3138
X-RFC2646: Format=Flowed; Response
NNTP-Posting-Host: 202.66.150.55
X-Original-NNTP-Posting-Host: 202.66.150.55
Message-ID: <46e1fba5$1@forums-1-dub>
Date: 7 Sep 2007 18:32:21 -0700
X-Trace: forums-1-dub 1189215141 202.66.150.55 (7 Sep 2007 18:32:21 -0700)
X-Original-Trace: 7 Sep 2007 18:32:21 -0700, 202.66.150.55
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.ejbclient:759
Article PK: 424859

I thing you should try, usually"Error calling method of a PBNI object" will
occur when your Client Jar file is inconsistent with your deployed Jar file
within your Application Server. So you can recomplie all your java source
and generate both updated client jar file and deployed jar file and also
regenerate your proxy in PB. then try to execute the program again.

"Steve" <nobody@home.com> ¼¶¼g©ó¶l¥ó·s»D:46e03a48$1@forums-1-dub...

>I posted this over on the pbni forum but was told to try here, so sorry for
>the crosspost.
>
> I've got a simple ejb proxy working in the IDE (PB10) and have managed to
> compile it. Problem is, when I click the button running the code which
> makes the proxy call, I get an App Terminated Error:
>
> Error calling method of a PBNI object
>
> The error is happening on this line:
>
> li_return = l_jvm.createJavaVM( "C:\Development\PBuilder\TestingThings",
> FALSE )
>
> This is a project with 3 pbls, 1 that is a regular pbl that compiles to an
> .exe, the other two are the ejbclient and one that is the holder of the
> proxy object. The .exe is running from the same directory as the code is
> but I'm figuring it's something to do with the app not finding a resource
> that the IDE is aware of. Problem is, I'm new to this so I'm not exactly
> sure what I should be looking for or checking; Java isn't in my 'comfort'
> zone as far as understanding goes.
>
> Any hints? The end goal is to take the ejb proxy we create (to make java
> calls) and deploy the whole thing as an app. This is just a small test of
> some larger functionality we need to create.
>
> Thanks.
>
>
>


bede Posted on 2007-09-10 12:00:34.0Z
From: bede <bedenosp@msofico.be>
Newsgroups: sybase.public.powerbuilder.ejbclient
Subject: Re: Using ejb_proxy for java call - error in compiled runtime
Message-ID: <MPG.214f5021470d358d9898ab@forums.sybase.com>
References: <46e03a48$1@forums-1-dub>
MIME-Version: 1.0
Content-Type: text/plain; charset="iso-8859-15"
Content-Transfer-Encoding: 7bit
User-Agent: MicroPlanet-Gravity/2.70.2067
NNTP-Posting-Host: uu194-7-38-226.unknown.uunet.be
X-Original-NNTP-Posting-Host: uu194-7-38-226.unknown.uunet.be
Date: 10 Sep 2007 05:00:34 -0700
X-Trace: forums-1-dub 1189425634 194.7.38.226 (10 Sep 2007 05:00:34 -0700)
X-Original-Trace: 10 Sep 2007 05:00:34 -0700, uu194-7-38-226.unknown.uunet.be
Lines: 45
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.ejbclient:761
Article PK: 424860

after you get the error, exit your application and go back to PB IDE.
Check the Java status via menu Tools/System Options/Java and when running, verify that the
JRE and classPath are the ones that you had expected.
If no Java is running, something must be wrong with the location PB searches for the JRE, so
doublecheck that as well (see HKEY_LOCAL_MACHINE\SOFTWARE\Sybase\PowerBuilder\10.X\Java )

Good luck,

Ben

PS: googling this newsgroup may give you more info


In article <46e03a48$1@forums-1-dub>, nobody@home.com says...

> I posted this over on the pbni forum but was told to try here, so sorry for
> the crosspost.
>
> I've got a simple ejb proxy working in the IDE (PB10) and have managed to
> compile it. Problem is, when I click the button running the code which
> makes the proxy call, I get an App Terminated Error:
>
> Error calling method of a PBNI object
>
> The error is happening on this line:
>
> li_return = l_jvm.createJavaVM( "C:\Development\PBuilder\TestingThings",
> FALSE )
>
> This is a project with 3 pbls, 1 that is a regular pbl that compiles to an
> .exe, the other two are the ejbclient and one that is the holder of the
> proxy object. The .exe is running from the same directory as the code is
> but I'm figuring it's something to do with the app not finding a resource
> that the IDE is aware of. Problem is, I'm new to this so I'm not exactly
> sure what I should be looking for or checking; Java isn't in my 'comfort'
> zone as far as understanding goes.
>
> Any hints? The end goal is to take the ejb proxy we create (to make java
> calls) and deploy the whole thing as an app. This is just a small test of
> some larger functionality we need to create.
>
> Thanks.
>
>
>
>


Steve Posted on 2007-09-11 13:00:40.0Z
From: "Steve" <nobody@home.com>
Newsgroups: sybase.public.powerbuilder.ejbclient
References: <46e03a48$1@forums-1-dub> <MPG.214f5021470d358d9898ab@forums.sybase.com>
Subject: Re: Using ejb_proxy for java call - error in compiled runtime
Lines: 64
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2869
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2962
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: 12.185.233.126
X-Original-NNTP-Posting-Host: 12.185.233.126
Message-ID: <46e69178@forums-1-dub>
Date: 11 Sep 2007 06:00:40 -0700
X-Trace: forums-1-dub 1189515640 12.185.233.126 (11 Sep 2007 06:00:40 -0700)
X-Original-Trace: 11 Sep 2007 06:00:40 -0700, 12.185.233.126
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.ejbclient:762
Article PK: 424861

I've been pressed with other matters so I haven't had time to recompile
everything as Ivan has suggested...

However from your suggestion I feel I need to clarify the problem.

I can run the app just fine from within the IDE. The error happens when I
try to run the compiled/deployed executable.

"bede" <bedenosp@msofico.be> wrote in message
news:MPG.214f5021470d358d9898ab@forums.sybase.com...
> after you get the error, exit your application and go back to PB IDE.
> Check the Java status via menu Tools/System Options/Java and when running,
> verify that the
> JRE and classPath are the ones that you had expected.
> If no Java is running, something must be wrong with the location PB
> searches for the JRE, so
> doublecheck that as well (see
> HKEY_LOCAL_MACHINE\SOFTWARE\Sybase\PowerBuilder\10.X\Java )
>
> Good luck,
>
> Ben
>
> PS: googling this newsgroup may give you more info
>
>
> In article <46e03a48$1@forums-1-dub>, nobody@home.com says...
>> I posted this over on the pbni forum but was told to try here, so sorry
>> for
>> the crosspost.
>>
>> I've got a simple ejb proxy working in the IDE (PB10) and have managed to
>> compile it. Problem is, when I click the button running the code which
>> makes the proxy call, I get an App Terminated Error:
>>
>> Error calling method of a PBNI object
>>
>> The error is happening on this line:
>>
>> li_return = l_jvm.createJavaVM( "C:\Development\PBuilder\TestingThings",
>> FALSE )
>>
>> This is a project with 3 pbls, 1 that is a regular pbl that compiles to
>> an
>> .exe, the other two are the ejbclient and one that is the holder of the
>> proxy object. The .exe is running from the same directory as the code is
>> but I'm figuring it's something to do with the app not finding a resource
>> that the IDE is aware of. Problem is, I'm new to this so I'm not exactly
>> sure what I should be looking for or checking; Java isn't in my 'comfort'
>> zone as far as understanding goes.
>>
>> Any hints? The end goal is to take the ejb proxy we create (to make java
>> calls) and deploy the whole thing as an app. This is just a small test
>> of
>> some larger functionality we need to create.
>>
>> Thanks.
>>
>>
>>
>>


bede Posted on 2007-09-12 07:25:21.0Z
From: bede <bedenosp@msofico.be>
Newsgroups: sybase.public.powerbuilder.ejbclient
Subject: Re: Using ejb_proxy for java call - error in compiled runtime
Message-ID: <MPG.2151b2c68cc36f2f9898ac@forums.sybase.com>
References: <46e03a48$1@forums-1-dub> <MPG.214f5021470d358d9898ab@forums.sybase.com> <46e69178@forums-1-dub>
MIME-Version: 1.0
Content-Type: text/plain; charset="iso-8859-15"
Content-Transfer-Encoding: 7bit
User-Agent: MicroPlanet-Gravity/2.70.2067
NNTP-Posting-Host: uu194-7-38-226.unknown.uunet.be
X-Original-NNTP-Posting-Host: uu194-7-38-226.unknown.uunet.be
Date: 12 Sep 2007 00:25:21 -0700
X-Trace: forums-1-dub 1189581921 194.7.38.226 (12 Sep 2007 00:25:21 -0700)
X-Original-Trace: 12 Sep 2007 00:25:21 -0700, uu194-7-38-226.unknown.uunet.be
Lines: 74
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.ejbclient:764
Article PK: 424862

my mistake..

in that case focus on:
- deployment of JRE compared to exe should be reflected by reg settings, eg: when copying a
jre into the folder with the exe, you could use these settings:
[HKEY_LOCAL_MACHINE\SOFTWARE\Sybase\PowerBuilder\10.5\Java]
"JDKLocation"="."
"JDKLocationDef"="."
"JREBinLocation"=".\\jre\\bin\\client"
"JREBinLocationDef"=".\\jre\\bin\\client"

- Check the settings under HKEY_LOCAL_MACHINE\SOFTWARE\Sybase\PowerBuilder\10.5\Java
\PBRTConfig for specific needs regarding your application server (eg: websphere usually
requires extras)

- start JavaVM in debug mode and interpret vm.out. indicate what you want logged in registry
again:

[HKEY_LOCAL_MACHINE\SOFTWARE\Sybase\PowerBuilder\10.5\Java\PBRTConfig\PBJVMconfig]
"0"="-verbose:jni"
"1"="-verbose:class"
"Count"="2"

In article <46e69178@forums-1-dub>, nobody@home.com says...

> I've been pressed with other matters so I haven't had time to recompile
> everything as Ivan has suggested...
>
> However from your suggestion I feel I need to clarify the problem.
>
> I can run the app just fine from within the IDE. The error happens when I
> try to run the compiled/deployed executable.
>
>
> "bede" <bedenosp@msofico.be> wrote in message
> news:MPG.214f5021470d358d9898ab@forums.sybase.com...
> > after you get the error, exit your application and go back to PB IDE.
> > Check the Java status via menu Tools/System Options/Java and when running,
> > verify that the
> > JRE and classPath are the ones that you had expected.
> > If no Java is running, something must be wrong with the location PB
> > searches for the JRE, so
> > doublecheck that as well (see
> > HKEY_LOCAL_MACHINE\SOFTWARE\Sybase\PowerBuilder\10.X\Java )
> >
> > Good luck,
> >
> > Ben
> >
> > PS: googling this newsgroup may give you more info
> >
> >
> > In article <46e03a48$1@forums-1-dub>, nobody@home.com says...
> >> I posted this over on the pbni forum but was told to try here, so sorry
> >> for
> >> the crosspost.
> >>
> >> I've got a simple ejb proxy working in the IDE (PB10) and have managed to
> >> compile it. Problem is, when I click the button running the code which
> >> makes the proxy call, I get an App Terminated Error:
> >>
> >> Error calling method of a PBNI object
> >>
> >> The error is happening on this line:
> >>
> >> li_return = l_jvm.createJavaVM( "C:\Development\PBuilder\TestingThings",
> >> FALSE )
> >>
> >> This is a project with 3 pbls, 1 that is a regular pbl that compiles to
> >> an
> >> .exe, the other two are the ejbclient and one that is the holder of the
> >> proxy object. The .exe is running from the same directory as the code is
> >> but I'm figuring it's something to do with the app not finding a resource
> >> that the IDE is aware of. Problem is, I'm new to this so I'm not exactly
> >> sure what I should be looking for or checking; Java isn't in my 'comfort'


Steve Posted on 2008-01-03 19:16:45.0Z
From: "Steve" <nobody@home.com>
Newsgroups: sybase.public.powerbuilder.ejbclient
References: <46e03a48$1@forums-1-dub> <MPG.214f5021470d358d9898ab@forums.sybase.com> <46e69178@forums-1-dub> <MPG.2151b2c68cc36f2f9898ac@forums.sybase.com>
Subject: Re: Using ejb_proxy for java call - error in compiled runtime
Lines: 119
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-RFC2646: Format=Flowed; Original
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3198
NNTP-Posting-Host: 12.185.233.126
X-Original-NNTP-Posting-Host: 12.185.233.126
Message-ID: <477d349d@forums-1-dub>
Date: 3 Jan 2008 11:16:45 -0800
X-Trace: forums-1-dub 1199387805 12.185.233.126 (3 Jan 2008 11:16:45 -0800)
X-Original-Trace: 3 Jan 2008 11:16:45 -0800, 12.185.233.126
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.ejbclient:780
Article PK: 424878

bede,

It's been a while and I'm now back to this mess.

I've set the java debug via PB to true:
li_return = l_jvm.createJavaVM( "C:\Development\PBuilder\EJBTesting", TRUE )

...and I get mixed results. Sometimes I'll get vm.out from running in the
IDE, but my issue is with the compiled version. I have yet to see output
from the debugger running the .exe.

You're registry checks below I really have no idea as to their meaning.
We're not running any servers, this is just doing an EJBProxy to call a java
class. The PBJVMconfig...I have exactly what you have below, I don't know
what it means.

I have another post in the PBNI group as we found a codexchange example that
bypasses the proxy...I'm not sure how but it works; Howerver I'm in the same
situation, I get an error calling method of PBNI object error trying to
execute the compiled version.

I'm lost and the other guy on my team helping can't believe this is THAT
difficult.

1=

"bede" <bedenosp@msofico.be> wrote in message
news:MPG.2151b2c68cc36f2f9898ac@forums.sybase.com...
> my mistake..
>
> in that case focus on:
> - deployment of JRE compared to exe should be reflected by reg settings,
> eg: when copying a
> jre into the folder with the exe, you could use these settings:
> [HKEY_LOCAL_MACHINE\SOFTWARE\Sybase\PowerBuilder\10.5\Java]
> "JDKLocation"="."
> "JDKLocationDef"="."
> "JREBinLocation"=".\\jre\\bin\\client"
> "JREBinLocationDef"=".\\jre\\bin\\client"
>
> - Check the settings under
> HKEY_LOCAL_MACHINE\SOFTWARE\Sybase\PowerBuilder\10.5\Java
> \PBRTConfig for specific needs regarding your application server (eg:
> websphere usually
> requires extras)
>
> - start JavaVM in debug mode and interpret vm.out. indicate what you want
> logged in registry
> again:
>
> [HKEY_LOCAL_MACHINE\SOFTWARE\Sybase\PowerBuilder\10.5\Java\PBRTConfig\PBJVMconfig]
> "0"="-verbose:jni"
> "1"="-verbose:class"
> "Count"="2"
>
> In article <46e69178@forums-1-dub>, nobody@home.com says...
>> I've been pressed with other matters so I haven't had time to recompile
>> everything as Ivan has suggested...
>>
>> However from your suggestion I feel I need to clarify the problem.
>>
>> I can run the app just fine from within the IDE. The error happens when
>> I
>> try to run the compiled/deployed executable.
>>
>>
>> "bede" <bedenosp@msofico.be> wrote in message
>> news:MPG.214f5021470d358d9898ab@forums.sybase.com...
>> > after you get the error, exit your application and go back to PB IDE.
>> > Check the Java status via menu Tools/System Options/Java and when
>> > running,
>> > verify that the
>> > JRE and classPath are the ones that you had expected.
>> > If no Java is running, something must be wrong with the location PB
>> > searches for the JRE, so
>> > doublecheck that as well (see
>> > HKEY_LOCAL_MACHINE\SOFTWARE\Sybase\PowerBuilder\10.X\Java )
>> >
>> > Good luck,
>> >
>> > Ben
>> >
>> > PS: googling this newsgroup may give you more info
>> >
>> >
>> > In article <46e03a48$1@forums-1-dub>, nobody@home.com says...
>> >> I posted this over on the pbni forum but was told to try here, so
>> >> sorry
>> >> for
>> >> the crosspost.
>> >>
>> >> I've got a simple ejb proxy working in the IDE (PB10) and have managed
>> >> to
>> >> compile it. Problem is, when I click the button running the code
>> >> which
>> >> makes the proxy call, I get an App Terminated Error:
>> >>
>> >> Error calling method of a PBNI object
>> >>
>> >> The error is happening on this line:
>> >>
>> >> li_return = l_jvm.createJavaVM(
>> >> "C:\Development\PBuilder\TestingThings",
>> >> FALSE )
>> >>
>> >> This is a project with 3 pbls, 1 that is a regular pbl that compiles
>> >> to
>> >> an
>> >> .exe, the other two are the ejbclient and one that is the holder of
>> >> the
>> >> proxy object. The .exe is running from the same directory as the code
>> >> is
>> >> but I'm figuring it's something to do with the app not finding a
>> >> resource
>> >> that the IDE is aware of. Problem is, I'm new to this so I'm not
>> >> exactly
>> >> sure what I should be looking for or checking; Java isn't in my
>> >> 'comfort'


bede Posted on 2008-02-06 15:03:46.0Z
From: bede <bedenosp@msofico.be>
Newsgroups: sybase.public.powerbuilder.ejbclient
Subject: Re: Using ejb_proxy for java call - error in compiled runtime
Message-ID: <MPG.2213eae8b456c6799898be@forums.sybase.com>
References: <46e03a48$1@forums-1-dub> <MPG.214f5021470d358d9898ab@forums.sybase.com> <46e69178@forums-1-dub> <MPG.2151b2c68cc36f2f9898ac@forums.sybase.com> <477d349d@forums-1-dub>
MIME-Version: 1.0
Content-Type: text/plain; charset="iso-8859-15"
Content-Transfer-Encoding: 7bit
User-Agent: MicroPlanet-Gravity/2.70.2067
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Date: 6 Feb 2008 07:03:46 -0800
X-Trace: forums-1-dub 1202310226 10.22.241.152 (6 Feb 2008 07:03:46 -0800)
X-Original-Trace: 6 Feb 2008 07:03:46 -0800, vip152.sybase.com
Lines: 67
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.ejbclient:781
Article PK: 424879

It's been a while for me too ;)


Please compare the values of following registry settings

HKEY_LOCAL_MACHINE\SOFTWARE\Sybase\PowerBuilder\XX.XX\Java\PBRTConfig

vs.

HKEY_LOCAL_MACHINE\SOFTWARE\Sybase\PowerBuilder\XX.XX\Java\PBIDEConfig

do they contain the same keys & values?




In article <477d349d@forums-1-dub>, nobody@home.com says...

> bede,
>
> It's been a while and I'm now back to this mess.
>
> I've set the java debug via PB to true:
> li_return = l_jvm.createJavaVM( "C:\Development\PBuilder\EJBTesting", TRUE )
>
> ...and I get mixed results. Sometimes I'll get vm.out from running in the
> IDE, but my issue is with the compiled version. I have yet to see output
> from the debugger running the .exe.
>
> You're registry checks below I really have no idea as to their meaning.
> We're not running any servers, this is just doing an EJBProxy to call a java
> class. The PBJVMconfig...I have exactly what you have below, I don't know
> what it means.
>
> I have another post in the PBNI group as we found a codexchange example that
> bypasses the proxy...I'm not sure how but it works; Howerver I'm in the same
> situation, I get an error calling method of PBNI object error trying to
> execute the compiled version.
>
> I'm lost and the other guy on my team helping can't believe this is THAT
> difficult.
>
> 1=
> "bede" <bedenosp@msofico.be> wrote in message
> news:MPG.2151b2c68cc36f2f9898ac@forums.sybase.com...
> > my mistake..
> >
> > in that case focus on:
> > - deployment of JRE compared to exe should be reflected by reg settings,
> > eg: when copying a
> > jre into the folder with the exe, you could use these settings:
> > [HKEY_LOCAL_MACHINE\SOFTWARE\Sybase\PowerBuilder\10.5\Java]
> > "JDKLocation"="."
> > "JDKLocationDef"="."
> > "JREBinLocation"=".\\jre\\bin\\client"
> > "JREBinLocationDef"=".\\jre\\bin\\client"
> >
> > - Check the settings under
> > HKEY_LOCAL_MACHINE\SOFTWARE\Sybase\PowerBuilder\10.5\Java
> > \PBRTConfig for specific needs regarding your application server (eg:
> > websphere usually
> > requires extras)
> >
> > - start JavaVM in debug mode and interpret vm.out. indicate what you want
> > logged in registry
> > again:
> >
> > [HKEY_LOCAL_MACHINE\SOFTWARE\Sybase\PowerBuilder\10.5\Java\PBRTConfig\PBJVMconfig]