Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

sp_dbextend 'set', threshold' command does not work through JDBC.

4 posts in Performance and Tuning Last posting was on 2007-09-20 12:12:14.0Z
Praveen Kumar Posted on 2007-09-20 08:22:24.0Z
Sender: 7e6e.46f22a24.1804289383@sybase.com
From: Praveen Kumar
Newsgroups: sybase.public.ase.performance+tuning
Subject: sp_dbextend 'set', threshold' command does not work through JDBC.
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <46f22dc0.7ebf.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 20 Sep 2007 01:22:24 -0700
X-Trace: forums-1-dub 1190276544 10.22.241.41 (20 Sep 2007 01:22:24 -0700)
X-Original-Trace: 20 Sep 2007 01:22:24 -0700, 10.22.241.41
Lines: 21
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.performance+tuning:10350
Article PK: 88986

Hi,
We are configuring our database during install. We are using
jdbc to make all the configurations.

The following command is not working through JDBC. The
command exits garcefully with out exceptions.

The same command works fine through ISQL Console.
could some one help us in this issue.

use mydb
go
sp_dbextend 'set', 'database',mydb, 'data01', '1024m'
go
use mydb
go
sp_dbextend 'set', 'threshold', mydb, 'data01', '256m'
go

Thanks
Praveen.


Simon Ogden Posted on 2007-09-20 10:11:34.0Z
From: "Simon Ogden" <sogden@sybase.com>
Newsgroups: sybase.public.ase.performance+tuning
References: <46f22dc0.7ebf.1681692777@sybase.com>
Subject: Re: sp_dbextend 'set', threshold' command does not work through JDBC.
Lines: 34
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3028
X-RFC2646: Format=Flowed; Original
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3028
NNTP-Posting-Host: sogden-xp.sybase.com
X-Original-NNTP-Posting-Host: sogden-xp.sybase.com
Message-ID: <46f24756$1@forums-1-dub>
Date: 20 Sep 2007 03:11:34 -0700
X-Trace: forums-1-dub 1190283094 10.50.7.190 (20 Sep 2007 03:11:34 -0700)
X-Original-Trace: 20 Sep 2007 03:11:34 -0700, sogden-xp.sybase.com
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.performance+tuning:10351
Article PK: 88988

Hi,

Do you get a stack trace in the error log?
What's the full JDBC connection string and from what application?

Cheers,

Simon

<Praveen Kumar> wrote in message news:46f22dc0.7ebf.1681692777@sybase.com...
> Hi,
> We are configuring our database during install. We are using
> jdbc to make all the configurations.
>
> The following command is not working through JDBC. The
> command exits garcefully with out exceptions.
>
> The same command works fine through ISQL Console.
> could some one help us in this issue.
>
> use mydb
> go
> sp_dbextend 'set', 'database',mydb, 'data01', '1024m'
> go
> use mydb
> go
> sp_dbextend 'set', 'threshold', mydb, 'data01', '256m'
> go
>
> Thanks
> Praveen.


Simon Ogden Posted on 2007-09-20 12:12:14.0Z
From: "Simon Ogden" <sogden@sybase.com>
Newsgroups: sybase.public.ase.performance+tuning
References: <46f24756$1@forums-1-dub> <46f253b1.477.1681692777@sybase.com>
Subject: Re: sp_dbextend 'set', threshold' command does not work through JDBC.
Lines: 57
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3028
X-RFC2646: Format=Flowed; Original
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3028
NNTP-Posting-Host: sogden-xp.sybase.com
X-Original-NNTP-Posting-Host: sogden-xp.sybase.com
Message-ID: <46f2639e$1@forums-1-dub>
Date: 20 Sep 2007 05:12:14 -0700
X-Trace: forums-1-dub 1190290334 10.50.7.190 (20 Sep 2007 05:12:14 -0700)
X-Original-Trace: 20 Sep 2007 05:12:14 -0700, sogden-xp.sybase.com
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.performance+tuning:10353
Article PK: 88989

I understand the other commands are fine.
What's the full JDBC connection string and from what
application?

Do you get a stack trace in the ASE error log?(not the application log or
any other log client side)

<Praveen Kumar> wrote in message news:46f253b1.477.1681692777@sybase.com...
> We have a whole lot of config commands that we run.
> all the commnads run fine through JDBC except the threshold
> config command.
>
> The problem is the command exits gracefully with out any
> errors or Exceptions.
>
> When verified using
> sp_dbconfig list, 'threshold'
> We get zero rows.
>
>
>> Hi,
>>
>> Do you get a stack trace in the error log?
>> ?
>>
>> Cheers,
>>
>> Simon
>>
>>
>> <Praveen Kumar> wrote in message
>> > news:46f22dc0.7ebf.1681692777@sybase.com... Hi,
>> > We are configuring our database during install. We are
>> > using jdbc to make all the configurations.
>> >
>> > The following command is not working through JDBC. The
>> > command exits garcefully with out exceptions.
>> >
>> > The same command works fine through ISQL Console.
>> > could some one help us in this issue.
>> >
>> > use mydb
>> > go
>> > sp_dbextend 'set', 'database',mydb, 'data01', '1024m'
>> > go
>> > use mydb
>> > go
>> > sp_dbextend 'set', 'threshold', mydb, 'data01', '256m'
>> > go
>> >
>> > Thanks
>> > Praveen.
>>
>>