Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

PD12.5 update on Sybase Workspace

3 posts in General Discussion Last posting was on 2007-09-27 21:20:42.0Z
gaborg Posted on 2007-09-27 12:55:28.0Z
Sender: 69b0.46fba824.1804289383@sybase.com
From: gaborg
Newsgroups: sybase.public.workspace.general
Subject: PD12.5 update on Sybase Workspace
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <46fba83f.69b1.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 27 Sep 2007 05:55:28 -0700
X-Trace: forums-1-dub 1190897728 10.22.241.41 (27 Sep 2007 05:55:28 -0700)
X-Original-Trace: 27 Sep 2007 05:55:28 -0700, 10.22.241.41
Lines: 8
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.workspace.general:500
Article PK: 1088186

Hi Gurus!

Can I update the PowerDesigner 12 coming with Sybase
workspace to 12.5?

Bye,

Gabor


Mike Crocker Posted on 2007-09-27 18:42:31.0Z
From: "Mike Crocker" <crocker@sybase.com>
Newsgroups: sybase.public.workspace.general
References: <46fba83f.69b1.1681692777@sybase.com>
Subject: Re: PD12.5 update on Sybase Workspace
Lines: 34
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-RFC2646: Format=Flowed; Original
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3138
NNTP-Posting-Host: crockerxp.sybase.com
X-Original-NNTP-Posting-Host: crockerxp.sybase.com
Message-ID: <46fbf997$1@forums-1-dub>
Date: 27 Sep 2007 11:42:31 -0700
X-Trace: forums-1-dub 1190918551 10.24.112.185 (27 Sep 2007 11:42:31 -0700)
X-Original-Trace: 27 Sep 2007 11:42:31 -0700, crockerxp.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.workspace.general:501
Article PK: 1088185

This is not officially supported!

PD 12.5 will officially be supported when WS 2.0 ships at the end of the
year.

But some folks have gotten it to work.

You have 2 ways:

1. Typically, if someone wants both the Win32 client and WS, they would
license PD and install the PD Eclipse plug-in to the WS directory.

2. When you download the PowerDesigner maintenance releases and EBFs from
downloads.sybase.com and apply them, they will "find" the version of PD that
got installed with Workspace and patch that installation. That is, you don't
install PowerDesigner itself anymore - instead install Workspace, and THAT
installs PowerDesigner. After that, you can either run the Win32 application
(pdshell.exe) or use the Eclipse version. What has not been figured out is
how to get Visual Studio to see the PD plugin for that environment. That
still doesn't work.

Mike

<gaborg> wrote in message news:46fba83f.69b1.1681692777@sybase.com...
> Hi Gurus!
>
> Can I update the PowerDesigner 12 coming with Sybase
> workspace to 12.5?
>
> Bye,
>
> Gabor


Mike Crocker Posted on 2007-09-27 21:20:42.0Z
From: "Mike Crocker" <crocker@sybase.com>
Newsgroups: sybase.public.workspace.general
References: <46fba83f.69b1.1681692777@sybase.com> <46fbf997$1@forums-1-dub>
Subject: Re: PD12.5 update on Sybase Workspace
Lines: 58
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-RFC2646: Format=Flowed; Response
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3138
NNTP-Posting-Host: crockerxp.sybase.com
X-Original-NNTP-Posting-Host: crockerxp.sybase.com
Message-ID: <46fc1eaa@forums-1-dub>
Date: 27 Sep 2007 14:20:42 -0700
X-Trace: forums-1-dub 1190928042 10.24.112.185 (27 Sep 2007 14:20:42 -0700)
X-Original-Trace: 27 Sep 2007 14:20:42 -0700, crockerxp.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.workspace.general:502
Article PK: 1088187

I just got a better response from the PD experts/engineers:

To run PDes in all 5 environments: WS, PB, Eclipse, VS, & Win32 you need to
license and install PowerDesigner with the Eclipse and VS plug-ins. As for
PB, that compatibility is managed by the PB engineering group as they hard
code the PDes version for the plug-in to their environment.
Therefore, you would need to uninstall WS Enterprise. Install WS (without
PD), then install PDes Enterprise with the plug-ins and it should work. For
the PDes Eclipse plug-in, place it in to the WS Eclipse directory.
Typically, if you install WS Enterprise and try to run PDes from the
pdshell.exe it will work for 15-days, the typical trial period. This would
only continue to work by bypassing SySAM somehow, exploiting a bug, or
providing a valid PDes license key for the shell.

To repeat: The easiest thing to do would be to not have WS Enterprise and
just use the PDes Eclipse plug-in for WS.

Mike

"Mike Crocker" <crocker@sybase.com> wrote in message
news:46fbf997$1@forums-1-dub...

> This is not officially supported!
>
> PD 12.5 will officially be supported when WS 2.0 ships at the end of the
> year.
>
> But some folks have gotten it to work.
>
> You have 2 ways:
>
> 1. Typically, if someone wants both the Win32 client and WS, they would
> license PD and install the PD Eclipse plug-in to the WS directory.
>
> 2. When you download the PowerDesigner maintenance releases and EBFs
> from downloads.sybase.com and apply them, they will "find" the version of
> PD that got installed with Workspace and patch that installation. That is,
> you don't install PowerDesigner itself anymore - instead install
> Workspace, and THAT installs PowerDesigner. After that, you can either run
> the Win32 application (pdshell.exe) or use the Eclipse version. What has
> not been figured out is how to get Visual Studio to see the PD plugin for
> that environment. That still doesn't work.
>
> Mike
>
> <gaborg> wrote in message news:46fba83f.69b1.1681692777@sybase.com...
>> Hi Gurus!
>>
>> Can I update the PowerDesigner 12 coming with Sybase
>> workspace to 12.5?
>>
>> Bye,
>>
>> Gabor
>
>