Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Problem FTP via WINFTP32.DLL in PB10

5 posts in Objects Last posting was on 2007-10-15 10:57:37.0Z
Marc Schmidtmayer Posted on 2007-10-11 08:40:17.0Z
Sender: 24fa.470de06a.1804289383@sybase.com
From: Marc Schmidtmayer
Newsgroups: sybase.public.powerbuilder.objects
Subject: Problem FTP via WINFTP32.DLL in PB10
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <470de171.250a.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 11 Oct 2007 01:40:17 -0700
X-Trace: forums-1-dub 1192092017 10.22.241.41 (11 Oct 2007 01:40:17 -0700)
X-Original-Trace: 11 Oct 2007 01:40:17 -0700, 10.22.241.41
Lines: 9
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:9513
Article PK: 736667

Hi, we use WINFTP32.DLL (3.59) for ftp.
In PB8 we have no problem.
In PB10 we HAVE a problem : ftp_login returns always -1.

Why does it work in PB8 and not in PB10 ?
Anyone an idea ?

Thanks,
Marc.


Bruce Armstrong [TeamSybase] Posted on 2007-10-11 18:12:29.0Z
From: "Bruce Armstrong [TeamSybase]" <NOCANSPAM_bruce.armstrong@teamsybase.com>
Newsgroups: sybase.public.powerbuilder.objects
References: <470de171.250a.1681692777@sybase.com>
Subject: Re: Problem FTP via WINFTP32.DLL in PB10
Lines: 18
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-RFC2646: Format=Flowed; Original
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3138
NNTP-Posting-Host: 12.198.167.34
X-Original-NNTP-Posting-Host: 12.198.167.34
Message-ID: <470e678d$1@forums-1-dub>
Date: 11 Oct 2007 11:12:29 -0700
X-Trace: forums-1-dub 1192126349 12.198.167.34 (11 Oct 2007 11:12:29 -0700)
X-Original-Trace: 11 Oct 2007 11:12:29 -0700, 12.198.167.34
X-Authenticated-User: TeamSybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:9514
Article PK: 736674

Probably because PB8 is ANSI and PB10 is unicode. Given that DLL was
written for Windows 3.1, it's likely expecting ANSI. You've have to review
the function calls to it to make sure that data is being sent in the format
it expects.

<Marc Schmidtmayer> wrote in message
news:470de171.250a.1681692777@sybase.com...
> Hi, we use WINFTP32.DLL (3.59) for ftp.
> In PB8 we have no problem.
> In PB10 we HAVE a problem : ftp_login returns always -1.
>
> Why does it work in PB8 and not in PB10 ?
> Anyone an idea ?
>
> Thanks,
> Marc.