Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

ulsync failed?

2 posts in General Discussion Last posting was on 2007-11-02 19:22:39.0Z
gpzhang Posted on 2007-11-02 06:44:06.0Z
From: "gpzhang" <gpzhang@sybase.com>
Newsgroups: ianywhere.public.general
Subject: ulsync failed?
Lines: 33
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-RFC2646: Format=Flowed; Original
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3198
NNTP-Posting-Host: gpzhang-desktop.sybase.com
X-Original-NNTP-Posting-Host: gpzhang-desktop.sybase.com
Message-ID: <472ad546@forums-1-dub>
Date: 1 Nov 2007 23:44:06 -0700
X-Trace: forums-1-dub 1193989446 10.42.14.187 (1 Nov 2007 23:44:06 -0700)
X-Original-Trace: 1 Nov 2007 23:44:06 -0700, gpzhang-desktop.sybase.com
X-Authenticated-User: pbplugin
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:6527
Article PK: 4800

I created a publication called my in ultralite db and use ulsync to sync
with sample custdb. I tried following, it failed.
>>>>>>>>>>>>>>>>
D:\tools\ASA10\win32>ulsync -c
DBF=D:\tools\ASA10\samples\UltraLite\CustDB\custdb.udb -x
"host=localhost;port=2439" -e "Username=50;Version=1;Publication=my"

SQL Anywhere UltraLite Database Synchronize Utility Version 10.0.0.2465
Sync failed: Database error: Information for synchronization is incomplete
or invalid, check 'version'
Results of this synchronization:
Succeeded
Download timestamp: 2007-11-02 10:43:41.942000
Upload OK
No ignored rows
Partial download retained
Authentication value: 1000 (0x3e8)
>>>>>>>>>>>>>>>>

I also tried:

D:\tools\ASA10\win32>ulsync -c
DBF=D:\tools\ASA10\samples\UltraLite\CustDB\custdb.udb -x
"host=localhost;port=2439" -e "Username=50;Version=custdb
10.0;Publication=my",

it failed with same results.

Any help would be appreciated.

Thanks,


Shuchit Posted on 2007-11-02 19:22:39.0Z
Newsgroups: ianywhere.public.general
Subject: Re: ulsync failed?
From: Shuchit <me@privacy.net>
References: <472ad546@forums-1-dub>
Message-ID: <Xns99DC9C61D19E5svelkarprivacynet@127.0.0.1>
User-Agent: Xnews/2006.08.24 Hamster/2.1.0.11
NNTP-Posting-Host: svelkar-pc.sybase.com
X-Original-NNTP-Posting-Host: svelkar-pc.sybase.com
Date: 2 Nov 2007 11:22:39 -0800
X-Trace: forums-1-dub 1194031359 10.25.98.144 (2 Nov 2007 11:22:39 -0800)
X-Original-Trace: 2 Nov 2007 11:22:39 -0800, svelkar-pc.sybase.com
Lines: 15
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:6529
Article PK: 4801


"gpzhang" <gpzhang@sybase.com> wrote in news:472ad546@forums-1-dub:

> D:\tools\ASA10\win32>ulsync -c
> DBF=D:\tools\ASA10\samples\UltraLite\CustDB\custdb.udb -x
> "host=localhost;port=2439" -e "Username=50;Version=custdb
> 10.0;Publication=my",
>

Try the following, (note: I have not tested it)

ulsync -c "uid=dba;pwd=sql;dbf=path_to_database\custdb.udb" -k tcpip
-x "host=localhost;port=2439" -e Username=50 -e Version="Custdb 10.0"
-e publication="my"