Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Help configuring the M-Bus redirector

2 posts in General Discussion Last posting was on 2007-11-30 22:34:41.0Z
"Paul Horan[TeamSybase]" Posted on 2007-11-30 21:48:07.0Z
From: "Paul Horan[TeamSybase]" <phoran AT sybase DOT com>
Newsgroups: ianywhere.public.mbusinessanywhere.general
Subject: Help configuring the M-Bus redirector
Lines: 78
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-RFC2646: Format=Flowed; Original
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3198
NNTP-Posting-Host: horanpxp.sybase.com
X-Original-NNTP-Posting-Host: horanpxp.sybase.com
Message-ID: <47508517$1@forums-1-dub>
Date: 30 Nov 2007 13:48:07 -0800
X-Trace: forums-1-dub 1196459287 10.24.50.249 (30 Nov 2007 13:48:07 -0800)
X-Original-Trace: 30 Nov 2007 13:48:07 -0800, horanpxp.sybase.com
X-Authenticated-User: teamsybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.mbusinessanywhere.general:1150
Article PK: 17896

I'm trying to get the Ultralite for M-Business sample app running, and I'm
really close. I think the problem now is setting up the "redirector" to
enable one-button synchronization through M-Business 6.5.

I've built the consolidated (SA) and remote (UL) databases, and got them
syncing correctly. I have the sample app working on the handheld, saving
data into the UL on-device database. But when I try and sync, I'm getting
SQLE_COMMUNICATION_ERROR

Here's my environment:
HHT:
Windows CE
MBus 6.5 build 216
UltraLite 10.0.1.3504 POD
ActiveSync connection to my laptop through the USB port.

Laptop:
SA10.0.1.3504 consolidated db
ML10.0.1.3504 server listening on HTTP(port=8050)

sync.conf file (pertinent lines only):
LoadModule iaredirect_module "C:\Program
Files\Sybase\M-BusinessAnywhereServer\bin\mod_iaredirect.dll"
SyncLoadFile "C:\Program
Files\Sybase\M-BusinessAnywhereServer\bin\mod_iaredirect.dll"
<Location \iaredirect\ml>
SetHandler iaredirect-handler
iaredirectorConfigFile "C:\Program
Files\Sybase\M-BusinessAnywhereServer\conf\redirector.config"
</Location>

redirector.config file:
LOGLEVEL=2
ML=HORANPXP:8050 #horanpxp is my host name
SLEEP=1800

Now, it says I'm supposed to be able to open a browser and enter
http://HORANPXP:8091/iaredirect/ml and get a line in the sync_error.log
file. That's not happening. What I get is this:
[Fri Nov 30 15:24:03 2007] [info] (22)Invalid argument:
[Fri Nov 30 15:24:03 2007] [info] (22)Invalid argument: mod_iaredirect:
redirector configuration file parameters:
[Fri Nov 30 15:24:03 2007] [info] (22)Invalid argument: mod_iaredirect:
ML=HORANPXP:8050
[Fri Nov 30 15:24:03 2007] [info] (22)Invalid argument: mod_iaredirect:
SLEEP=1800000 millisec
[Fri Nov 30 15:24:03 2007] [info] (22)Invalid argument:
[Fri Nov 30 15:24:03 2007] [info] (22)Invalid argument: mod_iaredirect:
PingThread Started ..........


The Javascript in my M-Bus client app looks like this:
function Synchronize()
{
var SyncParms = Connection.syncParms;
SyncParms.setStream(SyncParms.STREAM_TYPE_HTTP);
SyncParms.setUserName("EDCL1");
SyncParms.setVersion("V1.0");
SyncParms.setMBAServer("192.168.55.100", "8091", "/iaredirect/ml" );
SyncParms.setSendColumnNames(true);
Connection.saveSyncParms();

try {
Connection.synchronize();
} catch( ex ) {
alert( "Sync error: " + ex.getMessage() );
}
}

And its throwing the -85 communications error message.

Any insight, or a working example of a WinCE/WinMobile5 setup would be
appreciated.
Thanks,
Paul Horan[TeamSybase]


"Paul Horan[TeamSybase]" Posted on 2007-11-30 22:34:41.0Z
From: "Paul Horan[TeamSybase]" <phoran AT sybase DOT com>
Newsgroups: ianywhere.public.mbusinessanywhere.general
References: <47508517$1@forums-1-dub>
Subject: Re: Help configuring the M-Bus redirector
Lines: 97
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-RFC2646: Format=Flowed; Response
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3198
NNTP-Posting-Host: horanpxp.sybase.com
X-Original-NNTP-Posting-Host: horanpxp.sybase.com
Message-ID: <47509001$1@forums-1-dub>
Date: 30 Nov 2007 14:34:41 -0800
X-Trace: forums-1-dub 1196462081 10.24.50.249 (30 Nov 2007 14:34:41 -0800)
X-Original-Trace: 30 Nov 2007 14:34:41 -0800, horanpxp.sybase.com
X-Authenticated-User: teamsybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.mbusinessanywhere.general:1151
Article PK: 9273

Never mind! I figured it out!

The Javascript call to:
SyncParms.setMBAServer("192.168.55.100", "8091", "/iaredirect/ml" );
was the culprit.

I changed that to:
SyncParms.setMBAServer("192.168.55.100", "80", "/iaredirect/ml" );

And it all worked perfectly.

Time for a cold Labatt Blue.

-P-

"Paul Horan[TeamSybase]" <phoran AT sybase DOT com> wrote in message
news:47508517$1@forums-1-dub...
> I'm trying to get the Ultralite for M-Business sample app running, and I'm
> really close. I think the problem now is setting up the "redirector" to
> enable one-button synchronization through M-Business 6.5.
>
> I've built the consolidated (SA) and remote (UL) databases, and got them
> syncing correctly. I have the sample app working on the handheld, saving
> data into the UL on-device database. But when I try and sync, I'm getting
> SQLE_COMMUNICATION_ERROR
>
> Here's my environment:
> HHT:
> Windows CE
> MBus 6.5 build 216
> UltraLite 10.0.1.3504 POD
> ActiveSync connection to my laptop through the USB port.
>
> Laptop:
> SA10.0.1.3504 consolidated db
> ML10.0.1.3504 server listening on HTTP(port=8050)
>
> sync.conf file (pertinent lines only):
> LoadModule iaredirect_module "C:\Program
> Files\Sybase\M-BusinessAnywhereServer\bin\mod_iaredirect.dll"
> SyncLoadFile "C:\Program
> Files\Sybase\M-BusinessAnywhereServer\bin\mod_iaredirect.dll"
> <Location \iaredirect\ml>
> SetHandler iaredirect-handler
> iaredirectorConfigFile "C:\Program
> Files\Sybase\M-BusinessAnywhereServer\conf\redirector.config"
> </Location>
>
> redirector.config file:
> LOGLEVEL=2
> ML=HORANPXP:8050 #horanpxp is my host name
> SLEEP=1800
>
> Now, it says I'm supposed to be able to open a browser and enter
> http://HORANPXP:8091/iaredirect/ml and get a line in the sync_error.log
> file. That's not happening. What I get is this:
> [Fri Nov 30 15:24:03 2007] [info] (22)Invalid argument:
> [Fri Nov 30 15:24:03 2007] [info] (22)Invalid argument: mod_iaredirect:
> redirector configuration file parameters:
> [Fri Nov 30 15:24:03 2007] [info] (22)Invalid argument: mod_iaredirect:
> ML=HORANPXP:8050
> [Fri Nov 30 15:24:03 2007] [info] (22)Invalid argument: mod_iaredirect:
> SLEEP=1800000 millisec
> [Fri Nov 30 15:24:03 2007] [info] (22)Invalid argument:
> [Fri Nov 30 15:24:03 2007] [info] (22)Invalid argument: mod_iaredirect:
> PingThread Started ..........
>
>
> The Javascript in my M-Bus client app looks like this:
> function Synchronize()
> {
> var SyncParms = Connection.syncParms;
> SyncParms.setStream(SyncParms.STREAM_TYPE_HTTP);
> SyncParms.setUserName("EDCL1");
> SyncParms.setVersion("V1.0");
> SyncParms.setMBAServer("192.168.55.100", "8091", "/iaredirect/ml" );
> SyncParms.setSendColumnNames(true);
> Connection.saveSyncParms();
>
> try {
> Connection.synchronize();
> } catch( ex ) {
> alert( "Sync error: " + ex.getMessage() );
> }
> }
>
> And its throwing the -85 communications error message.
>
> Any insight, or a working example of a WinCE/WinMobile5 setup would be
> appreciated.
> Thanks,
> Paul Horan[TeamSybase]
>
>
>