Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

'SAOLEDB.10' provider is not

8 posts in General Discussion Last posting was on 2007-12-11 15:42:45.0Z
Bladimir Calcina Posted on 2007-12-06 20:24:52.0Z
Sender: 179c.4756aefc.1804289383@sybase.com
From: Bladimir Calcina
Newsgroups: ianywhere.public.general
Subject: 'SAOLEDB.10' provider is not
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <47585a94.6619.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 6 Dec 2007 12:24:52 -0800
X-Trace: forums-1-dub 1196972692 10.22.241.41 (6 Dec 2007 12:24:52 -0800)
X-Original-Trace: 6 Dec 2007 12:24:52 -0800, 10.22.241.41
Lines: 8
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:6623
Article PK: 4873

Help me, Please

I have developed an application with dw .net 2.5 and ASA 10,
but when I publish it my application in a server leaves the
following error to me "The 'SAOLEDB.10' provider is not
registered on the local machine"

Reggards


Chris Keating (Sybase iAnywhere) Posted on 2007-12-06 23:00:53.0Z
From: "Chris Keating (Sybase iAnywhere)" <keating_spam_free@ianywhere.com>
User-Agent: Thunderbird 2.0.0.9 (Windows/20071031)
MIME-Version: 1.0
Newsgroups: ianywhere.public.general
Subject: Re: 'SAOLEDB.10' provider is not
References: <47585a94.6619.1681692777@sybase.com>
In-Reply-To: <47585a94.6619.1681692777@sybase.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: cpe001217e36468-cm0014e8868e10.cpe.net.cable.rogers.com
X-Original-NNTP-Posting-Host: cpe001217e36468-cm0014e8868e10.cpe.net.cable.rogers.com
Message-ID: <47587f25$1@forums-1-dub>
Date: 6 Dec 2007 15:00:53 -0800
X-Trace: forums-1-dub 1196982053 99.236.107.169 (6 Dec 2007 15:00:53 -0800)
X-Original-Trace: 6 Dec 2007 15:00:53 -0800, cpe001217e36468-cm0014e8868e10.cpe.net.cable.rogers.com
Lines: 11
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:6624
Article PK: 4872

Have you deployed and registered the SA10 OLEDB driver?

Bladimir Calcina wrote:
> Help me, Please
>
> I have developed an application with dw .net 2.5 and ASA 10,
> but when I publish it my application in a server leaves the
> following error to me "The 'SAOLEDB.10' provider is not
> registered on the local machine"
>
> Reggards


Chris Keating (Sybase iAnywhere) Posted on 2007-12-07 13:26:36.0Z
From: "Chris Keating (Sybase iAnywhere)" <keating_spam_free@ianywhere.com>
User-Agent: Thunderbird 2.0.0.9 (Windows/20071031)
MIME-Version: 1.0
Newsgroups: ianywhere.public.general
Subject: Re: 'SAOLEDB.10' provider is not
References: <47585a94.6619.1681692777@sybase.com>
In-Reply-To: <47585a94.6619.1681692777@sybase.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 8bit
NNTP-Posting-Host: keating-d620.sybase.com
X-Original-NNTP-Posting-Host: keating-d620.sybase.com
Message-ID: <47594a0c$1@forums-1-dub>
Date: 7 Dec 2007 05:26:36 -0800
X-Trace: forums-1-dub 1197033996 10.25.98.110 (7 Dec 2007 05:26:36 -0800)
X-Original-Trace: 7 Dec 2007 05:26:36 -0800, keating-d620.sybase.com
Lines: 16
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:6626
Article PK: 4875

For deployment information, see

SQL Anywhere® Server - Programming > Deploying Databases and
Applications > Deploying client applications

Deploying OLE DB and ADO clients

Bladimir Calcina wrote:
> Help me, Please
>
> I have developed an application with dw .net 2.5 and ASA 10,
> but when I publish it my application in a server leaves the
> following error to me "The 'SAOLEDB.10' provider is not
> registered on the local machine"
>
> Reggards


Bladimir Calcina Posted on 2007-12-10 14:42:08.0Z
Sender: 709f.475d4d62.1804289383@sybase.com
From: Bladimir Calcina
Newsgroups: ianywhere.public.general
Subject: Re: 'SAOLEDB.10' provider is not
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <475d5040.70eb.1681692777@sybase.com>
References: <47594a0c$1@forums-1-dub>
MIME-Version: 1.0
Content-Type: text/plain; charset="ISO-8859-1"
Content-Transfer-Encoding: quoted-printable
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 10 Dec 2007 06:42:08 -0800
X-Trace: forums-1-dub 1197297728 10.22.241.41 (10 Dec 2007 06:42:08 -0800)
X-Original-Trace: 10 Dec 2007 06:42:08 -0800, 10.22.241.41
Lines: 27
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:6628
Article PK: 4877

Thanks Chris

I did everything what the manuals say, but continuous with
the same problem, the connection string that use is
"Provider=SAOLEDB.10;data source=conexion; user
id=XXX;Password=X" and too to try with
"Provider=SAOLEDB.10;data
source=conexion;eng=conexion;LINKS=tcpip; user
id=XXX;Password=X" but not result.

> For deployment information, see
>
> SQL Anywhere® Server - Programming > Deploying
Databases
> and Applications > Deploying client applications
>
> Deploying OLE DB and ADO clients
>
> Bladimir Calcina wrote:
> > Help me, Please
> >
> > I have developed an application with dw .net 2.5 and ASA
> > 10, but when I publish it my application in a server
> > leaves the following error to me "The 'SAOLEDB.10'
> > provider is not registered on the local machine"
> >
> > Reggards


Chris Keating (Sybase iAnywhere) Posted on 2007-12-10 14:51:03.0Z
From: "Chris Keating (Sybase iAnywhere)" <keating_spam_free@ianywhere.com>
User-Agent: Thunderbird 2.0.0.9 (Windows/20071031)
MIME-Version: 1.0
Newsgroups: ianywhere.public.general
Subject: Re: 'SAOLEDB.10' provider is not
References: <47594a0c$1@forums-1-dub> <475d5040.70eb.1681692777@sybase.com>
In-Reply-To: <475d5040.70eb.1681692777@sybase.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 8bit
NNTP-Posting-Host: vpneast-client-030.sybase.com
X-Original-NNTP-Posting-Host: vpneast-client-030.sybase.com
Message-ID: <475d5257$1@forums-1-dub>
Date: 10 Dec 2007 06:51:03 -0800
X-Trace: forums-1-dub 1197298263 10.18.242.37 (10 Dec 2007 06:51:03 -0800)
X-Original-Trace: 10 Dec 2007 06:51:03 -0800, vpneast-client-030.sybase.com
Lines: 33
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:6629
Article PK: 4878

Can you check the registry for SAOLEDB.10? To do so, simply open the
registry with regedit.exe and search for saoledb.10

Bladimir Calcina wrote:
> Thanks Chris
>
> I did everything what the manuals say, but continuous with
> the same problem, the connection string that use is
> "Provider=SAOLEDB.10;data source=conexion; user
> id=XXX;Password=X" and too to try with
> "Provider=SAOLEDB.10;data
> source=conexion;eng=conexion;LINKS=tcpip; user
> id=XXX;Password=X" but not result.
>
>> For deployment information, see
>>
>> SQL Anywhere® Server - Programming > Deploying
> Databases
>> and Applications > Deploying client applications
>>
>> Deploying OLE DB and ADO clients
>>
>> Bladimir Calcina wrote:
>>> Help me, Please
>>>
>>> I have developed an application with dw .net 2.5 and ASA
>>> 10, but when I publish it my application in a server
>>> leaves the following error to me "The 'SAOLEDB.10'
>>> provider is not registered on the local machine"
>>>
>>> Reggards


Bladimir Calcina Posted on 2007-12-10 15:42:30.0Z
Sender: 709f.475d4d62.1804289383@sybase.com
From: Bladimir Calcina
Newsgroups: ianywhere.public.general
Subject: Re: 'SAOLEDB.10' provider is not
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <475d5e66.724f.1681692777@sybase.com>
References: <475d5257$1@forums-1-dub>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 10 Dec 2007 07:42:30 -0800
X-Trace: forums-1-dub 1197301350 10.22.241.41 (10 Dec 2007 07:42:30 -0800)
X-Original-Trace: 10 Dec 2007 07:42:30 -0800, 10.22.241.41
Lines: 10
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:6630
Article PK: 4879

if this registered, the path is HKEY_CLASSES_ROOT\SAOLEDB.10
and too exists others register where is SAOLEDB.10, this
problem appeared at the time of publishing my application in
server IIS, when run from visual studio it works correctly

Reggards

> Can you check the registry for SAOLEDB.10? To do so,
> simply open the registry with regedit.exe and search for
> saoledb.10


Bladimiro :) Posted on 2007-12-11 15:42:45.0Z
Sender: 709f.475d4d62.1804289383@sybase.com
From: Bladimiro :)
Newsgroups: ianywhere.public.general
Subject: Re: 'SAOLEDB.10' provider is not
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <475eaff5.1288.1681692777@sybase.com>
References: <475d5e66.724f.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 11 Dec 2007 07:42:45 -0800
X-Trace: forums-1-dub 1197387765 10.22.241.41 (11 Dec 2007 07:42:45 -0800)
X-Original-Trace: 11 Dec 2007 07:42:45 -0800, 10.22.241.41
Lines: 20
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:6632
Article PK: 4881

Greetings,

To review file machine.config and has registered the OLEDB,
but continuous the problem. Due to just a short time that I
must to finish the application I have changed by object
Transaction and ODBC and now it works well.

Reggards

> if this registered, the path is
> HKEY_CLASSES_ROOT\SAOLEDB.10 and too exists others
> register where is SAOLEDB.10, this problem appeared at the
> time of publishing my application in server IIS, when run
> from visual studio it works correctly
>
> Reggards
>
> > Can you check the registry for SAOLEDB.10? To do so,
> > simply open the registry with regedit.exe and search
> > for saoledb.10


David Fishburn Posted on 2007-12-11 14:42:34.0Z
Newsgroups: ianywhere.public.general
Subject: Re: 'SAOLEDB.10' provider is not
From: David Fishburn <fishburn_spam@off.ianywhere.com>
References: <47585a94.6619.1681692777@sybase.com>
Organization: iAnywhere Solutions
Message-ID: <Xns9A03628B6D57Dfishburnsybasecom@127.0.0.1>
User-Agent: Xnews/2005.10.18 Hamster/2.1.0.0
NNTP-Posting-Host: vpneast-client-061.sybase.com
X-Original-NNTP-Posting-Host: vpneast-client-061.sybase.com
Date: 11 Dec 2007 06:42:34 -0800
X-Trace: forums-1-dub 1197384154 10.18.242.68 (11 Dec 2007 06:42:34 -0800)
X-Original-Trace: 11 Dec 2007 06:42:34 -0800, vpneast-client-061.sybase.com
Lines: 63
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:6631
Article PK: 4880

Bladimir Calcina wrote in news:47585a94.6619.1681692777@sybase.com
of ianywhere.public.general:

BC> I have developed an application with dw .net 2.5 and ASA 10,
BC> but when I publish it my application in a server leaves the
BC> following error to me "The 'SAOLEDB.10' provider is not
BC> registered on the local machine"

I had a similar issue recently.

How did you "deploy" the SQL Anywhere provider? How did you install SQL
Anywhere on the machine? Did you run the full blown SQL Anywhere
install? Did you write your own custom install? Did you use the SQL
Anywhere deployment wizard? Please try to be specific.

If you open this file:
c:\windows\microsoft.net\Framework\v2.0.50727\config\machine.config

Look for this section:
<DbProviderFactories>

In that section you should have something that looks like this. Most
likely the version information may be different. But what I am
interested in is if the "SQL Anywhere 10 Data Provider" exists.

<system.data>
<DbProviderFactories>
<add name="SQL Anywhere 10
Data Provider"
invariant="iAnywhere.Data.SQLAnywhere"
description=".Net
Framework Data Provider
for SQL Anywhere 10"
type="iAnywhere.Data.SQLAnywhere.SAFactory,
iAnywhere.Data.SQLAnywhere,
Version=10.0.1.34152,
Culture=neutral,
PublicKeyToken=f222fc4333e0d400"
/>
</DbProviderFactories>
</system.data>

--
David Fishburn
Certified ASA Developer Version 8
iAnywhere Solutions - Sybase
Professional Services
Please only post to the newsgroup
Please ALWAYS include version and MORE importantly BUILD number with
EACH post (dbeng10 -v).

EBFs and Maintenance Releases
http://downloads.sybase.com/

Developer Community / Whitepapers
http://www.ianywhere.com/developer

Case-Express - to report bugs
http://case-express.sybase.com

CodeXchange - Free samples
http://ianywhere.codexchange.sybase.com/servlets/ProjectDocumentList