Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Concurrent Server/Version

3 posts in Networking Last posting was on 2008-01-09 14:41:03.0Z
Benedictum Posted on 2008-01-08 13:29:25.0Z
From: "Benedictum" <Benedictus@dominusvobis.com>
Newsgroups: Advantage.Networking
Subject: Concurrent Server/Version
Date: Tue, 8 Jan 2008 07:29:25 -0600
Lines: 22
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3198
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: 76.16.150.72
Message-ID: <4783796f@solutions.advantagedatabase.com>
X-Trace: 8 Jan 2008 06:23:59 -0700, 76.16.150.72
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!76.16.150.72
Xref: solutions.advantagedatabase.com Advantage.Networking:734
Article PK: 1132153

I have a system which I need to upgrade. A server is running under ADS7.1.
In the same network, I plan to install ADS8.1 in a separate server. I wanted
to do this prior to a total conversion of the entire network to 8.1. My
reason is that 7.1 is working flawlessly and I hate to disrupt something
that works! I want to move to 8.1 to take advantage of the new features,
e.g. replication, etc. My questions are:
1. Can I install different versions in a network?
2. Are there any issues I need to know when I copy the tables, data dics,
etc. into 8.1 server?
3. In the client application, are there any changes which I need to do
(developed in Delphi with TDataset7.1). Any compatibility issues? I am still
using Delphi 5 because of other components not available to the newer Delphi
versions.
4.When the 8.1 server is fully tested and deemed trouble free, I would like
to make a new install using the 7.1 license into a separate network then
get the 8.1 upgrade for it. That means I would purchase a full version
license of 8.1 and an 8.1 upgrade license for the 7.1. Any issues?

Thanks,
B.


Joachim Duerr (ADS) Posted on 2008-01-08 14:02:10.0Z
From: "Joachim Duerr (ADS)" <jojo.duerr@gmx.de>
Subject: Re: Concurrent Server/Version
Newsgroups: Advantage.Networking
References: <4783796f@solutions.advantagedatabase.com>
Organization: iAnywhere
User-Agent: XanaNews/1.18.1.9
X-Face: ,QMv7[luB)BpWAQ~:"kw6n%0ieY63.:g2K3n~8ky0;||5Xle*Xq+=~<Fy:0CVC2nx@8~vZ
MIME-Version: 1.0
Content-Type: text/plain; charset=iso-8859-1
NNTP-Posting-Host: 10.56.66.108
Message-ID: <47838262@solutions.advantagedatabase.com>
Date: 8 Jan 2008 07:02:10 -0700
X-Trace: 8 Jan 2008 07:02:10 -0700, 10.56.66.108
Lines: 40
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!10.56.66.108
Xref: solutions.advantagedatabase.com Advantage.Networking:735
Article PK: 1132154


Benedictum wrote in <4783796f@solutions.advantagedatabase.com>:

> 1. Can I install different versions in a network?

yes if they're installed with a different serial number

> 2. Are there any issues I need to know when I copy the tables, data
> dics, etc. into 8.1 server?

using old files with newer servers should not hurt, but vice versa
could (e.g. when using new features, adding new triggers, ...).
Incompatibilites are listed in the readme.txt of the new server and in
the help file of the new server.

> 3. In the client application, are there
> any changes which I need to do (developed in Delphi with
> TDataset7.1). Any compatibility issues? I am still using Delphi 5
> because of other components not available to the newer Delphi
> versions.

could be, but shouldn't. There where some changes (e.g. adding support
for NUMERIC in ADT, which can influence the result set of some SQL
statements). But this is also listed in the readme of the client kit.
If you stay with the old client kit, there shouldn't be any
incompatibilites.

> 4.When the 8.1 server is fully tested and deemed trouble
> free, I would like to make a new install using the 7.1 license into a
> separate network then get the 8.1 upgrade for it. That means I would
> purchase a full version license of 8.1 and an 8.1 upgrade license for
> the 7.1. Any issues?

I'd suggest to keep the 8.1 trial server and just update the license
(adsstamp) after shutting down 7.1.

--
Joachim Duerr
System Consultant (Advantage Database Server)
Sybase iAnywhere
advantagesupport[AT]ianywhere.com


Benedictum Posted on 2008-01-09 14:41:03.0Z
From: "Benedictum" <Benedictus@DominusVobis.com>
Newsgroups: Advantage.Networking
References: <4783796f@solutions.advantagedatabase.com> <47838262@solutions.advantagedatabase.com>
Subject: Re: Concurrent Server/Version
Date: Wed, 9 Jan 2008 08:41:03 -0600
Lines: 47
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3198
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: 76.16.150.72
Message-ID: <4784dbcb@solutions.advantagedatabase.com>
X-Trace: 9 Jan 2008 07:35:55 -0700, 76.16.150.72
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!76.16.150.72
Xref: solutions.advantagedatabase.com Advantage.Networking:736
Article PK: 1132155

As usual, I get an excellent response. Off I go to work on your
suggestions. --thanks

"Joachim Duerr (ADS)" <jojo.duerr@gmx.de> wrote in message
news:47838262@solutions.advantagedatabase.com...
> Benedictum wrote in <4783796f@solutions.advantagedatabase.com>:
>
>> 1. Can I install different versions in a network?
>
> yes if they're installed with a different serial number
>
>> 2. Are there any issues I need to know when I copy the tables, data
>> dics, etc. into 8.1 server?
>
> using old files with newer servers should not hurt, but vice versa
> could (e.g. when using new features, adding new triggers, ...).
> Incompatibilites are listed in the readme.txt of the new server and in
> the help file of the new server.
>
>> 3. In the client application, are there
>> any changes which I need to do (developed in Delphi with
>> TDataset7.1). Any compatibility issues? I am still using Delphi 5
>> because of other components not available to the newer Delphi
>> versions.
>
> could be, but shouldn't. There where some changes (e.g. adding support
> for NUMERIC in ADT, which can influence the result set of some SQL
> statements). But this is also listed in the readme of the client kit.
> If you stay with the old client kit, there shouldn't be any
> incompatibilites.
>
>> 4.When the 8.1 server is fully tested and deemed trouble
>> free, I would like to make a new install using the 7.1 license into a
>> separate network then get the 8.1 upgrade for it. That means I would
>> purchase a full version license of 8.1 and an 8.1 upgrade license for
>> the 7.1. Any issues?
>
> I'd suggest to keep the 8.1 trial server and just update the license
> (adsstamp) after shutting down 7.1.
>
> --
> Joachim Duerr
> System Consultant (Advantage Database Server)
> Sybase iAnywhere
> advantagesupport[AT]ianywhere.com