Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Katastrophale Performance von SA10.0.1 (Build 3629) im Zusammenspiel mit Delphi 2006-Anwendung

8 posts in iAnywhere General Discussion (German) Last posting was on 2008-02-15 10:41:27.0Z
Axel Siepmann Posted on 2008-02-11 10:40:41.0Z
From: Axel Siepmann <no_spam_axel.siepmann@web.de>
User-Agent: Thunderbird 2.0.0.9 (Windows/20071031)
MIME-Version: 1.0
Newsgroups: ianywhere.public.german.general
Subject: Katastrophale Performance von SA10.0.1 (Build 3629) im Zusammenspiel mit Delphi 2006-Anwendung
Content-Type: text/plain; charset=ISO-8859-15; format=flowed
Content-Transfer-Encoding: 8bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <47b02629@forums-1-dub>
Date: 11 Feb 2008 02:40:41 -0800
X-Trace: forums-1-dub 1202726441 10.22.241.152 (11 Feb 2008 02:40:41 -0800)
X-Original-Trace: 11 Feb 2008 02:40:41 -0800, vip152.sybase.com
Lines: 22
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.german.general:415
Article PK: 1088

Hallo zusammen,

ich stehe vor einem Problem, dass ich mir absolut nicht erklÀren kann
und bei dem ich auch nicht weiß, wo ich ansetzen soll.
Unsere unter Delphi 2006 entwickelte CRM-Anwendung legt, wenn die
Datenbank unter SA10 lÀuft, eine absolut katastrophale Performance an
den Tag. Als DB-Treiber nutzen wir NativeDB.
Ich kann mir nicht vorstellen, dass es am SA10 selber liegt aber wenn
ich mir z. B. die VorgÀnge eines Kunden in unserer Anwendungen anzeigen
lasse (ein Formular mit mehreren Registerkarten, also diverse Abfragen
auf diverse Tabellen), dauert das mit ASA9 und einer frisch gestarteten
Datenbank (also Nichts im Cache) 12 Sekunden, mit einer
1:1-konvertierten, ebenso gerade gestarteten SA10-DB 52 Sekunden(!).
Wenn ich die Abfragen direkt gegen die beiden DBs laufen lasse, ergeben
sich nur marginale Unterschiede. Wobei hier SA10 allerdings meist auch
etwas langsamer ist als ASA9.
Hat vielleicht jemand Àhnliche Erfahrungen gemacht oder eine Idee, woran
das liegen könnte? So ist SA10 fÌr uns natÌrlich Ìberhaupt nicht nutzbar.

Schönen Gruß,

Axel Siepmann


Axel Siepmann Posted on 2008-02-12 11:03:01.0Z
From: Axel Siepmann <no_spam_axel.siepmann@web.de>
User-Agent: Thunderbird 2.0.0.9 (Windows/20071031)
MIME-Version: 1.0
Newsgroups: ianywhere.public.german.general
Subject: Re: Katastrophale Performance von SA10.0.1 (Build 3629) im Zusammenspielmit Delphi 2006-Anwendung
References: <47b02629@forums-1-dub>
In-Reply-To: <47b02629@forums-1-dub>
Content-Type: text/plain; charset=ISO-8859-15; format=flowed
Content-Transfer-Encoding: 8bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <47b17ce5@forums-1-dub>
Date: 12 Feb 2008 03:03:01 -0800
X-Trace: forums-1-dub 1202814181 10.22.241.152 (12 Feb 2008 03:03:01 -0800)
X-Original-Trace: 12 Feb 2008 03:03:01 -0800, vip152.sybase.com
Lines: 27
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.german.general:417
Article PK: 1090

Das Problem tritt allerdings anscheinend nur auf meinem Rechner auf und
nur, wenn Anwendung und Datenbank auf meinem Rechner laufen. LÀuft die
DB auf einem anderen Rechner, tritt das Problem nicht auf....

Axel Siepmann schrieb:

> Hallo zusammen,
>
> ich stehe vor einem Problem, dass ich mir absolut nicht erklÀren kann
> und bei dem ich auch nicht weiß, wo ich ansetzen soll.
> Unsere unter Delphi 2006 entwickelte CRM-Anwendung legt, wenn die
> Datenbank unter SA10 lÀuft, eine absolut katastrophale Performance an
> den Tag. Als DB-Treiber nutzen wir NativeDB.
> Ich kann mir nicht vorstellen, dass es am SA10 selber liegt aber wenn
> ich mir z. B. die VorgÀnge eines Kunden in unserer Anwendungen anzeigen
> lasse (ein Formular mit mehreren Registerkarten, also diverse Abfragen
> auf diverse Tabellen), dauert das mit ASA9 und einer frisch gestarteten
> Datenbank (also Nichts im Cache) 12 Sekunden, mit einer
> 1:1-konvertierten, ebenso gerade gestarteten SA10-DB 52 Sekunden(!).
> Wenn ich die Abfragen direkt gegen die beiden DBs laufen lasse, ergeben
> sich nur marginale Unterschiede. Wobei hier SA10 allerdings meist auch
> etwas langsamer ist als ASA9.
> Hat vielleicht jemand Àhnliche Erfahrungen gemacht oder eine Idee, woran
> das liegen könnte? So ist SA10 fÌr uns natÌrlich Ìberhaupt nicht nutzbar.
>
> Schönen Gruß,
>
> Axel Siepmann


"Frank Ploessel" <fpl... Posted on 2008-02-12 13:00:45.0Z
Subject: Re: Katastrophale Performance von SA10.0.1 (Build 3629) im Zusammenspielmit Delphi 2006-Anwendung
From: "Frank Ploessel" <fpl...@d_e.i_m_s_h_e_a_l_t_h.c_o_m>
Content-Type: text/plain; format=flowed; delsp=yes; charset=iso-8859-15
MIME-Version: 1.0
Newsgroups: ianywhere.public.german.general
References: <47b02629@forums-1-dub> <47b17ce5@forums-1-dub>
Content-Transfer-Encoding: 8bit
Message-ID: <op.t6ew3i0lj0bybf@bonw00164.internal.imsglobal.com>
User-Agent: Opera Mail/9.21 (Win32)
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Date: 12 Feb 2008 05:00:45 -0800
X-Trace: forums-1-dub 1202821245 10.22.241.152 (12 Feb 2008 05:00:45 -0800)
X-Original-Trace: 12 Feb 2008 05:00:45 -0800, vip152.sybase.com
Lines: 40
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.german.general:418
Article PK: 1092

Hallo Axel,

kann es sein, dass die Datenbankdatei auf der Platte fragmentiert ist? Das
Tool contig.exe von Sysinternals (inzwischen Microsoft) ist viel
effizienter als das Windows-Defragmentierungstool.
Herunterladen kann man es bei
http://technet.microsoft.com/en-us/sysinternals/bb897428.aspx.

Frank


On Tue, 12 Feb 2008 12:03:01 +0100, Axel Siepmann

<no_spam_axel.siepmann@web.de> wrote:

> Das Problem tritt allerdings anscheinend nur auf meinem Rechner auf und
> nur, wenn Anwendung und Datenbank auf meinem Rechner laufen. LÀuft die
> DB auf einem anderen Rechner, tritt das Problem nicht auf....
>
> Axel Siepmann schrieb:
>> Hallo zusammen,
>> ich stehe vor einem Problem, dass ich mir absolut nicht erklÀren kann
>> und bei dem ich auch nicht weiß, wo ich ansetzen soll.
>> Unsere unter Delphi 2006 entwickelte CRM-Anwendung legt, wenn die
>> Datenbank unter SA10 lÀuft, eine absolut katastrophale Performance an
>> den Tag. Als DB-Treiber nutzen wir NativeDB.
>> Ich kann mir nicht vorstellen, dass es am SA10 selber liegt aber wenn
>> ich mir z. B. die VorgÀnge eines Kunden in unserer Anwendungen anzeigen
>> lasse (ein Formular mit mehreren Registerkarten, also diverse Abfragen
>> auf diverse Tabellen), dauert das mit ASA9 und einer frisch gestarteten
>> Datenbank (also Nichts im Cache) 12 Sekunden, mit einer
>> 1:1-konvertierten, ebenso gerade gestarteten SA10-DB 52 Sekunden(!).
>> Wenn ich die Abfragen direkt gegen die beiden DBs laufen lasse, ergeben
>> sich nur marginale Unterschiede. Wobei hier SA10 allerdings meist auch
>> etwas langsamer ist als ASA9.
>> Hat vielleicht jemand Àhnliche Erfahrungen gemacht oder eine Idee,
>> woran das liegen könnte? So ist SA10 fÌr uns natÌrlich Ìberhaupt nicht
>> nutzbar.
>> Schönen Gruß,
>> Axel Siepmann


Axel Siepmann Posted on 2008-02-12 16:19:33.0Z
From: Axel Siepmann <no_spam_axel.siepmann@web.de>
User-Agent: Thunderbird 2.0.0.9 (Windows/20071031)
MIME-Version: 1.0
Newsgroups: ianywhere.public.german.general
Subject: Re: Katastrophale Performance von SA10.0.1 (Build 3629) im Zusammenspielmit Delphi 2006-Anwendung
References: <47b02629@forums-1-dub> <47b17ce5@forums-1-dub> <op.t6ew3i0lj0bybf@bonw00164.internal.imsglobal.com>
In-Reply-To: <op.t6ew3i0lj0bybf@bonw00164.internal.imsglobal.com>
Content-Type: text/plain; charset=ISO-8859-15; format=flowed
Content-Transfer-Encoding: 8bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <47b1c715@forums-1-dub>
Date: 12 Feb 2008 08:19:33 -0800
X-Trace: forums-1-dub 1202833173 10.22.241.152 (12 Feb 2008 08:19:33 -0800)
X-Original-Trace: 12 Feb 2008 08:19:33 -0800, vip152.sybase.com
Lines: 57
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.german.general:419
Article PK: 1091

Hallo Frank,

die Platte ist mit Sicherheit fragmentiert. Allerdings liegen ja beide
DBs - 9er wie 10er - auf derselben Platte. Daher dÃŒrfte das imho keine
große Rolle spielen. Mit der 9er lÀuft die Anwendung ja auch auf meinem
Rechner ganz normal. Ich könnte damit leben, wenn ich wÌsste, dass es
nur bei meiner Maschine auftritt aber beim Kunden können wir uns das
natÃŒrlich nicht leisten.
Aber 'trotzdem' danke fÌr den Tip! Das kannte ich noch nicht und hört
sich gut an!

Gruß,

Axel


Frank Ploessel schrieb:

> Hallo Axel,
>
> kann es sein, dass die Datenbankdatei auf der Platte fragmentiert ist?
> Das Tool contig.exe von Sysinternals (inzwischen Microsoft) ist viel
> effizienter als das Windows-Defragmentierungstool.
> Herunterladen kann man es bei
> http://technet.microsoft.com/en-us/sysinternals/bb897428.aspx.
>
> Frank
>
>
> On Tue, 12 Feb 2008 12:03:01 +0100, Axel Siepmann
> <no_spam_axel.siepmann@web.de> wrote:
>
>> Das Problem tritt allerdings anscheinend nur auf meinem Rechner auf
>> und nur, wenn Anwendung und Datenbank auf meinem Rechner laufen. LÀuft
>> die DB auf einem anderen Rechner, tritt das Problem nicht auf....
>>
>> Axel Siepmann schrieb:
>>> Hallo zusammen,
>>> ich stehe vor einem Problem, dass ich mir absolut nicht erklÀren
>>> kann und bei dem ich auch nicht weiß, wo ich ansetzen soll.
>>> Unsere unter Delphi 2006 entwickelte CRM-Anwendung legt, wenn die
>>> Datenbank unter SA10 lÀuft, eine absolut katastrophale Performance an
>>> den Tag. Als DB-Treiber nutzen wir NativeDB.
>>> Ich kann mir nicht vorstellen, dass es am SA10 selber liegt aber wenn
>>> ich mir z. B. die VorgÀnge eines Kunden in unserer Anwendungen
>>> anzeigen lasse (ein Formular mit mehreren Registerkarten, also
>>> diverse Abfragen auf diverse Tabellen), dauert das mit ASA9 und einer
>>> frisch gestarteten Datenbank (also Nichts im Cache) 12 Sekunden, mit
>>> einer 1:1-konvertierten, ebenso gerade gestarteten SA10-DB 52
>>> Sekunden(!). Wenn ich die Abfragen direkt gegen die beiden DBs laufen
>>> lasse, ergeben sich nur marginale Unterschiede. Wobei hier SA10
>>> allerdings meist auch etwas langsamer ist als ASA9.
>>> Hat vielleicht jemand Àhnliche Erfahrungen gemacht oder eine Idee,
>>> woran das liegen könnte? So ist SA10 fÌr uns natÌrlich Ìberhaupt
>>> nicht nutzbar.
>>> Schönen Gruß,
>>> Axel Siepmann
>


"Volker Barth" <No_VBarth Posted on 2008-02-13 08:46:23.0Z
From: "Volker Barth" <No_VBarth@Spam_GLOBAL-FINANZ.de>
Newsgroups: ianywhere.public.german.general
References: <47b02629@forums-1-dub> <47b17ce5@forums-1-dub> <op.t6ew3i0lj0bybf@bonw00164.internal.imsglobal.com> <47b1c715@forums-1-dub>
Subject: Re: Katastrophale Performance von SA10.0.1 (Build 3629) im Zusammenspielmit Delphi 2006-Anwendung
Lines: 72
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1914
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1914
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <47b2ae5f$1@forums-1-dub>
Date: 13 Feb 2008 00:46:23 -0800
X-Trace: forums-1-dub 1202892383 10.22.241.152 (13 Feb 2008 00:46:23 -0800)
X-Original-Trace: 13 Feb 2008 00:46:23 -0800, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.german.general:420
Article PK: 1093

Axel,

meiner Erfahrung nach können ASA-Datenbanken auf derselben Festplatte
durchaus sehr unterschiedlich stark fragmentiert sein, vor allem falls
Datenbanken oft kopiert werden, was auf einem Entwickler-Rechner sicher oft
vorkommt.
Die guten Erfahrungen mit Contig kann ich bestätigen.

Gruß
Volker

"Axel Siepmann" <no_spam_axel.siepmann@web.de> schrieb im Newsbeitrag
news:47b1c715@forums-1-dub...

> Hallo Frank,
>
> die Platte ist mit Sicherheit fragmentiert. Allerdings liegen ja beide
> DBs - 9er wie 10er - auf derselben Platte. Daher dürfte das imho keine
> große Rolle spielen. Mit der 9er läuft die Anwendung ja auch auf meinem
> Rechner ganz normal. Ich könnte damit leben, wenn ich wüsste, dass es
> nur bei meiner Maschine auftritt aber beim Kunden können wir uns das
> natürlich nicht leisten.
> Aber 'trotzdem' danke für den Tip! Das kannte ich noch nicht und hört
> sich gut an!
>
> Gruß,
>
> Axel
>
>
> Frank Ploessel schrieb:
> > Hallo Axel,
> >
> > kann es sein, dass die Datenbankdatei auf der Platte fragmentiert ist?
> > Das Tool contig.exe von Sysinternals (inzwischen Microsoft) ist viel
> > effizienter als das Windows-Defragmentierungstool.
> > Herunterladen kann man es bei
> > http://technet.microsoft.com/en-us/sysinternals/bb897428.aspx.
> >
> > Frank
> >
> >
> > On Tue, 12 Feb 2008 12:03:01 +0100, Axel Siepmann
> > <no_spam_axel.siepmann@web.de> wrote:
> >
> >> Das Problem tritt allerdings anscheinend nur auf meinem Rechner auf
> >> und nur, wenn Anwendung und Datenbank auf meinem Rechner laufen. Läuft
> >> die DB auf einem anderen Rechner, tritt das Problem nicht auf....
> >>
> >> Axel Siepmann schrieb:
> >>> Hallo zusammen,
> >>> ich stehe vor einem Problem, dass ich mir absolut nicht erklären
> >>> kann und bei dem ich auch nicht weiß, wo ich ansetzen soll.
> >>> Unsere unter Delphi 2006 entwickelte CRM-Anwendung legt, wenn die
> >>> Datenbank unter SA10 läuft, eine absolut katastrophale Performance an
> >>> den Tag. Als DB-Treiber nutzen wir NativeDB.
> >>> Ich kann mir nicht vorstellen, dass es am SA10 selber liegt aber wenn
> >>> ich mir z. B. die Vorgänge eines Kunden in unserer Anwendungen
> >>> anzeigen lasse (ein Formular mit mehreren Registerkarten, also
> >>> diverse Abfragen auf diverse Tabellen), dauert das mit ASA9 und einer
> >>> frisch gestarteten Datenbank (also Nichts im Cache) 12 Sekunden, mit
> >>> einer 1:1-konvertierten, ebenso gerade gestarteten SA10-DB 52
> >>> Sekunden(!). Wenn ich die Abfragen direkt gegen die beiden DBs laufen
> >>> lasse, ergeben sich nur marginale Unterschiede. Wobei hier SA10
> >>> allerdings meist auch etwas langsamer ist als ASA9.
> >>> Hat vielleicht jemand ähnliche Erfahrungen gemacht oder eine Idee,
> >>> woran das liegen könnte? So ist SA10 für uns natürlich überhaupt
> >>> nicht nutzbar.
> >>> Schönen Gruß,
> >>> Axel Siepmann
> >


Axel Siepmann Posted on 2008-02-13 11:34:47.0Z
From: Axel Siepmann <no_spam_axel.siepmann@web.de>
User-Agent: Thunderbird 2.0.0.9 (Windows/20071031)
MIME-Version: 1.0
Newsgroups: ianywhere.public.german.general
Subject: Re: Katastrophale Performance von SA10.0.1 (Build 3629) im Zusammenspielmit Delphi 2006-Anwendung
References: <47b02629@forums-1-dub> <47b17ce5@forums-1-dub> <op.t6ew3i0lj0bybf@bonw00164.internal.imsglobal.com> <47b1c715@forums-1-dub> <47b2ae5f$1@forums-1-dub>
In-Reply-To: <47b2ae5f$1@forums-1-dub>
Content-Type: text/plain; charset=ISO-8859-15; format=flowed
Content-Transfer-Encoding: 8bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <47b2d5d7$1@forums-1-dub>
Date: 13 Feb 2008 03:34:47 -0800
X-Trace: forums-1-dub 1202902487 10.22.241.152 (13 Feb 2008 03:34:47 -0800)
X-Original-Trace: 13 Feb 2008 03:34:47 -0800, vip152.sybase.com
Lines: 83
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.german.general:421
Article PK: 1095

Hallo Volker,

ich habe die contig.exe jetzt mal gegen die Datenbankdatei laufen lassen
und die Datei besteht jetzt auch nur noch aus einem Fragment statt
vorher 120. Der Effekt ist jedoch gleich null. Da muss es noch irgendein
anderes Problem geben...

Gruß,
Axel


Volker Barth schrieb:

> Axel,
>
> meiner Erfahrung nach können ASA-Datenbanken auf derselben Festplatte
> durchaus sehr unterschiedlich stark fragmentiert sein, vor allem falls
> Datenbanken oft kopiert werden, was auf einem Entwickler-Rechner sicher oft
> vorkommt.
> Die guten Erfahrungen mit Contig kann ich bestÀtigen.
>
> Gruß
> Volker
>
> "Axel Siepmann" <no_spam_axel.siepmann@web.de> schrieb im Newsbeitrag
> news:47b1c715@forums-1-dub...
>> Hallo Frank,
>>
>> die Platte ist mit Sicherheit fragmentiert. Allerdings liegen ja beide
>> DBs - 9er wie 10er - auf derselben Platte. Daher dÃŒrfte das imho keine
>> große Rolle spielen. Mit der 9er lÀuft die Anwendung ja auch auf meinem
>> Rechner ganz normal. Ich könnte damit leben, wenn ich wÌsste, dass es
>> nur bei meiner Maschine auftritt aber beim Kunden können wir uns das
>> natÃŒrlich nicht leisten.
>> Aber 'trotzdem' danke fÌr den Tip! Das kannte ich noch nicht und hört
>> sich gut an!
>>
>> Gruß,
>>
>> Axel
>>
>>
>> Frank Ploessel schrieb:
>>> Hallo Axel,
>>>
>>> kann es sein, dass die Datenbankdatei auf der Platte fragmentiert ist?
>>> Das Tool contig.exe von Sysinternals (inzwischen Microsoft) ist viel
>>> effizienter als das Windows-Defragmentierungstool.
>>> Herunterladen kann man es bei
>>> http://technet.microsoft.com/en-us/sysinternals/bb897428.aspx.
>>>
>>> Frank
>>>
>>>
>>> On Tue, 12 Feb 2008 12:03:01 +0100, Axel Siepmann
>>> <no_spam_axel.siepmann@web.de> wrote:
>>>
>>>> Das Problem tritt allerdings anscheinend nur auf meinem Rechner auf
>>>> und nur, wenn Anwendung und Datenbank auf meinem Rechner laufen. LÀuft
>>>> die DB auf einem anderen Rechner, tritt das Problem nicht auf....
>>>>
>>>> Axel Siepmann schrieb:
>>>>> Hallo zusammen,
>>>>> ich stehe vor einem Problem, dass ich mir absolut nicht erklÀren
>>>>> kann und bei dem ich auch nicht weiß, wo ich ansetzen soll.
>>>>> Unsere unter Delphi 2006 entwickelte CRM-Anwendung legt, wenn die
>>>>> Datenbank unter SA10 lÀuft, eine absolut katastrophale Performance an
>>>>> den Tag. Als DB-Treiber nutzen wir NativeDB.
>>>>> Ich kann mir nicht vorstellen, dass es am SA10 selber liegt aber wenn
>>>>> ich mir z. B. die VorgÀnge eines Kunden in unserer Anwendungen
>>>>> anzeigen lasse (ein Formular mit mehreren Registerkarten, also
>>>>> diverse Abfragen auf diverse Tabellen), dauert das mit ASA9 und einer
>>>>> frisch gestarteten Datenbank (also Nichts im Cache) 12 Sekunden, mit
>>>>> einer 1:1-konvertierten, ebenso gerade gestarteten SA10-DB 52
>>>>> Sekunden(!). Wenn ich die Abfragen direkt gegen die beiden DBs laufen
>>>>> lasse, ergeben sich nur marginale Unterschiede. Wobei hier SA10
>>>>> allerdings meist auch etwas langsamer ist als ASA9.
>>>>> Hat vielleicht jemand Àhnliche Erfahrungen gemacht oder eine Idee,
>>>>> woran das liegen könnte? So ist SA10 fÌr uns natÌrlich Ìberhaupt
>>>>> nicht nutzbar.
>>>>> Schönen Gruß,
>>>>> Axel Siepmann
>
>


"Frank Ploessel" <fpl... Posted on 2008-02-13 17:35:54.0Z
Subject: Re: Katastrophale Performance von SA10.0.1 (Build 3629) im Zusammenspielmit Delphi 2006-Anwendung
From: "Frank Ploessel" <fpl...@d_e.i_m_s_h_e_a_l_t_h.c_o_m>
Content-Type: text/plain; format=flowed; delsp=yes; charset=iso-8859-15
MIME-Version: 1.0
Newsgroups: ianywhere.public.german.general
References: <47b02629@forums-1-dub> <47b17ce5@forums-1-dub> <op.t6ew3i0lj0bybf@bonw00164.internal.imsglobal.com> <47b1c715@forums-1-dub> <47b2ae5f$1@forums-1-dub> <47b2d5d7$1@forums-1-dub>
Content-Transfer-Encoding: 8bit
Message-ID: <op.t6g4h2vrj0bybf@bonw00164.internal.imsglobal.com>
User-Agent: Opera Mail/9.21 (Win32)
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Date: 13 Feb 2008 09:35:54 -0800
X-Trace: forums-1-dub 1202924154 10.22.241.152 (13 Feb 2008 09:35:54 -0800)
X-Original-Trace: 13 Feb 2008 09:35:54 -0800, vip152.sybase.com
Lines: 95
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.german.general:422
Article PK: 1094

Hallo Axel,

Hat die DB genÃŒgend Cache, ist die Pagessize aller gleichzeitig laufenden
Datenbanken in der Engine identisch?
Vielleicht zeigt auch der Startbildschirm der eEngine irgendeinen Hinweis.

On Wed, 13 Feb 2008 12:34:47 +0100, Axel Siepmann

<no_spam_axel.siepmann@web.de> wrote:

> Hallo Volker,
>
> ich habe die contig.exe jetzt mal gegen die Datenbankdatei laufen lassen
> und die Datei besteht jetzt auch nur noch aus einem Fragment statt
> vorher 120. Der Effekt ist jedoch gleich null. Da muss es noch irgendein
> anderes Problem geben...
>
> Gruß,
> Axel
>
>
> Volker Barth schrieb:
>> Axel,
>> meiner Erfahrung nach können ASA-Datenbanken auf derselben Festplatte
>> durchaus sehr unterschiedlich stark fragmentiert sein, vor allem falls
>> Datenbanken oft kopiert werden, was auf einem Entwickler-Rechner sicher
>> oft
>> vorkommt.
>> Die guten Erfahrungen mit Contig kann ich bestÀtigen.
>> Gruß
>> Volker
>> "Axel Siepmann" <no_spam_axel.siepmann@web.de> schrieb im Newsbeitrag
>> news:47b1c715@forums-1-dub...
>>> Hallo Frank,
>>>
>>> die Platte ist mit Sicherheit fragmentiert. Allerdings liegen ja beide
>>> DBs - 9er wie 10er - auf derselben Platte. Daher dÃŒrfte das imho keine
>>> große Rolle spielen. Mit der 9er lÀuft die Anwendung ja auch auf meinem
>>> Rechner ganz normal. Ich könnte damit leben, wenn ich wÌsste, dass es
>>> nur bei meiner Maschine auftritt aber beim Kunden können wir uns das
>>> natÃŒrlich nicht leisten.
>>> Aber 'trotzdem' danke fÌr den Tip! Das kannte ich noch nicht und hört
>>> sich gut an!
>>>
>>> Gruß,
>>>
>>> Axel
>>>
>>>
>>> Frank Ploessel schrieb:
>>>> Hallo Axel,
>>>>
>>>> kann es sein, dass die Datenbankdatei auf der Platte fragmentiert ist?
>>>> Das Tool contig.exe von Sysinternals (inzwischen Microsoft) ist viel
>>>> effizienter als das Windows-Defragmentierungstool.
>>>> Herunterladen kann man es bei
>>>> http://technet.microsoft.com/en-us/sysinternals/bb897428.aspx.
>>>>
>>>> Frank
>>>>
>>>>
>>>> On Tue, 12 Feb 2008 12:03:01 +0100, Axel Siepmann
>>>> <no_spam_axel.siepmann@web.de> wrote:
>>>>
>>>>> Das Problem tritt allerdings anscheinend nur auf meinem Rechner auf
>>>>> und nur, wenn Anwendung und Datenbank auf meinem Rechner laufen.
>>>>> LÀuft
>>>>> die DB auf einem anderen Rechner, tritt das Problem nicht auf....
>>>>>
>>>>> Axel Siepmann schrieb:
>>>>>> Hallo zusammen,
>>>>>> ich stehe vor einem Problem, dass ich mir absolut nicht erklÀren
>>>>>> kann und bei dem ich auch nicht weiß, wo ich ansetzen soll.
>>>>>> Unsere unter Delphi 2006 entwickelte CRM-Anwendung legt, wenn die
>>>>>> Datenbank unter SA10 lÀuft, eine absolut katastrophale Performance
>>>>>> an
>>>>>> den Tag. Als DB-Treiber nutzen wir NativeDB.
>>>>>> Ich kann mir nicht vorstellen, dass es am SA10 selber liegt aber
>>>>>> wenn
>>>>>> ich mir z. B. die VorgÀnge eines Kunden in unserer Anwendungen
>>>>>> anzeigen lasse (ein Formular mit mehreren Registerkarten, also
>>>>>> diverse Abfragen auf diverse Tabellen), dauert das mit ASA9 und
>>>>>> einer
>>>>>> frisch gestarteten Datenbank (also Nichts im Cache) 12 Sekunden, mit
>>>>>> einer 1:1-konvertierten, ebenso gerade gestarteten SA10-DB 52
>>>>>> Sekunden(!). Wenn ich die Abfragen direkt gegen die beiden DBs
>>>>>> laufen
>>>>>> lasse, ergeben sich nur marginale Unterschiede. Wobei hier SA10
>>>>>> allerdings meist auch etwas langsamer ist als ASA9.
>>>>>> Hat vielleicht jemand Àhnliche Erfahrungen gemacht oder eine Idee,
>>>>>> woran das liegen könnte? So ist SA10 fÌr uns natÌrlich Ìberhaupt
>>>>>> nicht nutzbar.
>>>>>> Schönen Gruß,
>>>>>> Axel Siepmann
>>


Axel Siepmann Posted on 2008-02-15 10:41:27.0Z
From: "Axel Siepmann" <no_spam_axel.siepmann@web.de>
Newsgroups: ianywhere.public.german.general
References: <47b02629@forums-1-dub> <47b17ce5@forums-1-dub> <op.t6ew3i0lj0bybf@bonw00164.internal.imsglobal.com> <47b1c715@forums-1-dub> <47b2ae5f$1@forums-1-dub> <47b2d5d7$1@forums-1-dub> <op.t6g4h2vrj0bybf@bonw00164.internal.imsglobal.com>
Subject: Re: Katastrophale Performance von SA10.0.1 (Build 3629) im Zusammenspielmit Delphi 2006-Anwendung
Lines: 112
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-RFC2646: Format=Flowed; Response
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3198
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <47b56c57$1@forums-1-dub>
Date: 15 Feb 2008 02:41:27 -0800
X-Trace: forums-1-dub 1203072087 10.22.241.152 (15 Feb 2008 02:41:27 -0800)
X-Original-Trace: 15 Feb 2008 02:41:27 -0800, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.german.general:424
Article PK: 1097

Hallo Frank,

ich lasse die beiden DBs zum Vergleich allein jeweils in einer eigenen
Engine laufen, eine besondere Meldung erscheint nicht.
Habe jetzt sogar (aus anderen Gründen) meinen Rechner komplett platt gemacht
und neu installiert aber das Verhalten ist immer noch dasselbe. Keinen
blassen Schmimmer, was das sein kann.

Gruß,
Axel



"Frank Ploessel" <fpl...@d_e.i_m_s_h_e_a_l_t_h.c_o_m> schrieb im Newsbeitrag
news:op.t6g4h2vrj0bybf@bonw00164.internal.imsglobal.com...

> Hallo Axel,
>
> Hat die DB genügend Cache, ist die Pagessize aller gleichzeitig laufenden
> Datenbanken in der Engine identisch?
> Vielleicht zeigt auch der Startbildschirm der eEngine irgendeinen Hinweis.
>
> On Wed, 13 Feb 2008 12:34:47 +0100, Axel Siepmann
> <no_spam_axel.siepmann@web.de> wrote:
>
>> Hallo Volker,
>>
>> ich habe die contig.exe jetzt mal gegen die Datenbankdatei laufen lassen
>> und die Datei besteht jetzt auch nur noch aus einem Fragment statt
>> vorher 120. Der Effekt ist jedoch gleich null. Da muss es noch irgendein
>> anderes Problem geben...
>>
>> Gruß,
>> Axel
>>
>>
>> Volker Barth schrieb:
>>> Axel,
>>> meiner Erfahrung nach können ASA-Datenbanken auf derselben Festplatte
>>> durchaus sehr unterschiedlich stark fragmentiert sein, vor allem falls
>>> Datenbanken oft kopiert werden, was auf einem Entwickler-Rechner sicher
>>> oft
>>> vorkommt.
>>> Die guten Erfahrungen mit Contig kann ich bestätigen.
>>> Gruß
>>> Volker
>>> "Axel Siepmann" <no_spam_axel.siepmann@web.de> schrieb im Newsbeitrag
>>> news:47b1c715@forums-1-dub...
>>>> Hallo Frank,
>>>>
>>>> die Platte ist mit Sicherheit fragmentiert. Allerdings liegen ja beide
>>>> DBs - 9er wie 10er - auf derselben Platte. Daher dürfte das imho keine
>>>> große Rolle spielen. Mit der 9er läuft die Anwendung ja auch auf meinem
>>>> Rechner ganz normal. Ich könnte damit leben, wenn ich wüsste, dass es
>>>> nur bei meiner Maschine auftritt aber beim Kunden können wir uns das
>>>> natürlich nicht leisten.
>>>> Aber 'trotzdem' danke für den Tip! Das kannte ich noch nicht und hört
>>>> sich gut an!
>>>>
>>>> Gruß,
>>>>
>>>> Axel
>>>>
>>>>
>>>> Frank Ploessel schrieb:
>>>>> Hallo Axel,
>>>>>
>>>>> kann es sein, dass die Datenbankdatei auf der Platte fragmentiert ist?
>>>>> Das Tool contig.exe von Sysinternals (inzwischen Microsoft) ist viel
>>>>> effizienter als das Windows-Defragmentierungstool.
>>>>> Herunterladen kann man es bei
>>>>> http://technet.microsoft.com/en-us/sysinternals/bb897428.aspx.
>>>>>
>>>>> Frank
>>>>>
>>>>>
>>>>> On Tue, 12 Feb 2008 12:03:01 +0100, Axel Siepmann
>>>>> <no_spam_axel.siepmann@web.de> wrote:
>>>>>
>>>>>> Das Problem tritt allerdings anscheinend nur auf meinem Rechner auf
>>>>>> und nur, wenn Anwendung und Datenbank auf meinem Rechner laufen.
>>>>>> Läuft
>>>>>> die DB auf einem anderen Rechner, tritt das Problem nicht auf....
>>>>>>
>>>>>> Axel Siepmann schrieb:
>>>>>>> Hallo zusammen,
>>>>>>> ich stehe vor einem Problem, dass ich mir absolut nicht erklären
>>>>>>> kann und bei dem ich auch nicht weiß, wo ich ansetzen soll.
>>>>>>> Unsere unter Delphi 2006 entwickelte CRM-Anwendung legt, wenn die
>>>>>>> Datenbank unter SA10 läuft, eine absolut katastrophale Performance
>>>>>>> an
>>>>>>> den Tag. Als DB-Treiber nutzen wir NativeDB.
>>>>>>> Ich kann mir nicht vorstellen, dass es am SA10 selber liegt aber
>>>>>>> wenn
>>>>>>> ich mir z. B. die Vorgänge eines Kunden in unserer Anwendungen
>>>>>>> anzeigen lasse (ein Formular mit mehreren Registerkarten, also
>>>>>>> diverse Abfragen auf diverse Tabellen), dauert das mit ASA9 und
>>>>>>> einer
>>>>>>> frisch gestarteten Datenbank (also Nichts im Cache) 12 Sekunden, mit
>>>>>>> einer 1:1-konvertierten, ebenso gerade gestarteten SA10-DB 52
>>>>>>> Sekunden(!). Wenn ich die Abfragen direkt gegen die beiden DBs
>>>>>>> laufen
>>>>>>> lasse, ergeben sich nur marginale Unterschiede. Wobei hier SA10
>>>>>>> allerdings meist auch etwas langsamer ist als ASA9.
>>>>>>> Hat vielleicht jemand ähnliche Erfahrungen gemacht oder eine Idee,
>>>>>>> woran das liegen könnte? So ist SA10 für uns natürlich überhaupt
>>>>>>> nicht nutzbar.
>>>>>>> Schönen Gruß,
>>>>>>> Axel Siepmann
>>>
>