Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Error Executing AEP Stored Procedure

6 posts in AEP Last posting was on 2008-04-15 22:56:55.0Z
David Looney Posted on 2008-04-14 20:03:15.0Z
From: "David Looney" <davidl@autostarsolutions.com>
Newsgroups: Advantage.AEP
Subject: Error Executing AEP Stored Procedure
Date: Mon, 14 Apr 2008 15:03:15 -0500
Lines: 16
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-RFC2646: Format=Flowed; Original
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3198
NNTP-Posting-Host: 67.152.110.130
Message-ID: <4803b730@solutions.advantagedatabase.com>
X-Trace: 14 Apr 2008 13:57:36 -0700, 67.152.110.130
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!67.152.110.130
Xref: solutions.advantagedatabase.com Advantage.AEP:621
Article PK: 1103904

poQuery: Error 7200: AQE Error: State = HY000; NativeError = 5154;
[iAnywhere Solutions][Advantage SQL][ASA] Error 5154: Execution
of the stored procedure failed. The stored procedure named
"as_GetPaymentInfo" requires the AEP named
"C:\testdata\w_autocity_03_03_2008_new_delq\AsData1\AdsProcs.aep". The AEP
failed to load with an error code 193. %1 is not a valid
Win32 application.

I keep getting the above error and am not sure what it is telling me. I
have set the AEP file in the create procedure dialog and also set the
function name. The tables that are being operated on are attached to the
DD. Any help would be greatly appreciated.

David


Lance Schmidt Posted on 2008-04-14 20:19:43.0Z
From: "Lance Schmidt" <LanceSc@ExtendSys.com>
Newsgroups: Advantage.AEP
References: <4803b730@solutions.advantagedatabase.com>
Subject: Re: Error Executing AEP Stored Procedure
Date: Mon, 14 Apr 2008 14:19:43 -0600
Lines: 31
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-RFC2646: Format=Flowed; Response
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3198
NNTP-Posting-Host: 10.24.38.197
Message-ID: <4803bb08@solutions.advantagedatabase.com>
X-Trace: 14 Apr 2008 14:14:00 -0700, 10.24.38.197
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!10.24.38.197
Xref: solutions.advantagedatabase.com Advantage.AEP:622
Article PK: 1103900

Hi David,

What are you using to the build the AEP. AEPs are simply DLLs and when
Advantage ask the OS to load your AEP the OS doesn't think it is a valid
DLL. Can you load the AEP using local server from inside your debugger?

Best Regards,

Lance Schmidt
Advantage R&D

"David Looney" <davidl@autostarsolutions.com> wrote in message
news:4803b730@solutions.advantagedatabase.com...
> poQuery: Error 7200: AQE Error: State = HY000; NativeError = 5154;
> [iAnywhere Solutions][Advantage SQL][ASA] Error 5154: Execution
> of the stored procedure failed. The stored procedure named
> "as_GetPaymentInfo" requires the AEP named
> "C:\testdata\w_autocity_03_03_2008_new_delq\AsData1\AdsProcs.aep". The
> AEP failed to load with an error code 193. %1 is not a valid
> Win32 application.
>
> I keep getting the above error and am not sure what it is telling me. I
> have set the AEP file in the create procedure dialog and also set the
> function name. The tables that are being operated on are attached to the
> DD. Any help would be greatly appreciated.
>
> David
>


David Looney Posted on 2008-04-14 20:47:04.0Z
From: "David Looney" <davidl@autostarsolutions.com>
Newsgroups: Advantage.AEP
References: <4803b730@solutions.advantagedatabase.com> <4803bb08@solutions.advantagedatabase.com>
Subject: Re: Error Executing AEP Stored Procedure
Date: Mon, 14 Apr 2008 15:47:04 -0500
Lines: 40
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-RFC2646: Format=Flowed; Response
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3198
NNTP-Posting-Host: 67.152.110.130
Message-ID: <4803c175@solutions.advantagedatabase.com>
X-Trace: 14 Apr 2008 14:41:25 -0700, 67.152.110.130
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!67.152.110.130
Xref: solutions.advantagedatabase.com Advantage.AEP:623
Article PK: 1103903

I'm using Delphi v5 Pro to create the AEP. I have not tried loading in the
debugger, not quite sure how to go about doing that?

David

"Lance Schmidt" <LanceSc@ExtendSys.com> wrote in message
news:4803bb08@solutions.advantagedatabase.com...
> Hi David,
>
> What are you using to the build the AEP. AEPs are simply DLLs and when
> Advantage ask the OS to load your AEP the OS doesn't think it is a valid
> DLL. Can you load the AEP using local server from inside your debugger?
>
> Best Regards,
>
> Lance Schmidt
> Advantage R&D
>
>
> "David Looney" <davidl@autostarsolutions.com> wrote in message
> news:4803b730@solutions.advantagedatabase.com...
>> poQuery: Error 7200: AQE Error: State = HY000; NativeError = 5154;
>> [iAnywhere Solutions][Advantage SQL][ASA] Error 5154: Execution
>> of the stored procedure failed. The stored procedure named
>> "as_GetPaymentInfo" requires the AEP named
>> "C:\testdata\w_autocity_03_03_2008_new_delq\AsData1\AdsProcs.aep". The
>> AEP failed to load with an error code 193. %1 is not a valid
>> Win32 application.
>>
>> I keep getting the above error and am not sure what it is telling me. I
>> have set the AEP file in the create procedure dialog and also set the
>> function name. The tables that are being operated on are attached to the
>> DD. Any help would be greatly appreciated.
>>
>> David
>>
>
>


Lance Schmidt Posted on 2008-04-15 16:19:06.0Z
From: "Lance Schmidt" <LanceSc@ExtendSys.com>
Newsgroups: Advantage.AEP
References: <4803b730@solutions.advantagedatabase.com> <4803bb08@solutions.advantagedatabase.com> <4803c175@solutions.advantagedatabase.com>
Subject: Re: Error Executing AEP Stored Procedure
Date: Tue, 15 Apr 2008 10:19:06 -0600
Lines: 56
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-RFC2646: Format=Flowed; Response
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3198
NNTP-Posting-Host: 10.24.38.197
Message-ID: <4804d422@solutions.advantagedatabase.com>
X-Trace: 15 Apr 2008 10:13:22 -0700, 10.24.38.197
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!10.24.38.197
Xref: solutions.advantagedatabase.com Advantage.AEP:624
Article PK: 1103901

Hi David,

You just need to define a host application under Run | Parameters. You can
either use ARC with Local Server or ads.exe for remote server. If you use
ads.exe please remember to specify /exe as parameter. What version of
Advantage are you using and did you start the AEP by using the template?

Best Regards,

Lance Schmidt
Advantage R&D

"David Looney" <davidl@autostarsolutions.com> wrote in message
news:4803c175@solutions.advantagedatabase.com...
> I'm using Delphi v5 Pro to create the AEP. I have not tried loading in
> the debugger, not quite sure how to go about doing that?
>
> David
>
> "Lance Schmidt" <LanceSc@ExtendSys.com> wrote in message
> news:4803bb08@solutions.advantagedatabase.com...
>> Hi David,
>>
>> What are you using to the build the AEP. AEPs are simply DLLs and when
>> Advantage ask the OS to load your AEP the OS doesn't think it is a valid
>> DLL. Can you load the AEP using local server from inside your debugger?
>>
>> Best Regards,
>>
>> Lance Schmidt
>> Advantage R&D
>>
>>
>> "David Looney" <davidl@autostarsolutions.com> wrote in message
>> news:4803b730@solutions.advantagedatabase.com...
>>> poQuery: Error 7200: AQE Error: State = HY000; NativeError = 5154;
>>> [iAnywhere Solutions][Advantage SQL][ASA] Error 5154: Execution
>>> of the stored procedure failed. The stored procedure named
>>> "as_GetPaymentInfo" requires the AEP named
>>> "C:\testdata\w_autocity_03_03_2008_new_delq\AsData1\AdsProcs.aep". The
>>> AEP failed to load with an error code 193. %1 is not a valid
>>> Win32 application.
>>>
>>> I keep getting the above error and am not sure what it is telling me. I
>>> have set the AEP file in the create procedure dialog and also set the
>>> function name. The tables that are being operated on are attached to
>>> the DD. Any help would be greatly appreciated.
>>>
>>> David
>>>
>>
>>
>
>


David Looney Posted on 2008-04-15 21:09:43.0Z
From: "David Looney" <davidl@autostarsolutions.com>
Newsgroups: Advantage.AEP
References: <4803b730@solutions.advantagedatabase.com> <4803bb08@solutions.advantagedatabase.com> <4803c175@solutions.advantagedatabase.com> <4804d422@solutions.advantagedatabase.com>
Subject: Re: Error Executing AEP Stored Procedure
Date: Tue, 15 Apr 2008 16:09:43 -0500
Lines: 65
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-RFC2646: Format=Flowed; Response
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3198
NNTP-Posting-Host: 67.152.110.130
Message-ID: <48051844@solutions.advantagedatabase.com>
X-Trace: 15 Apr 2008 15:04:04 -0700, 67.152.110.130
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!67.152.110.130
Xref: solutions.advantagedatabase.com Advantage.AEP:625
Article PK: 1103902

I'm using Advantage 9 and yes I did use the template given to start my
procedure.

David

"Lance Schmidt" <LanceSc@ExtendSys.com> wrote in message
news:4804d422@solutions.advantagedatabase.com...
> Hi David,
>
> You just need to define a host application under Run | Parameters. You
> can either use ARC with Local Server or ads.exe for remote server. If you
> use ads.exe please remember to specify /exe as parameter. What version of
> Advantage are you using and did you start the AEP by using the template?
>
> Best Regards,
>
> Lance Schmidt
> Advantage R&D
>
> "David Looney" <davidl@autostarsolutions.com> wrote in message
> news:4803c175@solutions.advantagedatabase.com...
>> I'm using Delphi v5 Pro to create the AEP. I have not tried loading in
>> the debugger, not quite sure how to go about doing that?
>>
>> David
>>
>> "Lance Schmidt" <LanceSc@ExtendSys.com> wrote in message
>> news:4803bb08@solutions.advantagedatabase.com...
>>> Hi David,
>>>
>>> What are you using to the build the AEP. AEPs are simply DLLs and when
>>> Advantage ask the OS to load your AEP the OS doesn't think it is a valid
>>> DLL. Can you load the AEP using local server from inside your debugger?
>>>
>>> Best Regards,
>>>
>>> Lance Schmidt
>>> Advantage R&D
>>>
>>>
>>> "David Looney" <davidl@autostarsolutions.com> wrote in message
>>> news:4803b730@solutions.advantagedatabase.com...
>>>> poQuery: Error 7200: AQE Error: State = HY000; NativeError = 5154;
>>>> [iAnywhere Solutions][Advantage SQL][ASA] Error 5154: Execution
>>>> of the stored procedure failed. The stored procedure named
>>>> "as_GetPaymentInfo" requires the AEP named
>>>> "C:\testdata\w_autocity_03_03_2008_new_delq\AsData1\AdsProcs.aep". The
>>>> AEP failed to load with an error code 193. %1 is not a valid
>>>> Win32 application.
>>>>
>>>> I keep getting the above error and am not sure what it is telling me.
>>>> I have set the AEP file in the create procedure dialog and also set the
>>>> function name. The tables that are being operated on are attached to
>>>> the DD. Any help would be greatly appreciated.
>>>>
>>>> David
>>>>
>>>
>>>
>>
>>
>
>


Lance Schmidt Posted on 2008-04-15 22:56:55.0Z
From: "Lance Schmidt" <LanceSc@ExtendSys.com>
Newsgroups: Advantage.AEP
References: <4803b730@solutions.advantagedatabase.com> <4803bb08@solutions.advantagedatabase.com> <4803c175@solutions.advantagedatabase.com> <4804d422@solutions.advantagedatabase.com> <48051844@solutions.advantagedatabase.com>
Subject: Re: Error Executing AEP Stored Procedure
Date: Tue, 15 Apr 2008 16:56:55 -0600
Lines: 81
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-RFC2646: Format=Flowed; Response
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3198
NNTP-Posting-Host: 10.24.38.197
Message-ID: <4805315f@solutions.advantagedatabase.com>
X-Trace: 15 Apr 2008 16:51:11 -0700, 10.24.38.197
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!10.24.38.197
Xref: solutions.advantagedatabase.com Advantage.AEP:626
Article PK: 1103905

Hi David,

If you post your code and resulting executable I would be happy to take a
look at it for you.

Best Regards,

Lance Schmidt
Advantage R&D

"David Looney" <davidl@autostarsolutions.com> wrote in message
news:48051844@solutions.advantagedatabase.com...
> I'm using Advantage 9 and yes I did use the template given to start my
> procedure.
>
> David
>
> "Lance Schmidt" <LanceSc@ExtendSys.com> wrote in message
> news:4804d422@solutions.advantagedatabase.com...
>> Hi David,
>>
>> You just need to define a host application under Run | Parameters. You
>> can either use ARC with Local Server or ads.exe for remote server. If
>> you use ads.exe please remember to specify /exe as parameter. What
>> version of Advantage are you using and did you start the AEP by using the
>> template?
>>
>> Best Regards,
>>
>> Lance Schmidt
>> Advantage R&D
>>
>> "David Looney" <davidl@autostarsolutions.com> wrote in message
>> news:4803c175@solutions.advantagedatabase.com...
>>> I'm using Delphi v5 Pro to create the AEP. I have not tried loading in
>>> the debugger, not quite sure how to go about doing that?
>>>
>>> David
>>>
>>> "Lance Schmidt" <LanceSc@ExtendSys.com> wrote in message
>>> news:4803bb08@solutions.advantagedatabase.com...
>>>> Hi David,
>>>>
>>>> What are you using to the build the AEP. AEPs are simply DLLs and when
>>>> Advantage ask the OS to load your AEP the OS doesn't think it is a
>>>> valid DLL. Can you load the AEP using local server from inside your
>>>> debugger?
>>>>
>>>> Best Regards,
>>>>
>>>> Lance Schmidt
>>>> Advantage R&D
>>>>
>>>>
>>>> "David Looney" <davidl@autostarsolutions.com> wrote in message
>>>> news:4803b730@solutions.advantagedatabase.com...
>>>>> poQuery: Error 7200: AQE Error: State = HY000; NativeError = 5154;
>>>>> [iAnywhere Solutions][Advantage SQL][ASA] Error 5154: Execution
>>>>> of the stored procedure failed. The stored procedure named
>>>>> "as_GetPaymentInfo" requires the AEP named
>>>>> "C:\testdata\w_autocity_03_03_2008_new_delq\AsData1\AdsProcs.aep".
>>>>> The AEP failed to load with an error code 193. %1 is not a valid
>>>>> Win32 application.
>>>>>
>>>>> I keep getting the above error and am not sure what it is telling me.
>>>>> I have set the AEP file in the create procedure dialog and also set
>>>>> the function name. The tables that are being operated on are attached
>>>>> to the DD. Any help would be greatly appreciated.
>>>>>
>>>>> David
>>>>>
>>>>
>>>>
>>>
>>>
>>
>>
>
>