Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Workspace navigator becomes unusable...

3 posts in General Discussion Last posting was on 2008-04-17 14:02:36.0Z
mpeppler Posted on 2008-04-15 10:13:53.0Z
Sender: 5c32.48033a38.1804289383@sybase.com
From: mpeppler@peppler.org
Newsgroups: sybase.public.workspace.general
Subject: Workspace navigator becomes unusable...
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <48047fe1.74f5.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 15 Apr 2008 03:13:53 -0700
X-Trace: forums-1-dub 1208254433 10.22.241.41 (15 Apr 2008 03:13:53 -0700)
X-Original-Trace: 15 Apr 2008 03:13:53 -0700, 10.22.241.41
Lines: 11
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.workspace.general:680
Article PK: 1088359

... when a workspace maps to a directory with more than
about 1000 objects (files). The files show up, but you get
an hour-glass cursor, and there is a lot of CPU usage. This
is with 2.0.1.

Note that this doesn't appear to be directly attributable to
Eclipse - I have another Eclipse installation from a
competing product (on trial basis only :-) which does not
exhibit this behavior.

Michael


Samir Nigam Posted on 2008-04-16 18:08:38.0Z
Reply-To: "Samir Nigam" <samir_dot_nigam@sybase.com>
From: "Samir Nigam" <samir_dot_nigam@sybase.com>
Newsgroups: sybase.public.workspace.general
References: <48047fe1.74f5.1681692777@sybase.com>
Subject: Re: Workspace navigator becomes unusable...
Lines: 33
Organization: Sybase, Inc
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3198
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <480640a6$1@forums-1-dub>
Date: 16 Apr 2008 11:08:38 -0700
X-Trace: forums-1-dub 1208369318 10.22.241.152 (16 Apr 2008 11:08:38 -0700)
X-Original-Trace: 16 Apr 2008 11:08:38 -0700, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.workspace.general:684
Article PK: 1088361

Does WorkSpace show "Building workspace" message at the bottom right side of
the workbench in the status bar area? If you let it continue and finish
(however long it takes), does it still do it next time around when you make
save some changes.

One way is to disable "automatic build" of the project from the Project
menu. If your project contains files that don't need validation or
compilation (ex, .sql files), then you should be ok to do that. Or, you can
also go to your project's properties sheet and see Natures (which sets up
Builders) are enabled. You can disable either the builders that you know are
not needed for the project.

Hope that helps.

Regards,
Samir

<mpeppler@peppler.org> wrote in message
news:48047fe1.74f5.1681692777@sybase.com...
> ... when a workspace maps to a directory with more than
> about 1000 objects (files). The files show up, but you get
> an hour-glass cursor, and there is a lot of CPU usage. This
> is with 2.0.1.
>
> Note that this doesn't appear to be directly attributable to
> Eclipse - I have another Eclipse installation from a
> competing product (on trial basis only :-) which does not
> exhibit this behavior.
>
> Michael


mpeppler Posted on 2008-04-17 14:02:36.0Z
Sender: 2cdb.48072219.1804289383@sybase.com
From: mpeppler@peppler.org
Newsgroups: sybase.public.workspace.general
Subject: Re: Workspace navigator becomes unusable...
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4807587c.321c.1681692777@sybase.com>
References: <480640a6$1@forums-1-dub>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 17 Apr 2008 07:02:36 -0700
X-Trace: forums-1-dub 1208440956 10.22.241.41 (17 Apr 2008 07:02:36 -0700)
X-Original-Trace: 17 Apr 2008 07:02:36 -0700, 10.22.241.41
Lines: 44
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.workspace.general:686
Article PK: 1088367

Hi - disabling the automatic build feature does indeed fix
the problem. As I'm using Workspace only for SQL file
editing and executing this solution works well for me.

Thanks,

Michael

> Does WorkSpace show "Building workspace" message at the
> bottom right side of the workbench in the status bar
> area? If you let it continue and finish (however long it
> takes), does it still do it next time around when you make
> save some changes.
>
> One way is to disable "automatic build" of the project
> from the Project menu. If your project contains files
> that don't need validation or compilation (ex, .sql
> files), then you should be ok to do that. Or, you can
> also go to your project's properties sheet and see Natures
> (which sets up Builders) are enabled. You can disable
> either the builders that you know are not needed for the
> project.
>
> Hope that helps.
>
> Regards,
> Samir
>
> <mpeppler@peppler.org> wrote in message
> news:48047fe1.74f5.1681692777@sybase.com...
> > ... when a workspace maps to a directory with more than
> > about 1000 objects (files). The files show up, but you
> > get an hour-glass cursor, and there is a lot of CPU
> > usage. This is with 2.0.1.
> >
> > Note that this doesn't appear to be directly
> > attributable to Eclipse - I have another Eclipse
> > installation from a competing product (on trial basis
> > only :-) which does not exhibit this behavior.
> >
> > Michael
>
>