Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Clear datefield

3 posts in DataWindow Last posting was on 2008-04-24 16:22:47.0Z
Bart Posted on 2008-04-24 09:49:08.0Z
Sender: 35a7.4810570b.1804289383@sybase.com
From: Bart
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: Clear datefield
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <48105794.35ae.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 24 Apr 2008 02:49:08 -0700
X-Trace: forums-1-dub 1209030548 10.22.241.41 (24 Apr 2008 02:49:08 -0700)
X-Original-Trace: 24 Apr 2008 02:49:08 -0700, 10.22.241.41
Lines: 9
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:86706
Article PK: 415965

Hi, I'm having a strange issue here.
When I go in my build version of the application and I go to
a date-field (format dd/mm/yy) and I fill in 00/00/00 for
clearing it out, it changes automatically to 01/01/00.

When I do it in the powerbuilder development version, I
don't have it. Does anyone have an idea about it ? It's
driving me crazy. Thanks in advance,
Bart


Tom Mackin Posted on 2008-04-24 14:57:58.0Z
From: Tom Mackin <ThomasDOTMackinATLFGDOTcom>
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.2) Gecko/20040804 Netscape/7.2 (ax)
X-Accept-Language: en-us, en
MIME-Version: 1.0
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: Re: Clear datefield
References: <48105794.35ae.1681692777@sybase.com>
In-Reply-To: <48105794.35ae.1681692777@sybase.com>
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <48109ff6$1@forums-1-dub>
Date: 24 Apr 2008 07:57:58 -0700
X-Trace: forums-1-dub 1209049078 10.22.241.152 (24 Apr 2008 07:57:58 -0700)
X-Original-Trace: 24 Apr 2008 07:57:58 -0700, vip152.sybase.com
Lines: 16
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:86707
Article PK: 415966

We put a picture button on the datawindow right next to the date field.
The buttonclicked event sets the date to null.

Tom

Bart wrote:
> Hi, I'm having a strange issue here.
> When I go in my build version of the application and I go to
> a date-field (format dd/mm/yy) and I fill in 00/00/00 for
> clearing it out, it changes automatically to 01/01/00.
>
> When I do it in the powerbuilder development version, I
> don't have it. Does anyone have an idea about it ? It's
> driving me crazy. Thanks in advance,
> Bart


Terry Dykstra Posted on 2008-04-24 16:22:47.0Z
Reply-To: "Terry Dykstra" <dontreply_tddykstra@forestoil.ca.x>
From: "Terry Dykstra" <tddykstra@forestoil.ca>
Newsgroups: sybase.public.powerbuilder.datawindow
References: <48105794.35ae.1681692777@sybase.com>
Subject: Re: Clear datefield
Lines: 23
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
x-mimeole: Produced By Microsoft MimeOLE V6.00.2900.3198
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4810b3d7$1@forums-1-dub>
Date: 24 Apr 2008 09:22:47 -0700
X-Trace: forums-1-dub 1209054167 10.22.241.152 (24 Apr 2008 09:22:47 -0700)
X-Original-Trace: 24 Apr 2008 09:22:47 -0700, vip152.sybase.com
X-Authenticated-User: TeamSybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:86710
Article PK: 415969

Different versions of deployment dlls?
What version,build of PB. Every version of PB seems to behave differently
with respect to date field behavior.

--
Terry Dykstra (TeamSybase)
http://powerbuilder.codeXchange.sybase.com/
http://casexpress.sybase.com/cx/cx.stm
product enhancement requests:
http://my.isug.com/cgi-bin/1/c/submit_enhancement

<Bart> wrote in message news:48105794.35ae.1681692777@sybase.com...
> Hi, I'm having a strange issue here.
> When I go in my build version of the application and I go to
> a date-field (format dd/mm/yy) and I fill in 00/00/00 for
> clearing it out, it changes automatically to 01/01/00.
>
> When I do it in the powerbuilder development version, I
> don't have it. Does anyone have an idea about it ? It's
> driving me crazy. Thanks in advance,
> Bart