Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

datetime editmask different between PB 9 and 11.1

3 posts in DataWindow Last posting was on 2008-04-29 19:53:24.0Z
Ed Van Haren Posted on 2008-04-28 20:56:03.0Z
From: "Ed Van Haren" <ed.VanHaren@worksafebc.com>
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: datetime editmask different between PB 9 and 11.1
Lines: 18
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-MIMEOLE: Produced By Microsoft MimeOLE V6.00.2900.3198
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <481639e3$1@forums-1-dub>
Date: 28 Apr 2008 13:56:03 -0700
X-Trace: forums-1-dub 1209416163 10.22.241.152 (28 Apr 2008 13:56:03 -0700)
X-Original-Trace: 28 Apr 2008 13:56:03 -0700, vip152.sybase.com
X-Authenticated-User: pb110beta
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:86731
Article PK: 415990

Hi,

I have a datawindow with a datetime column with a [date] editmask. In PB 9,
if the user types 2008 and tabs out of the column, the date defaults to
2008-01-01 (user liked this feature). In PB 11.1, if the user types 2008 and
tabs out, they get a validation error indicating 2008-00-01 is not valid.
Notice the month value is 00 and the day value is 01.

Interestingly enough, if the column was defined as a date, typing 2008 and
tabbing out works (defaults month and day to 01).

Is this a known issue to anyone. I tested this with just a simple external
datawindow.

TIA
Ed


Jason 'Bug' Fenter [TeamSybase] Posted on 2008-04-28 23:18:57.0Z
From: "Jason 'Bug' Fenter [TeamSybase]" <NO_SPAMMING_jason.fenter_AT_teamsybase.com>
User-Agent: Thunderbird 2.0.0.12 (Windows/20080213)
MIME-Version: 1.0
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: Re: datetime editmask different between PB 9 and 11.1
References: <481639e3$1@forums-1-dub>
In-Reply-To: <481639e3$1@forums-1-dub>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <48165b61$1@forums-1-dub>
Date: 28 Apr 2008 16:18:57 -0700
X-Trace: forums-1-dub 1209424737 10.22.241.152 (28 Apr 2008 16:18:57 -0700)
X-Original-Trace: 28 Apr 2008 16:18:57 -0700, vip152.sybase.com
Lines: 37
X-Authenticated-User: teamsybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:86733
Article PK: 415992

This sounds like a bug to me. I would submit this via CaseXpress.


Off topic:
Sybase has been reviewing NNTP availability and is looking at
alternative ways to build a user community. As a test-bed /
proof-of-concept, I have personally created a community on Ning
(http://powerbuilder.ning.com). While Ning certainly doesn't offer all
of the features that I'd like to see Sybase eventually implement, I am
trying to foster some community involvement on that site. Several of the
TeamSybase members have joined already and are available to answer
questions there.

Please sign up; give it a try. My hope is that it evolves into more than
just a Q&A database, but it won't get there without your participation.

Ed Van Haren wrote:
> Hi,
>
> I have a datawindow with a datetime column with a [date] editmask. In PB 9,
> if the user types 2008 and tabs out of the column, the date defaults to
> 2008-01-01 (user liked this feature). In PB 11.1, if the user types 2008 and
> tabs out, they get a validation error indicating 2008-00-01 is not valid.
> Notice the month value is 00 and the day value is 01.
>
> Interestingly enough, if the column was defined as a date, typing 2008 and
> tabbing out works (defaults month and day to 01).
>
> Is this a known issue to anyone. I tested this with just a simple external
> datawindow.
>
> TIA
> Ed
>
>


Ed Van Haren Posted on 2008-04-29 19:53:24.0Z
From: "Ed Van Haren" <ed.VanHaren@worksafebc.com>
Newsgroups: sybase.public.powerbuilder.datawindow
References: <481639e3$1@forums-1-dub>
Subject: Re: datetime editmask different between PB 9 and 11.1
Lines: 29
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-RFC2646: Format=Flowed; Response
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3198
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <48177cb4$1@forums-1-dub>
Date: 29 Apr 2008 12:53:24 -0700
X-Trace: forums-1-dub 1209498804 10.22.241.152 (29 Apr 2008 12:53:24 -0700)
X-Original-Trace: 29 Apr 2008 12:53:24 -0700, vip152.sybase.com
X-Authenticated-User: pb110beta
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:86747
Article PK: 416006

Has anyone else seen this behaviour? I haven't downloaded PB 11.2 yet (right
in the middle of a promotion of my PB 11.1 version). Can anyone verify if
the behaviour still exists in PB 11.2. Am also waiting to get the bug raised
to Sybase (contact person from the company here is away).

TIA
Ed

"Ed Van Haren" <ed.VanHaren@worksafebc.com> wrote in message
news:481639e3$1@forums-1-dub...
> Hi,
>
> I have a datawindow with a datetime column with a [date] editmask. In PB
> 9, if the user types 2008 and tabs out of the column, the date defaults to
> 2008-01-01 (user liked this feature). In PB 11.1, if the user types 2008
> and tabs out, they get a validation error indicating 2008-00-01 is not
> valid. Notice the month value is 00 and the day value is 01.
>
> Interestingly enough, if the column was defined as a date, typing 2008 and
> tabbing out works (defaults month and day to 01).
>
> Is this a known issue to anyone. I tested this with just a simple external
> datawindow.
>
> TIA
> Ed
>