Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Problem displaying Chinese characters on Palm device

4 posts in General Discussion Last posting was on 2008-06-03 17:11:41.0Z
Jie Che Posted on 2008-05-21 05:17:51.0Z
Reply-To: "Jie Che" <jche@sybase.com>
From: "Jie Che" <jche@sybase.com>
Newsgroups: ianywhere.public.onebridge.general
Subject: Problem displaying Chinese characters on Palm device
Lines: 18
Organization: Sybase
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-RFC2646: Format=Flowed; Original
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3138
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4833b07f$1@forums-1-dub>
Date: 20 May 2008 22:17:51 -0700
X-Trace: forums-1-dub 1211347071 10.22.241.152 (20 May 2008 22:17:51 -0700)
X-Original-Trace: 20 May 2008 22:17:51 -0700, vip152.sybase.com
X-Authenticated-User: eastport
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.onebridge.general:13
Article PK: 18291

Anyone has experience displaying Chinese characters (or any other double
byte characters) on Palm device? We are seeing display problems which do not
show up on Windows Mobile and Symbian devices: When the email contains
Chinese characters, the OneBridge client only displays question marks
"?????????". However, when the email was originally forwarded from an
Internet mail account (e.g., hotmail.com etc.), the Chinese characters
display correctly (not sure if it has something to do with the fact that
internet email contents were sent as html).

OneBridge client version: 5.5.2007.0702/5.5.2008.0115 (OneBridge server
version is the one Sybase uses, this question is from Sybase internal)
Palm devices: Palm 680, Palm 650

Please help. Thanks!

Jie


Ted Hamlin Posted on 2008-05-21 19:14:22.0Z
From: "Ted Hamlin" <ted.hamlin@ianywhere.com>
Newsgroups: ianywhere.public.onebridge.general
References: <4833b07f$1@forums-1-dub>
Subject: Re: Problem displaying Chinese characters on Palm device
Lines: 33
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-RFC2646: Format=Flowed; Response
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3198
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4834748e$1@forums-1-dub>
Date: 21 May 2008 12:14:22 -0700
X-Trace: forums-1-dub 1211397262 10.22.241.152 (21 May 2008 12:14:22 -0700)
X-Original-Trace: 21 May 2008 12:14:22 -0700, vip152.sybase.com
X-Authenticated-User: sybaseianywhere
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.onebridge.general:14
Article PK: 9788

Technically, OneBridge should be able to support displaying Chinese emails
on a Chinese Palm OS device.
If you are using an English OS and using a 3rd party applicaiton to get the
Chinese characters on the device, there could potentially be a problem.
Do you have a sample of what is not working when using a Chinese OS? For
example, email body, title, etc.
Please also clarify what you mean by the Chinese characters displaying
correctly when being forwarded from an Internet Mail account. Does this
mean that your Notes client is showing the characters correctly and it only
turns to '???' following a OneBridge sync? Do other types of emails (such
as ones originating from a Notes account) ever display Chinese characters
correctly?

"Jie Che" <jche@sybase.com> wrote in message news:4833b07f$1@forums-1-dub...
> Anyone has experience displaying Chinese characters (or any other double
> byte characters) on Palm device? We are seeing display problems which do
> not show up on Windows Mobile and Symbian devices: When the email contains
> Chinese characters, the OneBridge client only displays question marks
> "?????????". However, when the email was originally forwarded from an
> Internet mail account (e.g., hotmail.com etc.), the Chinese characters
> display correctly (not sure if it has something to do with the fact that
> internet email contents were sent as html).
>
> OneBridge client version: 5.5.2007.0702/5.5.2008.0115 (OneBridge server
> version is the one Sybase uses, this question is from Sybase internal)
> Palm devices: Palm 680, Palm 650
>
> Please help. Thanks!
>
> Jie
>


Jie Che Posted on 2008-06-02 06:16:41.0Z
Reply-To: "Jie Che" <jche@sybase.com>
From: "Jie Che" <jche@sybase.com>
Newsgroups: ianywhere.public.onebridge.general
References: <4833b07f$1@forums-1-dub> <4834748e$1@forums-1-dub>
Subject: Re: Problem displaying Chinese characters on Palm device
Lines: 1837
Organization: Sybase
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3138
X-RFC2646: Format=Flowed; Response
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <48439049@forums-1-dub>
Date: 1 Jun 2008 23:16:41 -0700
X-Trace: forums-1-dub 1212387401 10.22.241.152 (1 Jun 2008 23:16:41 -0700)
X-Original-Trace: 1 Jun 2008 23:16:41 -0700, vip152.sybase.com
X-Authenticated-User: eastport
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.onebridge.general:17
Article PK: 18293

Hi Ted,

I was told that there was no official Chinese Palm OS :-( So yes everyone
who uses Palm in China is using a 3rd party application to get the Chinese
display and input. The problematic Chinese character display only happens on
OneBridge client, i.e., they display correctly on Notes client. I have
attached the screenshots of the emails with "????" here. However, would like
to bring the following to your attention:

1. If the email with Chinese content was created in OneBridge client and
sent out, the received content in OB client displays correctly, however the
Notes client will display incorrectly. (that sounds like Palm OS is doing
something special regarding the character conversion)

2. Emails from different internet mailing system could behave differently
also. For instance, we have found that emails from sohu.com could display
correctly on Palm, however emails from gmail couldn't.

Jie

"Ted Hamlin" <ted.hamlin@ianywhere.com> wrote in message
news:4834748e$1@forums-1-dub...
> Technically, OneBridge should be able to support displaying Chinese emails
> on a Chinese Palm OS device.
> If you are using an English OS and using a 3rd party applicaiton to get
> the
> Chinese characters on the device, there could potentially be a problem.
> Do you have a sample of what is not working when using a Chinese OS? For
> example, email body, title, etc.
> Please also clarify what you mean by the Chinese characters displaying
> correctly when being forwarded from an Internet Mail account. Does this
> mean that your Notes client is showing the characters correctly and it
> only
> turns to '???' following a OneBridge sync? Do other types of emails (such
> as ones originating from a Notes account) ever display Chinese characters
> correctly?
>
> "Jie Che" <jche@sybase.com> wrote in message
> news:4833b07f$1@forums-1-dub...
>> Anyone has experience displaying Chinese characters (or any other double
>> byte characters) on Palm device? We are seeing display problems which do
>> not show up on Windows Mobile and Symbian devices: When the email
>> contains
>> Chinese characters, the OneBridge client only displays question marks
>> "?????????". However, when the email was originally forwarded from an
>> Internet mail account (e.g., hotmail.com etc.), the Chinese characters
>> display correctly (not sure if it has something to do with the fact that
>> internet email contents were sent as html).
>>
>> OneBridge client version: 5.5.2007.0702/5.5.2008.0115 (OneBridge server
>> version is the one Sybase uses, this question is from Sybase internal)
>> Palm devices: Palm 680, Palm 650
>>
>> Please help. Thanks!
>>
>> Jie
>>
>
>

screenshot0002.JPG
screenshot0000.JPG
screenshot0001.JPG

Ted Hamlin Posted on 2008-06-03 17:11:41.0Z
From: "Ted Hamlin" <ted.hamlin@ianywhere.com>
Newsgroups: ianywhere.public.onebridge.general
References: <4833b07f$1@forums-1-dub> <4834748e$1@forums-1-dub> <48439049@forums-1-dub>
Subject: Re: Problem displaying Chinese characters on Palm device
Lines: 71
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3198
X-RFC2646: Format=Flowed; Response
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <48457b4d@forums-1-dub>
Date: 3 Jun 2008 10:11:41 -0700
X-Trace: forums-1-dub 1212513101 10.22.241.152 (3 Jun 2008 10:11:41 -0700)
X-Original-Trace: 3 Jun 2008 10:11:41 -0700, vip152.sybase.com
X-Authenticated-User: sybaseianywhere
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.onebridge.general:18
Article PK: 9789

It sounds like there is an issue with OneBridge working with the 3rd party
application to properly display the Chinese characters.

"Jie Che" <jche@sybase.com> wrote in message news:48439049@forums-1-dub...
> Hi Ted,
>
> I was told that there was no official Chinese Palm OS :-( So yes everyone
> who uses Palm in China is using a 3rd party application to get the Chinese
> display and input. The problematic Chinese character display only happens
> on OneBridge client, i.e., they display correctly on Notes client. I have
> attached the screenshots of the emails with "????" here. However, would
> like to bring the following to your attention:
>
> 1. If the email with Chinese content was created in OneBridge client and
> sent out, the received content in OB client displays correctly, however
> the Notes client will display incorrectly. (that sounds like Palm OS is
> doing something special regarding the character conversion)
>
> 2. Emails from different internet mailing system could behave differently
> also. For instance, we have found that emails from sohu.com could display
> correctly on Palm, however emails from gmail couldn't.
>
> Jie
>
> "Ted Hamlin" <ted.hamlin@ianywhere.com> wrote in message
> news:4834748e$1@forums-1-dub...
>> Technically, OneBridge should be able to support displaying Chinese
>> emails
>> on a Chinese Palm OS device.
>> If you are using an English OS and using a 3rd party applicaiton to get
>> the
>> Chinese characters on the device, there could potentially be a problem.
>> Do you have a sample of what is not working when using a Chinese OS? For
>> example, email body, title, etc.
>> Please also clarify what you mean by the Chinese characters displaying
>> correctly when being forwarded from an Internet Mail account. Does this
>> mean that your Notes client is showing the characters correctly and it
>> only
>> turns to '???' following a OneBridge sync? Do other types of emails
>> (such
>> as ones originating from a Notes account) ever display Chinese characters
>> correctly?
>>
>> "Jie Che" <jche@sybase.com> wrote in message
>> news:4833b07f$1@forums-1-dub...
>>> Anyone has experience displaying Chinese characters (or any other double
>>> byte characters) on Palm device? We are seeing display problems which do
>>> not show up on Windows Mobile and Symbian devices: When the email
>>> contains
>>> Chinese characters, the OneBridge client only displays question marks
>>> "?????????". However, when the email was originally forwarded from an
>>> Internet mail account (e.g., hotmail.com etc.), the Chinese characters
>>> display correctly (not sure if it has something to do with the fact that
>>> internet email contents were sent as html).
>>>
>>> OneBridge client version: 5.5.2007.0702/5.5.2008.0115 (OneBridge server
>>> version is the one Sybase uses, this question is from Sybase internal)
>>> Palm devices: Palm 680, Palm 650
>>>
>>> Please help. Thanks!
>>>
>>> Jie
>>>
>>
>>
>
>
>