Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Clear column in dw and odd number appears

6 posts in DataWindow Last posting was on 2008-06-03 19:01:15.0Z
cln Posted on 2008-06-02 00:34:19.0Z
Sender: 550f.48433e19.1804289383@sybase.com
From: cln
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: Clear column in dw and odd number appears
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4843400b.552e.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 1 Jun 2008 17:34:19 -0700
X-Trace: forums-1-dub 1212366859 10.22.241.41 (1 Jun 2008 17:34:19 -0700)
X-Original-Trace: 1 Jun 2008 17:34:19 -0700, 10.22.241.41
Lines: 16
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:87017
Article PK: 416273

I have an integer column coming from the database into my
datawindow. I don't currently have any validation on the
column. During runtime, if I clear the number brought in
from the database by highlighting the column, clicking the
delete button and then clicking away, instead of the column
being empty or even 0, some odd number shows up. Then I go
to the next row, and the same thing occurs but the number
has been incremented by 3-10 numbers (it's not the same each
time). I don't know where this number is coming from but
the worst part is that it actually saves with the datawindow
as if I entered that number.

Does anyone know what this is all about or how I can get it
to stop doing this?

Any help or info would be greatly appreciated!!


"Jerry Siegel [TeamSybase]" <jNOsSPAMsiegel Posted on 2008-06-02 13:47:57.0Z
From: "Jerry Siegel [TeamSybase]" <jNOsSPAMsiegel@yahoo!.com>
Newsgroups: sybase.public.powerbuilder.datawindow
References: <4843400b.552e.1681692777@sybase.com>
Subject: Re: Clear column in dw and odd number appears
Lines: 23
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5512
X-RFC2646: Format=Flowed; Original
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5512
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4843fa0d@forums-1-dub>
Date: 2 Jun 2008 06:47:57 -0700
X-Trace: forums-1-dub 1212414477 10.22.241.152 (2 Jun 2008 06:47:57 -0700)
X-Original-Trace: 2 Jun 2008 06:47:57 -0700, vip152.sybase.com
X-Authenticated-User: TeamSybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:87021
Article PK: 416278

What version of PB?
Any format on the column or did it default to [general]?
What edit style? Is Empty String is Null set?

<cln> wrote in message news:4843400b.552e.1681692777@sybase.com...
>I have an integer column coming from the database into my
> datawindow. I don't currently have any validation on the
> column. During runtime, if I clear the number brought in
> from the database by highlighting the column, clicking the
> delete button and then clicking away, instead of the column
> being empty or even 0, some odd number shows up. Then I go
> to the next row, and the same thing occurs but the number
> has been incremented by 3-10 numbers (it's not the same each
> time). I don't know where this number is coming from but
> the worst part is that it actually saves with the datawindow
> as if I entered that number.
>
> Does anyone know what this is all about or how I can get it
> to stop doing this?
>
> Any help or info would be greatly appreciated!!


clm Posted on 2008-06-03 02:04:04.0Z
Sender: 2317.4844a599.1804289383@sybase.com
From: clm
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: Re: Clear column in dw and odd number appears
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4844a694.2329.1681692777@sybase.com>
References: <4843fa0d@forums-1-dub>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 2 Jun 2008 19:04:04 -0700
X-Trace: forums-1-dub 1212458644 10.22.241.41 (2 Jun 2008 19:04:04 -0700)
X-Original-Trace: 2 Jun 2008 19:04:04 -0700, 10.22.241.41
Lines: 29
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:87035
Article PK: 416292

v 10.2.1. Build 9
Format is defaulted to [general].
Just the default [Edit] edit style.
Empty String is Null is not set.

> What version of PB?
> Any format on the column or did it default to [general]?
> What edit style? Is Empty String is Null set?
>
> <cln> wrote in message
> news:4843400b.552e.1681692777@sybase.com... >I have an
> > integer column coming from the database into my
> > datawindow. I don't currently have any validation on
> the column. During runtime, if I clear the number brought
> > in from the database by highlighting the column,
> > clicking the delete button and then clicking away,
> > instead of the column being empty or even 0, some odd
> > number shows up. Then I go to the next row, and the
> > same thing occurs but the number has been incremented by
> > 3-10 numbers (it's not the same each time). I don't
> > know where this number is coming from but the worst part
> > is that it actually saves with the datawindow as if I
> entered that number. >
> > Does anyone know what this is all about or how I can get
> > it to stop doing this?
> >
> > Any help or info would be greatly appreciated!!
>
>


cln Posted on 2008-06-03 02:06:25.0Z
Sender: 2317.4844a599.1804289383@sybase.com
From: cln
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: Re: Clear column in dw and odd number appears
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4844a721.2338.1681692777@sybase.com>
References: <4844a694.2329.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 2 Jun 2008 19:06:25 -0700
X-Trace: forums-1-dub 1212458785 10.22.241.41 (2 Jun 2008 19:06:25 -0700)
X-Original-Trace: 2 Jun 2008 19:06:25 -0700, 10.22.241.41
Lines: 31
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:87036
Article PK: 416296

Sorry - it's Build 9004

> v 10.2.1. Build 9
> Format is defaulted to [general].
> Just the default [Edit] edit style.
> Empty String is Null is not set.
>
> > What version of PB?
> > Any format on the column or did it default to [general]?
> > What edit style? Is Empty String is Null set?
> >
> > <cln> wrote in message
> > news:4843400b.552e.1681692777@sybase.com... >I have an
> > > integer column coming from the database into my
> > > datawindow. I don't currently have any validation on
> > the column. During runtime, if I clear the number
> > > brought in from the database by highlighting the
> > > column, clicking the delete button and then clicking
> > > away, instead of the column being empty or even 0,
> > > some odd number shows up. Then I go to the next row,
> > > and the same thing occurs but the number has been
> > > incremented by 3-10 numbers (it's not the same each
> > > time). I don't know where this number is coming from
> > > but the worst part is that it actually saves with the
> > datawindow as if I entered that number. >
> > > Does anyone know what this is all about or how I can
> > > get it to stop doing this?
> > >
> > > Any help or info would be greatly appreciated!!
> >
> >


"Jerry Siegel [TeamSybase]" <jNOsSPAMsiegel Posted on 2008-06-03 10:25:10.0Z
From: "Jerry Siegel [TeamSybase]" <jNOsSPAMsiegel@yahoo!.com>
Newsgroups: sybase.public.powerbuilder.datawindow
References: <4844a694.2329.1681692777@sybase.com> <4844a721.2338.1681692777@sybase.com>
Subject: Re: Clear column in dw and odd number appears
Lines: 38
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5512
X-RFC2646: Format=Flowed; Original
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5512
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <48451c06$1@forums-1-dub>
Date: 3 Jun 2008 03:25:10 -0700
X-Trace: forums-1-dub 1212488710 10.22.241.152 (3 Jun 2008 03:25:10 -0700)
X-Original-Trace: 3 Jun 2008 03:25:10 -0700, vip152.sybase.com
X-Authenticated-User: TeamSybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:87039
Article PK: 416294

I don't have 10 installed, but I couldn't recreate that in 11.1.
What is that 'delete button' doing?
First thing I'd try is empty string is null.

<cln> wrote in message news:4844a721.2338.1681692777@sybase.com...
> Sorry - it's Build 9004
>
>> v 10.2.1. Build 9
>> Format is defaulted to [general].
>> Just the default [Edit] edit style.
>> Empty String is Null is not set.
>>
>> > What version of PB?
>> > Any format on the column or did it default to [general]?
>> > What edit style? Is Empty String is Null set?
>> >
>> > <cln> wrote in message
>> > news:4843400b.552e.1681692777@sybase.com... >I have an
>> > > integer column coming from the database into my
>> > > datawindow. I don't currently have any validation on
>> > the column. During runtime, if I clear the number
>> > > brought in from the database by highlighting the
>> > > column, clicking the delete button and then clicking
>> > > away, instead of the column being empty or even 0,
>> > > some odd number shows up. Then I go to the next row,
>> > > and the same thing occurs but the number has been
>> > > incremented by 3-10 numbers (it's not the same each
>> > > time). I don't know where this number is coming from
>> > > but the worst part is that it actually saves with the
>> > datawindow as if I entered that number. >
>> > > Does anyone know what this is all about or how I can
>> > > get it to stop doing this?
>> > >
>> > > Any help or info would be greatly appreciated!!
>> >
>> >


cln Posted on 2008-06-03 19:01:15.0Z
Sender: 2317.4844a599.1804289383@sybase.com
From: cln
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: Re: Clear column in dw and odd number appears
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <484594fb.405d.1681692777@sybase.com>
References: <48451c06$1@forums-1-dub>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 3 Jun 2008 12:01:15 -0700
X-Trace: forums-1-dub 1212519675 10.22.241.41 (3 Jun 2008 12:01:15 -0700)
X-Original-Trace: 3 Jun 2008 12:01:15 -0700, 10.22.241.41
Lines: 47
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:87046
Article PK: 416300

That did the trick. I do still get it if a stored procedure
that I'm calling in the itemchanged event for that field
errors and displays a message box. After you click ok to
the box, that funcky number is what's left, but I'm just
coding around that error return to not show the message box
for now but to display it a step later in rowfocuschanged
(not my ideal but that number being left there is worse).
Thanks for your help!

> I don't have 10 installed, but I couldn't recreate that in
> 11.1. What is that 'delete button' doing?
> First thing I'd try is empty string is null.
>
> <cln> wrote in message
> > news:4844a721.2338.1681692777@sybase.com... Sorry - it's
> Build 9004 >
> >> v 10.2.1. Build 9
> >> Format is defaulted to [general].
> >> Just the default [Edit] edit style.
> >> Empty String is Null is not set.
> >>
> >> > What version of PB?
> >> > Any format on the column or did it default to
> [general]? >> > What edit style? Is Empty String is Null
> set? >> >
> >> > <cln> wrote in message
> >> > news:4843400b.552e.1681692777@sybase.com... >I have
> an >> > > integer column coming from the database into my
> >> > > datawindow. I don't currently have any validation
> on >> > the column. During runtime, if I clear the number
> >> > > brought in from the database by highlighting the
> >> > > column, clicking the delete button and then
> clicking >> > > away, instead of the column being empty or
> even 0, >> > > some odd number shows up. Then I go to the
> next row, >> > > and the same thing occurs but the number
> has been >> > > incremented by 3-10 numbers (it's not the
> same each >> > > time). I don't know where this number
> is coming from >> > > but the worst part is that it
> actually saves with the >> > datawindow as if I entered
> that number. > >> > > Does anyone know what this is all
> about or how I can >> > > get it to stop doing this?
> >> > >
> >> > > Any help or info would be greatly appreciated!!
> >> >
> >> >
>
>