Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

workspace, debug, sybase 12.5, breakpoints: not breaking

2 posts in General Discussion Last posting was on 2008-06-09 21:17:19.0Z
larry_in_ regina Posted on 2008-06-04 18:11:24.0Z
Sender: 5bc7.4846bc44.1804289383@sybase.com
From: larry_in_ regina
Newsgroups: sybase.public.workspace.general
Subject: workspace, debug, sybase 12.5, breakpoints: not breaking
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4846dacc.6081.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 4 Jun 2008 11:11:24 -0700
X-Trace: forums-1-dub 1212603084 10.22.241.41 (4 Jun 2008 11:11:24 -0700)
X-Original-Trace: 4 Jun 2008 11:11:24 -0700, 10.22.241.41
Lines: 22
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.workspace.general:713
Article PK: 1088388

Does workspace 2.0.0 (debug) work in Sybase 12.5?

I have a lengthy sp (4,000 + lines) that I'm trying to
debug.
When debugging in Sybase 15 - debugger works as it is
supposed to (ie stopping at breakpoints etc) (by the way - I
have been using the tool for several months and have a few
issues with it (another blog), but am not completely
comfortable with it).

Same sp in Sybase 12.5 - will not break at any breakpoints.

I've closed workspace down completely and restarted it
(which has cleared up some other problems for me in the
past) and only opened the Sybase 12 database connection,
completely removed all breakpoints, redid the breakpoints,
tried debugging and it still will not break at any
breakpoint. Is there a known problem with workspace and
Sybase 12.5?

I do have to debug this one problem in Sybase 12.5 due to
table sizes, disk space, etc.


Hung Hsi Posted on 2008-06-09 21:17:19.0Z
From: "Hung Hsi" <hhsi@sybase.com>
Newsgroups: sybase.public.workspace.general
References: <4846dacc.6081.1681692777@sybase.com>
Subject: Re: workspace, debug, sybase 12.5, breakpoints: not breaking
Lines: 60
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3028
X-RFC2646: Format=Flowed; Original
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3028
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <484d9ddf$1@forums-1-dub>
Date: 9 Jun 2008 14:17:19 -0700
X-Trace: forums-1-dub 1213046239 10.22.241.152 (9 Jun 2008 14:17:19 -0700)
X-Original-Trace: 9 Jun 2008 14:17:19 -0700, vip152.sybase.com
X-Authenticated-User: wsctp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.workspace.general:715
Article PK: 1088391

Hi Larry,

There is a known problem related to stored procedrues with long names:
"
CR# 434657 SQLDBGR: Cannot debug Database objects with Long names
When debugging a T-SQL batch putting breakpoints in procedures with long
names, the
debugger just continues without stopping on the breakpoints set.
Notes: This problem is being seen in 12.5.2, 12.5.3, and 15. The name length
that causes the problem differs depending on ASE verion:
-12.5.2 and 12.5.3, 21 bytes
-15.0, 120 bytes
************************************************

This CR is fixed in ASE 12.5.4 ESD #3 and ASE 15.0.1 ESD #1

To work around the problem:
1. Remove ALL breakpoints, expecially those SPs w/ names longer than 19.
If there're more than one users using WorkSpace and have set breakpoints on
the long names, you need to ask them to remove the bps also. Because the
very first thing WorkSpace did is to set those break points during start up,
and it will cause ASE to behave abnormally, and render it useless for
debugging.
2. Shut down WorkSpace.
3. Restart ASE.
4. Restart WorkSpace, set bp on shorter stored procedures, or rename the sp
to a short name.

I'd suggest you install the aforementioned 12.5.4 ESD#3 to avoid all the
debugger related issues.

Thanks and regards,
Hung

<larry_in_ regina> wrote in message
news:4846dacc.6081.1681692777@sybase.com...
> Does workspace 2.0.0 (debug) work in Sybase 12.5?
>
> I have a lengthy sp (4,000 + lines) that I'm trying to
> debug.
> When debugging in Sybase 15 - debugger works as it is
> supposed to (ie stopping at breakpoints etc) (by the way - I
> have been using the tool for several months and have a few
> issues with it (another blog), but am not completely
> comfortable with it).
>
> Same sp in Sybase 12.5 - will not break at any breakpoints.
>
> I've closed workspace down completely and restarted it
> (which has cleared up some other problems for me in the
> past) and only opened the Sybase 12 database connection,
> completely removed all breakpoints, redid the breakpoints,
> tried debugging and it still will not break at any
> breakpoint. Is there a known problem with workspace and
> Sybase 12.5?
>
> I do have to debug this one problem in Sybase 12.5 due to
> table sizes, disk space, etc.