Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

DataWindow.Table.Select

5 posts in DataWindow Last posting was on 2008-06-09 17:49:26.0Z
Jacqueline Posted on 2008-06-04 22:04:25.0Z
From: "Jacqueline" <jacqueline.mcmullan@medtronic.com>
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: DataWindow.Table.Select
Lines: 19
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-RFC2646: Format=Flowed; Original
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3198
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <48471169$1@forums-1-dub>
Date: 4 Jun 2008 15:04:25 -0700
X-Trace: forums-1-dub 1212617065 10.22.241.152 (4 Jun 2008 15:04:25 -0700)
X-Original-Trace: 4 Jun 2008 15:04:25 -0700, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:87076
Article PK: 416334

Environment: PB 10.2.1 Build 9004, Oracle 9i

Situation: Using Modify/datawindow Table.Select properties to change dw SQL
statement. continue to receive following error: Line 1 Column 33:
incorrect syntax.

I have been over and over the sql statement. Providing SQLPreview before
database commit of datawindow action. I even changed the transaction tab in
the database profiles 'static bind' selected as uncheck, also set
transaction parameter in powerscript as 'staticbind = 0' as the
documentation instructs. Including regenerating this datawindow object and
import/export object, nothing seems to clear up this problem. I continue to
get the same error.

Does anyone have any idea why this object is behaving so odd? Suggestions?

TIA


Terry Dykstra Posted on 2008-06-05 03:27:59.0Z
From: "Terry Dykstra" <dontreply_tddykstra@forestoil.ca.x>
Newsgroups: sybase.public.powerbuilder.datawindow
References: <48471169$1@forums-1-dub>
Subject: Re: DataWindow.Table.Select
Lines: 30
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3198
X-RFC2646: Format=Flowed; Response
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <48475d3f$1@forums-1-dub>
Date: 4 Jun 2008 20:27:59 -0700
X-Trace: forums-1-dub 1212636479 10.22.241.152 (4 Jun 2008 20:27:59 -0700)
X-Original-Trace: 4 Jun 2008 20:27:59 -0700, vip152.sybase.com
X-Authenticated-User: Teamsybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:87078
Article PK: 416335

You'll have so show some code, otherwise we're just guessing.

--
Terry Dykstra (TeamSybase)
http://powerbuilder.codeXchange.sybase.com/
http://case-express.sybase.com/cx/welcome.do
http://my.isug.com/index.php?mo=is&op=in

"Jacqueline" <jacqueline.mcmullan@medtronic.com> wrote in message
news:48471169$1@forums-1-dub...
> Environment: PB 10.2.1 Build 9004, Oracle 9i
>
> Situation: Using Modify/datawindow Table.Select properties to change dw
> SQL statement. continue to receive following error: Line 1 Column 33:
> incorrect syntax.
>
> I have been over and over the sql statement. Providing SQLPreview before
> database commit of datawindow action. I even changed the transaction tab
> in the database profiles 'static bind' selected as uncheck, also set
> transaction parameter in powerscript as 'staticbind = 0' as the
> documentation instructs. Including regenerating this datawindow object
> and import/export object, nothing seems to clear up this problem. I
> continue to get the same error.
>
> Does anyone have any idea why this object is behaving so odd?
> Suggestions?
>
> TIA
>


Chris Werner Posted on 2008-06-05 07:25:56.0Z
From: "Chris Werner" <cwAT{PleaseNoSpam}f-s.de>
Newsgroups: sybase.public.powerbuilder.datawindow
References: <48471169$1@forums-1-dub>
Subject: Re: DataWindow.Table.Select
Lines: 41
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3198
X-RFC2646: Format=Flowed; Response
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <48479504@forums-1-dub>
Date: 5 Jun 2008 00:25:56 -0700
X-Trace: forums-1-dub 1212650756 10.22.241.152 (5 Jun 2008 00:25:56 -0700)
X-Original-Trace: 5 Jun 2008 00:25:56 -0700, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:87083
Article PK: 416340

Hi Jaqueline,

please show us the modify expression. Please don't guess but do
something like this:

string ls_expr, ls_err

ls_expr = "datwindow.table.select=..." // whatever you need here
ls_err = dw_1.modidy(ls_expr)

Debug that code and copy and paste the content of the variables
ls_err and ls_expr in a post here.

Best regards

Chris Werner
f+s software gmbh

"Jacqueline" <jacqueline.mcmullan@medtronic.com> schrieb im Newsbeitrag
news:48471169$1@forums-1-dub...

> Environment: PB 10.2.1 Build 9004, Oracle 9i
>
> Situation: Using Modify/datawindow Table.Select properties to change dw
> SQL statement. continue to receive following error: Line 1 Column 33:
> incorrect syntax.
>
> I have been over and over the sql statement. Providing SQLPreview before
> database commit of datawindow action. I even changed the transaction tab
> in the database profiles 'static bind' selected as uncheck, also set
> transaction parameter in powerscript as 'staticbind = 0' as the
> documentation instructs. Including regenerating this datawindow object
> and import/export object, nothing seems to clear up this problem. I
> continue to get the same error.
>
> Does anyone have any idea why this object is behaving so odd?
> Suggestions?
>
> TIA
>


Jacqueline Posted on 2008-06-06 20:38:14.0Z
From: "Jacqueline" <jacqueline.mcmullan@medtronic.com>
Newsgroups: sybase.public.powerbuilder.datawindow
References: <48471169$1@forums-1-dub> <48479504@forums-1-dub>
Subject: Re: DataWindow.Table.Select
Lines: 97
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-RFC2646: Format=Flowed; Response
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3198
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4849a036$1@forums-1-dub>
Date: 6 Jun 2008 13:38:14 -0700
X-Trace: forums-1-dub 1212784694 10.22.241.152 (6 Jun 2008 13:38:14 -0700)
X-Original-Trace: 6 Jun 2008 13:38:14 -0700, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:87108
Article PK: 416365

Sorry,

Have been busy, some of the source is below...

Thanks I was able figure out what is the problem. I needed to clear (reset
DataWindow.Table.Select before modifications. Now later in the code I
recieve an -1 error after datawindow was altered and attempted to retrieve.
Do you know what is the cause, and best solution to fix?

PowerBuilder Script:
string ls_expr, ls_err
adw_Custom.Modify("DataWindow.Table.Select = '' ") //Remove the datawindow
select statement
ls_expr = "DataWindow.Table.Select = '" + trim(ls_dwSQLStmt) + "'"
ls_err = adw_Custom.modify(upper(ls_expr))
return ls_err

Variable values
ls_expr = DataWindow.Table.Select = 'SELECT Distinct Unit_Test.UT_ID,
Unit_Lot, Unit_Wafer, Unit_X, Unit_Y, Unit_Serial, Unit_PIN,
Unit_Model, Unit_Type, Unit_Test.Test_Date, Test_Elapsed_Time,
Test_Bin_Code, Test_Status_Code,
Test_Purpose_Code, Test_Operation_Code, Test_HW1, Test_HW2, Test_HW3,
Test_Facility_Code,
Test_Set_ID, Test_Operator_ID, Station_Serial, First_Test_Flag,
Last_Test_Flag
FROM MODEL, FAMILY, Unit_Test
WHERE UNIT_TEST.UNIT_MODEL = MODEL.MODEL and MODEL.FAMILY =
FAMILY.FAMILY(+)
and unit_test.test_date between to_date(~'05/30/2008 00:00:00~',
~'MM/DD/YYYY hh24:mi:ss~') and to_date(~'05/30/2008 23:59:59~', ~'MM/DD/YYYY
hh24:mi:ss~')
and upper(test_set_id) like ~'SEAL_3771_128~'
and upper(unit_model)=~'37713~'
and upper(unit_serial)=~'NJK729012Q~'
ORDER BY Unit_Test.Test_Date
'

ls_err = ""

...
dw_1.settransobject(it_mai_trans)
li_ret = dw_1.retrieve()

li_ret = -1

Does anyone know why I have an -1. I tired to get the sqlcode, sqldbcode
and sqlerrtext, but the numeric were 0 and the test was null. So I dont
know if there is a retrieve issue or a syntax error with the modified sql
statement.

TIA

"Chris Werner" <cwAT{PleaseNoSpam}f-s.de> wrote in message
news:48479504@forums-1-dub...
> Hi Jaqueline,
>
> please show us the modify expression. Please don't guess but do
> something like this:
>
> string ls_expr, ls_err
>
> ls_expr = "datwindow.table.select=..." // whatever you need here
> ls_err = dw_1.modidy(ls_expr)
>
> Debug that code and copy and paste the content of the variables
> ls_err and ls_expr in a post here.
>
> Best regards
>
> Chris Werner
> f+s software gmbh
>
> "Jacqueline" <jacqueline.mcmullan@medtronic.com> schrieb im Newsbeitrag
> news:48471169$1@forums-1-dub...
>> Environment: PB 10.2.1 Build 9004, Oracle 9i
>>
>> Situation: Using Modify/datawindow Table.Select properties to change dw
>> SQL statement. continue to receive following error: Line 1 Column 33:
>> incorrect syntax.
>>
>> I have been over and over the sql statement. Providing SQLPreview before
>> database commit of datawindow action. I even changed the transaction tab
>> in the database profiles 'static bind' selected as uncheck, also set
>> transaction parameter in powerscript as 'staticbind = 0' as the
>> documentation instructs. Including regenerating this datawindow object
>> and import/export object, nothing seems to clear up this problem. I
>> continue to get the same error.
>>
>> Does anyone have any idea why this object is behaving so odd?
>> Suggestions?
>>
>> TIA
>>
>
>


KM Posted on 2008-06-09 17:49:26.0Z
Sender: e0e.484d6a99.1804289383@sybase.com
From: KM
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: Re: DataWindow.Table.Select
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <484d6d26.e94.1681692777@sybase.com>
References: <4849a036$1@forums-1-dub>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 9 Jun 2008 10:49:26 -0700
X-Trace: forums-1-dub 1213033766 10.22.241.41 (9 Jun 2008 10:49:26 -0700)
X-Original-Trace: 9 Jun 2008 10:49:26 -0700, 10.22.241.41
Lines: 115
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:87122
Article PK: 416379

Just for fun, check the return of settransobject.
Also, add this:
string ls_sql
ls_sql = dw_1.GetSQLSelect()
'Catch' ls_sql in the debugger (after you do the modify) and
paste it into your
database tool and see if the select 'flies' or if you get a
syntax error.

JAI
KM

> Sorry,
>
> Have been busy, some of the source is below...
>
> Thanks I was able figure out what is the problem. I
> needed to clear (reset DataWindow.Table.Select before
> modifications. Now later in the code I recieve an -1
> error after datawindow was altered and attempted to
> retrieve. Do you know what is the cause, and best
> solution to fix?
>
> PowerBuilder Script:
> string ls_expr, ls_err
> adw_Custom.Modify("DataWindow.Table.Select = '' ")
> //Remove the datawindow select statement
> ls_expr = "DataWindow.Table.Select = '" +
> trim(ls_dwSQLStmt) + "'"
> ls_err = adw_Custom.modify(upper(ls_expr))
> return ls_err
>
> Variable values
> ls_expr = DataWindow.Table.Select = 'SELECT Distinct
> Unit_Test.UT_ID, Unit_Lot, Unit_Wafer, Unit_X, Unit_Y,
> Unit_Serial, Unit_PIN, Unit_Model, Unit_Type,
> Unit_Test.Test_Date, Test_Elapsed_Time, Test_Bin_Code,
> Test_Status_Code, Test_Purpose_Code, Test_Operation_Code,
> Test_HW1, Test_HW2, Test_HW3, Test_Facility_Code,
> Test_Set_ID, Test_Operator_ID, Station_Serial,
> First_Test_Flag, Last_Test_Flag
> FROM MODEL, FAMILY, Unit_Test
> WHERE UNIT_TEST.UNIT_MODEL = MODEL.MODEL and MODEL.FAMILY
> = FAMILY.FAMILY(+)
> and unit_test.test_date between to_date(~'05/30/2008
> 00:00:00~', ~'MM/DD/YYYY hh24:mi:ss~') and
> to_date(~'05/30/2008 23:59:59~', ~'MM/DD/YYYY
> hh24:mi:ss~')
> and upper(test_set_id) like ~'SEAL_3771_128~'
> and upper(unit_model)=~'37713~'
> and upper(unit_serial)=~'NJK729012Q~'
> ORDER BY Unit_Test.Test_Date
> '
>
> ls_err = ""
>
> ...
> dw_1.settransobject(it_mai_trans)
> li_ret = dw_1.retrieve()
>
> li_ret = -1
>
> Does anyone know why I have an -1. I tired to get the
> sqlcode, sqldbcode and sqlerrtext, but the numeric were 0
> and the test was null. So I dont know if there is a
> retrieve issue or a syntax error with the modified sql
> statement.
>
> TIA
> "Chris Werner" <cwAT{PleaseNoSpam}f-s.de> wrote in message
> news:48479504@forums-1-dub...
> > Hi Jaqueline,
> >
> > please show us the modify expression. Please don't guess
> > but do something like this:
> >
> > string ls_expr, ls_err
> >
> > ls_expr = "datwindow.table.select=..." // whatever you
> > need here ls_err = dw_1.modidy(ls_expr)
> >
> > Debug that code and copy and paste the content of the
> > variables ls_err and ls_expr in a post here.
> >
> > Best regards
> >
> > Chris Werner
> > f+s software gmbh
> >
> > "Jacqueline" <jacqueline.mcmullan@medtronic.com> schrieb
> > im Newsbeitrag news:48471169$1@forums-1-dub...
> >> Environment: PB 10.2.1 Build 9004, Oracle 9i
> >>
> >> Situation: Using Modify/datawindow Table.Select
> properties to change dw >> SQL statement. continue to
> receive following error: Line 1 Column 33: >> incorrect
> syntax. >>
> >> I have been over and over the sql statement. Providing
> SQLPreview before >> database commit of datawindow
> action. I even changed the transaction tab >> in the
> database profiles 'static bind' selected as uncheck, also
> set >> transaction parameter in powerscript as
> 'staticbind = 0' as the >> documentation instructs.
> Including regenerating this datawindow object >> and
> import/export object, nothing seems to clear up this
> problem. I >> continue to get the same error.
> >>
> >> Does anyone have any idea why this object is behaving
> so odd? >> Suggestions?
> >>
> >> TIA
> >>
> >
> >
>
>