Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Datawindow Read Error

6 posts in DataWindow Last posting was on 2008-06-10 15:39:16.0Z
Bobby D. Posted on 2008-06-06 19:20:05.0Z
Sender: 417e.484972dd.1804289383@sybase.com
From: Bobby D.
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: Datawindow Read Error
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <48498de5.4619.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 6 Jun 2008 12:20:05 -0700
X-Trace: forums-1-dub 1212780005 10.22.241.41 (6 Jun 2008 12:20:05 -0700)
X-Original-Trace: 6 Jun 2008 12:20:05 -0700, 10.22.241.41
Lines: 14
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:87103
Article PK: 416360

I am experiencing the attached error "Error accessing
external object property agency_id". When I checked the
code, the error is
coming from this line of code

if dw_report.object.r_case_type.object.agency_id[1] = 31035
....
end if

My thinking is, the application is failing to read the dot
notation. What DLLs do I need to ensure that the application
can read the dot notation.
Using the GetItemNumber() function is not an option as the
release has already gone out.


"Jerry Siegel [TeamSybase]" <jNOsSPAMsiegel Posted on 2008-06-06 21:46:30.0Z
From: "Jerry Siegel [TeamSybase]" <jNOsSPAMsiegel@yahoo!.com>
Newsgroups: sybase.public.powerbuilder.datawindow
References: <48498de5.4619.1681692777@sybase.com>
Subject: Re: Datawindow Read Error
Lines: 21
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5512
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5512
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4849b036@forums-1-dub>
Date: 6 Jun 2008 14:46:30 -0700
X-Trace: forums-1-dub 1212788790 10.22.241.152 (6 Jun 2008 14:46:30 -0700)
X-Original-Trace: 6 Jun 2008 14:46:30 -0700, vip152.sybase.com
X-Authenticated-User: TeamSybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:87109
Article PK: 416367

No additional DLL is needed - dot notation is native.
If that's a report within a composite and everything is spelled right, maybe
row 1 does not exist?

<Bobby D.> wrote in message news:48498de5.4619.1681692777@sybase.com...
>I am experiencing the attached error "Error accessing
> external object property agency_id". When I checked the
> code, the error is
> coming from this line of code
>
> if dw_report.object.r_case_type.object.agency_id[1] = 31035
> ....
> end if
>
> My thinking is, the application is failing to read the dot
> notation. What DLLs do I need to ensure that the application
> can read the dot notation.
> Using the GetItemNumber() function is not an option as the
> release has already gone out.


Bobby D. Posted on 2008-06-09 15:10:15.0Z
Sender: 631.484d4754.1804289383@sybase.com
From: Bobby D.
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: Re: Datawindow Read Error
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <484d47d7.64c.1681692777@sybase.com>
References: <4849b036@forums-1-dub>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 9 Jun 2008 08:10:15 -0700
X-Trace: forums-1-dub 1213024215 10.22.241.41 (9 Jun 2008 08:10:15 -0700)
X-Original-Trace: 9 Jun 2008 08:10:15 -0700, 10.22.241.41
Lines: 25
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:87120
Article PK: 416377

Row 1 does exist. Infact, when other users run the same
report, the problem does not arise. This is happening only
on the user's machine.

> No additional DLL is needed - dot notation is native.
> If that's a report within a composite and everything is
> spelled right, maybe row 1 does not exist?
>
> <Bobby D.> wrote in message
> news:48498de5.4619.1681692777@sybase.com... >I am
> > experiencing the attached error "Error accessing
> > external object property agency_id". When I checked the
> > code, the error is coming from this line of code
> >
> > if dw_report.object.r_case_type.object.agency_id[1] =
> > 31035 ....
> > end if
> >
> > My thinking is, the application is failing to read the
> > dot notation. What DLLs do I need to ensure that the
> > application can read the dot notation.
> > Using the GetItemNumber() function is not an option as
> > the release has already gone out.
>
>


"Jerry Siegel [TeamSybase]" <jNOsSPAMsiegel Posted on 2008-06-09 15:25:05.0Z
From: "Jerry Siegel [TeamSybase]" <jNOsSPAMsiegel@yahoo!.com>
Newsgroups: sybase.public.powerbuilder.datawindow
References: <4849b036@forums-1-dub> <484d47d7.64c.1681692777@sybase.com>
Subject: Re: Datawindow Read Error
Lines: 32
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5512
X-MIMEOLE: Produced By Microsoft MimeOLE V6.00.2900.5512
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <484d4b51$1@forums-1-dub>
Date: 9 Jun 2008 08:25:05 -0700
X-Trace: forums-1-dub 1213025105 10.22.241.152 (9 Jun 2008 08:25:05 -0700)
X-Original-Trace: 9 Jun 2008 08:25:05 -0700, vip152.sybase.com
X-Authenticated-User: TeamSybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:87121
Article PK: 416378

Only one user gets the error, others with the same installation are OK?
Can this user see the report or is that code running during retrieve?
Are you certain this user has DBMS rights to retrieve the report?

<Bobby D.> wrote in message news:484d47d7.64c.1681692777@sybase.com...
> Row 1 does exist. Infact, when other users run the same
> report, the problem does not arise. This is happening only
> on the user's machine.
>
>> No additional DLL is needed - dot notation is native.
>> If that's a report within a composite and everything is
>> spelled right, maybe row 1 does not exist?
>>
>> <Bobby D.> wrote in message
>> news:48498de5.4619.1681692777@sybase.com... >I am
>> > experiencing the attached error "Error accessing
>> > external object property agency_id". When I checked the
>> > code, the error is coming from this line of code
>> >
>> > if dw_report.object.r_case_type.object.agency_id[1] =
>> > 31035 ....
>> > end if
>> >
>> > My thinking is, the application is failing to read the
>> > dot notation. What DLLs do I need to ensure that the
>> > application can read the dot notation.
>> > Using the GetItemNumber() function is not an option as
>> > the release has already gone out.
>>
>>


Bobby D. Posted on 2008-06-10 15:22:46.0Z
Sender: 631.484d4754.1804289383@sybase.com
From: Bobby D.
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: Re: Datawindow Read Error
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <484e9c46.3efb.1681692777@sybase.com>
References: <484d4b51$1@forums-1-dub>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 10 Jun 2008 08:22:46 -0700
X-Trace: forums-1-dub 1213111366 10.22.241.41 (10 Jun 2008 08:22:46 -0700)
X-Original-Trace: 10 Jun 2008 08:22:46 -0700, 10.22.241.41
Lines: 37
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:87133
Article PK: 416390

The code runs during retrieve, and yes the user has DBMS
rights. The user has a new computer which made me think, a
DLL might be missing from the user's machine.

> Only one user gets the error, others with the same
> installation are OK? Can this user see the report or is
> that code running during retrieve? Are you certain this
> user has DBMS rights to retrieve the report?
>
> <Bobby D.> wrote in message
> > news:484d47d7.64c.1681692777@sybase.com... Row 1 does
> > exist. Infact, when other users run the same report, the
> > problem does not arise. This is happening only on the
> user's machine. >
> >> No additional DLL is needed - dot notation is native.
> >> If that's a report within a composite and everything is
> >> spelled right, maybe row 1 does not exist?
> >>
> >> <Bobby D.> wrote in message
> >> news:48498de5.4619.1681692777@sybase.com... >I am
> >> > experiencing the attached error "Error accessing
> >> > external object property agency_id". When I checked
> the >> > code, the error is coming from this line of code
> >> >
> >> > if dw_report.object.r_case_type.object.agency_id[1] =
> >> > 31035 ....
> >> > end if
> >> >
> >> > My thinking is, the application is failing to read
> the >> > dot notation. What DLLs do I need to ensure that
> the >> > application can read the dot notation.
> >> > Using the GetItemNumber() function is not an option
> as >> > the release has already gone out.
> >>
> >>
>
>


"Jerry Siegel [TeamSybase]" <jNOsSPAMsiegel Posted on 2008-06-10 15:39:16.0Z
From: "Jerry Siegel [TeamSybase]" <jNOsSPAMsiegel@yahoo!.com>
Newsgroups: sybase.public.powerbuilder.datawindow
References: <484d4b51$1@forums-1-dub> <484e9c46.3efb.1681692777@sybase.com>
Subject: Re: Datawindow Read Error
Lines: 50
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5512
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5512
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <484ea024$1@forums-1-dub>
Date: 10 Jun 2008 08:39:16 -0700
X-Trace: forums-1-dub 1213112356 10.22.241.152 (10 Jun 2008 08:39:16 -0700)
X-Original-Trace: 10 Jun 2008 08:39:16 -0700, vip152.sybase.com
X-Authenticated-User: TeamSybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:87134
Article PK: 416394

Unlikely, but you may want to take another look at the Deployment chapter in
the Application Techniques HTML book to be certain. I think it's more likely
that a DW is omitted from the deployment (can happen with dynamic assignment
of dataobject), or a wrong version, or duplicate names in two PBL (first one
in the library list is used.)
If you were to install an earlier version of your application on the user's
new machine and then reinstall the one that is having problems, and that
made the problem go away that would be an indication that something was
missing from the new deploy.

<Bobby D.> wrote in message news:484e9c46.3efb.1681692777@sybase.com...
> The code runs during retrieve, and yes the user has DBMS
> rights. The user has a new computer which made me think, a
> DLL might be missing from the user's machine.
>
>> Only one user gets the error, others with the same
>> installation are OK? Can this user see the report or is
>> that code running during retrieve? Are you certain this
>> user has DBMS rights to retrieve the report?
>>
>> <Bobby D.> wrote in message
>> > news:484d47d7.64c.1681692777@sybase.com... Row 1 does
>> > exist. Infact, when other users run the same report, the
>> > problem does not arise. This is happening only on the
>> user's machine. >
>> >> No additional DLL is needed - dot notation is native.
>> >> If that's a report within a composite and everything is
>> >> spelled right, maybe row 1 does not exist?
>> >>
>> >> <Bobby D.> wrote in message
>> >> news:48498de5.4619.1681692777@sybase.com... >I am
>> >> > experiencing the attached error "Error accessing
>> >> > external object property agency_id". When I checked
>> the >> > code, the error is coming from this line of code
>> >> >
>> >> > if dw_report.object.r_case_type.object.agency_id[1] =
>> >> > 31035 ....
>> >> > end if
>> >> >
>> >> > My thinking is, the application is failing to read
>> the >> > dot notation. What DLLs do I need to ensure that
>> the >> > application can read the dot notation.
>> >> > Using the GetItemNumber() function is not an option
>> as >> > the release has already gone out.
>> >>
>> >>
>>
>>